Grr, forgot to cvs rm these.
This commit is contained in:
parent
071437e00e
commit
58aa66b42e
5 changed files with 0 additions and 328 deletions
|
@ -1,16 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2007/01/09 23:36:45 wiz Exp $
|
||||
|
||||
--- configure.ac.orig 2005-05-07 23:05:24.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -40,9 +40,9 @@ fi
|
||||
AC_PROG_CC
|
||||
|
||||
# Checks for libraries.
|
||||
-AC_CHECK_LIB(FLAC, FLAC__file_decoder_new, [haveflac=yes], [haveflac=no], -lm)
|
||||
+AC_CHECK_LIB(FLAC, FLAC__stream_decoder_new, [haveflac=yes], [haveflac=no], -lm -logg)
|
||||
if test "$haveflac" = "yes"; then
|
||||
- FLAC_LIBS="-lFLAC -lm"
|
||||
+ FLAC_LIBS="-lFLAC -logg -lm"
|
||||
AC_SUBST(FLAC_LIBS)
|
||||
else
|
||||
AC_MSG_ERROR(FLAC required!)
|
|
@ -1,69 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1 2007/01/09 23:36:45 wiz Exp $
|
||||
|
||||
--- configure.orig 2007-01-09 23:33:42.000000000 +0000
|
||||
+++ configure
|
||||
@@ -2688,13 +2688,13 @@ CCDEPMODE=depmode=$am_cv_CC_dependencies
|
||||
|
||||
# Checks for libraries.
|
||||
|
||||
-echo "$as_me:$LINENO: checking for FLAC__file_decoder_new in -lFLAC" >&5
|
||||
-echo $ECHO_N "checking for FLAC__file_decoder_new in -lFLAC... $ECHO_C" >&6
|
||||
-if test "${ac_cv_lib_FLAC_FLAC__file_decoder_new+set}" = set; then
|
||||
+echo "$as_me:$LINENO: checking for FLAC__stream_decoder_new in -lFLAC" >&5
|
||||
+echo $ECHO_N "checking for FLAC__stream_decoder_new in -lFLAC... $ECHO_C" >&6
|
||||
+if test "${ac_cv_lib_FLAC_FLAC__stream_decoder_new+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_check_lib_save_LIBS=$LIBS
|
||||
-LIBS="-lFLAC -lm $LIBS"
|
||||
+LIBS="-lFLAC -logg -lm $LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
#line $LINENO "configure"
|
||||
/* confdefs.h. */
|
||||
@@ -2709,11 +2709,11 @@ extern "C"
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char FLAC__file_decoder_new ();
|
||||
+char FLAC__stream_decoder_new ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-FLAC__file_decoder_new ();
|
||||
+FLAC__stream_decoder_new ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -2730,26 +2730,26 @@ if { (eval echo "$as_me:$LINENO: \"$ac_l
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_lib_FLAC_FLAC__file_decoder_new=yes
|
||||
+ ac_cv_lib_FLAC_FLAC__stream_decoder_new=yes
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
|
||||
-ac_cv_lib_FLAC_FLAC__file_decoder_new=no
|
||||
+ac_cv_lib_FLAC_FLAC__stream_decoder_new=no
|
||||
fi
|
||||
rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
|
||||
LIBS=$ac_check_lib_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_lib_FLAC_FLAC__file_decoder_new" >&5
|
||||
-echo "${ECHO_T}$ac_cv_lib_FLAC_FLAC__file_decoder_new" >&6
|
||||
-if test $ac_cv_lib_FLAC_FLAC__file_decoder_new = yes; then
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_lib_FLAC_FLAC__stream_decoder_new" >&5
|
||||
+echo "${ECHO_T}$ac_cv_lib_FLAC_FLAC__stream_decoder_new" >&6
|
||||
+if test $ac_cv_lib_FLAC_FLAC__stream_decoder_new = yes; then
|
||||
haveflac=yes
|
||||
else
|
||||
haveflac=no
|
||||
fi
|
||||
|
||||
if test "$haveflac" = "yes"; then
|
||||
- FLAC_LIBS="-lFLAC -lm"
|
||||
+ FLAC_LIBS="-lFLAC -logg -lm"
|
||||
|
||||
else
|
||||
{ { echo "$as_me:$LINENO: error: FLAC required!" >&5
|
|
@ -1,184 +0,0 @@
|
|||
$NetBSD: patch-ac,v 1.1 2007/01/09 23:36:45 wiz Exp $
|
||||
|
||||
--- flac123.c.orig 2005-05-09 04:25:20.000000000 +0000
|
||||
+++ flac123.c
|
||||
@@ -49,12 +49,17 @@ struct poptOption cli_options[] = {
|
||||
|
||||
static void play_file(const char *);
|
||||
static void play_remote_file(void);
|
||||
-void flac_error_hdl(const FLAC__FileDecoder *, FLAC__StreamDecoderErrorStatus,
|
||||
- void *);
|
||||
-void flac_metadata_hdl(const FLAC__FileDecoder *, const FLAC__StreamMetadata *,
|
||||
- void *);
|
||||
+#ifdef LEGACY_FLAC
|
||||
+void flac_error_hdl(const FLAC__FileDecoder *, FLAC__StreamDecoderErrorStatus, void *);
|
||||
+void flac_metadata_hdl(const FLAC__FileDecoder *, const FLAC__StreamMetadata *, void *);
|
||||
FLAC__StreamDecoderWriteStatus flac_write_hdl(const FLAC__FileDecoder *,
|
||||
const FLAC__Frame *, const FLAC__int32 * const buf[], void *);
|
||||
+#else
|
||||
+void flac_error_hdl(const FLAC__StreamDecoder *, FLAC__StreamDecoderErrorStatus, void *);
|
||||
+void flac_metadata_hdl(const FLAC__StreamDecoder *, const FLAC__StreamMetadata *, void *);
|
||||
+FLAC__StreamDecoderWriteStatus flac_write_hdl(const FLAC__StreamDecoder *,
|
||||
+ const FLAC__Frame *, const FLAC__int32 * const buf[], void *);
|
||||
+#endif
|
||||
|
||||
static void signal_handler(int);
|
||||
static int quit_now = 0;
|
||||
@@ -190,6 +195,7 @@ FLAC__bool decoder_constructor(const cha
|
||||
file_info.year[VORBIS_YEAR_LEN] = '\0';
|
||||
|
||||
/* create and initialize flac decoder object */
|
||||
+#ifdef LEGACY_FLAC
|
||||
file_info.decoder = FLAC__file_decoder_new();
|
||||
FLAC__file_decoder_set_md5_checking(file_info.decoder, true);
|
||||
FLAC__file_decoder_set_filename(file_info.decoder, filename);
|
||||
@@ -210,13 +216,29 @@ FLAC__bool decoder_constructor(const cha
|
||||
FLAC__file_decoder_delete(file_info.decoder);
|
||||
return false;
|
||||
}
|
||||
+#else
|
||||
+ file_info.decoder = FLAC__stream_decoder_new();
|
||||
+ FLAC__stream_decoder_set_md5_checking(file_info.decoder, true);
|
||||
+
|
||||
+ /* read metadata */
|
||||
+ if ((FLAC__stream_decoder_init_file(file_info.decoder, filename, flac_write_hdl, flac_metadata_hdl, flac_error_hdl, (void *)&file_info) != FLAC__STREAM_DECODER_INIT_STATUS_OK)
|
||||
+ || (!FLAC__stream_decoder_process_until_end_of_metadata(file_info.decoder)))
|
||||
+ {
|
||||
+ FLAC__stream_decoder_delete(file_info.decoder);
|
||||
+ return false;
|
||||
+ }
|
||||
+#endif
|
||||
|
||||
/* open libao output device */
|
||||
if (cli_args.wavfile) {
|
||||
if (!(file_info.ao_dev = ao_open_file(ao_driver_id("wav"), cli_args.wavfile, /*overwrite*/ 1, &(file_info.ao_fmt), NULL)))
|
||||
{
|
||||
fprintf(stderr, "Error opening wav file %s\n", cli_args.wavfile);
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_delete(file_info.decoder);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_delete(file_info.decoder);
|
||||
+#endif
|
||||
return false;
|
||||
}
|
||||
}
|
||||
@@ -224,7 +246,11 @@ FLAC__bool decoder_constructor(const cha
|
||||
if (!(file_info.ao_dev = ao_open_live(ao_output_id, &(file_info.ao_fmt), NULL)))
|
||||
{
|
||||
fprintf(stderr, "Error opening ao device %d\n", ao_output_id);
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_delete(file_info.decoder);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_delete(file_info.decoder);
|
||||
+#endif
|
||||
return false;
|
||||
}
|
||||
}
|
||||
@@ -237,7 +263,11 @@ FLAC__bool decoder_constructor(const cha
|
||||
if (!(file_info.ao_dev = ao_open_live(ao_output_id, &(file_info.ao_fmt), NULL)))
|
||||
{
|
||||
fprintf(stderr, "Error opening ao device %d\n", ao_output_id);
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_delete(file_info.decoder);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_delete(file_info.decoder);
|
||||
+#endif
|
||||
return false;
|
||||
}
|
||||
}
|
||||
@@ -257,8 +287,13 @@ FLAC__bool decoder_constructor(const cha
|
||||
|
||||
void decoder_destructor(void)
|
||||
{
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_finish(file_info.decoder);
|
||||
FLAC__file_decoder_delete(file_info.decoder);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_finish(file_info.decoder);
|
||||
+ FLAC__stream_decoder_delete(file_info.decoder);
|
||||
+#endif
|
||||
file_info.is_loaded = false;
|
||||
file_info.is_playing = false;
|
||||
file_info.filename[0] = '\0';
|
||||
@@ -272,9 +307,15 @@ static void play_file(const char *filena
|
||||
return;
|
||||
}
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
while (FLAC__file_decoder_process_single(file_info.decoder) == true &&
|
||||
FLAC__file_decoder_get_state(file_info.decoder) ==
|
||||
FLAC__FILE_DECODER_OK && !interrupted)
|
||||
+#else
|
||||
+ while (FLAC__stream_decoder_process_single(file_info.decoder) == true &&
|
||||
+ FLAC__stream_decoder_get_state(file_info.decoder) <
|
||||
+ FLAC__STREAM_DECODER_END_OF_STREAM && !interrupted)
|
||||
+#endif
|
||||
{
|
||||
}
|
||||
interrupted = 0; /* more accurate feedback if placed after loop */
|
||||
@@ -292,13 +333,22 @@ static void play_remote_file(void)
|
||||
{
|
||||
if (file_info.is_playing == true)
|
||||
{
|
||||
+#ifdef LEGACY_FLAC
|
||||
if (FLAC__file_decoder_get_state(file_info.decoder) ==
|
||||
FLAC__FILE_DECODER_END_OF_FILE)
|
||||
+#else
|
||||
+ if (FLAC__stream_decoder_get_state(file_info.decoder) ==
|
||||
+ FLAC__STREAM_DECODER_END_OF_STREAM)
|
||||
+#endif
|
||||
{
|
||||
decoder_destructor();
|
||||
printf("@P 0\n");
|
||||
}
|
||||
+#ifdef LEGACY_FLAC
|
||||
else if (!FLAC__file_decoder_process_single(file_info.decoder))
|
||||
+#else
|
||||
+ else if (!FLAC__stream_decoder_process_single(file_info.decoder))
|
||||
+#endif
|
||||
{
|
||||
fprintf(stderr, "error decoding single frame!\n");
|
||||
}
|
||||
@@ -314,14 +364,24 @@ static void play_remote_file(void)
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
void flac_error_hdl(const FLAC__FileDecoder *dec,
|
||||
FLAC__StreamDecoderErrorStatus status, void *data)
|
||||
+#else
|
||||
+void flac_error_hdl(const FLAC__StreamDecoder *dec,
|
||||
+ FLAC__StreamDecoderErrorStatus status, void *data)
|
||||
+#endif
|
||||
{
|
||||
fprintf(stderr, "error handler called!\n");
|
||||
}
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
void flac_metadata_hdl(const FLAC__FileDecoder *dec,
|
||||
const FLAC__StreamMetadata *meta, void *data)
|
||||
+#else
|
||||
+void flac_metadata_hdl(const FLAC__StreamDecoder *dec,
|
||||
+ const FLAC__StreamMetadata *meta, void *data)
|
||||
+#endif
|
||||
{
|
||||
file_info_struct *p = (file_info_struct *) data;
|
||||
|
||||
@@ -344,10 +404,17 @@ void flac_metadata_hdl(const FLAC__FileD
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__StreamDecoderWriteStatus flac_write_hdl(const FLAC__FileDecoder *dec,
|
||||
const FLAC__Frame *frame,
|
||||
const FLAC__int32 * const buf[],
|
||||
void *data)
|
||||
+#else
|
||||
+FLAC__StreamDecoderWriteStatus flac_write_hdl(const FLAC__StreamDecoder *dec,
|
||||
+ const FLAC__Frame *frame,
|
||||
+ const FLAC__int32 * const buf[],
|
||||
+ void *data)
|
||||
+#endif
|
||||
{
|
||||
int sample, channel, i;
|
||||
uint_32 samples = frame->header.blocksize;
|
|
@ -1,29 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2007/01/09 23:36:45 wiz Exp $
|
||||
|
||||
--- flac123.h.orig 2005-02-25 05:52:02.000000000 +0000
|
||||
+++ flac123.h
|
||||
@@ -22,13 +22,24 @@
|
||||
#include <limits.h>
|
||||
#include <FLAC/all.h>
|
||||
|
||||
+/* by LEGACY_FLAC we mean pre-1.1.3 before FLAC__FileDecoder was merged into FLAC__StreamDecoder */
|
||||
+#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
|
||||
+#define LEGACY_FLAC
|
||||
+#else
|
||||
+#undef LEGACY_FLAC
|
||||
+#endif
|
||||
+
|
||||
/* string widths for printing ID3 (vorbis) data in remote mode */
|
||||
#define VORBIS_TAG_LEN 30
|
||||
#define VORBIS_YEAR_LEN 4
|
||||
|
||||
/* the main data structure of the program */
|
||||
typedef struct {
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__FileDecoder *decoder;
|
||||
+#else
|
||||
+ FLAC__StreamDecoder *decoder;
|
||||
+#endif
|
||||
|
||||
/* bits, rate, channels, byte_format */
|
||||
ao_sample_format sam_fmt; /* input sample's true format */
|
|
@ -1,30 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1 2007/01/09 23:36:45 wiz Exp $
|
||||
|
||||
--- remote.c.orig 2005-02-25 05:50:41.000000000 +0000
|
||||
+++ remote.c
|
||||
@@ -150,8 +150,13 @@ static int remote_parse_input(void)
|
||||
file_info.current_sample += delta_frames;
|
||||
}
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_seek_absolute(file_info.decoder,
|
||||
file_info.current_sample);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_seek_absolute(file_info.decoder,
|
||||
+ file_info.current_sample);
|
||||
+#endif
|
||||
}
|
||||
/* absolute seek */
|
||||
else
|
||||
@@ -161,7 +166,11 @@ static int remote_parse_input(void)
|
||||
file_info.elapsed_time = absolute_time;
|
||||
file_info.current_sample = absolute_frame;
|
||||
|
||||
+#ifdef LEGACY_FLAC
|
||||
FLAC__file_decoder_seek_absolute(file_info.decoder, absolute_frame);
|
||||
+#else
|
||||
+ FLAC__stream_decoder_seek_absolute(file_info.decoder, absolute_frame);
|
||||
+#endif
|
||||
}
|
||||
|
||||
}
|
Loading…
Reference in a new issue