Floating point exceptions are enabled for __x86_64__ on all operation

systems, but the code that take care of them is inly implemented
on Linux.  This made the build go into an infinite loop on NetBSD.

Disable floating point exceptions on NetBSD/amd64 for now, until
I get around implementing and testing the necessary sigaction glue.
This commit is contained in:
kristerw 2006-01-01 18:24:58 +00:00
parent 2c5c5f56b5
commit 5922f27089
3 changed files with 29 additions and 1 deletions

View file

@ -1,7 +1,9 @@
$NetBSD: distinfo,v 1.5 2005/12/30 10:32:16 ghen Exp $
$NetBSD: distinfo,v 1.6 2006/01/01 18:24:58 kristerw Exp $
SHA1 (erlang/otp_src_R10B-9.tar.gz) = 2255209fca6101e39d7e3d5af2c074239e29d79d
RMD160 (erlang/otp_src_R10B-9.tar.gz) = e92b655d3250a6dd4c11106fbc0fb0626a5cf6e9
Size (erlang/otp_src_R10B-9.tar.gz) = 9961340 bytes
SHA1 (patch-aa) = 43eb492a22462442e3f717ee32056df11d1a0e43
SHA1 (patch-ab) = ced331e223b3b1de88426de5f18fe066ca8be028
SHA1 (patch-ac) = f584b213db636f3be29fb4f99b9cfb85ee9374ad
SHA1 (patch-ad) = 180db5c15a1c238773288e842f86c102614ba2a6

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ac,v 1.3 2006/01/01 18:24:58 kristerw Exp $
--- erts/configure.orig 2006-01-01 17:45:43.000000000 +0100
+++ erts/configure 2006-01-01 17:46:23.000000000 +0100
@@ -5724,7 +5724,7 @@
__asm__ __volatile__("fldcw %0" : : "m"(cw));
}
-#if defined(__x86_64__)
+#if defined(__x86_64__) && !defined(__NetBSD__)
static void unmask_sse2(void)
{
unsigned int mxcsr;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1 2006/01/01 18:24:58 kristerw Exp $
--- erts/emulator/sys/unix/sys_float.c.orig 2006-01-01 17:46:42.000000000 +0100
+++ erts/emulator/sys/unix/sys_float.c 2006-01-01 17:47:07.000000000 +0100
@@ -52,7 +52,7 @@
__asm__ __volatile__("fldcw %0" : : "m"(cw));
}
-#if defined(__x86_64__)
+#if defined(__x86_64__) && !defined(__NetBSD__)
static void unmask_sse2(void)
{
unsigned int mxcsr;