freeglut: fix usage on illumos/solaris

This commit is contained in:
nros 2023-11-09 09:59:49 +00:00
parent 411a718b93
commit 5959e196ab
2 changed files with 22 additions and 1 deletions

View File

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.19 2023/05/03 15:20:41 triaxx Exp $
$NetBSD: distinfo,v 1.20 2023/11/09 09:59:49 nros Exp $
BLAKE2s (freeglut-3.4.0.tar.gz) = 710aa8aa2705736bfd941e0b94c4503235f82d1b687a40d891fd0c727b4b5fb7
SHA512 (freeglut-3.4.0.tar.gz) = 4bb6d6c086bac7a9c0ec78062dce58987555785abe6375f462ee249f65210a964a28fb10ba7ee8a42d7fafb00eb8d196eb403d65d255f02f88467369c187228b
Size (freeglut-3.4.0.tar.gz) = 413389 bytes
SHA1 (patch-src_x11_fg__joystick__x11.c) = ac82cffd2a9cd6b801cbe1519ee84ef8738f7f82

View File

@ -0,0 +1,20 @@
$NetBSD: patch-src_x11_fg__joystick__x11.c,v 1.6 2023/11/09 09:59:49 nros Exp $
fghJoystickRawRead is now called fgJoystickRawRead
https://github.com/FreeGLUTProject/freeglut/commit/eb622d9862158bd088988758b175532563827e39
This caused linking problems in packages using freeglut
complaining that it can't find fghJoystickRawRead on Illumos/Solaris.
Filed upstream:
https://github.com/FreeGLUTProject/freeglut/pull/150
--- src/x11/fg_joystick_x11.c.orig 2023-11-08 23:41:40.649322173 +0000
+++ src/x11/fg_joystick_x11.c
@@ -627,7 +627,7 @@ void fgPlatformJoystickOpen( SFG_Joystic
do
{
- fghJoystickRawRead( joy, NULL, joy->center );
+ fgJoystickRawRead( joy, NULL, joy->center );
counter++;
} while( !joy->error &&
counter < 100 &&