add py-distribute-0.6.28, a replacement for py-setuptools which
also works with Python3
This commit is contained in:
parent
9b65835422
commit
5979091eeb
5 changed files with 204 additions and 0 deletions
8
devel/py-distribute/DESCR
Normal file
8
devel/py-distribute/DESCR
Normal file
|
@ -0,0 +1,8 @@
|
|||
Distribute is a fork of the Setuptools project.
|
||||
The fork has two goals:
|
||||
-Providing a backward compatible version to replace Setuptools and make all
|
||||
distributions that depend on Setuptools work as before, but with less bugs
|
||||
and behaviorial issues.
|
||||
Distribute supports Python 3.
|
||||
-Refactoring the code, and releasing it in several distributions. This work
|
||||
is being done in the 0.7.x series but not yet released.
|
20
devel/py-distribute/Makefile
Normal file
20
devel/py-distribute/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
# $NetBSD: Makefile,v 1.1 2012/07/25 19:05:51 drochner Exp $
|
||||
#
|
||||
|
||||
DISTNAME= distribute-0.6.28
|
||||
PKGNAME= ${PYPKGPREFIX}-distribute-0.6.28
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://pypi.python.org/packages/source/d/distribute/
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://pypi.python.org/pypi/distribute
|
||||
COMMENT= Replacement for setuptools
|
||||
LICENSE= python-software-foundation # or ZPL
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
CONFLICTS+= ${PYPKGPREFIX}-setuptools-[0-9]*
|
||||
PYTHON_VERSIONS_INCLUDE_3X= yes
|
||||
PLIST_SUBST+= PYVERSSUFFIX=${PYVERSSUFFIX}
|
||||
|
||||
.include "../../lang/python/distutils.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
157
devel/py-distribute/PLIST
Normal file
157
devel/py-distribute/PLIST
Normal file
|
@ -0,0 +1,157 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2012/07/25 19:05:51 drochner Exp $
|
||||
bin/easy_install-${PYVERSSUFFIX}
|
||||
${PYSITELIB}/${EGG_FILE}/PKG-INFO
|
||||
${PYSITELIB}/${EGG_FILE}/SOURCES.txt
|
||||
${PYSITELIB}/${EGG_FILE}/dependency_links.txt
|
||||
${PYSITELIB}/${EGG_FILE}/entry_points.txt
|
||||
${PYSITELIB}/${EGG_FILE}/top_level.txt
|
||||
${PYSITELIB}/${EGG_FILE}/zip-safe
|
||||
${PYSITELIB}/easy_install.py
|
||||
${PYSITELIB}/easy_install.pyc
|
||||
${PYSITELIB}/easy_install.pyo
|
||||
${PYSITELIB}/pkg_resources.py
|
||||
${PYSITELIB}/pkg_resources.pyc
|
||||
${PYSITELIB}/pkg_resources.pyo
|
||||
${PYSITELIB}/setuptools-0.6c11-py${PYVERSSUFFIX}.egg-info
|
||||
${PYSITELIB}/setuptools.pth
|
||||
${PYSITELIB}/setuptools/__init__.py
|
||||
${PYSITELIB}/setuptools/__init__.pyc
|
||||
${PYSITELIB}/setuptools/__init__.pyo
|
||||
${PYSITELIB}/setuptools/archive_util.py
|
||||
${PYSITELIB}/setuptools/archive_util.pyc
|
||||
${PYSITELIB}/setuptools/archive_util.pyo
|
||||
${PYSITELIB}/setuptools/cli-32.exe
|
||||
${PYSITELIB}/setuptools/cli-64.exe
|
||||
${PYSITELIB}/setuptools/cli.exe
|
||||
${PYSITELIB}/setuptools/command/__init__.py
|
||||
${PYSITELIB}/setuptools/command/__init__.pyc
|
||||
${PYSITELIB}/setuptools/command/__init__.pyo
|
||||
${PYSITELIB}/setuptools/command/alias.py
|
||||
${PYSITELIB}/setuptools/command/alias.pyc
|
||||
${PYSITELIB}/setuptools/command/alias.pyo
|
||||
${PYSITELIB}/setuptools/command/bdist_egg.py
|
||||
${PYSITELIB}/setuptools/command/bdist_egg.pyc
|
||||
${PYSITELIB}/setuptools/command/bdist_egg.pyo
|
||||
${PYSITELIB}/setuptools/command/bdist_rpm.py
|
||||
${PYSITELIB}/setuptools/command/bdist_rpm.pyc
|
||||
${PYSITELIB}/setuptools/command/bdist_rpm.pyo
|
||||
${PYSITELIB}/setuptools/command/bdist_wininst.py
|
||||
${PYSITELIB}/setuptools/command/bdist_wininst.pyc
|
||||
${PYSITELIB}/setuptools/command/bdist_wininst.pyo
|
||||
${PYSITELIB}/setuptools/command/build_ext.py
|
||||
${PYSITELIB}/setuptools/command/build_ext.pyc
|
||||
${PYSITELIB}/setuptools/command/build_ext.pyo
|
||||
${PYSITELIB}/setuptools/command/build_py.py
|
||||
${PYSITELIB}/setuptools/command/build_py.pyc
|
||||
${PYSITELIB}/setuptools/command/build_py.pyo
|
||||
${PYSITELIB}/setuptools/command/develop.py
|
||||
${PYSITELIB}/setuptools/command/develop.pyc
|
||||
${PYSITELIB}/setuptools/command/develop.pyo
|
||||
${PYSITELIB}/setuptools/command/easy_install.py
|
||||
${PYSITELIB}/setuptools/command/easy_install.pyc
|
||||
${PYSITELIB}/setuptools/command/easy_install.pyo
|
||||
${PYSITELIB}/setuptools/command/egg_info.py
|
||||
${PYSITELIB}/setuptools/command/egg_info.pyc
|
||||
${PYSITELIB}/setuptools/command/egg_info.pyo
|
||||
${PYSITELIB}/setuptools/command/install.py
|
||||
${PYSITELIB}/setuptools/command/install.pyc
|
||||
${PYSITELIB}/setuptools/command/install.pyo
|
||||
${PYSITELIB}/setuptools/command/install_egg_info.py
|
||||
${PYSITELIB}/setuptools/command/install_egg_info.pyc
|
||||
${PYSITELIB}/setuptools/command/install_egg_info.pyo
|
||||
${PYSITELIB}/setuptools/command/install_lib.py
|
||||
${PYSITELIB}/setuptools/command/install_lib.pyc
|
||||
${PYSITELIB}/setuptools/command/install_lib.pyo
|
||||
${PYSITELIB}/setuptools/command/install_scripts.py
|
||||
${PYSITELIB}/setuptools/command/install_scripts.pyc
|
||||
${PYSITELIB}/setuptools/command/install_scripts.pyo
|
||||
${PYSITELIB}/setuptools/command/register.py
|
||||
${PYSITELIB}/setuptools/command/register.pyc
|
||||
${PYSITELIB}/setuptools/command/register.pyo
|
||||
${PYSITELIB}/setuptools/command/rotate.py
|
||||
${PYSITELIB}/setuptools/command/rotate.pyc
|
||||
${PYSITELIB}/setuptools/command/rotate.pyo
|
||||
${PYSITELIB}/setuptools/command/saveopts.py
|
||||
${PYSITELIB}/setuptools/command/saveopts.pyc
|
||||
${PYSITELIB}/setuptools/command/saveopts.pyo
|
||||
${PYSITELIB}/setuptools/command/sdist.py
|
||||
${PYSITELIB}/setuptools/command/sdist.pyc
|
||||
${PYSITELIB}/setuptools/command/sdist.pyo
|
||||
${PYSITELIB}/setuptools/command/setopt.py
|
||||
${PYSITELIB}/setuptools/command/setopt.pyc
|
||||
${PYSITELIB}/setuptools/command/setopt.pyo
|
||||
${PYSITELIB}/setuptools/command/test.py
|
||||
${PYSITELIB}/setuptools/command/test.pyc
|
||||
${PYSITELIB}/setuptools/command/test.pyo
|
||||
${PYSITELIB}/setuptools/command/upload.py
|
||||
${PYSITELIB}/setuptools/command/upload.pyc
|
||||
${PYSITELIB}/setuptools/command/upload.pyo
|
||||
${PYSITELIB}/setuptools/command/upload_docs.py
|
||||
${PYSITELIB}/setuptools/command/upload_docs.pyc
|
||||
${PYSITELIB}/setuptools/command/upload_docs.pyo
|
||||
${PYSITELIB}/setuptools/depends.py
|
||||
${PYSITELIB}/setuptools/depends.pyc
|
||||
${PYSITELIB}/setuptools/depends.pyo
|
||||
${PYSITELIB}/setuptools/dist.py
|
||||
${PYSITELIB}/setuptools/dist.pyc
|
||||
${PYSITELIB}/setuptools/dist.pyo
|
||||
${PYSITELIB}/setuptools/extension.py
|
||||
${PYSITELIB}/setuptools/extension.pyc
|
||||
${PYSITELIB}/setuptools/extension.pyo
|
||||
${PYSITELIB}/setuptools/gui-32.exe
|
||||
${PYSITELIB}/setuptools/gui-64.exe
|
||||
${PYSITELIB}/setuptools/gui.exe
|
||||
${PYSITELIB}/setuptools/package_index.py
|
||||
${PYSITELIB}/setuptools/package_index.pyc
|
||||
${PYSITELIB}/setuptools/package_index.pyo
|
||||
${PYSITELIB}/setuptools/sandbox.py
|
||||
${PYSITELIB}/setuptools/sandbox.pyc
|
||||
${PYSITELIB}/setuptools/sandbox.pyo
|
||||
${PYSITELIB}/setuptools/script template (dev).py
|
||||
${PYSITELIB}/setuptools/script template (dev).pyc
|
||||
${PYSITELIB}/setuptools/script template (dev).pyo
|
||||
${PYSITELIB}/setuptools/script template.py
|
||||
${PYSITELIB}/setuptools/script template.pyc
|
||||
${PYSITELIB}/setuptools/script template.pyo
|
||||
${PYSITELIB}/setuptools/tests/__init__.py
|
||||
${PYSITELIB}/setuptools/tests/__init__.pyc
|
||||
${PYSITELIB}/setuptools/tests/__init__.pyo
|
||||
${PYSITELIB}/setuptools/tests/doctest.py
|
||||
${PYSITELIB}/setuptools/tests/doctest.pyc
|
||||
${PYSITELIB}/setuptools/tests/doctest.pyo
|
||||
${PYSITELIB}/setuptools/tests/py26compat.py
|
||||
${PYSITELIB}/setuptools/tests/py26compat.pyc
|
||||
${PYSITELIB}/setuptools/tests/py26compat.pyo
|
||||
${PYSITELIB}/setuptools/tests/server.py
|
||||
${PYSITELIB}/setuptools/tests/server.pyc
|
||||
${PYSITELIB}/setuptools/tests/server.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_bdist_egg.py
|
||||
${PYSITELIB}/setuptools/tests/test_bdist_egg.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_bdist_egg.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_build_ext.py
|
||||
${PYSITELIB}/setuptools/tests/test_build_ext.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_build_ext.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_develop.py
|
||||
${PYSITELIB}/setuptools/tests/test_develop.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_develop.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_dist_info.py
|
||||
${PYSITELIB}/setuptools/tests/test_dist_info.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_dist_info.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_easy_install.py
|
||||
${PYSITELIB}/setuptools/tests/test_easy_install.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_easy_install.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_packageindex.py
|
||||
${PYSITELIB}/setuptools/tests/test_packageindex.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_packageindex.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_resources.py
|
||||
${PYSITELIB}/setuptools/tests/test_resources.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_resources.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_sandbox.py
|
||||
${PYSITELIB}/setuptools/tests/test_sandbox.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_sandbox.pyo
|
||||
${PYSITELIB}/setuptools/tests/test_upload_docs.py
|
||||
${PYSITELIB}/setuptools/tests/test_upload_docs.pyc
|
||||
${PYSITELIB}/setuptools/tests/test_upload_docs.pyo
|
||||
${PYSITELIB}/site.py
|
||||
${PYSITELIB}/site.pyc
|
||||
${PYSITELIB}/site.pyo
|
6
devel/py-distribute/distinfo
Normal file
6
devel/py-distribute/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1 2012/07/25 19:05:52 drochner Exp $
|
||||
|
||||
SHA1 (distribute-0.6.28.tar.gz) = 709bd97d46050d69865d4b588c7707768dfe6711
|
||||
RMD160 (distribute-0.6.28.tar.gz) = 6f484adca518fc59ef736bccf63d24ca3e94ecfc
|
||||
Size (distribute-0.6.28.tar.gz) = 627530 bytes
|
||||
SHA1 (patch-aa) = f71c01fc59d71e731c4e239790acb7968e29e7d9
|
13
devel/py-distribute/patches/patch-aa
Normal file
13
devel/py-distribute/patches/patch-aa
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-aa,v 1.1 2012/07/25 19:05:52 drochner Exp $
|
||||
|
||||
--- setup.py.orig 2012-07-22 20:26:44.000000000 +0000
|
||||
+++ setup.py
|
||||
@@ -49,7 +49,7 @@ from setuptools.command.test import test
|
||||
|
||||
scripts = []
|
||||
|
||||
-console_scripts = ["easy_install = setuptools.command.easy_install:main"]
|
||||
+console_scripts = []
|
||||
if os.environ.get("DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT") is None:
|
||||
console_scripts.append("easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3])
|
||||
|
Loading…
Reference in a new issue