devel/ruby-pycall: import ruby27-pycall-1.3.1

This library provides the features to directly call and partially
interoperate with Python from the Ruby language. You can import
arbitrary Python modules into Ruby modules, call Python functions
with automatic type conversion from Ruby to Python.
This commit is contained in:
ryoon 2020-09-20 08:34:37 +00:00
parent d9905fa0d5
commit 59d438990c
5 changed files with 121 additions and 0 deletions

4
devel/ruby-pycall/DESCR Normal file
View file

@ -0,0 +1,4 @@
This library provides the features to directly call and partially
interoperate with Python from the Ruby language. You can import
arbitrary Python modules into Ruby modules, call Python functions
with automatic type conversion from Ruby to Python.

View file

@ -0,0 +1,18 @@
# $NetBSD: Makefile,v 1.1 2020/09/20 08:34:37 ryoon Exp $
DISTNAME= pycall-1.3.1
MAINTAINER= ryoon@NetBSD.org
HOMEPAGE= https://github.com/mrkn/pycall.rb
COMMENT= Calling Python functions from Ruby
LICENSE= mit
SUBST_CLASSES+= python
SUBST_STAGE.python= pre-configure
SUBST_MESSAGE.python= USe python command from pkgsrc
SUBST_FILES.python= lib/pycall/libpython/finder.rb
SUBST_VARS.python= PYTHONBIN
.include "../../lang/ruby/gem.mk"
.include "../../lang/python/pyversion.mk"
.include "../../mk/bsd.pkg.mk"

78
devel/ruby-pycall/PLIST Normal file
View file

@ -0,0 +1,78 @@
@comment $NetBSD: PLIST,v 1.1 2020/09/20 08:34:37 ryoon Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_EXTSDIR}/gem.build_complete
${GEM_EXTSDIR}/pycall.${RUBY_DLEXT}
${GEM_LIBDIR}/.github/workflows/ci.yml
${GEM_LIBDIR}/.gitignore
${GEM_LIBDIR}/.rspec
${GEM_LIBDIR}/.travis.yml
${GEM_LIBDIR}/CHANGES.md
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/LICENSE.txt
${GEM_LIBDIR}/README.md
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/appveyor.yml
${GEM_LIBDIR}/bin/console
${GEM_LIBDIR}/bin/guard
${GEM_LIBDIR}/bin/rspec
${GEM_LIBDIR}/bin/runner
${GEM_LIBDIR}/bin/setup
${GEM_LIBDIR}/ci/travis_before_script.sh
${GEM_LIBDIR}/ci/travis_install.sh
${GEM_LIBDIR}/ci/travis_retry.sh
${GEM_LIBDIR}/config/Guardfile
${GEM_LIBDIR}/docker/Dockerfile
${GEM_LIBDIR}/docker/Gemfile
${GEM_LIBDIR}/docker/README.md
${GEM_LIBDIR}/examples/classifier_comparison.rb
${GEM_LIBDIR}/examples/datascience_rb_20170519.ipynb
${GEM_LIBDIR}/examples/hist.rb
${GEM_LIBDIR}/examples/notebooks/classifier_comparison.ipynb
${GEM_LIBDIR}/examples/notebooks/forest_importances.ipynb
${GEM_LIBDIR}/examples/notebooks/iruby_integration.ipynb
${GEM_LIBDIR}/examples/notebooks/lorenz_attractor.ipynb
${GEM_LIBDIR}/examples/notebooks/polar_axes.ipynb
${GEM_LIBDIR}/examples/notebooks/sum_benchmarking.ipynb
${GEM_LIBDIR}/examples/notebooks/xkcd_style.ipynb
${GEM_LIBDIR}/examples/plot_forest_importances_faces.rb
${GEM_LIBDIR}/examples/sum_benchmarking.rb
${GEM_LIBDIR}/ext/pycall/extconf.rb
${GEM_LIBDIR}/ext/pycall/gc.c
${GEM_LIBDIR}/ext/pycall/libpython.c
${GEM_LIBDIR}/ext/pycall/pycall.c
${GEM_LIBDIR}/ext/pycall/pycall.h
${GEM_LIBDIR}/ext/pycall/pycall_internal.h
${GEM_LIBDIR}/ext/pycall/range.c
${GEM_LIBDIR}/ext/pycall/ruby_wrapper.c
${GEM_LIBDIR}/ext/pycall/thread.c
${GEM_LIBDIR}/images/pycallrb_logo.png
${GEM_LIBDIR}/images/pycallrb_logo_200.png
${GEM_LIBDIR}/lib/pycall.rb
${GEM_LIBDIR}/lib/pycall.${RUBY_DLEXT}
${GEM_LIBDIR}/lib/pycall/dict.rb
${GEM_LIBDIR}/lib/pycall/error.rb
${GEM_LIBDIR}/lib/pycall/gc_guard.rb
${GEM_LIBDIR}/lib/pycall/import.rb
${GEM_LIBDIR}/lib/pycall/init.rb
${GEM_LIBDIR}/lib/pycall/iruby_helper.rb
${GEM_LIBDIR}/lib/pycall/libpython.rb
${GEM_LIBDIR}/lib/pycall/libpython/finder.rb
${GEM_LIBDIR}/lib/pycall/libpython/pyobject_struct.rb
${GEM_LIBDIR}/lib/pycall/libpython/pytypeobject_struct.rb
${GEM_LIBDIR}/lib/pycall/list.rb
${GEM_LIBDIR}/lib/pycall/pretty_print.rb
${GEM_LIBDIR}/lib/pycall/pyerror.rb
${GEM_LIBDIR}/lib/pycall/pymodule_wrapper.rb
${GEM_LIBDIR}/lib/pycall/pyobject_wrapper.rb
${GEM_LIBDIR}/lib/pycall/python/PyCall/__init__.py
${GEM_LIBDIR}/lib/pycall/python/PyCall/six.py
${GEM_LIBDIR}/lib/pycall/python/investigator.py
${GEM_LIBDIR}/lib/pycall/pytypeobject_wrapper.rb
${GEM_LIBDIR}/lib/pycall/set.rb
${GEM_LIBDIR}/lib/pycall/slice.rb
${GEM_LIBDIR}/lib/pycall/version.rb
${GEM_LIBDIR}/lib/pycall/wrapper_object_cache.rb
${GEM_LIBDIR}/pycall.gemspec
${GEM_LIBDIR}/tasks/docker.rake
${GEM_LIBDIR}/tasks/pycall.rake
${GEM_HOME}/specifications/${GEM_NAME}.gemspec

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1 2020/09/20 08:34:37 ryoon Exp $
SHA1 (pycall-1.3.1.gem) = c42bf7d95baadd0e4c7c1f0361e3218fa3c683ea
RMD160 (pycall-1.3.1.gem) = 643a59c8c6d56c356a4c1359e10d78c85be6b51f
SHA512 (pycall-1.3.1.gem) = 9fb65b0e9659455ae90f4b34d12f13c45e4d7e4c4efab5df9630ab4bfbef941cc3ee4d31ad535f256a8a8e6945d69b15fd9db11f949876800b7743e1d3c3d495
Size (pycall-1.3.1.gem) = 1577984 bytes
SHA1 (patch-lib_pycall_libpython_finder.rb) = 5f2903481232920acdb394e7b278d8afbe0b6ee5

View file

@ -0,0 +1,14 @@
$NetBSD: patch-lib_pycall_libpython_finder.rb,v 1.1 2020/09/20 08:34:37 ryoon Exp $
* Detect Python command from pkgsrc.
--- lib/pycall/libpython/finder.rb.orig 2020-09-18 09:47:08.145777201 +0000
+++ lib/pycall/libpython/finder.rb
@@ -20,6 +20,7 @@ module PyCall
class << self
DEFAULT_PYTHON = [
+ -'@PYTHONBIN@',
-'python3',
-'python',
].freeze