Add guavac 1.0, a Java compiler, to the NetBSD packages collection.
This package was done by "Martin J. Laubach" <mjl@emsi.priv.at>, and fixes PR pkg/4953. Small modicications by me to: (a) Get pre-formatted manual page handling right (although the page itself says version 0.2.5, so it's not exactly up-to-date) (b) Add NetBSD RCS Id to the PLIST. (c) Don't install an empty info file, and remove it from the PLIST. (d) Don't try to strip a script (gcok) on installation.
This commit is contained in:
parent
121502bf74
commit
59dbfe516d
6 changed files with 84 additions and 0 deletions
24
lang/guavac/Makefile
Normal file
24
lang/guavac/Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
# New ports collection makefile for: guavac
|
||||
# Version required: 1.0
|
||||
# Date created: 07-02-98
|
||||
# Whom: mjl@emsi.priv.at
|
||||
#
|
||||
# $NetBSD: Makefile,v 1.1 1998/02/10 15:45:03 agc Exp $
|
||||
#
|
||||
|
||||
CATEGORIES= lang
|
||||
DISTNAME= guavac-1.0
|
||||
MASTER_SITES= ftp://summit.stanford.edu/pub/guavac/ \
|
||||
ftp://ftp.Germany.EU.net/pub/programming/languages/java/guavac/ \
|
||||
ftp://sunsite.mff.cuni.cz/Languages/Java/guavac/ \
|
||||
ftp://sunsite.auc.dk/pub/languages/java/guavac/ \
|
||||
ftp://ftp.unicamp.br/pub/languages/java/guavac/
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
MAN1= guavac.1
|
||||
CAT1= guavac.0
|
||||
|
||||
post-install:
|
||||
${MV} ${PREFIX}/man/cat1/guavac.man ${PREFIX}/man/cat1/guavac.0
|
||||
|
||||
.include <bsd.port.mk>
|
1
lang/guavac/files/md5
Normal file
1
lang/guavac/files/md5
Normal file
|
@ -0,0 +1 @@
|
|||
MD5 (guavac-1.0.tar.gz) = d5456f8a90e66c5727e9a606b00fdfdd
|
39
lang/guavac/patches/patch-aa
Normal file
39
lang/guavac/patches/patch-aa
Normal file
|
@ -0,0 +1,39 @@
|
|||
--- doc/Makefile.in 1998/02/10 11:34:57 1.1
|
||||
+++ doc/Makefile.in 1998/02/10 11:35:41
|
||||
@@ -59,11 +59,11 @@
|
||||
else mv version.tmp $(srcdir)/version.texi; fi
|
||||
date > $@
|
||||
|
||||
-install: all
|
||||
- $(srcdir)/../mkinstalldirs $(infodir)
|
||||
- cd $(srcdir) && for file in $(PRODUCT).info*; do \
|
||||
- $(INSTALL_DATA) $$file $(infodir)/$$file; \
|
||||
- done
|
||||
+install: all;
|
||||
+# $(srcdir)/../mkinstalldirs $(infodir)
|
||||
+# cd $(srcdir) && for file in $(PRODUCT).info*; do \
|
||||
+# $(INSTALL_DATA) $$file $(infodir)/$$file; \
|
||||
+# done
|
||||
|
||||
uninstall:
|
||||
rm -f $(infodir)/$(PRODUCT).info*
|
||||
--- checks/Makefile.in 1998/02/10 14:56:28 1.1
|
||||
+++ checks/Makefile.in 1998/02/10 14:56:45
|
||||
@@ -26,7 +26,7 @@
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_DATA = @INSTALL_DATA@
|
||||
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
+INSTALL_SCRIPT = ${INSTALL} -m 0755
|
||||
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
@@ -39,7 +39,7 @@
|
||||
install:
|
||||
$(srcdir)/../mkinstalldirs $(bindir)
|
||||
cd $(srcdir) && for file in gcok; do \
|
||||
- $(INSTALL_PROGRAM) $$file $(bindir)/$$file; \
|
||||
+ $(INSTALL_SCRIPT) $$file $(bindir)/$$file; \
|
||||
done
|
||||
|
||||
uninstall:
|
1
lang/guavac/pkg/COMMENT
Normal file
1
lang/guavac/pkg/COMMENT
Normal file
|
@ -0,0 +1 @@
|
|||
A free compiler for the Java language
|
11
lang/guavac/pkg/DESCR
Normal file
11
lang/guavac/pkg/DESCR
Normal file
|
@ -0,0 +1,11 @@
|
|||
Guavac is a compiler for the Java language, written by Effective Edge
|
||||
Technologies and distributed under the Gnu Public License. You should feel
|
||||
free to use, copy and modify it, based on the terms in the COPYING file
|
||||
included in this distribution.
|
||||
We are distributing guavac free of charge in the hopes that other people will
|
||||
find it useful and possibly enhance its utility in turn.
|
||||
|
||||
Guavac should produce correct bytecode for valid Java input, but you may
|
||||
encounter some difficulties in compiling guavac itself, due inadequate
|
||||
tools on some platforms.
|
||||
|
8
lang/guavac/pkg/PLIST
Normal file
8
lang/guavac/pkg/PLIST
Normal file
|
@ -0,0 +1,8 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 1998/02/10 15:45:12 agc Exp $
|
||||
bin/guavac
|
||||
bin/guavad
|
||||
bin/gcok
|
||||
man/cat1/guavac.0
|
||||
man/man1/guavac.1
|
||||
share/guavac/classes.zip
|
||||
@dirrm share/guavac
|
Loading…
Reference in a new issue