Fix compilation with g++2, per a hint from hubertf.

This commit is contained in:
wiz 2004-04-03 11:28:53 +00:00
parent 711715e9b9
commit 59dc20ae2f
2 changed files with 28 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.1.1.1 2004/03/29 22:04:09 recht Exp $
$NetBSD: distinfo,v 1.2 2004/04/03 11:28:53 wiz Exp $
SHA1 (ttmkfdir2.20021109.tar.bz2) = bee1944ce3e5b6c4503a14e6429737cc558a24c0
Size (ttmkfdir2.20021109.tar.bz2) = 701900 bytes
SHA1 (patch-aa) = 513c6922cfa60a6c2dbf332a5d65e0277bd89929
SHA1 (patch-ab) = d22b1eb7de9c2ba622583bb2e2fe6c4ccd4b26d2
SHA1 (patch-ac) = 23eb6e500522a1ce826a9b0899d7afff6017d096
SHA1 (patch-ad) = 0c328908ffae3397293ff6b00094444e23164788

View file

@ -0,0 +1,26 @@
$NetBSD: patch-ad,v 1.1 2004/04/03 11:28:53 wiz Exp $
--- directory.cpp.orig Tue Jan 11 01:44:44 2000
+++ directory.cpp
@@ -5,6 +5,8 @@
#include "directory.h"
+using namespace std;
+
directory::~directory (void)
{
}
@@ -48,8 +50,8 @@ ttfdirectory::select (const char *name)
/* we make the decision by the extension of the file name */
return (((len = strlen (name)) > 4) &&
(name[len - 4] == '.') &&
- (std::toupper(name[len - 3]) == 'T') &&
- (std::toupper(name[len - 2]) == 'T') &&
- ((std::toupper(name[len - 1]) == 'F') ||
- (std::toupper(name[len - 1]) == 'C')));
+ (toupper(name[len - 3]) == 'T') &&
+ (toupper(name[len - 2]) == 'T') &&
+ ((toupper(name[len - 1]) == 'F') ||
+ (toupper(name[len - 1]) == 'C')));
}