Import wireshark-2.0.1 as net/wireshark2.
Wireshark is a network traffic analyzer, or "sniffer", for Unix and Unix-like operating systems. It uses GTK+, a graphical user interface library, and libpcap, a packet capture and filtering library. The Wireshark distribution also comes with TShark, which is a line-oriented sniffer (similar to Sun's snoop, or tcpdump) that uses the same dissection, capture-file reading and writing, and packet filtering code as Wireshark, and with editcap, which is a program to read capture files and write the packets from that capture file, possibly in a different capture file format, and with some packets possibly removed from the capture. This package tracks version 2 stable branch.
This commit is contained in:
parent
c203572012
commit
59ef8f6071
8 changed files with 611 additions and 0 deletions
13
net/wireshark2/DESCR
Normal file
13
net/wireshark2/DESCR
Normal file
|
@ -0,0 +1,13 @@
|
|||
Wireshark is a network traffic analyzer, or "sniffer", for Unix and
|
||||
Unix-like operating systems. It uses GTK+, a graphical user interface
|
||||
library, and libpcap, a packet capture and filtering library.
|
||||
|
||||
The Wireshark distribution also comes with TShark, which is a
|
||||
line-oriented sniffer (similar to Sun's snoop, or tcpdump) that uses the
|
||||
same dissection, capture-file reading and writing, and packet filtering
|
||||
code as Wireshark, and with editcap, which is a program to read capture
|
||||
files and write the packets from that capture file, possibly in a
|
||||
different capture file format, and with some packets possibly removed
|
||||
from the capture.
|
||||
|
||||
This package tracks version 2 stable branch.
|
85
net/wireshark2/Makefile
Normal file
85
net/wireshark2/Makefile
Normal file
|
@ -0,0 +1,85 @@
|
|||
# $NetBSD: Makefile,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
DISTNAME= wireshark-2.0.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= https://www.wireshark.org/download/src/
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://www.wireshark.org/
|
||||
COMMENT= Network protocol analyzer
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
CONFLICTS+= ethereal-[0-9]*
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_TOOLS+= gmake perl pkg-config yacc lex
|
||||
|
||||
USE_LIBTOOL= yes
|
||||
SHLIBTOOL_OVERRIDE= # empty
|
||||
CHECK_PORTABILITY_SKIP+=packaging/macosx/*/*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --enable-static=no
|
||||
CONFIGURE_ARGS+= --with-ssl=${SSLBASE:Q}
|
||||
CONFIGURE_ARGS+= --with-pcap=${BUILDLINK_PREFIX.libpcap}
|
||||
CONFIGURE_ARGS+= --with-zlib=${BUILDLINK_PREFIX.zlib}
|
||||
CONFIGURE_ENV+= ac_cv_path_YACCDUMMY=${TOOLS_PATH.yacc}
|
||||
CONFIGURE_ENV+= ac_cv_path_LEXDUMMY=${TOOLS_PATH.lex}
|
||||
|
||||
PTHREAD_OPTS+= require
|
||||
|
||||
PYTHON_FOR_BUILD_ONLY= yes
|
||||
PYTHON_VERSIONS_INCOMPATIBLE= 33 34 35 # not yet ported as of 1.10.5
|
||||
REPLACE_PYTHON+= help/faq.py
|
||||
REPLACE_PYTHON+= tools/asn2deb
|
||||
REPLACE_PYTHON+= tools/asn2wrs.py
|
||||
REPLACE_PYTHON+= tools/dfilter-test.py
|
||||
REPLACE_PYTHON+= tools/ftsanity.py
|
||||
REPLACE_PYTHON+= tools/html2text.py
|
||||
REPLACE_PYTHON+= tools/idl2deb
|
||||
REPLACE_PYTHON+= tools/indexcap.py
|
||||
REPLACE_PYTHON+= tools/make-dissector-reg.py
|
||||
REPLACE_PYTHON+= tools/make-tap-reg.py
|
||||
REPLACE_PYTHON+= tools/msnchat
|
||||
REPLACE_PYTHON+= tools/ncp2222.py
|
||||
REPLACE_PYTHON+= tools/netscreen2dump.py
|
||||
REPLACE_PYTHON+= tools/pkt-from-core.py
|
||||
REPLACE_PYTHON+= tools/rdps.py
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
.include "options.mk"
|
||||
|
||||
.if !empty(MACHINE_PLATFORM:MDarwin-[567].*-*)
|
||||
USE_BUILTIN.libpcap= no
|
||||
.endif
|
||||
|
||||
.if ${OPSYS} == "Darwin"
|
||||
CONFIGURE_ARGS+= --disable-osx-deploy-target
|
||||
.endif
|
||||
|
||||
# Extra post install targets are in options.mk
|
||||
post-install: ${POST_INSTALL_TARGETS}
|
||||
|
||||
# wireshark no longer builds with NetBSD 3.x provided zlib
|
||||
BUILDLINK_API_DEPENDS.zlib=zlib>=1.2.1
|
||||
|
||||
# wireshark uses gdk_pixbuf_new_from_inline which is deprecated, but asks
|
||||
# to hide deprecated prototypes. This leads to pointer truncation.
|
||||
# gui_utils.c:514:12: warning: incompatible integer to pointer conversion
|
||||
# assigning to 'GdkPixbuf *' (aka 'struct _GdkPixbuf *') from 'int'
|
||||
# [-Wint-conversion]
|
||||
BUILDLINK_TRANSFORM+= rm:-DGDK_PIXBUF_DISABLE_DEPRECATED
|
||||
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../net/libpcap/buildlink3.mk"
|
||||
.include "../../devel/libsmi/buildlink3.mk"
|
||||
.include "../../security/libgcrypt/buildlink3.mk"
|
||||
.include "../../security/gnutls/buildlink3.mk"
|
||||
.include "../../security/openssl/buildlink3.mk"
|
||||
|
||||
.include "../../lang/python/application.mk"
|
||||
.include "../../mk/pthread.buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
345
net/wireshark2/PLIST
Normal file
345
net/wireshark2/PLIST
Normal file
|
@ -0,0 +1,345 @@
|
|||
@comment $NetBSD: PLIST,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
bin/androiddump
|
||||
bin/capinfos
|
||||
bin/captype
|
||||
bin/dftest
|
||||
bin/dumpcap
|
||||
bin/editcap
|
||||
bin/idl2wrs
|
||||
bin/mergecap
|
||||
bin/randpkt
|
||||
bin/rawshark
|
||||
bin/reordercap
|
||||
bin/text2pcap
|
||||
bin/tshark
|
||||
${PLIST.gtk3}bin/wireshark-gtk
|
||||
${PLIST.qt5}bin/wireshark
|
||||
lib/libwireshark.la
|
||||
lib/libwiretap.la
|
||||
lib/libwsutil.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/docsis.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/ethercat.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/gryphon.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/irda.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/m2m.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/mate.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/opcua.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/profinet.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/stats_tree.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/unistim.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/wimax.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/wimaxasncp.la
|
||||
lib/wireshark/plugins/${PKGVERSION}/wimaxmacphy.la
|
||||
man/man1/capinfos.1
|
||||
man/man1/dftest.1
|
||||
man/man1/dumpcap.1
|
||||
man/man1/editcap.1
|
||||
man/man1/mergecap.1
|
||||
man/man1/randpkt.1
|
||||
man/man1/rawshark.1
|
||||
man/man1/reordercap.1
|
||||
man/man1/text2pcap.1
|
||||
man/man1/tshark.1
|
||||
${PLIST.icons}man/man1/wireshark.1
|
||||
man/man4/wireshark-filter.4
|
||||
${PLIST.icons}share/appdata/wireshark.appdata.xml
|
||||
${PLIST.icons}share/applications/wireshark-gtk.desktop
|
||||
${PLIST.icons}share/applications/wireshark.desktop
|
||||
${PLIST.icons}share/icons/hicolor/128x128/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/128x128/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/128x128/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/16x16/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/16x16/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/16x16/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/24x24/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/24x24/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/24x24/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/256x256/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/256x256/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/256x256/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/32x32/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/32x32/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/32x32/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/48x48/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/48x48/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/48x48/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/64x64/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/hicolor/64x64/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
${PLIST.icons}share/icons/hicolor/64x64/mimetypes/application-wireshark-doc.png
|
||||
${PLIST.icons}share/icons/hicolor/scalable/apps/wireshark.svg
|
||||
${PLIST.icons}share/icons/locolor/16x16/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/locolor/32x32/apps/wireshark.png
|
||||
${PLIST.icons}share/icons/locolor/48x48/apps/wireshark.png
|
||||
${PLIST.icons}share/mime/packages/wireshark.xml
|
||||
share/wireshark/AUTHORS-SHORT
|
||||
share/wireshark/COPYING
|
||||
share/wireshark/androiddump.html
|
||||
share/wireshark/capinfos.html
|
||||
share/wireshark/cfilters
|
||||
share/wireshark/colorfilters
|
||||
${PLIST.lua}share/wireshark/console.lua
|
||||
share/wireshark/dfilters
|
||||
share/wireshark/dftest.html
|
||||
share/wireshark/diameter/AlcatelLucent.xml
|
||||
share/wireshark/diameter/Cisco.xml
|
||||
share/wireshark/diameter/Custom.xml
|
||||
share/wireshark/diameter/Ericsson.xml
|
||||
share/wireshark/diameter/HP.xml
|
||||
share/wireshark/diameter/Nokia.xml
|
||||
share/wireshark/diameter/NokiaSolutionsAndNetworks.xml
|
||||
share/wireshark/diameter/Oracle.xml
|
||||
share/wireshark/diameter/Starent.xml
|
||||
share/wireshark/diameter/TGPP.xml
|
||||
share/wireshark/diameter/TGPP2.xml
|
||||
share/wireshark/diameter/Vodafone.xml
|
||||
share/wireshark/diameter/chargecontrol.xml
|
||||
share/wireshark/diameter/dictionary.dtd
|
||||
share/wireshark/diameter/dictionary.xml
|
||||
share/wireshark/diameter/eap.xml
|
||||
share/wireshark/diameter/etsie2e4.xml
|
||||
share/wireshark/diameter/mobileipv4.xml
|
||||
share/wireshark/diameter/mobileipv6.xml
|
||||
share/wireshark/diameter/nasreq.xml
|
||||
share/wireshark/diameter/sip.xml
|
||||
share/wireshark/diameter/sunping.xml
|
||||
${PLIST.lua}share/wireshark/dtd_gen.lua
|
||||
share/wireshark/dtds/dc.dtd
|
||||
share/wireshark/dtds/itunes.dtd
|
||||
share/wireshark/dtds/mscml.dtd
|
||||
share/wireshark/dtds/pocsettings.dtd
|
||||
share/wireshark/dtds/presence.dtd
|
||||
share/wireshark/dtds/reginfo.dtd
|
||||
share/wireshark/dtds/rlmi.dtd
|
||||
share/wireshark/dtds/rss.dtd
|
||||
share/wireshark/dtds/smil.dtd
|
||||
share/wireshark/dtds/watcherinfo.dtd
|
||||
share/wireshark/dtds/xcap-caps.dtd
|
||||
share/wireshark/dtds/xcap-error.dtd
|
||||
share/wireshark/dumpcap.html
|
||||
share/wireshark/editcap.html
|
||||
share/wireshark/help/capture_filters.txt
|
||||
share/wireshark/help/capturing.txt
|
||||
share/wireshark/help/display_filters.txt
|
||||
share/wireshark/help/faq.txt
|
||||
share/wireshark/help/getting_started.txt
|
||||
share/wireshark/help/overview.txt
|
||||
share/wireshark/help/toc
|
||||
${PLIST.lua}share/wireshark/init.lua
|
||||
share/wireshark/ipmap.html
|
||||
share/wireshark/manuf
|
||||
share/wireshark/mergecap.html
|
||||
share/wireshark/pdml2html.xsl
|
||||
share/wireshark/profiles/Bluetooth/colorfilters
|
||||
share/wireshark/profiles/Classic/colorfilters
|
||||
share/wireshark/radius/README.radius_dictionary
|
||||
share/wireshark/radius/custom.includes
|
||||
share/wireshark/radius/dictionary
|
||||
share/wireshark/radius/dictionary.3com
|
||||
share/wireshark/radius/dictionary.3gpp
|
||||
share/wireshark/radius/dictionary.3gpp2
|
||||
share/wireshark/radius/dictionary.acc
|
||||
share/wireshark/radius/dictionary.acme
|
||||
share/wireshark/radius/dictionary.actelis
|
||||
share/wireshark/radius/dictionary.aerohive
|
||||
share/wireshark/radius/dictionary.airespace
|
||||
share/wireshark/radius/dictionary.alcatel
|
||||
share/wireshark/radius/dictionary.alcatel-lucent.aaa
|
||||
share/wireshark/radius/dictionary.alcatel.esam
|
||||
share/wireshark/radius/dictionary.alcatel.sr
|
||||
share/wireshark/radius/dictionary.alteon
|
||||
share/wireshark/radius/dictionary.altiga
|
||||
share/wireshark/radius/dictionary.alvarion
|
||||
share/wireshark/radius/dictionary.alvarion.wimax.v2_2
|
||||
share/wireshark/radius/dictionary.apc
|
||||
share/wireshark/radius/dictionary.aptis
|
||||
share/wireshark/radius/dictionary.arbor
|
||||
share/wireshark/radius/dictionary.aruba
|
||||
share/wireshark/radius/dictionary.ascend
|
||||
share/wireshark/radius/dictionary.asn
|
||||
share/wireshark/radius/dictionary.audiocodes
|
||||
share/wireshark/radius/dictionary.avaya
|
||||
share/wireshark/radius/dictionary.azaire
|
||||
share/wireshark/radius/dictionary.bay
|
||||
share/wireshark/radius/dictionary.bintec
|
||||
share/wireshark/radius/dictionary.bluecoat
|
||||
share/wireshark/radius/dictionary.bristol
|
||||
share/wireshark/radius/dictionary.broadsoft
|
||||
share/wireshark/radius/dictionary.brocade
|
||||
share/wireshark/radius/dictionary.bskyb
|
||||
share/wireshark/radius/dictionary.bt
|
||||
share/wireshark/radius/dictionary.cablelabs
|
||||
share/wireshark/radius/dictionary.cabletron
|
||||
share/wireshark/radius/dictionary.camiant
|
||||
share/wireshark/radius/dictionary.chillispot
|
||||
share/wireshark/radius/dictionary.cisco
|
||||
share/wireshark/radius/dictionary.cisco.asa
|
||||
share/wireshark/radius/dictionary.cisco.bbsm
|
||||
share/wireshark/radius/dictionary.cisco.vpn3000
|
||||
share/wireshark/radius/dictionary.cisco.vpn5000
|
||||
share/wireshark/radius/dictionary.citrix
|
||||
share/wireshark/radius/dictionary.clavister
|
||||
share/wireshark/radius/dictionary.colubris
|
||||
share/wireshark/radius/dictionary.columbia_university
|
||||
share/wireshark/radius/dictionary.compat
|
||||
share/wireshark/radius/dictionary.compatible
|
||||
share/wireshark/radius/dictionary.cosine
|
||||
share/wireshark/radius/dictionary.dante
|
||||
share/wireshark/radius/dictionary.dhcp
|
||||
share/wireshark/radius/dictionary.digium
|
||||
share/wireshark/radius/dictionary.dlink
|
||||
share/wireshark/radius/dictionary.dragonwave
|
||||
share/wireshark/radius/dictionary.efficientip
|
||||
share/wireshark/radius/dictionary.eltex
|
||||
share/wireshark/radius/dictionary.epygi
|
||||
share/wireshark/radius/dictionary.equallogic
|
||||
share/wireshark/radius/dictionary.ericsson
|
||||
share/wireshark/radius/dictionary.ericsson.ab
|
||||
share/wireshark/radius/dictionary.ericsson.packet.core.networks
|
||||
share/wireshark/radius/dictionary.erx
|
||||
share/wireshark/radius/dictionary.extreme
|
||||
share/wireshark/radius/dictionary.f5
|
||||
share/wireshark/radius/dictionary.fdxtended
|
||||
share/wireshark/radius/dictionary.fortinet
|
||||
share/wireshark/radius/dictionary.foundry
|
||||
share/wireshark/radius/dictionary.freedhcp
|
||||
share/wireshark/radius/dictionary.freeradius
|
||||
share/wireshark/radius/dictionary.freeradius.internal
|
||||
share/wireshark/radius/dictionary.freeswitch
|
||||
share/wireshark/radius/dictionary.gandalf
|
||||
share/wireshark/radius/dictionary.garderos
|
||||
share/wireshark/radius/dictionary.gemtek
|
||||
share/wireshark/radius/dictionary.h3c
|
||||
share/wireshark/radius/dictionary.hp
|
||||
share/wireshark/radius/dictionary.huawei
|
||||
share/wireshark/radius/dictionary.iana
|
||||
share/wireshark/radius/dictionary.iea
|
||||
share/wireshark/radius/dictionary.infoblox
|
||||
share/wireshark/radius/dictionary.infonet
|
||||
share/wireshark/radius/dictionary.ipunplugged
|
||||
share/wireshark/radius/dictionary.issanni
|
||||
share/wireshark/radius/dictionary.itk
|
||||
share/wireshark/radius/dictionary.jradius
|
||||
share/wireshark/radius/dictionary.juniper
|
||||
share/wireshark/radius/dictionary.karlnet
|
||||
share/wireshark/radius/dictionary.kineto
|
||||
share/wireshark/radius/dictionary.lancom
|
||||
share/wireshark/radius/dictionary.livingston
|
||||
share/wireshark/radius/dictionary.localweb
|
||||
share/wireshark/radius/dictionary.lucent
|
||||
share/wireshark/radius/dictionary.manzara
|
||||
share/wireshark/radius/dictionary.meinberg
|
||||
share/wireshark/radius/dictionary.merit
|
||||
share/wireshark/radius/dictionary.meru
|
||||
share/wireshark/radius/dictionary.microsoft
|
||||
share/wireshark/radius/dictionary.mikrotik
|
||||
share/wireshark/radius/dictionary.motorola
|
||||
share/wireshark/radius/dictionary.motorola.wimax
|
||||
share/wireshark/radius/dictionary.navini
|
||||
share/wireshark/radius/dictionary.netscreen
|
||||
share/wireshark/radius/dictionary.networkphysics
|
||||
share/wireshark/radius/dictionary.nexans
|
||||
share/wireshark/radius/dictionary.nokia
|
||||
share/wireshark/radius/dictionary.nokia.conflict
|
||||
share/wireshark/radius/dictionary.nomadix
|
||||
share/wireshark/radius/dictionary.nortel
|
||||
share/wireshark/radius/dictionary.ntua
|
||||
share/wireshark/radius/dictionary.openser
|
||||
share/wireshark/radius/dictionary.packeteer
|
||||
share/wireshark/radius/dictionary.paloalto
|
||||
share/wireshark/radius/dictionary.patton
|
||||
share/wireshark/radius/dictionary.perle
|
||||
share/wireshark/radius/dictionary.propel
|
||||
share/wireshark/radius/dictionary.prosoft
|
||||
share/wireshark/radius/dictionary.proxim
|
||||
share/wireshark/radius/dictionary.purewave
|
||||
share/wireshark/radius/dictionary.quiconnect
|
||||
share/wireshark/radius/dictionary.quintum
|
||||
share/wireshark/radius/dictionary.redcreek
|
||||
share/wireshark/radius/dictionary.rfc2865
|
||||
share/wireshark/radius/dictionary.rfc2866
|
||||
share/wireshark/radius/dictionary.rfc2867
|
||||
share/wireshark/radius/dictionary.rfc2868
|
||||
share/wireshark/radius/dictionary.rfc2869
|
||||
share/wireshark/radius/dictionary.rfc3162
|
||||
share/wireshark/radius/dictionary.rfc3576
|
||||
share/wireshark/radius/dictionary.rfc3580
|
||||
share/wireshark/radius/dictionary.rfc4072
|
||||
share/wireshark/radius/dictionary.rfc4372
|
||||
share/wireshark/radius/dictionary.rfc4603
|
||||
share/wireshark/radius/dictionary.rfc4675
|
||||
share/wireshark/radius/dictionary.rfc4679
|
||||
share/wireshark/radius/dictionary.rfc4818
|
||||
share/wireshark/radius/dictionary.rfc4849
|
||||
share/wireshark/radius/dictionary.rfc5090
|
||||
share/wireshark/radius/dictionary.rfc5176
|
||||
share/wireshark/radius/dictionary.rfc5447
|
||||
share/wireshark/radius/dictionary.rfc5580
|
||||
share/wireshark/radius/dictionary.rfc5607
|
||||
share/wireshark/radius/dictionary.rfc5904
|
||||
share/wireshark/radius/dictionary.rfc6519
|
||||
share/wireshark/radius/dictionary.rfc6572
|
||||
share/wireshark/radius/dictionary.rfc6677
|
||||
share/wireshark/radius/dictionary.rfc6911
|
||||
share/wireshark/radius/dictionary.rfc6929
|
||||
share/wireshark/radius/dictionary.rfc6930
|
||||
share/wireshark/radius/dictionary.rfc7055
|
||||
share/wireshark/radius/dictionary.rfc7155
|
||||
share/wireshark/radius/dictionary.rfc7268
|
||||
share/wireshark/radius/dictionary.rfc7499
|
||||
share/wireshark/radius/dictionary.riverbed
|
||||
share/wireshark/radius/dictionary.riverstone
|
||||
share/wireshark/radius/dictionary.roaringpenguin
|
||||
share/wireshark/radius/dictionary.ruckus
|
||||
share/wireshark/radius/dictionary.ruggedcom
|
||||
share/wireshark/radius/dictionary.sg
|
||||
share/wireshark/radius/dictionary.shasta
|
||||
share/wireshark/radius/dictionary.shiva
|
||||
share/wireshark/radius/dictionary.siemens
|
||||
share/wireshark/radius/dictionary.slipstream
|
||||
share/wireshark/radius/dictionary.sofaware
|
||||
share/wireshark/radius/dictionary.sonicwall
|
||||
share/wireshark/radius/dictionary.springtide
|
||||
share/wireshark/radius/dictionary.starent
|
||||
share/wireshark/radius/dictionary.starent.vsa1
|
||||
share/wireshark/radius/dictionary.surfnet
|
||||
share/wireshark/radius/dictionary.symbol
|
||||
share/wireshark/radius/dictionary.t_systems_nova
|
||||
share/wireshark/radius/dictionary.telebit
|
||||
share/wireshark/radius/dictionary.telkom
|
||||
share/wireshark/radius/dictionary.terena
|
||||
share/wireshark/radius/dictionary.trapeze
|
||||
share/wireshark/radius/dictionary.travelping
|
||||
share/wireshark/radius/dictionary.tropos
|
||||
share/wireshark/radius/dictionary.ukerna
|
||||
share/wireshark/radius/dictionary.unix
|
||||
share/wireshark/radius/dictionary.usr
|
||||
share/wireshark/radius/dictionary.utstarcom
|
||||
share/wireshark/radius/dictionary.valemount
|
||||
share/wireshark/radius/dictionary.versanet
|
||||
share/wireshark/radius/dictionary.vqp
|
||||
share/wireshark/radius/dictionary.walabi
|
||||
share/wireshark/radius/dictionary.waverider
|
||||
share/wireshark/radius/dictionary.wichorus
|
||||
share/wireshark/radius/dictionary.wimax
|
||||
share/wireshark/radius/dictionary.wimax.alvarion
|
||||
share/wireshark/radius/dictionary.wimax.wichorus
|
||||
share/wireshark/radius/dictionary.wispr
|
||||
share/wireshark/radius/dictionary.xedia
|
||||
share/wireshark/radius/dictionary.xylan
|
||||
share/wireshark/radius/dictionary.yubico
|
||||
share/wireshark/radius/dictionary.zeus
|
||||
share/wireshark/radius/dictionary.zte
|
||||
share/wireshark/radius/dictionary.zyxel
|
||||
share/wireshark/randpkt.html
|
||||
share/wireshark/rawshark.html
|
||||
share/wireshark/reordercap.html
|
||||
share/wireshark/services
|
||||
share/wireshark/smi_modules
|
||||
share/wireshark/text2pcap.html
|
||||
share/wireshark/tpncp/tpncp.dat
|
||||
share/wireshark/tshark.html
|
||||
share/wireshark/wimaxasncp/dictionary.dtd
|
||||
share/wireshark/wimaxasncp/dictionary.xml
|
||||
share/wireshark/wireshark-filter.html
|
||||
share/wireshark/wireshark.html
|
||||
share/wireshark/ws.css
|
9
net/wireshark2/distinfo
Normal file
9
net/wireshark2/distinfo
Normal file
|
@ -0,0 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
SHA1 (wireshark-2.0.1.tar.bz2) = 6703221128305ac33802f0da13d368476ce90688
|
||||
RMD160 (wireshark-2.0.1.tar.bz2) = 0a83fb6d2c74005840492d0811a4eca29b565602
|
||||
SHA512 (wireshark-2.0.1.tar.bz2) = fc029759cecd10d20bd323d6ea41d6bd1326a1a0f8d847d681ce218eb0e7ece84fba4e91709adab556e9495812bf0fa8bcb40318053e6403c3d5c9d899d544ca
|
||||
Size (wireshark-2.0.1.tar.bz2) = 31016295 bytes
|
||||
SHA1 (patch-configure) = 23a639e38dfc3192b55afc3b605efc3bd70588f4
|
||||
SHA1 (patch-configure.ac) = e69ef2d5468287e0339ccf30a1f33b077626ff94
|
||||
SHA1 (patch-ui_qt_mtp3__summary__dialog.cpp) = 3d434377581e1993802fbe4b02c98849d0e6a9bb
|
100
net/wireshark2/options.mk
Normal file
100
net/wireshark2/options.mk
Normal file
|
@ -0,0 +1,100 @@
|
|||
# $NetBSD: options.mk,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
PKG_OPTIONS_VAR= PKG_OPTIONS.wireshark
|
||||
PKG_SUPPORTED_OPTIONS= gtk3 lua qt5
|
||||
PKG_SUGGESTED_OPTIONS= gtk3 lua
|
||||
.include "../../mk/bsd.options.mk"
|
||||
|
||||
PLIST_VARS+= gtk3 icons qt5
|
||||
|
||||
.if empty(PKG_OPTIONS:Mqt5)
|
||||
CONFIGURE_ARGS+= --without-qt
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-qt=5
|
||||
CONFIGURE_ENV+= MOC=${QTDIR}/bin/moc
|
||||
CONFIGURE_ENV+= RCC=${QTDIR}/bin/rcc
|
||||
CONFIGURE_ENV+= UIC=${QTDIR}/bin/uic
|
||||
# RCC is not configured, so fix it here; see patch-ui_qt_Makefile.in
|
||||
SUBST_CLASSES+= fix-rcc
|
||||
SUBST_MESSAGE.fix-rcc= Fixing rcc path.
|
||||
SUBST_STAGE.fix-rcc= pre-configure
|
||||
SUBST_FILES.fix-rcc= ui/qt/Makefile.in
|
||||
SUBST_SED.fix-rcc= -e 's,@RCC@,${QTDIR}/bin/rcc,'
|
||||
PLIST.qt5= yes
|
||||
.include "../../x11/qt5-qtbase/buildlink3.mk"
|
||||
. if ${OPSYS} == "Darwin"
|
||||
.include "../../x11/qt5-qtmacextras/buildlink3.mk"
|
||||
. else
|
||||
.include "../../x11/qt5-qtx11extras/buildlink3.mk"
|
||||
. endif
|
||||
.endif
|
||||
|
||||
.if empty(PKG_OPTIONS:Mgtk3)
|
||||
CONFIGURE_ARGS+= --without-gtk3
|
||||
.else
|
||||
CONFIGURE_ARGS+= --with-gtk3
|
||||
PLIST.gtk3= yes
|
||||
POST_INSTALL_TARGETS+= install-gtk-desktop
|
||||
.include "../../x11/gtk3/buildlink3.mk"
|
||||
|
||||
.PHONY: install-gtk-desktop
|
||||
install-gtk-desktop:
|
||||
${INSTALL_DATA} ${WRKSRC}/wireshark.desktop \
|
||||
${DESTDIR}${PREFIX}/share/applications
|
||||
|
||||
.endif
|
||||
|
||||
# We might install the qt front end one day as well,
|
||||
# so have a generic icon target
|
||||
.if !empty(PKG_OPTIONS:Mgtk3) || !empty(PKG_OPTIONS:Mqt5)
|
||||
CONFIGURE_ARGS+= --enable-wireshark
|
||||
PLIST.icons= yes
|
||||
POST_INSTALL_TARGETS+= install-icons
|
||||
INSTALLATION_DIRS+= share/applications
|
||||
INSTALLATION_DIRS+= share/icons/hicolor/scalable/apps
|
||||
ICON_COLORS= hi lo
|
||||
ICON_SIZES= 16 32 48
|
||||
MIMEICON_SIZES= 16 24 32 48 64 128 256
|
||||
|
||||
. for c in ${ICON_COLORS}
|
||||
. for d in ${ICON_SIZES}
|
||||
INSTALLATION_DIRS+= share/icons/${c}color/${d}x${d}/apps
|
||||
. endfor
|
||||
. endfor
|
||||
|
||||
. for d in ${MIMEICON_SIZES}
|
||||
INSTALLATION_DIRS+= share/icons/hicolor/${d}x${d}/mimetypes
|
||||
. endfor
|
||||
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||
|
||||
.PHONY: install-icons
|
||||
install-icons:
|
||||
${INSTALL_DATA} ${WRKSRC}/image/wsicon.svg \
|
||||
${DESTDIR}${PREFIX}/share/icons/hicolor/scalable/apps/wireshark.svg
|
||||
. for c in ${ICON_COLORS}
|
||||
. for d in ${ICON_SIZES}
|
||||
${INSTALL_DATA} ${WRKSRC}/image/${c}${d}-app-wireshark.png \
|
||||
${DESTDIR}${PREFIX}/share/icons/${c}color/${d}x${d}/apps/wireshark.png
|
||||
. endfor
|
||||
. endfor
|
||||
|
||||
. for d in ${MIMEICON_SIZES}
|
||||
${INSTALL_DATA} ${WRKSRC}/image/WiresharkDoc-${d}.png \
|
||||
${DESTDIR}${PREFIX}/share/icons/hicolor/${d}x${d}/mimetypes/application-vnd.tcpdump.pcap.png
|
||||
. endfor
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-wireshark
|
||||
.endif
|
||||
|
||||
PLIST_VARS+= lua
|
||||
|
||||
.if empty(PKG_OPTIONS:Mlua)
|
||||
CONFIGURE_ARGS+= --with-lua=no
|
||||
.else
|
||||
.include "../../lang/lua/buildlink3.mk"
|
||||
|
||||
CONFIGURE_ARGS+= --with-lua=yes
|
||||
PLIST.lua= yes
|
||||
.endif
|
13
net/wireshark2/patches/patch-configure
Normal file
13
net/wireshark2/patches/patch-configure
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-configure,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
--- configure.orig 2015-12-29 21:49:49.000000000 +0000
|
||||
+++ configure
|
||||
@@ -5014,7 +5014,7 @@ $as_echo "none needed" >&6; } ;; #(
|
||||
$as_echo "$ac_cv_prog_cc_stdc" >&6; } ;;
|
||||
esac
|
||||
|
||||
-if test "$ac_cv_prog_cc_stdc" == "no"
|
||||
+if test "$ac_cv_prog_cc_stdc" = "no"
|
||||
then
|
||||
as_fn_error $? "The C compiler does not support standard C" "$LINENO" 5
|
||||
fi
|
13
net/wireshark2/patches/patch-configure.ac
Normal file
13
net/wireshark2/patches/patch-configure.ac
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-configure.ac,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
--- configure.ac.orig 2015-12-29 21:49:18.000000000 +0000
|
||||
+++ configure.ac
|
||||
@@ -60,7 +60,7 @@ AM_DISABLE_STATIC
|
||||
# Checks for programs used in the main build process.
|
||||
#
|
||||
AC_PROG_CC_STDC
|
||||
-if test "$ac_cv_prog_cc_stdc" == "no"
|
||||
+if test "$ac_cv_prog_cc_stdc" = "no"
|
||||
then
|
||||
AC_MSG_ERROR([The C compiler does not support standard C])
|
||||
fi
|
33
net/wireshark2/patches/patch-ui_qt_mtp3__summary__dialog.cpp
Normal file
33
net/wireshark2/patches/patch-ui_qt_mtp3__summary__dialog.cpp
Normal file
|
@ -0,0 +1,33 @@
|
|||
$NetBSD: patch-ui_qt_mtp3__summary__dialog.cpp,v 1.1 2016/01/02 23:59:02 ryoon Exp $
|
||||
|
||||
--- ui/qt/mtp3_summary_dialog.cpp.orig 2015-12-29 21:49:23.000000000 +0000
|
||||
+++ ui/qt/mtp3_summary_dialog.cpp
|
||||
@@ -208,7 +208,7 @@ QString Mtp3SummaryDialog::summaryToHtml
|
||||
<< table_hheader15_tmpl.arg(tr("Bytes/s"))
|
||||
<< table_row_end;
|
||||
|
||||
- for (size_t si_code = 0; si_code < MTP3_NUM_SI_CODE; si_code++) {
|
||||
+ for (size_t ws_si_code = 0; ws_si_code < MTP3_NUM_SI_CODE; ws_si_code++) {
|
||||
int si_msus = 0;
|
||||
int si_bytes = 0;
|
||||
QString msus_s_str = n_a;
|
||||
@@ -216,8 +216,8 @@ QString Mtp3SummaryDialog::summaryToHtml
|
||||
QString bytes_s_str = n_a;
|
||||
|
||||
for (size_t stat_idx = 0; stat_idx < mtp3_num_used; stat_idx++) {
|
||||
- si_msus += mtp3_stat[stat_idx].mtp3_si_code[si_code].num_msus;
|
||||
- si_bytes += mtp3_stat[stat_idx].mtp3_si_code[si_code].size;
|
||||
+ si_msus += mtp3_stat[stat_idx].mtp3_si_code[ws_si_code].num_msus;
|
||||
+ si_bytes += mtp3_stat[stat_idx].mtp3_si_code[ws_si_code].size;
|
||||
}
|
||||
total_msus += si_msus;
|
||||
total_bytes += si_bytes;
|
||||
@@ -232,7 +232,7 @@ QString Mtp3SummaryDialog::summaryToHtml
|
||||
}
|
||||
|
||||
out << table_row_begin
|
||||
- << table_data_tmpl.arg(mtp3_service_indicator_code_short_vals[si_code].strptr)
|
||||
+ << table_data_tmpl.arg(mtp3_service_indicator_code_short_vals[ws_si_code].strptr)
|
||||
<< table_data_tmpl.arg(si_msus)
|
||||
<< table_data_tmpl.arg(msus_s_str)
|
||||
<< table_data_tmpl.arg(si_bytes)
|
Loading…
Reference in a new issue