Fix build with png-1.5.

This commit is contained in:
wiz 2011-04-05 11:04:39 +00:00
parent 8d43eff24d
commit 5a2bbff676
4 changed files with 37 additions and 5 deletions

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.20 2010/02/03 22:13:09 joerg Exp $
$NetBSD: distinfo,v 1.21 2011/04/05 11:04:39 wiz Exp $
SHA1 (tuxpaint-0.9.17.tar.gz) = 88e42d19339bb1faa03bce45a28d3fe11fbe05b4
RMD160 (tuxpaint-0.9.17.tar.gz) = c7cf3636875cad87646cda4df978f9adbbf18630
Size (tuxpaint-0.9.17.tar.gz) = 7570223 bytes
SHA1 (patch-aa) = 85365ebbe02084a3f11dcd365e5e5ecdee8c86c9
SHA1 (patch-ab) = 78cba52d776088c5ad8ba3ea77a8584d0f708159
SHA1 (patch-ab) = 48277925cd9caf53f4f1a4ed391fc9acc21ea80b
SHA1 (patch-ad) = ac33e71f3cd7e581d67206a86875492af2836f47

View file

@ -1,6 +1,8 @@
$NetBSD: patch-ab,v 1.4 2007/09/04 21:11:58 drochner Exp $
$NetBSD: patch-ab,v 1.5 2011/04/05 11:04:40 wiz Exp $
--- src/tuxpaint.c.orig 2007-07-01 03:38:03.000000000 +0200
Third chunk: fix build with png-1.5.
--- src/tuxpaint.c.orig 2007-07-01 01:38:03.000000000 +0000
+++ src/tuxpaint.c
@@ -170,7 +170,7 @@ static scaleparams scaletable[] = {
likely available; if not using GNU, you can set HAVE_STRCASESTR to
@ -22,3 +24,17 @@ $NetBSD: patch-ab,v 1.4 2007/09/04 21:11:58 drochner Exp $
#if !defined(RSVG_H) || !defined(RSVG_CAIRO_H)
#error "---------------------------------------------------"
#error "If you installed libRSVG from packages, be sure"
@@ -12528,12 +12528,7 @@ static int do_png_save(FILE * fi, const
{
png_init_io(png_ptr, fi);
- info_ptr->width = surf->w;
- info_ptr->height = surf->h;
- info_ptr->bit_depth = 8;
- info_ptr->color_type = PNG_COLOR_TYPE_RGB;
- info_ptr->interlace_type = 1;
- info_ptr->valid = 0; // will be updated by various png_set_FOO() functions
+ png_set_IHDR(png_ptr, info_ptr, surf->w, surf->h, 8, PNG_COLOR_TYPE_RGB, 1, PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
png_set_sRGB_gAMA_and_cHRM(png_ptr, info_ptr,
PNG_sRGB_INTENT_PERCEPTUAL);

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.2 2005/02/23 17:36:22 wiz Exp $
$NetBSD: distinfo,v 1.3 2011/04/05 11:06:59 wiz Exp $
SHA1 (xcursorgen-4.3.0.tar.bz2) = ade20086c9122d47da82deaeb2707b720e72b735
RMD160 (xcursorgen-4.3.0.tar.bz2) = 2daa61f0781db6d775b01d6b6fd627e8c0931919
@ -6,3 +6,4 @@ Size (xcursorgen-4.3.0.tar.bz2) = 2195176 bytes
SHA1 (patch-aa) = 8eb4d1783b747f3212daeee7d3907b1862d8320c
SHA1 (patch-ab) = 56c7d3e860c14cc7a18c90865847ecf271df438c
SHA1 (patch-ac) = 31151a77830170cccbd1f33be83d1157bfd4344a
SHA1 (patch-xcursorgen.c) = 11d3b0d12872db2d0beadb1622c12e1b61a2626f

View file

@ -0,0 +1,15 @@
$NetBSD: patch-xcursorgen.c,v 1.1 2011/04/05 11:06:59 wiz Exp $
Fix build with png-1.5.
--- xcursorgen.c.orig 2003-02-28 13:19:21.000000000 +0000
+++ xcursorgen.c
@@ -182,7 +182,7 @@ load_image (struct flist *list, char *pr
return NULL;
}
- if (setjmp (png->jmpbuf))
+ if (setjmp (png_jmpbuf(png)))
{
png_destroy_read_struct (&png, &info, NULL);
return NULL;