Make this compile on 1.3ish m68k machines:

In engine-m68000-netbsd.c: Move the declaration of __sycall() before the
	function it's first used in
In syscall-m68000-netbsd.S don't use the compat_13 sigprocmask/sigsuspend
	syscall number constants, they were just SYS__sigprocmask/suspend.
Fix the configure script to do the same dance for the 1.3ish systems as
	for the other architectures.
Fix a typo in config.guess.
This commit is contained in:
bad 1999-09-10 20:38:23 +00:00
parent 647c6fc003
commit 5a2f89f447
5 changed files with 43 additions and 25 deletions

View file

@ -1,7 +1,7 @@
$NetBSD: patch-aj,v 1.7 1999/08/02 18:18:17 bad Exp $
$NetBSD: patch-aj,v 1.8 1999/09/10 20:38:23 bad Exp $
--- config/configure.orig Wed Nov 13 22:03:02 1996
+++ config/configure Tue Jul 27 16:25:36 1999
+++ config/configure Fri Sep 10 20:51:21 1999
@@ -1049,6 +1049,17 @@
name=$host_cpu-$host_os
@ -74,17 +74,25 @@ $NetBSD: patch-aj,v 1.7 1999/08/02 18:18:17 bad Exp $
i386-*-netbsd1.1* | i386-*-netbsd1.2*)
name=i386-netbsd-1.0
sysincludes=netbsd-1.1
@@ -1129,6 +1173,9 @@
@@ -1127,8 +1171,16 @@
name=i386-netbsd-0.9
sysincludes=netbsd-0.9
;;
m68*-*-netbsd*)
- m68*-*-netbsd*)
+ m68*-*-netbsd1.3[H-Z]|m68*-*-netbsd1.4*)
name=m68000-netbsd
+ sysincludes=netbsd-1.1
+ except="lseek ftruncate pipe fstat"
+ available_syscalls="sigsuspend sigprocmask"
+ ;;
+ m68*-*-netbsd1.3*)
+ name=m68000-netbsd
+ sysincludes=netbsd-1.1
+ except="lseek ftruncate pipe fstat sigsuspend sigprocmask"
;;
i386-*-freebsd2.*)
name=i386-freebsd-2.0
@@ -1697,6 +1744,39 @@
@@ -1697,6 +1749,39 @@
if test $pthreads_cv_timespec_in_time = yes ; then
cat >> confdefs.h <<\EOF
#define _OS_HAS_TIMESPEC 1

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ak,v 1.7 1999/08/02 18:18:17 bad Exp $
$NetBSD: patch-ak,v 1.8 1999/09/10 20:38:23 bad Exp $
--- config/configure.in.orig Wed Nov 13 22:03:08 1996
+++ config/configure.in Mon Aug 2 19:48:50 1999
+++ config/configure.in Fri Sep 10 20:54:50 1999
@@ -124,6 +124,19 @@
name=$host_cpu-$host_os
@ -82,17 +82,27 @@ $NetBSD: patch-ak,v 1.7 1999/08/02 18:18:17 bad Exp $
i386-*-netbsd1.1* | i386-*-netbsd1.2*)
name=i386-netbsd-1.0
sysincludes=netbsd-1.1
@@ -195,6 +247,9 @@
@@ -193,8 +245,18 @@
name=i386-netbsd-0.9
sysincludes=netbsd-0.9
;;
m68*-*-netbsd*)
- m68*-*-netbsd*)
+changequote(,)dnl
+ m68*-*-netbsd1.3[H-Z]|m68*-*-netbsd1.4*)
name=m68000-netbsd
+ sysincludes=netbsd-1.1
+ except="lseek ftruncate pipe fstat"
+ available_syscalls="sigsuspend sigprocmask"
+ ;;
+changequote([,])dnl
+ m68*-*-netbsd1.3*)
+ name=m68000-netbsd
+ sysincludes=netbsd-1.1
+ except="lseek ftruncate pipe fstat sigsuspend sigprocmask"
;;
i386-*-freebsd2.*)
name=i386-freebsd-2.0
@@ -304,6 +359,16 @@
@@ -304,6 +366,16 @@
AC_MSG_RESULT($pthreads_cv_timespec_in_time)
if test $pthreads_cv_timespec_in_time = yes ; then
AC_DEFINE(_OS_HAS_TIMESPEC)

View file

@ -1,7 +1,7 @@
$NetBSD: patch-bm,v 1.1 1999/07/29 16:44:43 bad Exp $
$NetBSD: patch-bm,v 1.2 1999/09/10 20:38:23 bad Exp $
--- /dev/null Wed Jul 28 16:32:34 1999
+++ machdep/engine-m68000-netbsd.c Wed Jul 28 23:54:31 1999
--- /dev/null Fri Sep 10 15:38:20 1999
+++ machdep/engine-m68000-netbsd.c Fri Sep 10 20:57:07 1999
@@ -0,0 +1,256 @@
+/* ==== machdep.c ============================================================
+ * Copyright (c) 1993, 1994 Chris Provenzano, proven@athena.mit.edu
@ -47,7 +47,7 @@ $NetBSD: patch-bm,v 1.1 1999/07/29 16:44:43 bad Exp $
+ */
+
+#ifndef lint
+static const char rcsid[] = "$Id: patch-bm,v 1.1 1999/07/29 16:44:43 bad Exp $";
+static const char rcsid[] = "$Id: patch-bm,v 1.2 1999/09/10 20:38:23 bad Exp $";
+#endif
+
+#include "pthread.h"
@ -230,13 +230,13 @@ $NetBSD: patch-bm,v 1.1 1999/07/29 16:44:43 bad Exp $
+ return(machdep_sys_getdents(fd, buf, len));
+}
+
+extern off_t __syscall();
+
+/* ==========================================================================
+ * machdep_sys_lseek()
+ */
+off_t machdep_sys_lseek(int fd, off_t offset, int whence)
+{
+ extern off_t __syscall();
+
+ return(__syscall((quad_t)SYS_lseek, fd, 0, offset, whence));
+}
+

View file

@ -1,12 +1,12 @@
$NetBSD: patch-bn,v 1.2 1999/08/01 22:12:29 bad Exp $
$NetBSD: patch-bn,v 1.3 1999/09/10 20:38:23 bad Exp $
--- /dev/null Fri Jul 30 03:20:45 1999
+++ machdep/syscall-m68000-netbsd.S Fri Jul 30 23:23:08 1999
--- /dev/null Fri Sep 10 15:38:20 1999
+++ machdep/syscall-m68000-netbsd.S Fri Sep 10 20:57:21 1999
@@ -0,0 +1,83 @@
+
+#ifndef lint
+ .text
+ .asciz "$Id: patch-bn,v 1.2 1999/08/01 22:12:29 bad Exp $";
+ .asciz "$Id: patch-bn,v 1.3 1999/09/10 20:38:23 bad Exp $";
+#endif
+
+#include <machine/asm.h>
@ -56,7 +56,7 @@ $NetBSD: patch-bn,v 1.2 1999/08/01 22:12:29 bad Exp $
+ENTRY(machdep_sys_sigsuspend)
+ movl sp@(4),a0
+ movl a0@,sp@(4)
+ movl #SYS_compat_13_sigsuspend13,d0
+ movl #SYS_sigsuspend,d0
+ trap #0
+ jcs err
+ clrl d0
@ -75,7 +75,7 @@ $NetBSD: patch-bn,v 1.2 1999/08/01 22:12:29 bad Exp $
+ movl sp@(8),a0
+ movl a0@,sp@(8)
+doit:
+ movl #SYS_compat_13_sigprocmask13,d0
+ movl #SYS_sigprocmask,d0
+ trap #0
+ jcs err
+ tstl sp@(12)

View file

@ -1,7 +1,7 @@
$NetBSD: patch-bp,v 1.1 1999/07/29 16:44:44 bad Exp $
$NetBSD: patch-bp,v 1.2 1999/09/10 20:38:23 bad Exp $
--- config/config.guess.orig Sun Jul 7 05:51:23 1996
+++ config/config.guess Tue Jul 27 16:55:36 1999
+++ config/config.guess Fri Sep 10 19:42:26 1999
@@ -261,8 +261,29 @@
CRAY-2:UNICOS:*:*)
echo cray2-cray-unicos
@ -18,7 +18,7 @@ $NetBSD: patch-bp,v 1.1 1999/07/29 16:44:44 bad Exp $
+ mac68k:NetBSD:*:*)
+ echo m68k-apple-netbsd${UNAME_RELEASE}
+ exit 0 ;;
+ mvme68:NetBSD:*:*)
+ mvme68k:NetBSD:*:*)
+ echo m68k-motorola-netbsd${UNAME_RELEASE}
+ exit 0 ;;
+ next68k:NetBSD:*:*)