Fix two C glitches when ncurses is compiled with trace support.
This commit is contained in:
parent
fe7a2c5726
commit
5a7fcb9489
2 changed files with 24 additions and 1 deletions
|
@ -1,5 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2006/01/26 23:00:51 xtraeme Exp $
|
||||
$NetBSD: distinfo,v 1.2 2006/02/08 15:50:19 joerg Exp $
|
||||
|
||||
SHA1 (ncurses-ruby-1.0.tar.bz2) = 99c42b2bb0a8fc096e4bc5f7f2ffdac81fe664ab
|
||||
RMD160 (ncurses-ruby-1.0.tar.bz2) = 17102c384ca44c21f5be8ca71a2ba558bd17a423
|
||||
Size (ncurses-ruby-1.0.tar.bz2) = 46328 bytes
|
||||
SHA1 (patch-aa) = c59399a7338cdd5a8e91d7d896055401369161e6
|
||||
|
|
22
devel/ruby-ncurses/patches/patch-aa
Normal file
22
devel/ruby-ncurses/patches/patch-aa
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-aa,v 1.1 2006/02/08 15:50:20 joerg Exp $
|
||||
|
||||
--- ncurses_wrap.c.orig 2006-02-07 17:28:43.000000000 +0000
|
||||
+++ ncurses_wrap.c
|
||||
@@ -2362,7 +2362,7 @@ static VALUE rbncurs_wprintw(int argc, V
|
||||
|
||||
/* Debugging : use with libncurses_g.a */
|
||||
#ifdef HAVE__TRACEF
|
||||
-static VALUE rbncurs_tracef(int argc, VALUE * argv, VALUE)
|
||||
+static VALUE rbncurs_tracef(int argc, VALUE * argv, VALUE dummy)
|
||||
{
|
||||
if (argc < 1) {
|
||||
rb_raise(rb_eArgError, "function needs at least 1 argument");
|
||||
@@ -2374,7 +2374,7 @@ static VALUE rbncurs_tracef(int argc, VA
|
||||
}
|
||||
#endif /* HAVE__TRACEF */
|
||||
#ifdef HAVE__TRACEDUMP
|
||||
-static VALUE rbncurs_tracedump(VALUE dummy, VALUE rb_label, label rb_win)
|
||||
+static VALUE rbncurs_tracedump(VALUE dummy, VALUE rb_label, VALUE rb_win)
|
||||
{
|
||||
_tracedump(STR2CSTR(rb_label), get_window(rb_win));
|
||||
}
|
Loading…
Reference in a new issue