mail/smtpfeed: SMTP Fast Exploding External Deliverer for Sendmail

(builds patched sendmail as well)
This commit is contained in:
itojun 1999-11-29 08:33:29 +00:00
parent 1b65fba788
commit 5a98c78547
5 changed files with 881 additions and 3 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: Makefile,v 1.29 1999/10/19 21:42:43 perry Exp $
$NetBSD: Makefile,v 1.30 1999/11/29 08:33:29 itojun Exp $
# FreeBSD Id: Makefile,v 1.45 1997/08/13 18:35:22 andreas Exp
#
@ -40,6 +40,7 @@
SUBDIR += qpopper
SUBDIR += sendmail
# SUBDIR += smail
SUBDIR += smtpfeed
SUBDIR += wmmail
# SUBDIR += xfaces
SUBDIR += xfmail

View file

@ -1,5 +1,5 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
# KAME $Id: Makefile,v 1.1.1.1 1999/11/29 08:06:32 itojun Exp $
# $NetBSD: Makefile,v 1.2 1999/11/29 08:33:30 itojun Exp $
# KAME $Id: Makefile,v 1.2 1999/11/29 08:33:30 itojun Exp $
# Based on FreeBSD Id: Makefile,v 1.27 1999/04/03 08:25:18 itojun Exp
#
@ -35,15 +35,24 @@ DOCS= COPYRIGHT FEATURES FEATURES.j FYI FYI.j INSTALL INSTALL.j \
OPTIONS OPTIONS.j README README.j RELEASE.NOTE SIGNAL SIGNAL.j TODO
DOCDIR= ${PREFIX}/share/doc/smtpfeed
BUILD_DEFS+= USE_INET6
.include "../../mk/bsd.prefs.mk"
post-patch:
@${ECHO_MSG} "===> Applying smtpfeed patch ${SENDMAILPATCH} to ${SENDMAIL}"
@(cd ${_DISTDIR}; for i in ${SENDMAILPATCH}.patch.gz; do \
${GZCAT} $$i | ${PATCH} ${PATCH_SENDMAIL_ARGS}; \
done)
${CP} -f ${FILESDIR}/site.config-v6.kame ${WRKSRC_SENDMAIL}
post-build:
@${ECHO_MSG} "===> Building patched ${SENDMAIL}"
.if defined(USE_INET6) && ${USE_INET6} == YES
@(cd ${WRKSRC_SENDMAIL}; sh makesendmail -f site.config-v6.kame)
.else
@(cd ${WRKSRC_SENDMAIL}; sh makesendmail )
.endif
post-install:
.if !defined(NOPORTDOCS)

View file

@ -0,0 +1,5 @@
$NetBSD: patch-sum,v 1.1 1999/11/29 08:33:30 itojun Exp $
MD5 (patch-aa) = 6de18b970a3394448dd4e01fe051a792
MD5 (patch-ab) = d42dd724dfb4748d997b5eb5ba06375c
MD5 (patch-ba) = 32b5348ac5751f0e2c737f108dbbe04e

View file

@ -0,0 +1 @@
PREPENDDEF(`confENVDEF', ``-DNETINET6=1'')

View file

@ -0,0 +1,862 @@
$NetBSD: patch-ba,v 1.1 1999/11/29 08:33:31 itojun Exp $
Index: configure
===================================================================
RCS file: /cvsroot/apps/smtpfeed/configure,v
retrieving revision 1.1.1.1
diff -u -r1.1.1.1 configure
--- configure 1999/11/29 07:42:40 1.1.1.1
+++ configure 1999/11/29 08:21:12
@@ -1101,10 +1101,11 @@
ipv6type=unknown
ipv6lib=none
+v6trylibc=no
if test "$ipv6" = "yes"; then
echo $ac_n "checking for lib_exec""... $ac_c" 1>&6
-echo "configure:1108: checking for lib_exec" >&5
+echo "configure:1109: checking for lib_exec" >&5
if eval "test \"`echo '$''{'my_cv_path_lib_exec'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
@@ -1121,12 +1122,12 @@
echo "$ac_t""$lib_exec" 1>&6
echo $ac_n "checking ipv6 stack type""... $ac_c" 1>&6
-echo "configure:1125: checking ipv6 stack type" >&5
- for i in inria kame toshiba v6d zeta linux bsdi; do
+echo "configure:1126: checking ipv6 stack type" >&5
+ for i in inria kame toshiba v6d zeta linux-glibc linux-libinet6 bsdi; do
case $i in
inria)
cat > conftest.$ac_ext <<EOF
-#line 1130 "configure"
+#line 1131 "configure"
#include "confdefs.h"
dnl
#include <netinet/in.h>
@@ -1145,7 +1146,7 @@
;;
kame)
cat > conftest.$ac_ext <<EOF
-#line 1149 "configure"
+#line 1150 "configure"
#include "confdefs.h"
dnl
#include <netinet/in.h>
@@ -1159,6 +1160,7 @@
ipv6type=$i;
ipv6lib=inet6;
ipv6libdir=/usr/local/v6/lib;
+ v6trylibc=yes;
IPV6_DEF="-DINET6"
fi
rm -f conftest*
@@ -1166,7 +1168,7 @@
;;
toshiba)
cat > conftest.$ac_ext <<EOF
-#line 1170 "configure"
+#line 1172 "configure"
#include "confdefs.h"
dnl
#include <sys/param.h>
@@ -1187,7 +1189,7 @@
;;
v6d)
cat > conftest.$ac_ext <<EOF
-#line 1191 "configure"
+#line 1193 "configure"
#include "confdefs.h"
dnl
#include </usr/local/v6/include/sys/v6config.h>
@@ -1208,7 +1210,7 @@
;;
zeta)
cat > conftest.$ac_ext <<EOF
-#line 1212 "configure"
+#line 1214 "configure"
#include "confdefs.h"
dnl
#include <sys/param.h>
@@ -1227,12 +1229,32 @@
rm -f conftest*
;;
- linux)
- if test -d /usr/inet6; then
+ linux-glibc)
+ cat > conftest.$ac_ext <<EOF
+#line 1235 "configure"
+#include "confdefs.h"
+dnl
+#include <features.h>
+#if defined(__GLIBC__) && __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 1
+yes
+#endif
+EOF
+if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+ egrep "yes" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ipv6type=$i;
+ CFLAGS="-DINET6 $CFLAGS"
+fi
+rm -f conftest*
+
+ ;;
+ linux-libinet6)
+ if test -d /usr/inet6 -o -f /usr/include/netinet/ip6.h; then
ipv6type=$i
ipv6lib=inet6
ipv6libdir=/usr/inet6/lib
- IPV6_DEF="-DINET6 -I/usr/inet6/include"
+ ipv6trylibc=yes;
+ CFLAGS="-DINET6 -I/usr/inet6/include $CFLAGS"
fi
;;
bsdi)
@@ -1251,23 +1273,28 @@
break
fi
done
- echo "$ac_t""$ipv6type" 1>&6
fi
if test "$ipv6" = "yes" -a "$ipv6lib" != "none"; then
if test -d $ipv6libdir -a -f $ipv6libdir/lib$ipv6lib.a; then
LIBS="-L$ipv6libdir -l$ipv6lib $LIBS"
+ echo "$ac_t"""$ipv6type using lib$ipv6lib"" 1>&6
else
- echo 'Fatal: no $ipv6lib library found. cannot continue.'
- echo "You need to fetch lib$ipv6lib.a from appropriate"
- echo 'ipv6 kit and compile beforehand.'
- exit 1
- fi
+ if test "$v6trylibc" = "yes"; then
+ echo "$ac_t"""$ipv6type using libc"" 1>&6
+ else
+ echo
+ echo "Fatal: no IPv6 library lib$v6lib.a found."
+ exit 1
+ fi
fi
+ else
+ echo "$ac_t"""$ipv6type using libc"" 1>&6
+fi
echo $ac_n "checking for main in -lnsl""... $ac_c" 1>&6
-echo "configure:1271: checking for main in -lnsl" >&5
+echo "configure:1298: checking for main in -lnsl" >&5
ac_lib_var=`echo nsl'_'main | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1275,14 +1302,14 @@
ac_save_LIBS="$LIBS"
LIBS="-lnsl $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1279 "configure"
+#line 1306 "configure"
#include "confdefs.h"
int main() {
main()
; return 0; }
EOF
-if { (eval echo configure:1286: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1313: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1310,12 +1337,12 @@
fi
echo $ac_n "checking for connect""... $ac_c" 1>&6
-echo "configure:1314: checking for connect" >&5
+echo "configure:1341: checking for connect" >&5
if eval "test \"`echo '$''{'ac_cv_func_connect'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1319 "configure"
+#line 1346 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char connect(); below. */
@@ -1338,7 +1365,7 @@
; return 0; }
EOF
-if { (eval echo configure:1342: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1369: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_connect=yes"
else
@@ -1356,7 +1383,7 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for connect in -lsocket""... $ac_c" 1>&6
-echo "configure:1360: checking for connect in -lsocket" >&5
+echo "configure:1387: checking for connect in -lsocket" >&5
ac_lib_var=`echo socket'_'connect | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1364,7 +1391,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lsocket $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1368 "configure"
+#line 1395 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1375,7 +1402,7 @@
connect()
; return 0; }
EOF
-if { (eval echo configure:1379: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1406: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1405,7 +1432,7 @@
fi
echo $ac_n "checking for setproctitle in -lutil""... $ac_c" 1>&6
-echo "configure:1409: checking for setproctitle in -lutil" >&5
+echo "configure:1436: checking for setproctitle in -lutil" >&5
ac_lib_var=`echo util'_'setproctitle | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1413,7 +1440,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lutil $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1417 "configure"
+#line 1444 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1424,7 +1451,7 @@
setproctitle()
; return 0; }
EOF
-if { (eval echo configure:1428: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1455: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1454,10 +1481,10 @@
if test "$ipv6" = "yes"; then
echo $ac_n "checking for IPv6 resolver type""... $ac_c" 1>&6
-echo "configure:1458: checking for IPv6 resolver type" >&5
+echo "configure:1485: checking for IPv6 resolver type" >&5
CPPFLAGS="${IPV6_DEF} ${CPPFLAGS}"
cat > conftest.$ac_ext <<EOF
-#line 1461 "configure"
+#line 1488 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
@@ -1467,7 +1494,7 @@
_res_ext.nsaddr_list[0].__ss_family = 1;
; return 0; }
EOF
-if { (eval echo configure:1471: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1498: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
cat >> confdefs.h <<\EOF
#define RESOLVER_KAME 1
@@ -1479,7 +1506,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
cat > conftest.$ac_ext <<EOF
-#line 1483 "configure"
+#line 1510 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
@@ -1489,7 +1516,7 @@
_res_ext.nsaddr_list[0].ss_family = 1;
; return 0; }
EOF
-if { (eval echo configure:1493: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1520: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
cat >> confdefs.h <<\EOF
#define RESOLVER_KAME 1
@@ -1501,7 +1528,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
cat > conftest.$ac_ext <<EOF
-#line 1505 "configure"
+#line 1532 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
@@ -1511,7 +1538,7 @@
_res.nsaddr_list_un[0].sin6.sin6_family = 1;
; return 0; }
EOF
-if { (eval echo configure:1515: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1542: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
cat >> confdefs.h <<\EOF
#define RESOLVER_OLDKAME 1
@@ -1523,7 +1550,7 @@
cat conftest.$ac_ext >&5
rm -rf conftest*
cat > conftest.$ac_ext <<EOF
-#line 1527 "configure"
+#line 1554 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/socket.h>
@@ -1533,7 +1560,7 @@
_res.nsaddr_list[0].sin_family = 1;
; return 0; }
EOF
-if { (eval echo configure:1537: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1564: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
cat >> confdefs.h <<\EOF
#define RESOLVER_V4 1
@@ -1558,7 +1585,7 @@
if test "${bind8}" = "yes" ; then
echo $ac_n "checking for inet_ntoa in -lbind""... $ac_c" 1>&6
-echo "configure:1562: checking for inet_ntoa in -lbind" >&5
+echo "configure:1589: checking for inet_ntoa in -lbind" >&5
ac_lib_var=`echo bind'_'inet_ntoa | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1566,7 +1593,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lbind $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1570 "configure"
+#line 1597 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1577,7 +1604,7 @@
inet_ntoa()
; return 0; }
EOF
-if { (eval echo configure:1581: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1608: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1593,7 +1620,7 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
echo $ac_n "checking for __inet_aton in -lbind""... $ac_c" 1>&6
-echo "configure:1597: checking for __inet_aton in -lbind" >&5
+echo "configure:1624: checking for __inet_aton in -lbind" >&5
ac_lib_var=`echo bind'_'__inet_aton | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1601,7 +1628,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lbind $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1605 "configure"
+#line 1632 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1612,7 +1639,7 @@
__inet_aton()
; return 0; }
EOF
-if { (eval echo configure:1616: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1643: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1645,7 +1672,7 @@
elif test "${ipv6type}" != "v6d" ; then
echo $ac_n "checking for main in -lresolv""... $ac_c" 1>&6
-echo "configure:1649: checking for main in -lresolv" >&5
+echo "configure:1676: checking for main in -lresolv" >&5
ac_lib_var=`echo resolv'_'main | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1653,14 +1680,14 @@
ac_save_LIBS="$LIBS"
LIBS="-lresolv $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1657 "configure"
+#line 1684 "configure"
#include "confdefs.h"
int main() {
main()
; return 0; }
EOF
-if { (eval echo configure:1664: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1691: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1688,7 +1715,7 @@
fi
echo $ac_n "checking for inet_aton in -lresolv""... $ac_c" 1>&6
-echo "configure:1692: checking for inet_aton in -lresolv" >&5
+echo "configure:1719: checking for inet_aton in -lresolv" >&5
ac_lib_var=`echo resolv'_'inet_aton | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1696,7 +1723,7 @@
ac_save_LIBS="$LIBS"
LIBS="-lresolv $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1700 "configure"
+#line 1727 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1707,7 +1734,7 @@
inet_aton()
; return 0; }
EOF
-if { (eval echo configure:1711: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1738: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1723,7 +1750,7 @@
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
echo $ac_n "checking for inet_aton in -l44bsd""... $ac_c" 1>&6
-echo "configure:1727: checking for inet_aton in -l44bsd" >&5
+echo "configure:1754: checking for inet_aton in -l44bsd" >&5
ac_lib_var=`echo 44bsd'_'inet_aton | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
@@ -1731,7 +1758,7 @@
ac_save_LIBS="$LIBS"
LIBS="-l44bsd $LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1735 "configure"
+#line 1762 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error. */
/* We use char because int might match the return type of a gcc2
@@ -1742,7 +1769,7 @@
inet_aton()
; return 0; }
EOF
-if { (eval echo configure:1746: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1773: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_lib_$ac_lib_var=yes"
else
@@ -1776,12 +1803,12 @@
fi
echo $ac_n "checking for ANSI C header files""... $ac_c" 1>&6
-echo "configure:1780: checking for ANSI C header files" >&5
+echo "configure:1807: checking for ANSI C header files" >&5
if eval "test \"`echo '$''{'ac_cv_header_stdc'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1785 "configure"
+#line 1812 "configure"
#include "confdefs.h"
#include <stdlib.h>
#include <stdarg.h>
@@ -1789,7 +1816,7 @@
#include <float.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1793: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1820: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1806,7 +1833,7 @@
if test $ac_cv_header_stdc = yes; then
# SunOS 4.x string.h does not declare mem*, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1810 "configure"
+#line 1837 "configure"
#include "confdefs.h"
#include <string.h>
EOF
@@ -1824,7 +1851,7 @@
if test $ac_cv_header_stdc = yes; then
# ISC 2.0.2 stdlib.h does not declare free, contrary to ANSI.
cat > conftest.$ac_ext <<EOF
-#line 1828 "configure"
+#line 1855 "configure"
#include "confdefs.h"
#include <stdlib.h>
EOF
@@ -1845,7 +1872,7 @@
:
else
cat > conftest.$ac_ext <<EOF
-#line 1849 "configure"
+#line 1876 "configure"
#include "confdefs.h"
#include <ctype.h>
#define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
@@ -1856,7 +1883,7 @@
exit (0); }
EOF
-if { (eval echo configure:1860: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
+if { (eval echo configure:1887: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext} && (./conftest; exit) 2>/dev/null
then
:
else
@@ -1883,17 +1910,17 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-echo "configure:1887: checking for $ac_hdr" >&5
+echo "configure:1914: checking for $ac_hdr" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1892 "configure"
+#line 1919 "configure"
#include "confdefs.h"
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1897: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1924: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1922,17 +1949,17 @@
ac_safe=`echo "netinet/in.h" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for netinet/in.h""... $ac_c" 1>&6
-echo "configure:1926: checking for netinet/in.h" >&5
+echo "configure:1953: checking for netinet/in.h" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1931 "configure"
+#line 1958 "configure"
#include "confdefs.h"
#include <netinet/in.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:1936: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:1963: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
@@ -1949,7 +1976,7 @@
if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
echo "$ac_t""yes" 1>&6
cat > conftest.$ac_ext <<EOF
-#line 1953 "configure"
+#line 1980 "configure"
#include "confdefs.h"
#include <netinet/in.h>
EOF
@@ -1972,12 +1999,12 @@
echo $ac_n "checking for working const""... $ac_c" 1>&6
-echo "configure:1976: checking for working const" >&5
+echo "configure:2003: checking for working const" >&5
if eval "test \"`echo '$''{'ac_cv_c_const'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1981 "configure"
+#line 2008 "configure"
#include "confdefs.h"
int main() {
@@ -2026,7 +2053,7 @@
; return 0; }
EOF
-if { (eval echo configure:2030: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:2057: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_c_const=yes
else
@@ -2047,12 +2074,12 @@
fi
echo $ac_n "checking for size_t""... $ac_c" 1>&6
-echo "configure:2051: checking for size_t" >&5
+echo "configure:2078: checking for size_t" >&5
if eval "test \"`echo '$''{'ac_cv_type_size_t'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2056 "configure"
+#line 2083 "configure"
#include "confdefs.h"
#include <sys/types.h>
#if STDC_HEADERS
@@ -2080,12 +2107,12 @@
fi
echo $ac_n "checking whether time.h and sys/time.h may both be included""... $ac_c" 1>&6
-echo "configure:2084: checking whether time.h and sys/time.h may both be included" >&5
+echo "configure:2111: checking whether time.h and sys/time.h may both be included" >&5
if eval "test \"`echo '$''{'ac_cv_header_time'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2089 "configure"
+#line 2116 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <sys/time.h>
@@ -2094,7 +2121,7 @@
struct tm *tp;
; return 0; }
EOF
-if { (eval echo configure:2098: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:2125: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_header_time=yes
else
@@ -2117,13 +2144,13 @@
if test $ac_cv_prog_gcc = yes; then
echo $ac_n "checking whether ${CC-cc} needs -traditional""... $ac_c" 1>&6
-echo "configure:2121: checking whether ${CC-cc} needs -traditional" >&5
+echo "configure:2148: checking whether ${CC-cc} needs -traditional" >&5
if eval "test \"`echo '$''{'ac_cv_prog_gcc_traditional'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_pattern="Autoconf.*'x'"
cat > conftest.$ac_ext <<EOF
-#line 2127 "configure"
+#line 2154 "configure"
#include "confdefs.h"
#include <sgtty.h>
Autoconf TIOCGETP
@@ -2141,7 +2168,7 @@
if test $ac_cv_prog_gcc_traditional = no; then
cat > conftest.$ac_ext <<EOF
-#line 2145 "configure"
+#line 2172 "configure"
#include "confdefs.h"
#include <termio.h>
Autoconf TCGETA
@@ -2163,12 +2190,12 @@
fi
echo $ac_n "checking return type of signal handlers""... $ac_c" 1>&6
-echo "configure:2167: checking return type of signal handlers" >&5
+echo "configure:2194: checking return type of signal handlers" >&5
if eval "test \"`echo '$''{'ac_cv_type_signal'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2172 "configure"
+#line 2199 "configure"
#include "confdefs.h"
#include <sys/types.h>
#include <signal.h>
@@ -2185,7 +2212,7 @@
int i;
; return 0; }
EOF
-if { (eval echo configure:2189: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:2216: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
ac_cv_type_signal=void
else
@@ -2206,12 +2233,12 @@
for ac_func in strerror snprintf
do
echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
-echo "configure:2210: checking for $ac_func" >&5
+echo "configure:2237: checking for $ac_func" >&5
if eval "test \"`echo '$''{'ac_cv_func_$ac_func'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2215 "configure"
+#line 2242 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char $ac_func(); below. */
@@ -2234,7 +2261,7 @@
; return 0; }
EOF
-if { (eval echo configure:2238: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2265: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_$ac_func=yes"
else
@@ -2259,12 +2286,12 @@
done
echo $ac_n "checking for setproctitle""... $ac_c" 1>&6
-echo "configure:2263: checking for setproctitle" >&5
+echo "configure:2290: checking for setproctitle" >&5
if eval "test \"`echo '$''{'ac_cv_func_setproctitle'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2268 "configure"
+#line 2295 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char setproctitle(); below. */
@@ -2287,7 +2314,7 @@
; return 0; }
EOF
-if { (eval echo configure:2291: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2318: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_setproctitle=yes"
else
@@ -2308,12 +2335,12 @@
else
echo "$ac_t""no" 1>&6
echo $ac_n "checking for pstat""... $ac_c" 1>&6
-echo "configure:2312: checking for pstat" >&5
+echo "configure:2339: checking for pstat" >&5
if eval "test \"`echo '$''{'ac_cv_func_pstat'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2317 "configure"
+#line 2344 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char pstat(); below. */
@@ -2336,7 +2363,7 @@
; return 0; }
EOF
-if { (eval echo configure:2340: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:2367: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_pstat=yes"
else
@@ -2358,17 +2385,17 @@
echo "$ac_t""no" 1>&6
ac_safe=`echo "sys/sysnews.h" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for sys/sysnews.h""... $ac_c" 1>&6
-echo "configure:2362: checking for sys/sysnews.h" >&5
+echo "configure:2389: checking for sys/sysnews.h" >&5
if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 2367 "configure"
+#line 2394 "configure"
#include "confdefs.h"
#include <sys/sysnews.h>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-{ (eval echo configure:2372: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+{ (eval echo configure:2399: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
if test -z "$ac_err"; then
rm -rf conftest*
Index: configure.in
===================================================================
RCS file: /cvsroot/apps/smtpfeed/configure.in,v
retrieving revision 1.1.1.1
diff -u -r1.1.1.1 configure.in
--- configure.in 1999/11/29 07:42:40 1.1.1.1
+++ configure.in 1999/11/29 08:21:13
@@ -117,12 +117,13 @@
ipv6type=unknown
ipv6lib=none
+v6trylibc=no
if test "$ipv6" = "yes"; then
AC_CHECK_DIR_PATH(lib_exec, [$]libexecdir /usr/local/v6/sbin /usr/libexec /usr/lib)
AC_MSG_CHECKING([ipv6 stack type])
dnl linux is checked later, as it does not have #define for IPv6
- for i in inria kame toshiba v6d zeta linux bsdi; do
+ for i in inria kame toshiba v6d zeta linux-glibc linux-libinet6 bsdi; do
case $i in
inria)
dnl http://www.inria.fr/
@@ -144,6 +145,7 @@
[ipv6type=$i;
ipv6lib=inet6;
ipv6libdir=/usr/local/v6/lib;
+ v6trylibc=yes;
IPV6_DEF="-DINET6"])
;;
toshiba)
@@ -179,13 +181,24 @@
ipv6libdir=/usr/local/v6/lib;
IPV6_DEF="-DINET6"])
;;
- linux)
+ linux-glibc)
dnl http://www.v6.linux.or.jp/
- if test -d /usr/inet6; then
+ AC_EGREP_CPP(yes, [dnl
+#include <features.h>
+#if defined(__GLIBC__) && __GLIBC__ >= 2 && __GLIBC_MINOR__ >= 1
+yes
+#endif],
+ [ipv6type=$i;
+ CFLAGS="-DINET6 $CFLAGS"])
+ ;;
+ linux-libinet6)
+ dnl http://www.v6.linux.or.jp/
+ if test -d /usr/inet6 -o -f /usr/include/netinet/ip6.h; then
ipv6type=$i
ipv6lib=inet6
ipv6libdir=/usr/inet6/lib
- IPV6_DEF="-DINET6 -I/usr/inet6/include"
+ ipv6trylibc=yes;
+ CFLAGS="-DINET6 -I/usr/inet6/include $CFLAGS"
fi
;;
bsdi)
@@ -205,19 +218,24 @@
break
fi
done
- AC_MSG_RESULT($ipv6type)
fi
if test "$ipv6" = "yes" -a "$ipv6lib" != "none"; then
if test -d $ipv6libdir -a -f $ipv6libdir/lib$ipv6lib.a; then
LIBS="-L$ipv6libdir -l$ipv6lib $LIBS"
+ AC_MSG_RESULT("$ipv6type using lib$ipv6lib")
else
- echo 'Fatal: no $ipv6lib library found. cannot continue.'
- echo "You need to fetch lib$ipv6lib.a from appropriate"
- echo 'ipv6 kit and compile beforehand.'
- exit 1
+ if test "$v6trylibc" = "yes"; then
+ AC_MSG_RESULT("$ipv6type using libc")
+ else
+ echo
+ echo "Fatal: no IPv6 library lib$v6lib.a found."
+ exit 1
+ fi
fi
dnl AC_CHECK_LIB($ipv6lib, main)
+else
+ AC_MSG_RESULT("$ipv6type using libc")
fi
AC_SUBST(IPV6_DEF)