Initial import of net-snmp-5.0.6 as net/net-snmp. This package is based

on net/net-snmp-current and on the FreeBSD net-snmp port, and may be
considered as an update to ucd-snmp.  Changes since ucd-snmp include:

	* complete rewrite of the agent internals
	* new agent module API
	* SNMPv3
	* improved AgentX subagent handling
	* many, many bugfixes in plugged memory leaks
	* prevent DoS attacks from authenticated users
This commit is contained in:
jlam 2002-10-24 08:29:33 +00:00
parent 41e5f39f18
commit 5ae966807d
11 changed files with 1078 additions and 0 deletions

15
net/net-snmp/DEINSTALL Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: DEINSTALL,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
# The config files could possibly be in either ${PKG_PREFIX}/share/snmp
# of in ${PKG_SYSCONFDIR}.
#
ALL_FILES="${ALL_FILES} /dev/null ${PKG_PREFIX}/share/snmp/snmpd.conf"
ALL_FILES="${ALL_FILES} /dev/null ${PKG_PREFIX}/share/snmp/snmptrapd.conf"
ALL_FILES="${ALL_FILES} /dev/null ${PKG_SYSCONFDIR}/snmpd.conf"
ALL_FILES="${ALL_FILES} /dev/null ${PKG_SYSCONFDIR}/snmptrapd.conf"
case ${STAGE} in
DEINSTALL)
${RM} -f ${PKG_PREFIX}/share/snmp/mibs/.index
;;
esac

12
net/net-snmp/DESCR Normal file
View file

@ -0,0 +1,12 @@
Net-SNMP contains various tools relating to the Simple Network Management
Protocol including:
* an extensible agent
* an SNMP library
* tools to request or set information from SNMP agents
* tools to generate and handle SNMP traps
* a version of the unix 'netstat' command using SNMP
This package is originally based on the Carnegie Mellon University
SNMP implementation (version 2.1.2.1), but has developed significantly
since then.

13
net/net-snmp/MESSAGE Normal file
View file

@ -0,0 +1,13 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
If you do not have an existing snmpd.conf configuration file, you may
generate one using snmpconf(1), e.g.:
${PREFIX}/bin/snmpconf -g basic_setup
The resulting config file should be placed in:
${PKG_SYSCONFDIR}/snmpd.conf
===========================================================================

94
net/net-snmp/Makefile Normal file
View file

@ -0,0 +1,94 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
DISTNAME= net-snmp-5.0.6
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=net-snmp/} \
ftp://ftp.net-smnp.org/pub/sourceforge/net-snmp/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.net-snmp.org/
COMMENT= Extensible SNMP implementation
CONFLICTS= ucd-snmp-[0-9]*
BUILD_DEFS+= USE_INET6
.include "../../mk/bsd.prefs.mk"
NET_SNMP_SYS_CONTACT?= default_user@contact.domain
NET_SNMP_SYS_LOCATION?= defaultlocation
NET_SNMP_LOGFILE?= /var/log/snmpd.log
NET_SNMP_PERSISTENTDIR?= /var/net-snmp
NET_SNMP_MIBDIRS?= \$$HOME/.snmp/mibs:${PREFIX}/share/snmp/mibs
USE_BUILDLINK2= # defined
USE_LIBTOOL= # defined
LIBTOOL_OVERRIDE= ${WRKSRC}/libtool
.if (${OPSYS} == "NetBSD")
CFLAGS+= -Dnetbsd1
.endif
GNU_CONFIGURE= # defined
CONFIGURE_ARGS+= --enable-shared
.if defined(USE_INET6) && (${USE_INET6} == "YES")
CONFIGURE_ARGS+= --enable-ipv6
.else
CONFIGURE_ARGS+= --disable-ipv6
.endif
CONFIGURE_ARGS+= --with-defaults
CONFIGURE_ARGS+= --with-libwrap
CONFIGURE_ARGS+= --with-openssl
CONFIGURE_ARGS+= --with-sys-contact="${NET_SNMP_SYS_CONTACT}"
CONFIGURE_ARGS+= --with-sys-location="${NET_SNMP_SYS_LOCATION}"
CONFIGURE_ARGS+= --with-logfile="${NET_SNMP_LOGFILE}"
CONFIGURE_ARGS+= --with-persistent-directory="${NET_SNMP_PERSISTENTDIR}"
.if !empty(NET_SNMP_MIBDIRS)
CONFIGURE_ARGS+= --with-mibdirs="${NET_SNMP_MIBDIRS}"
.endif
#
# Using "dummy" values is technically not compliant with SNMP specs, but
# otherwise, some tools, e.g. net/tcl-scotty, net/tkined, may ignore results
# when they shouldn't.
#
CONFIGURE_ARGS+= --with-dummy-values
.if !exists(/usr/bin/lpstat)
CONFIGURE_ENV+= ac_cv_path_LPSTAT_PATH=no
.endif
CONFIGURE_ENV+= PERLPROG="${PERL5}"
# Handle ${PREFIX}/share/snmp in the DEINSTALL script since it may contain
# leftover config files or pidfiles after deinstallation.
#
OWN_DIRS= ${PREFIX}/share/snmp
RCD_SCRIPTS= snmpd snmptrapd
pre-configure:
.if !empty(MACHINE_PLATFORM:MNetBSD-1.5.[123]*-i386)
${MKDIR} ${BUILDLINK_DIR}/include/sys
${CP} ${FILESDIR}/disklabel.h ${BUILDLINK_DIR}/include/sys
.endif
.if ${OPSYS} == SunOS
#
# Adapt for the fact that the default I've seen of ac_max_sed_cmds=90
# will not work w/ built-in sed on Solaris.
#
cd ${WRKSRC}; for file in ${CONFIGURE_SCRIPT}; do \
${SED} -e "s|ac_max_sed_cmds=[0-9][0-9]*|ac_max_sed_cmds=10|" \
$${file} > $${file}.fixed; \
${MV} -f $${file}.fixed $${file}; \
done
.endif
post-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/net-snmp
${INSTALL_DATA} ${WRKSRC}/EXAMPLE.conf \
${PREFIX}/share/examples/net-snmp/EXAMPLE.conf
.include "../../lang/perl5/buildlink2.mk"
.include "../../security/openssl/buildlink2.mk"
.include "../../security/tcp_wrappers/buildlink2.mk"
.include "../../mk/bsd.pkg.install.mk"
.include "../../mk/bsd.pkg.mk"

349
net/net-snmp/PLIST Normal file
View file

@ -0,0 +1,349 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
bin/encode_keychange
bin/fixproc
bin/ipf-mod.pl
bin/mib2c
bin/net-snmp-config
bin/snmpbulkget
bin/snmpbulkwalk
bin/snmpcheck
bin/snmpconf
bin/snmpdelta
bin/snmpdf
bin/snmpget
bin/snmpgetnext
bin/snmpinform
bin/snmpnetstat
bin/snmpset
bin/snmpstatus
bin/snmptable
bin/snmptest
bin/snmptranslate
bin/snmptrap
bin/snmpusm
bin/snmpvacm
bin/snmpwalk
bin/tkmib
bin/traptoemail
etc/rc.d/snmpd
etc/rc.d/snmptrapd
include/net-snmp/agent/agent_callbacks.h
include/net-snmp/agent/agent_handler.h
include/net-snmp/agent/agent_index.h
include/net-snmp/agent/agent_read_config.h
include/net-snmp/agent/agent_registry.h
include/net-snmp/agent/agent_trap.h
include/net-snmp/agent/all_helpers.h
include/net-snmp/agent/auto_nlist.h
include/net-snmp/agent/bulk_to_next.h
include/net-snmp/agent/debug_handler.h
include/net-snmp/agent/ds_agent.h
include/net-snmp/agent/instance.h
include/net-snmp/agent/mib_module_config.h
include/net-snmp/agent/mib_module_includes.h
include/net-snmp/agent/multiplexer.h
include/net-snmp/agent/net-snmp-agent-includes.h
include/net-snmp/agent/null.h
include/net-snmp/agent/old_api.h
include/net-snmp/agent/read_only.h
include/net-snmp/agent/scalar.h
include/net-snmp/agent/serialize.h
include/net-snmp/agent/set_helper.h
include/net-snmp/agent/snmp_agent.h
include/net-snmp/agent/snmp_vars.h
include/net-snmp/agent/table.h
include/net-snmp/agent/table_array.h
include/net-snmp/agent/table_data.h
include/net-snmp/agent/table_dataset.h
include/net-snmp/agent/table_iterator.h
include/net-snmp/agent/var_struct.h
include/net-snmp/agent/watcher.h
include/net-snmp/config_api.h
include/net-snmp/definitions.h
include/net-snmp/library/README
include/net-snmp/library/asn1.h
include/net-snmp/library/callback.h
include/net-snmp/library/check_varbind.h
include/net-snmp/library/cmu_compat.h
include/net-snmp/library/container.h
include/net-snmp/library/container_binary_array.h
include/net-snmp/library/data_list.h
include/net-snmp/library/default_store.h
include/net-snmp/library/factory.h
include/net-snmp/library/getopt.h
include/net-snmp/library/int64.h
include/net-snmp/library/keytools.h
include/net-snmp/library/lcd_time.h
include/net-snmp/library/md5.h
include/net-snmp/library/mib.h
include/net-snmp/library/mt_support.h
include/net-snmp/library/oid_stash.h
include/net-snmp/library/parse.h
include/net-snmp/library/read_config.h
include/net-snmp/library/scapi.h
include/net-snmp/library/snmp-tc.h
include/net-snmp/library/snmp.h
include/net-snmp/library/snmpCallbackDomain.h
include/net-snmp/library/snmpTCPDomain.h
include/net-snmp/library/snmpTCPIPv6Domain.h
include/net-snmp/library/snmpUDPDomain.h
include/net-snmp/library/snmpUDPIPv6Domain.h
include/net-snmp/library/snmpUnixDomain.h
include/net-snmp/library/snmp_alarm.h
include/net-snmp/library/snmp_api.h
include/net-snmp/library/snmp_assert.h
include/net-snmp/library/snmp_client.h
include/net-snmp/library/snmp_debug.h
include/net-snmp/library/snmp_enum.h
include/net-snmp/library/snmp_impl.h
include/net-snmp/library/snmp_locking.h
include/net-snmp/library/snmp_logging.h
include/net-snmp/library/snmp_parse_args.h
include/net-snmp/library/snmp_secmod.h
include/net-snmp/library/snmp_transport.h
include/net-snmp/library/snmpusm.h
include/net-snmp/library/snmpv3-security-includes.h
include/net-snmp/library/snmpv3.h
include/net-snmp/library/system.h
include/net-snmp/library/tools.h
include/net-snmp/library/transform_oids.h
include/net-snmp/library/ucd_compat.h
include/net-snmp/library/vacm.h
include/net-snmp/library/winservice.h
include/net-snmp/machine/generic.h
include/net-snmp/mib_api.h
include/net-snmp/net-snmp-config.h
include/net-snmp/net-snmp-includes.h
include/net-snmp/output_api.h
include/net-snmp/pdu_api.h
include/net-snmp/session_api.h
include/net-snmp/snmpv3_api.h
include/net-snmp/system/aix.h
include/net-snmp/system/bsd.h
include/net-snmp/system/bsdi.h
include/net-snmp/system/bsdi3.h
include/net-snmp/system/bsdi4.h
include/net-snmp/system/cygwin.h
include/net-snmp/system/darwin.h
include/net-snmp/system/dynix.h
include/net-snmp/system/freebsd.h
include/net-snmp/system/freebsd2.h
include/net-snmp/system/freebsd3.h
include/net-snmp/system/freebsd4.h
include/net-snmp/system/generic.h
include/net-snmp/system/hpux.h
include/net-snmp/system/irix.h
include/net-snmp/system/linux.h
include/net-snmp/system/mips.h
include/net-snmp/system/netbsd.h
include/net-snmp/system/openbsd.h
include/net-snmp/system/solaris.h
include/net-snmp/system/solaris2.6.h
include/net-snmp/system/solaris2.7.h
include/net-snmp/system/solaris2.8.h
include/net-snmp/system/sunos.h
include/net-snmp/system/svr5.h
include/net-snmp/system/sysv.h
include/net-snmp/system/ultrix4.h
include/net-snmp/types.h
include/net-snmp/utilities.h
include/net-snmp/varbind_api.h
include/net-snmp/version.h
lib/libnetsnmp.a
lib/libnetsnmp.la
lib/libnetsnmp.so
lib/libnetsnmp.so.5
lib/libnetsnmp.so.5.6
lib/libnetsnmpagent.a
lib/libnetsnmpagent.la
lib/libnetsnmpagent.so
lib/libnetsnmpagent.so.5
lib/libnetsnmpagent.so.5.6
lib/libnetsnmphelpers.a
lib/libnetsnmphelpers.la
lib/libnetsnmphelpers.so
lib/libnetsnmphelpers.so.5
lib/libnetsnmphelpers.so.5.6
lib/libnetsnmpmibs.a
lib/libnetsnmpmibs.la
lib/libnetsnmpmibs.so
lib/libnetsnmpmibs.so.5
lib/libnetsnmpmibs.so.5.6
man/man1/mib2c.1
man/man1/snmpbulkget.1
man/man1/snmpbulkwalk.1
man/man1/snmpcmd.1
man/man1/snmpconf.1
man/man1/snmpd.1
man/man1/snmpdelta.1
man/man1/snmpdf.1
man/man1/snmpget.1
man/man1/snmpgetnext.1
man/man1/snmpinform.1
man/man1/snmpnetstat.1
man/man1/snmpset.1
man/man1/snmpstatus.1
man/man1/snmptable.1
man/man1/snmptest.1
man/man1/snmptranslate.1
man/man1/snmptrap.1
man/man1/snmpusm.1
man/man1/snmpwalk.1
man/man3/add_mibdir.3
man/man3/add_module_replacement.3
man/man3/default_store.3
man/man3/get_module_node.3
man/man3/init_mib.3
man/man3/init_mib_internals.3
man/man3/mib_api.3
man/man3/netsnmp_agent.3
man/man3/netsnmp_bulk_to_next.3
man/man3/netsnmp_debug.3
man/man3/netsnmp_example_scalar_int.3
man/man3/netsnmp_handler.3
man/man3/netsnmp_instance.3
man/man3/netsnmp_mib_handler_methods.3
man/man3/netsnmp_multiplexer.3
man/man3/netsnmp_old_api.3
man/man3/netsnmp_read_only.3
man/man3/netsnmp_scalar.3
man/man3/netsnmp_serialize.3
man/man3/netsnmp_table.3
man/man3/netsnmp_table_array.3
man/man3/netsnmp_table_data.3
man/man3/netsnmp_table_dataset.3
man/man3/netsnmp_table_iterator.3
man/man3/netsnmp_todo.3
man/man3/netsnmp_watcher.3
man/man3/print_description.3
man/man3/print_mib.3
man/man3/print_objid.3
man/man3/print_value.3
man/man3/print_variable.3
man/man3/read_all_mibs.3
man/man3/read_config.3
man/man3/read_mib.3
man/man3/read_module.3
man/man3/read_module_node.3
man/man3/read_objid.3
man/man3/shutdown_mib.3
man/man3/snmp_agent_api.3
man/man3/snmp_alarm.3
man/man3/snmp_api.3
man/man3/snmp_api_errstring.3
man/man3/snmp_close.3
man/man3/snmp_error.3
man/man3/snmp_free_pdu.3
man/man3/snmp_open.3
man/man3/snmp_perror.3
man/man3/snmp_read.3
man/man3/snmp_select_info.3
man/man3/snmp_send.3
man/man3/snmp_sess_api.3
man/man3/snmp_sess_async_send.3
man/man3/snmp_sess_close.3
man/man3/snmp_sess_error.3
man/man3/snmp_sess_init.3
man/man3/snmp_sess_open.3
man/man3/snmp_sess_perror.3
man/man3/snmp_sess_read.3
man/man3/snmp_sess_select_info.3
man/man3/snmp_sess_send.3
man/man3/snmp_sess_session.3
man/man3/snmp_sess_timeout.3
man/man3/snmp_set_mib_warnings.3
man/man3/snmp_set_save_descriptions.3
man/man3/snmp_timeout.3
man/man3/snmp_trap_api.3
man/man5/snmp.conf.5
man/man5/snmp_config.5
man/man5/snmpd.conf.5
man/man5/snmptrapd.conf.5
man/man5/variables.5
man/man8/snmptrapd.8
sbin/snmpd
sbin/snmptrapd
share/examples/net-snmp/EXAMPLE.conf
share/snmp/mib2c.array-user.conf
share/snmp/mib2c.column_defines.conf
share/snmp/mib2c.column_enums.conf
share/snmp/mib2c.conf
share/snmp/mib2c.create-dataset.conf
share/snmp/mib2c.iterate.conf
share/snmp/mib2c.old-api.conf
share/snmp/mibs/AGENTX-MIB.txt
share/snmp/mibs/DISMAN-SCHEDULE-MIB.txt
share/snmp/mibs/DISMAN-SCRIPT-MIB.txt
share/snmp/mibs/EtherLike-MIB.txt
share/snmp/mibs/HCNUM-TC.txt
share/snmp/mibs/HOST-RESOURCES-MIB.txt
share/snmp/mibs/HOST-RESOURCES-TYPES.txt
share/snmp/mibs/IANA-ADDRESS-FAMILY-NUMBERS-MIB.txt
share/snmp/mibs/IANA-LANGUAGE-MIB.txt
share/snmp/mibs/IANAifType-MIB.txt
share/snmp/mibs/IF-INVERTED-STACK-MIB.txt
share/snmp/mibs/IF-MIB.txt
share/snmp/mibs/INET-ADDRESS-MIB.txt
share/snmp/mibs/IP-FORWARD-MIB.txt
share/snmp/mibs/IP-MIB.txt
share/snmp/mibs/IPV6-ICMP-MIB.txt
share/snmp/mibs/IPV6-MIB.txt
share/snmp/mibs/IPV6-TC.txt
share/snmp/mibs/IPV6-TCP-MIB.txt
share/snmp/mibs/IPV6-UDP-MIB.txt
share/snmp/mibs/NET-SNMP-AGENT-MIB.txt
share/snmp/mibs/NET-SNMP-EXAMPLES-MIB.txt
share/snmp/mibs/NET-SNMP-MIB.txt
share/snmp/mibs/NOTIFICATION-LOG-MIB.txt
share/snmp/mibs/RFC-1215.txt
share/snmp/mibs/RFC1155-SMI.txt
share/snmp/mibs/RFC1213-MIB.txt
share/snmp/mibs/RMON-MIB.txt
share/snmp/mibs/SMUX-MIB.txt
share/snmp/mibs/SNMP-COMMUNITY-MIB.txt
share/snmp/mibs/SNMP-FRAMEWORK-MIB.txt
share/snmp/mibs/SNMP-MPD-MIB.txt
share/snmp/mibs/SNMP-NOTIFICATION-MIB.txt
share/snmp/mibs/SNMP-PROXY-MIB.txt
share/snmp/mibs/SNMP-TARGET-MIB.txt
share/snmp/mibs/SNMP-USER-BASED-SM-MIB.txt
share/snmp/mibs/SNMP-VIEW-BASED-ACM-MIB.txt
share/snmp/mibs/SNMPv2-CONF.txt
share/snmp/mibs/SNMPv2-MIB.txt
share/snmp/mibs/SNMPv2-SMI.txt
share/snmp/mibs/SNMPv2-TC.txt
share/snmp/mibs/SNMPv2-TM.txt
share/snmp/mibs/TCP-MIB.txt
share/snmp/mibs/UCD-DEMO-MIB.txt
share/snmp/mibs/UCD-DISKIO-MIB.txt
share/snmp/mibs/UCD-DLMOD-MIB.txt
share/snmp/mibs/UCD-IPFWACC-MIB.txt
share/snmp/mibs/UCD-SNMP-MIB.txt
share/snmp/mibs/UDP-MIB.txt
share/snmp/snmpconf-data/snmp-data/authopts
share/snmp/snmpconf-data/snmp-data/debugging
share/snmp/snmpconf-data/snmp-data/mibs
share/snmp/snmpconf-data/snmp-data/output
share/snmp/snmpconf-data/snmp-data/snmpconf-config
share/snmp/snmpconf-data/snmpd-data/acl
share/snmp/snmpconf-data/snmpd-data/basic_setup
share/snmp/snmpconf-data/snmpd-data/extending
share/snmp/snmpconf-data/snmpd-data/monitor
share/snmp/snmpconf-data/snmpd-data/operation
share/snmp/snmpconf-data/snmpd-data/snmpconf-config
share/snmp/snmpconf-data/snmpd-data/system
share/snmp/snmpconf-data/snmpd-data/trapsinks
share/snmp/snmpconf-data/snmptrapd-data/formatting
share/snmp/snmpconf-data/snmptrapd-data/snmpconf-config
share/snmp/snmpconf-data/snmptrapd-data/traphandle
@dirrm share/snmp/snmpconf-data/snmptrapd-data
@dirrm share/snmp/snmpconf-data/snmpd-data
@dirrm share/snmp/snmpconf-data/snmp-data
@dirrm share/snmp/snmpconf-data
@dirrm share/snmp/mibs
@dirrm share/examples/net-snmp
@dirrm include/net-snmp/system
@dirrm include/net-snmp/machine
@dirrm include/net-snmp/library
@dirrm include/net-snmp/agent
@dirrm include/net-snmp

View file

@ -0,0 +1,24 @@
# $NetBSD: buildlink2.mk,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
.if !defined(NET_SNMP_BUILDLINK2_MK)
NET_SNMP_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= net-snmp
BUILDLINK_PKGBASE.net-snmp= net-snmp
BUILDLINK_DEPENDS.net-snmp?= net-snmp>=5.0.6
BUILDLINK_PKGSRCDIR.net-snmp?= ../../net/net-snmp
EVAL_PREFIX+= BUILDLINK_PREFIX.net-snmp=net-snmp
BUILDLINK_PREFIX.net-snmp_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.net-snmp= include/net-snmp/*/*
BUILDLINK_FILES.net-snmp= include/net-snmp/*
BUILDLINK_FILES.net-snmp+= lib/libnetsnmp.*
BUILDLINK_FILES.net-snmp+= lib/libnetsnmpagent.*
BUILDLINK_FILES.net-snmp+= lib/libnetsnmphelpers.*
BUILDLINK_FILES.net-snmp+= lib/libnetsnmpmibs.*
BUILDLINK_TARGETS+= net-snmp-buildlink
net-snmp-buildlink: _BUILDLINK_USE
.endif # NET_SNMP_BUILDLINK2_MK

5
net/net-snmp/distinfo Normal file
View file

@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.1.1.1 2002/10/24 08:29:33 jlam Exp $
SHA1 (net-snmp-5.0.6.tar.gz) = c4aa9e638161014a02bc670fc7d5c09a34024f8c
Size (net-snmp-5.0.6.tar.gz) = 2209625 bytes
SHA1 (patch-aa) = 186aeb6c637a3ebe2a0d65d819a4af2bfc4467e9

View file

@ -0,0 +1,493 @@
/* $NetBSD: disklabel.h,v 1.1.1.1 2002/10/24 08:29:34 jlam Exp $ */
/* */
/* NetBSD: disklabel.h,v 1.60.4.4 2002/01/29 22:16:37 he Exp */
/*
* Copyright (c) 1987, 1988, 1993
* The Regents of the University of California. All rights reserved.
*
* Redistribution and use in source and binary forms, with or without
* modification, are permitted provided that the following conditions
* are met:
* 1. Redistributions of source code must retain the above copyright
* notice, this list of conditions and the following disclaimer.
* 2. Redistributions in binary form must reproduce the above copyright
* notice, this list of conditions and the following disclaimer in the
* documentation and/or other materials provided with the distribution.
* 3. All advertising materials mentioning features or use of this software
* must display the following acknowledgement:
* This product includes software developed by the University of
* California, Berkeley and its contributors.
* 4. Neither the name of the University nor the names of its contributors
* may be used to endorse or promote products derived from this software
* without specific prior written permission.
*
* THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
* ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
* IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
* ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
* FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
* DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
* OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
* HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
* LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
* OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
* SUCH DAMAGE.
*
* @(#)disklabel.h 8.2 (Berkeley) 7/10/94
*/
#ifndef _SYS_DISKLABEL_H_
#define _SYS_DISKLABEL_H_
/*
* We need <machine/types.h> for __HAVE_OLD_DISKLABEL
*/
#ifndef _LOCORE
#include <sys/types.h>
#endif
/*
* Each disk has a label which includes information about the hardware
* disk geometry, filesystem partitions, and drive specific information.
* The location of the label, as well as the number of partitions the
* label can describe and the number of the "whole disk" (raw)
* paritition are machine dependent.
*/
#include <machine/disklabel.h>
/*
* The absolute maximum number of disk partitions allowed.
* This is the maximum value of MAXPARTITIONS for which 'struct disklabel'
* is <= DEV_BSIZE bytes long. If MAXPARTITIONS is greater than this, beware.
*/
#define MAXMAXPARTITIONS 22
#if MAXPARTITIONS > MAXMAXPARTITIONS
#warning beware: MAXPARTITIONS bigger than MAXMAXPARTITIONS
#endif
/*
* Ports can switch their MAXPARTITIONS once, as follows:
*
* - define OLDMAXPARTITIONS in <machine/disklabel.h> as the old number
* - define MAXPARTITIONS as the new number
* - define DISKUNIT, DISKPART and DISKMINOR macros in <machine/disklabel.h>
* as appropriate for the port (see the i386 one for an example).
* - define __HAVE_OLD_DISKLABEL in <machine/types.h>
*/
#if defined(_KERNEL) && defined(__HAVE_OLD_DISKLABEL) && \
(MAXPARTITIONS < OLDMAXPARTITIONS)
#error "can only grow disklabel size"
#endif
/*
* Translate between device numbers and major/disk unit/disk partition.
*/
#ifndef __HAVE_OLD_DISKLABEL
#define DISKUNIT(dev) (minor(dev) / MAXPARTITIONS)
#define DISKPART(dev) (minor(dev) % MAXPARTITIONS)
#define DISKMINOR(unit, part) \
(((unit) * MAXPARTITIONS) + (part))
#endif
#define MAKEDISKDEV(maj, unit, part) \
(makedev((maj), DISKMINOR((unit), (part))))
#define DISKMAGIC ((u_int32_t)0x82564557) /* The disk magic number */
#ifndef _LOCORE
struct disklabel {
u_int32_t d_magic; /* the magic number */
u_int16_t d_type; /* drive type */
u_int16_t d_subtype; /* controller/d_type specific */
char d_typename[16]; /* type name, e.g. "eagle" */
/*
* d_packname contains the pack identifier and is returned when
* the disklabel is read off the disk or in-core copy.
* d_boot0 and d_boot1 are the (optional) names of the
* primary (block 0) and secondary (block 1-15) bootstraps
* as found in /usr/mdec. These are returned when using
* getdiskbyname(3) to retrieve the values from /etc/disktab.
*/
union {
char un_d_packname[16]; /* pack identifier */
struct {
char *un_d_boot0; /* primary bootstrap name */
char *un_d_boot1; /* secondary bootstrap name */
} un_b;
} d_un;
#define d_packname d_un.un_d_packname
#define d_boot0 d_un.un_b.un_d_boot0
#define d_boot1 d_un.un_b.un_d_boot1
/* disk geometry: */
u_int32_t d_secsize; /* # of bytes per sector */
u_int32_t d_nsectors; /* # of data sectors per track */
u_int32_t d_ntracks; /* # of tracks per cylinder */
u_int32_t d_ncylinders; /* # of data cylinders per unit */
u_int32_t d_secpercyl; /* # of data sectors per cylinder */
u_int32_t d_secperunit; /* # of data sectors per unit */
/*
* Spares (bad sector replacements) below are not counted in
* d_nsectors or d_secpercyl. Spare sectors are assumed to
* be physical sectors which occupy space at the end of each
* track and/or cylinder.
*/
u_int16_t d_sparespertrack; /* # of spare sectors per track */
u_int16_t d_sparespercyl; /* # of spare sectors per cylinder */
/*
* Alternative cylinders include maintenance, replacement,
* configuration description areas, etc.
*/
u_int32_t d_acylinders; /* # of alt. cylinders per unit */
/* hardware characteristics: */
/*
* d_interleave, d_trackskew and d_cylskew describe perturbations
* in the media format used to compensate for a slow controller.
* Interleave is physical sector interleave, set up by the
* formatter or controller when formatting. When interleaving is
* in use, logically adjacent sectors are not physically
* contiguous, but instead are separated by some number of
* sectors. It is specified as the ratio of physical sectors
* traversed per logical sector. Thus an interleave of 1:1
* implies contiguous layout, while 2:1 implies that logical
* sector 0 is separated by one sector from logical sector 1.
* d_trackskew is the offset of sector 0 on track N relative to
* sector 0 on track N-1 on the same cylinder. Finally, d_cylskew
* is the offset of sector 0 on cylinder N relative to sector 0
* on cylinder N-1.
*/
u_int16_t d_rpm; /* rotational speed */
u_int16_t d_interleave; /* hardware sector interleave */
u_int16_t d_trackskew; /* sector 0 skew, per track */
u_int16_t d_cylskew; /* sector 0 skew, per cylinder */
u_int32_t d_headswitch; /* head switch time, usec */
u_int32_t d_trkseek; /* track-to-track seek, usec */
u_int32_t d_flags; /* generic flags */
#define NDDATA 5
u_int32_t d_drivedata[NDDATA]; /* drive-type specific information */
#define NSPARE 5
u_int32_t d_spare[NSPARE]; /* reserved for future use */
u_int32_t d_magic2; /* the magic number (again) */
u_int16_t d_checksum; /* xor of data incl. partitions */
/* filesystem and partition information: */
u_int16_t d_npartitions; /* number of partitions in following */
u_int32_t d_bbsize; /* size of boot area at sn0, bytes */
u_int32_t d_sbsize; /* max size of fs superblock, bytes */
struct partition { /* the partition table */
u_int32_t p_size; /* number of sectors in partition */
u_int32_t p_offset; /* starting sector */
u_int32_t p_fsize; /* filesystem basic fragment size */
u_int8_t p_fstype; /* filesystem type, see below */
u_int8_t p_frag; /* filesystem fragments per block */
union {
u_int16_t cpg; /* UFS: FS cylinders per group */
u_int16_t sgs; /* LFS: FS segment shift */
} __partition_u1;
#define p_cpg __partition_u1.cpg
#define p_sgs __partition_u1.sgs
} d_partitions[MAXPARTITIONS]; /* actually may be more */
};
#ifdef __HAVE_OLD_DISKLABEL
/*
* Same as above, but with OLDMAXPARTITIONS partitions. For use in
* the old DIOC* ioctl calls.
*/
struct olddisklabel {
u_int32_t d_magic;
u_int16_t d_type;
u_int16_t d_subtype;
char d_typename[16];
union {
char un_d_packname[16];
struct {
char *un_d_boot0;
char *un_d_boot1;
} un_b;
} d_un;
u_int32_t d_secsize;
u_int32_t d_nsectors;
u_int32_t d_ntracks;
u_int32_t d_ncylinders;
u_int32_t d_secpercyl;
u_int32_t d_secperunit;
u_int16_t d_sparespertrack;
u_int16_t d_sparespercyl;
u_int32_t d_acylinders;
u_int16_t d_rpm;
u_int16_t d_interleave;
u_int16_t d_trackskew;
u_int16_t d_cylskew;
u_int32_t d_headswitch;
u_int32_t d_trkseek;
u_int32_t d_flags;
u_int32_t d_drivedata[NDDATA];
u_int32_t d_spare[NSPARE];
u_int32_t d_magic2;
u_int16_t d_checksum;
u_int16_t d_npartitions;
u_int32_t d_bbsize;
u_int32_t d_sbsize;
struct opartition {
u_int32_t p_size;
u_int32_t p_offset;
u_int32_t p_fsize;
u_int8_t p_fstype;
u_int8_t p_frag;
union {
u_int16_t cpg;
u_int16_t sgs;
} __partition_u1;
} d_partitions[OLDMAXPARTITIONS];
};
#endif /* __HAVE_OLD_DISKLABEL */
#else /* _LOCORE */
/*
* offsets for asm boot files.
*/
.set d_secsize,40
.set d_nsectors,44
.set d_ntracks,48
.set d_ncylinders,52
.set d_secpercyl,56
.set d_secperunit,60
.set d_end_,276 /* size of disk label */
#endif /* _LOCORE */
/* d_type values: */
#define DTYPE_SMD 1 /* SMD, XSMD; VAX hp/up */
#define DTYPE_MSCP 2 /* MSCP */
#define DTYPE_DEC 3 /* other DEC (rk, rl) */
#define DTYPE_SCSI 4 /* SCSI */
#define DTYPE_ESDI 5 /* ESDI interface */
#define DTYPE_ST506 6 /* ST506 etc. */
#define DTYPE_HPIB 7 /* CS/80 on HP-IB */
#define DTYPE_HPFL 8 /* HP Fiber-link */
#define DTYPE_FLOPPY 10 /* floppy */
#define DTYPE_CCD 11 /* concatenated disk device */
#define DTYPE_VND 12 /* vnode pseudo-disk */
#define DTYPE_ATAPI 13 /* ATAPI */
#define DTYPE_RAID 14 /* RAIDframe */
#define DTYPE_LD 15 /* logical disk */
#ifdef DKTYPENAMES
static const char *const dktypenames[] = {
"unknown",
"SMD",
"MSCP",
"old DEC",
"SCSI",
"ESDI",
"ST506",
"HP-IB",
"HP-FL",
"type 9",
"floppy",
"ccd",
"vnd",
"ATAPI",
"RAID",
"ld",
NULL
};
#define DKMAXTYPES (sizeof(dktypenames) / sizeof(dktypenames[0]) - 1)
#endif
/*
* Filesystem type and version.
* Used to interpret other filesystem-specific
* per-partition information.
*/
#define FS_UNUSED 0 /* unused */
#define FS_SWAP 1 /* swap */
#define FS_V6 2 /* Sixth Edition */
#define FS_V7 3 /* Seventh Edition */
#define FS_SYSV 4 /* System V */
#define FS_V71K 5 /* V7 with 1K blocks (4.1, 2.9) */
#define FS_V8 6 /* Eighth Edition, 4K blocks */
#define FS_BSDFFS 7 /* 4.2BSD fast file system */
#define FS_MSDOS 8 /* MSDOS file system */
#define FS_BSDLFS 9 /* 4.4BSD log-structured file system */
#define FS_OTHER 10 /* in use, but unknown/unsupported */
#define FS_HPFS 11 /* OS/2 high-performance file system */
#define FS_ISO9660 12 /* ISO 9660, normally CD-ROM */
#define FS_BOOT 13 /* partition contains bootstrap */
#define FS_ADOS 14 /* AmigaDOS fast file system */
#define FS_HFS 15 /* Macintosh HFS */
#define FS_FILECORE 16 /* Acorn Filecore Filing System */
#define FS_EX2FS 17 /* Linux Extended 2 file system */
#define FS_NTFS 18 /* Windows/NT file system */
#define FS_RAID 19 /* RAIDframe component */
#define FS_CCD 20 /* concatenated disk component */
#ifdef FSTYPENAMES
static const char *const fstypenames[] = {
"unused",
"swap",
"Version 6",
"Version 7",
"System V",
"4.1BSD",
"Eighth Edition",
"4.2BSD",
"MSDOS",
"4.4LFS",
"unknown",
"HPFS",
"ISO9660",
"boot",
"ADOS",
"HFS",
"FILECORE",
"Linux Ext2",
"NTFS",
"RAID",
"ccd",
NULL
};
#define FSMAXTYPES (sizeof(fstypenames) / sizeof(fstypenames[0]) - 1)
#endif
#ifdef FSCKNAMES
/* These are the names MOUNT_XXX from <sys/mount.h> */
static const char *const fscknames[] = {
NULL, /* unused */
NULL, /* swap */
NULL, /* Version 6 */
NULL, /* Version 7 */
NULL, /* System V */
NULL, /* 4.1BSD */
NULL, /* Eighth edition */
"ffs", /* 4.2BSD */
"msdos", /* MSDOS */
"lfs", /* 4.4LFS */
NULL, /* unknown */
NULL, /* HPFS */
NULL, /* ISO9660 */
NULL, /* boot */
NULL, /* ADOS */
NULL, /* HFS */
NULL, /* FILECORE */
"ext2fs", /* Linux Ext2 */
NULL, /* Windows/NT */
NULL, /* RAID Component */
NULL, /* concatenated disk component */
NULL /* NULL */
};
#define FSMAXNAMES (sizeof(fscknames) / sizeof(fscknames[0]) - 1)
#endif
#ifdef MOUNTNAMES
/* These are the names MOUNT_XXX from <sys/mount.h> */
static const char *const mountnames[] = {
NULL, /* unused */
NULL, /* swap */
NULL, /* Version 6 */
NULL, /* Version 7 */
NULL, /* System V */
NULL, /* 4.1BSD */
NULL, /* Eighth edition */
"ffs", /* 4.2BSD */
"msdos", /* MSDOS */
"lfs", /* 4.4LFS */
NULL, /* unknown */
NULL, /* HPFS */
"cd9660", /* ISO9660 */
NULL, /* boot */
"ados", /* ADOS */
NULL, /* HFS */
"filecore", /* FILECORE */
"ext2fs", /* Linux Ext2 */
"ntfs", /* Windows/NT */
NULL, /* RAID Component */
NULL, /* concatenated disk component */
NULL /* NULL */
};
#define FSMAXMOUNTNAMES (sizeof(mountnames) / sizeof(mountnames[0]) - 1)
#endif
/*
* flags shared by various drives:
*/
#define D_REMOVABLE 0x01 /* removable media */
#define D_ECC 0x02 /* supports ECC */
#define D_BADSECT 0x04 /* supports bad sector forw. */
#define D_RAMDISK 0x08 /* disk emulator */
#define D_CHAIN 0x10 /* can do back-back transfers */
/*
* Drive data for SMD.
*/
#define d_smdflags d_drivedata[0]
#define D_SSE 0x1 /* supports skip sectoring */
#define d_mindist d_drivedata[1]
#define d_maxdist d_drivedata[2]
#define d_sdist d_drivedata[3]
/*
* Drive data for ST506.
*/
#define d_precompcyl d_drivedata[0]
#define d_gap3 d_drivedata[1] /* used only when formatting */
/*
* Drive data for SCSI.
*/
#define d_blind d_drivedata[0]
#ifndef _LOCORE
/*
* Structure used to perform a format or other raw operation,
* returning data and/or register values. Register identification
* and format are device- and driver-dependent.
*/
struct format_op {
char *df_buf;
int df_count; /* value-result */
daddr_t df_startblk;
int df_reg[8]; /* result */
};
/*
* Structure used internally to retrieve information about a partition
* on a disk.
*/
struct partinfo {
struct disklabel *disklab;
struct partition *part;
};
#ifdef _KERNEL
struct buf_queue;
void diskerr
__P((struct buf *, char *, char *, int, int, struct disklabel *));
void disksort_cylinder __P((struct buf_queue *, struct buf *));
void disksort_blkno __P((struct buf_queue *, struct buf *));
void disksort_tail __P((struct buf_queue *, struct buf *));
u_int dkcksum __P((struct disklabel *));
int setdisklabel __P((struct disklabel *, struct disklabel *, u_long,
struct cpu_disklabel *));
char *readdisklabel __P((dev_t, void (*)(struct buf *), struct disklabel *,
struct cpu_disklabel *));
int writedisklabel __P((dev_t, void (*)(struct buf *), struct disklabel *,
struct cpu_disklabel *));
int bounds_check_with_label __P((struct buf *, struct disklabel *, int));
#endif
#endif /* _LOCORE */
#if !defined(_KERNEL) && !defined(_LOCORE)
#include <sys/cdefs.h>
#endif
#endif /* !_SYS_DISKLABEL_H_ */

View file

@ -0,0 +1,29 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: snmpd.sh,v 1.1.1.1 2002/10/24 08:29:34 jlam Exp $
#
# PROVIDE: snmpd
# REQUIRE: DAEMON
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
fi
name="snmpd"
rcvar=$name
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
snmpd_flags="-s" # log using syslog
command_args="-P ${pidfile}"
if [ -f @PKG_SYSCONFDIR@/snmpd.conf ]; then
command_args="${command_args} -c @PKG_SYSCONFDIR@/snmpd.conf"
fi
if [ -f /etc/rc.subr -a -f /etc/rc.conf -a -f /etc/rc.d/DAEMON ]; then
load_rc_config $name
run_rc_command "$1"
else
@ECHO@ -n " ${name}"
${command} ${snmpd_flags} ${command_args}
fi

View file

@ -0,0 +1,29 @@
#!@RCD_SCRIPTS_SHELL@
#
# $NetBSD: snmptrapd.sh,v 1.1.1.1 2002/10/24 08:29:34 jlam Exp $
#
# PROVIDE: snmptrapd
# REQUIRE: DAEMON
if [ -f /etc/rc.subr ]; then
. /etc/rc.subr
fi
name="snmptrapd"
rcvar=$name
command="@PREFIX@/sbin/${name}"
pidfile="/var/run/${name}.pid"
snmptrapd_flags="-s -l 1" # log using syslog w/ facility LOG_LOCAL1
command_args="-u ${pidfile}"
if [ -f @PKG_SYSCONFDIR@/snmptrapd.conf ]; then
command_args="${command_args} -c @PKG_SYSCONFDIR@/snmptrapd.conf"
fi
if [ -f /etc/rc.subr -a -f /etc/rc.conf -a -f /etc/rc.d/DAEMON ]; then
load_rc_config $name
run_rc_command "$1"
else
@ECHO@ -n " ${name}"
${command} ${snmptrapd_flags} ${command_args}
fi

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/10/24 08:29:34 jlam Exp $
--- agent/snmp_agent.c.orig Sat Oct 5 16:41:58 2002
+++ agent/snmp_agent.c
@@ -69,6 +69,10 @@ SOFTWARE.
#include <dmalloc.h>
#endif
+#if HAVE_SYSLOG_H
+#include <syslog.h>
+#endif
+
#ifdef USE_LIBWRAP
#include <tcpd.h>
int allow_severity = LOG_INFO;