* Fixed buildling with Clang.

* Program crashes with image cache enabled. (Image cache doesn't help, anyway.)
This commit is contained in:
adam 2010-12-14 18:26:34 +00:00
parent 24e30fa207
commit 5b05041271
5 changed files with 73 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.7 2010/06/13 22:44:29 wiz Exp $
# $NetBSD: Makefile,v 1.8 2010/12/14 18:26:34 adam Exp $
DISTNAME= enblend-enfuse-4.0
# XXX distribution file has changed; remove the line below on next update
@ -10,7 +10,6 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=enblend/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://enblend.sourceforge.net/
COMMENT= Combines overlapping images without seams, with good exposure
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
@ -21,6 +20,7 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake perl:build pkg-config
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-image-cache
.include "../../mk/bsd.prefs.mk"
@ -29,12 +29,12 @@ CONFIGURE_ARGS+= --enable-openmp
CONFIGURE_ARGS+= --with-apple-opengl-framework
.else
CONFIGURE_ARGS+= --with-x
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/glut/buildlink3.mk"
.endif
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/glew/buildlink3.mk"
.include "../../graphics/lcms/buildlink3.mk"
.include "../../graphics/libxmi/buildlink3.mk"
.include "../../graphics/openexr/buildlink3.mk"

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2010/06/13 22:44:29 wiz Exp $
$NetBSD: distinfo,v 1.6 2010/12/14 18:26:34 adam Exp $
SHA1 (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 34c3a5ce11c6ef0ef520d8a15a3cb6a94a567033
RMD160 (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 9e531b5bf6f7258ef8778c01b456979e0bc04338
@ -6,5 +6,7 @@ Size (enblend-enfuse-4.0/enblend-enfuse-4.0.tar.gz) = 1046677 bytes
SHA1 (patch-aa) = b1809fe6ef6609658b697635c6cbf0c112a03fd1
SHA1 (patch-ab) = afc074bb94e2a2b96c654c37540072514ba0bce0
SHA1 (patch-ac) = 916f4655ff30013583014eb8deecc72bd19ae55d
SHA1 (patch-ad) = bc0a04dbf7477c3db7c9ef979fb851a975a93571
SHA1 (patch-ad) = 735b9bb01a8a76ec3dc4a13cece4d79681c2d951
SHA1 (patch-ae) = d16fc0157c9796bfc63bc434cc627dcf99669d6f
SHA1 (patch-af) = a32710958e30000fe75ecd436071306ea4b1844c
SHA1 (patch-ag) = 6ef31f8b5ce54883e636adf23b4ea615ae9c752d

View file

@ -1,8 +1,28 @@
$NetBSD: patch-ad,v 1.1 2010/05/15 05:47:58 adam Exp $
$NetBSD: patch-ad,v 1.2 2010/12/14 18:26:35 adam Exp $
--- configure.orig 2009-12-20 15:40:28.000000000 +0000
+++ configure
@@ -14111,11 +14107,11 @@ cat >>conftest.$ac_ext <<_ACEOF
@@ -5533,10 +5533,6 @@ echo "${ECHO_T}no" >&6; }
fi
-if test "x$GXX" = xyes; then
- # Fixes SourceForge bug id 2121647 on some systems with newer GCCs.
- CXXFLAGS="$CXXFLAGS --param inline-unit-growth=60"
-fi
@@ -14030,7 +14030,7 @@ if test "x$enable_debug" = "xyes" \
echo "${ECHO_T}yes" >&6; }
enable_debug=yes
else
- CXXFLAGS="$CXXFLAGS -O2 -DNDEBUG -Wall"
+ CXXFLAGS="$CXXFLAGS -DNDEBUG -Wall"
{ echo "$as_me:$LINENO: result: no" >&5
echo "${ECHO_T}no" >&6; }
enable_debug=no
@@ -14111,11 +14111,11 @@ cat >>conftest.$ac_ext <<_ACEOF
#ifdef __cplusplus
extern "C"
#endif

View file

@ -0,0 +1,22 @@
$NetBSD: patch-af,v 1.1 2010/12/14 18:26:35 adam Exp $
--- src/anneal.h.orig 2010-10-30 19:43:51.000000000 +0000
+++ src/anneal.h
@@ -656,14 +656,14 @@ protected:
bool segmentIntersect(const Point2D& l1a, const Point2D& l1b,
const Point2D& l2a, const Point2D& l2b) const {
- const int denom =
+ int denom =
(l2b.y - l2a.y) * (l1b.x - l1a.x) - (l2b.x - l2a.x) * (l1b.y - l1a.y);
if (denom == 0) {
return false; // lines are parallel or coincident
}
- const int uaNum =
+ int uaNum =
(l2b.x - l2a.x) * (l1a.y - l2a.y) - (l2b.y - l2a.y) * (l1a.x - l2a.x);
- const int ubNum =
+ int ubNum =
(l1b.x - l1a.x) * (l1a.y - l2a.y) - (l1b.y - l1a.y) * (l1a.x - l2a.x);
if (denom < 0) {
uaNum *= -1;

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ag,v 1.1 2010/12/14 18:26:35 adam Exp $
--- include/vigra/cachedfileimage.hxx.orig 2010-10-30 19:45:49.000000000 +0000
+++ include/vigra/cachedfileimage.hxx
@@ -556,7 +556,7 @@ class NotifyingDirectionSelector;
template <class T, class Notify>
class NotifyingDirectionSelector<UnstridedArrayTag, T, Notify>
{
-#ifdef __GNUC__
+#if defined(__GNUC__) && !defined(__clang__)
friend class Notify::self_type;
#else
friend typename Notify::self_type;
@@ -602,7 +602,7 @@ private:
template <class T, class Notify>
class NotifyingDirectionSelector<StridedArrayTag, T, Notify> {
-#ifdef __GNUC__
+#if defined(__GNUC__) && !defined(__clang__)
friend class Notify::self_type;
#else
friend typename Notify::self_type;