nullptr is a reserved name in C++11, so use a different identifier.
This commit is contained in:
parent
b1f45d6ea5
commit
5b1820ddec
2 changed files with 20 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.5 2011/11/24 08:22:52 obache Exp $
|
||||
$NetBSD: distinfo,v 1.6 2013/04/29 21:17:47 joerg Exp $
|
||||
|
||||
SHA1 (bouml_4.22.2.tar.gz) = 860f182af76d259ed10f6acd001520914604fe30
|
||||
RMD160 (bouml_4.22.2.tar.gz) = 1dcd456dbb567174ea768ce662e49a92c9c3680c
|
||||
Size (bouml_4.22.2.tar.gz) = 5474273 bytes
|
||||
SHA1 (patch-aa) = 59321e789df42151abf13c995894478d02e8f5f9
|
||||
SHA1 (patch-src_JavaCat_Class.cpp) = 3d4bec4e17df54a77901d2e66ae93f767e9f286f
|
||||
|
|
18
devel/bouml/patches/patch-src_JavaCat_Class.cpp
Normal file
18
devel/bouml/patches/patch-src_JavaCat_Class.cpp
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-src_JavaCat_Class.cpp,v 1.1 2013/04/29 21:17:48 joerg Exp $
|
||||
|
||||
--- src/JavaCat/Class.cpp.orig 2013-04-29 20:02:00.000000000 +0000
|
||||
+++ src/JavaCat/Class.cpp
|
||||
@@ -601,11 +601,11 @@ bool Class::reverse(ClassContainer * con
|
||||
if (CurrentArtifact->associatedClasses().isEmpty()) {
|
||||
// first association, to set artifact def
|
||||
Package * pack = (Package *) cl->parent();
|
||||
- UmlArtifact * nullptr = 0;
|
||||
+ UmlArtifact * my_nullptr = 0;
|
||||
|
||||
CurrentArtifact->addAssociatedClass(cl_uml);
|
||||
cl_uml->need_artifact(pack->get_imports(), pack->is_java_lang_added(),
|
||||
- pack->get_static_imports(), path, nullptr);
|
||||
+ pack->get_static_imports(), path, my_nullptr);
|
||||
}
|
||||
else
|
||||
CurrentArtifact->addAssociatedClass(cl_uml);
|
Loading…
Reference in a new issue