Update to 5.2.1; remove ONLY_FOR_PLATFORM: even though gdb is in the NetBSD
base system, people may want to install it from pkgsrc, particularly on Darwin (?), Linux, SunOS and since there is no problem in having one gdb in pkgsrc and one in the base-system, no harm is done. Changes since the last version (4.18) are numerous; highlights include: * New command "set trust-readonly-sections on[off]". * New command "generate-core-file" (or "gcore"). * New command line option --pid or -p followed by a process id * The new `--args' feature can be used to specify command-line arguments for the inferior from gdb's command line. * a new `operate-and-get-next' function bound to `C-o'.
This commit is contained in:
parent
dacd43efdf
commit
5b2528cab1
4 changed files with 45 additions and 20 deletions
|
@ -1,16 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.4 2002/02/18 15:14:10 seb Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2002/08/07 14:18:26 jschauma Exp $
|
||||
#
|
||||
|
||||
DISTNAME= gdb-4.18
|
||||
DISTNAME= gdb-5.2.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gdb/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNU:=gdb/}
|
||||
|
||||
MAINTAINER= packages@netbsd.org
|
||||
HOMEPAGE= http://www.gnu.org/software/gdb/gdb.html
|
||||
COMMENT= symbolic debugger for multiple language frontends
|
||||
|
||||
ONLY_FOR_PLATFORM= SunOS-*-* # in NetBSD base system
|
||||
|
||||
MAKE_ENV+= CPPFLAGS=
|
||||
INFO_FILES= gdb.info gdbint.info stabs.info bfd.info
|
||||
INFO_FILES+= mmalloc.info standards.info
|
||||
|
|
|
@ -1,16 +1,15 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2002/02/18 15:14:10 seb Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2002/08/07 14:18:27 jschauma Exp $
|
||||
bin/gdb
|
||||
include/bfd.h
|
||||
include/ansidecl.h
|
||||
include/bfd.h
|
||||
include/bfdlink.h
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/standards.info %D/info/dir
|
||||
include/dis-asm.h
|
||||
include/symcat.h
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/mmalloc.info %D/info/dir
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/bfd.info %D/info/dir
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/gdb.info %D/info/dir
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/gdbint.info %D/info/dir
|
||||
@unexec ${INSTALL_INFO} --delete %D/info/stabs.info %D/info/dir
|
||||
info/standards.info
|
||||
info/mmalloc.info
|
||||
info/bfd.info
|
||||
info/bfd.info-1
|
||||
info/bfd.info-2
|
||||
|
@ -18,9 +17,22 @@ info/bfd.info-3
|
|||
info/bfd.info-4
|
||||
info/bfd.info-5
|
||||
info/bfd.info-6
|
||||
info/bfd.info-7
|
||||
info/bfd.info-8
|
||||
info/bfd.info-9
|
||||
info/configure.info
|
||||
info/configure.info-1
|
||||
info/configure.info-2
|
||||
info/configure.info-3
|
||||
info/gdb.info
|
||||
info/gdb.info-1
|
||||
info/gdb.info-10
|
||||
info/gdb.info-11
|
||||
info/gdb.info-12
|
||||
info/gdb.info-13
|
||||
info/gdb.info-14
|
||||
info/gdb.info-15
|
||||
info/gdb.info-16
|
||||
info/gdb.info-2
|
||||
info/gdb.info-3
|
||||
info/gdb.info-4
|
||||
|
@ -33,12 +45,18 @@ info/gdbint.info
|
|||
info/gdbint.info-1
|
||||
info/gdbint.info-2
|
||||
info/gdbint.info-3
|
||||
info/gdbint.info-4
|
||||
info/gdbint.info-5
|
||||
info/gdbint.info-6
|
||||
info/mmalloc.info
|
||||
info/stabs.info
|
||||
info/stabs.info-1
|
||||
info/stabs.info-2
|
||||
info/stabs.info-3
|
||||
info/stabs.info-4
|
||||
info/standards.info
|
||||
@exec ${INSTALL_INFO} %D/info/standards.info %D/info/dir
|
||||
@exec ${INSTALL_INFO} %D/info/configure.info %D/info/dir
|
||||
@exec ${INSTALL_INFO} %D/info/mmalloc.info %D/info/dir
|
||||
@exec ${INSTALL_INFO} %D/info/bfd.info %D/info/dir
|
||||
@exec ${INSTALL_INFO} %D/info/gdb.info %D/info/dir
|
||||
|
@ -51,3 +69,14 @@ lib/libopcodes.a
|
|||
lib/libopcodes.la
|
||||
lib/libmmalloc.a
|
||||
man/man1/gdb.1
|
||||
share/locale/da/LC_MESSAGES/opcodes.mo
|
||||
share/locale/de/LC_MESSAGES/opcodes.mo
|
||||
share/locale/es/LC_MESSAGES/bfd.mo
|
||||
share/locale/es/LC_MESSAGES/opcodes.mo
|
||||
share/locale/fr/LC_MESSAGES/bfd.mo
|
||||
share/locale/fr/LC_MESSAGES/opcodes.mo
|
||||
share/locale/ja/LC_MESSAGES/bfd.mo
|
||||
share/locale/sv/LC_MESSAGES/bfd.mo
|
||||
share/locale/sv/LC_MESSAGES/opcodes.mo
|
||||
share/locale/tr/LC_MESSAGES/bfd.mo
|
||||
share/locale/tr/LC_MESSAGES/opcodes.mo
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:18 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2002/08/07 14:18:27 jschauma Exp $
|
||||
|
||||
SHA1 (gdb-4.18.tar.gz) = 4b8abe282a62e581ceb95dd8bf5e467a4521d971
|
||||
Size (gdb-4.18.tar.gz) = 11657032 bytes
|
||||
SHA1 (patch-aa) = a256a6a9e0fe126462ea92c8a5c8a3864333bb67
|
||||
SHA1 (gdb-5.2.1.tar.gz) = 516fc00911a661c6e29bfdb402f3863e5fc2a2aa
|
||||
Size (gdb-5.2.1.tar.gz) = 14715792 bytes
|
||||
SHA1 (patch-aa) = 11c29e1af9ec6301c81735310e85fe18e7407251
|
||||
|
|
|
@ -1,10 +1,8 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 1999/07/01 15:26:20 agc Exp $
|
||||
$NetBSD: patch-aa,v 1.2 2002/08/07 14:18:28 jschauma Exp $
|
||||
|
||||
Don't install readline.
|
||||
|
||||
--- Makefile.in Wed Apr 7 22:40:04 1999
|
||||
+++ Makefile.in Thu Jul 1 15:15:36 1999
|
||||
@@ -699,7 +699,6 @@
|
||||
--- Makefile.in.orig Sat Jul 27 19:25:33 2002
|
||||
+++ Makefile.in Sat Jul 27 19:25:41 2002
|
||||
@@ -712,7 +712,6 @@
|
||||
install-perl \
|
||||
install-prms \
|
||||
install-rcs \
|
||||
|
|
Loading…
Reference in a new issue