Changes 2.4.14:

Lib/
* Added ldap.controls.openldap.SearchNoOpControl
* New method ldap.async.AsyncSearchHandler.afterFirstResult()
  for doing something right after successfully receiving but before
  processing first result
* Better log data written when invoking ldap.LDAPLock.acquire() and
  ldap.LDAPLock.release()
* LDAPObject and friends now pass `desc' to ldap.LDAPLock() which
  results in better logging
* ldapobject.ReconnectLDAPObject now uses internal class-wide
  lock for serializing reconnects
* Method signature of ReconnectLDAPObject.reconnect() changed to be able
  to call it with separate retry_max and retry_delay values
Modules/
* Added support for retrieving negotiated TLS version/cipher
  with LDAPObject.get_option() with the help of upcoming OpenLDAP libs
This commit is contained in:
adam 2014-03-03 17:01:34 +00:00
parent 374dfca2a5
commit 5b48ea9f50
4 changed files with 12 additions and 12 deletions

View file

@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.53 2014/02/12 23:17:44 tron Exp $
# $NetBSD: Makefile,v 1.54 2014/03/03 17:01:34 adam Exp $
DISTNAME= python-ldap-2.4.13
DISTNAME= python-ldap-2.4.14
PKGNAME= ${DISTNAME:S/python/${PYPKGPREFIX}/}
PKGREVISION= 1
CATEGORIES= databases python
MASTER_SITES= http://pypi.python.org/packages/source/p/python-ldap/

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.10 2011/11/28 10:58:50 adam Exp $
@comment $NetBSD: PLIST,v 1.11 2014/03/03 17:01:34 adam Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
@ -107,6 +107,7 @@ share/doc/py-ldap/Demo/passwd_ext_op.py
share/doc/py-ldap/Demo/pickle_ldapobject.py
share/doc/py-ldap/Demo/pyasn1/README
share/doc/py-ldap/Demo/pyasn1/dds.py
share/doc/py-ldap/Demo/pyasn1/noopsearch.py
share/doc/py-ldap/Demo/pyasn1/ppolicy.py
share/doc/py-ldap/Demo/pyasn1/psearch.py
share/doc/py-ldap/Demo/pyasn1/readentrycontrol.py

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.20 2013/08/20 15:27:07 adam Exp $
$NetBSD: distinfo,v 1.21 2014/03/03 17:01:34 adam Exp $
SHA1 (python-ldap-2.4.13.tar.gz) = 5222e66a6351263852c36b9767427fb4d52267e1
RMD160 (python-ldap-2.4.13.tar.gz) = b7b9aa4bcd2a5fade00bc5cabb60418cc1246714
Size (python-ldap-2.4.13.tar.gz) = 135550 bytes
SHA1 (patch-aa) = cb22d78d24fcbf8f4ea3ae7be1260a412eb890eb
SHA1 (python-ldap-2.4.14.tar.gz) = ecfc85d8c20272fa05a6d4b50a0cba3a0ae5e8b3
RMD160 (python-ldap-2.4.14.tar.gz) = c7cc8d13b973a9ce6b32230f65838297e547b539
Size (python-ldap-2.4.14.tar.gz) = 136808 bytes
SHA1 (patch-aa) = 9666857ff98f506fca100d202613fdd6b0c39493

View file

@ -1,11 +1,11 @@
$NetBSD: patch-aa,v 1.9 2012/02/28 00:01:05 adam Exp $
$NetBSD: patch-aa,v 1.10 2014/03/03 17:01:34 adam Exp $
--- setup.cfg.orig 2012-02-21 17:18:54.000000000 +0000
+++ setup.cfg
@@ -1,10 +1,10 @@
[_ldap]
-library_dirs = /opt/openldap-RE24/lib /usr/lib
-include_dirs = /opt/openldap-RE24/include /usr/include/sasl /usr/include
-library_dirs = /opt/openldap/lib64 /usr/lib
-include_dirs = /opt/openldap/include /usr/include/sasl /usr/include
-defines = HAVE_SASL HAVE_TLS HAVE_LIBLDAP_R
+library_dirs = @PY_LDAP_LIBRARY_DIRS@
+include_dirs = @PY_LDAP_INCLUDE_DIRS@