define __USE_BSD to get u_char etal to successfully detect libpcap on linux

This commit is contained in:
markd 2011-01-30 01:25:09 +00:00
parent c8ba04dd4e
commit 5b65ce4f38
3 changed files with 31 additions and 8 deletions

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.44 2010/11/30 11:04:58 obache Exp $
$NetBSD: distinfo,v 1.45 2011/01/30 01:25:09 markd Exp $
SHA1 (nmap-5.35DC1.tar.bz2) = 5fd786d4bbe6b4fbc0ae625fbb6893b19fbde627
RMD160 (nmap-5.35DC1.tar.bz2) = d0663a669824a38f05e89c14a2ad5fd9932eddcc
Size (nmap-5.35DC1.tar.bz2) = 11302092 bytes
SHA1 (patch-aa) = 61593e0479a79bcb4cce2e88b2e5753fa14bc429
SHA1 (patch-ab) = 22c377e9a340a6e6d7b9a36b63e6ffc47a084b3b
SHA1 (patch-ab) = d290652bef2ba345e7d95ffe8eb3fe3055c9b6d8
SHA1 (patch-ac) = c22e8f6411b1152a6e7582c90e5ec5bd4c6acaad
SHA1 (patch-aj) = 868440ce24a70c1a747af6d65eed24f20c4bb892
SHA1 (patch-ak) = ffc530fb2987fadbb4990314947015e8cd26c2c9
SHA1 (patch-al) = e7ea6235c964aa17bd03c2bef460eb99716fb932

View file

@ -1,8 +1,8 @@
$NetBSD: patch-ab,v 1.13 2010/03/21 21:58:23 pettai Exp $
$NetBSD: patch-ab,v 1.14 2011/01/30 01:25:09 markd Exp $
--- configure.orig 2009-11-05 20:50:33.000000000 +0100
+++ configure 2010-01-27 23:57:35.000000000 +0100
@@ -5891,7 +5891,7 @@
--- configure.orig 2010-07-16 00:43:59.000000000 +0000
+++ configure
@@ -6212,7 +6212,7 @@ if test "${am_cv_pathless_PYTHON+set}" =
$as_echo_n "(cached) " >&6
else
@ -11,7 +11,7 @@ $NetBSD: patch-ab,v 1.13 2010/03/21 21:58:23 pettai Exp $
test "$am_cv_pathless_PYTHON" = none && break
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
@@ -6145,7 +6145,7 @@
@@ -6466,7 +6466,7 @@ if test "${am_cv_pathless_PYTHON+set}" =
$as_echo_n "(cached) " >&6
else
@ -20,7 +20,7 @@ $NetBSD: patch-ab,v 1.13 2010/03/21 21:58:23 pettai Exp $
test "$am_cv_pathless_PYTHON" = none && break
prog="import sys
# split strings by '.' and convert to numeric. Append some zeros
@@ -7161,6 +7161,7 @@
@@ -7664,6 +7664,7 @@ cat >>conftest.$ac_ext <<_ACEOF
extern char pcap_version[];
int main() {
int major, minor1, minor2;
@ -28,3 +28,12 @@ $NetBSD: patch-ab,v 1.13 2010/03/21 21:58:23 pettai Exp $
sscanf(pcap_version,"%d.%d.%d", &major, &minor1, &minor2);
if (major > 0)
exit(0);
@@ -7714,6 +7715,8 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */
+#define __USE_BSD
+#include <sys/types.h>
#include <stdio.h>
#ifdef HAVE_SYS_IOCCOM_H
#include <sys/ioccom.h>

13
net/nmap/patches/patch-al Normal file
View file

@ -0,0 +1,13 @@
$NetBSD: patch-al,v 1.1 2011/01/30 01:25:09 markd Exp $
--- nping/configure.orig 2011-01-26 10:07:02.311910853 +0000
+++ nping/configure
@@ -5068,6 +5068,8 @@ else
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
+#define __USE_BSD
+#include <sys/types.h>
#include <stdio.h>
#ifdef HAVE_SYS_IOCCOM_H
#include <sys/ioccom.h>