Update to 0.20.13:

0.20.13
=======

Changes since 0.20.12:

- Fix cyclic includes.
- Avoid redefinition of symbols.
- Fix missing function declaration.
- Don't check von connman.pc.
- Allow actions without arguments.
- Respect "prefer_bigger" even if there is no icon size.
- DOAP fixes.
- Fix VAPI generation.
- Fix reference counting.
- Port to new libsoup API.

Bugs fixed in this release:
 - https://bugzilla.gnome.org/show_bug.cgi?id=722696
 - https://bugzilla.gnome.org/show_bug.cgi?id=731209
 - https://bugzilla.gnome.org/show_bug.cgi?id=731457
 - https://bugzilla.gnome.org/show_bug.cgi?id=733241
 - https://bugzilla.gnome.org/show_bug.cgi?id=740267
 - https://bugzilla.gnome.org/show_bug.cgi?id=742075

All contributors to this release:
 - Jens Georg <mail@jensge.org>
 - Sven Neumann <neumann@teufel.de>
 - Jussi Kukkonen <jku@goto.fi>
 - Olav Vitters <olav@vitters.nl>
 - Etienne Peron <etienne.peron@parrot.com>
 - Andre Klapper <a9016009@gmx.de>
This commit is contained in:
wiz 2015-01-17 09:23:26 +00:00
parent cb1c6009ae
commit 5b86669f06
5 changed files with 7 additions and 62 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.35 2014/10/07 16:47:13 adam Exp $
# $NetBSD: Makefile,v 1.36 2015/01/17 09:23:26 wiz Exp $
DISTNAME= gupnp-0.20.12
PKGREVISION= 1
DISTNAME= gupnp-0.20.13
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gupnp/0.20/}
EXTRACT_SUFX= .tar.xz
@ -32,6 +31,7 @@ pre-configure:
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/gobject-introspection/buildlink3.mk"
.include "../../lang/python/application.mk"
BUILDLINK_API_DEPENDS.libsoup24+= libsoup24>=2.48.0
.include "../../net/libsoup24/buildlink3.mk"
.include "../../net/gssdp/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.17 2014/06/24 06:10:54 dholland Exp $
$NetBSD: distinfo,v 1.18 2015/01/17 09:23:26 wiz Exp $
SHA1 (gupnp-0.20.12.tar.xz) = fbc23c0fa0df70f44d50b2ed88dc2c4dc06d166c
RMD160 (gupnp-0.20.12.tar.xz) = ec84d9d351ca0f6d8b5821719f39d0b25abad2b1
Size (gupnp-0.20.12.tar.xz) = 394316 bytes
SHA1 (gupnp-0.20.13.tar.xz) = eaec209a94e40dc98ba3af96277d79eeba59ddad
RMD160 (gupnp-0.20.13.tar.xz) = bb1c41f910de4b14e7babda0fef0420415400a4b
Size (gupnp-0.20.13.tar.xz) = 395356 bytes
SHA1 (patch-ab) = e43380eac64d815fff1a1b62f73e35e1bdfb9633
SHA1 (patch-ad) = 3c10a9883b7c6e0508fe93f26f0e2334a09fb816
SHA1 (patch-libgupnp_gupnp-acl.h) = 058eb86efcb11088b32d2784e8779d389e4d27b1

View file

@ -1,21 +0,0 @@
$NetBSD: patch-libgupnp_gupnp-acl.h,v 1.1 2014/06/24 06:10:54 dholland Exp $
Fix build.
--- libgupnp/gupnp-acl.h.orig 2014-05-29 12:51:43.000000000 +0000
+++ libgupnp/gupnp-acl.h
@@ -68,8 +68,14 @@ typedef struct _GUPnPAcl GUPnPAcl;
typedef struct _GUPnPAclInterface GUPnPAclInterface;
/* Forward declarations to avoid recursive includes */
+#ifndef GUPNPDEVICE_DEFINED
+#define GUPNPDEVICE_DEFINED
typedef struct _GUPnPDevice GUPnPDevice;
+#endif
+#ifndef GUPNPSERVICE_DEFINED
+#define GUPNPSERVICE_DEFINED
typedef struct _GUPnPService GUPnPService;
+#endif
struct _GUPnPAclInterface {
GTypeInterface parent;

View file

@ -1,17 +0,0 @@
$NetBSD: patch-libgupnp_gupnp-device.h,v 1.1 2014/06/24 06:10:54 dholland Exp $
Fix build.
--- libgupnp/gupnp-device.h~ 2014-05-29 12:47:53.000000000 +0000
+++ libgupnp/gupnp-device.h
@@ -51,7 +51,10 @@ gupnp_device_get_type (void) G_GNUC_CONS
GUPnPDeviceClass))
typedef struct _GUPnPDevicePrivate GUPnPDevicePrivate;
+#ifndef GUPNPDEVICE_DEFINED
+#define GUPNPDEVICE_DEFINED
typedef struct _GUPnPDevice GUPnPDevice;
+#endif
typedef struct _GUPnPDeviceClass GUPnPDeviceClass;
/**

View file

@ -1,17 +0,0 @@
$NetBSD: patch-libgupnp_gupnp-service.h,v 1.1 2014/06/24 06:10:54 dholland Exp $
Fix build.
--- libgupnp/gupnp-service.h~ 2014-05-29 12:47:53.000000000 +0000
+++ libgupnp/gupnp-service.h
@@ -65,7 +65,10 @@ gupnp_service_action_get_type (void) G_G
#define GUPNP_TYPE_SERVICE_ACTION (gupnp_service_action_get_type ())
typedef struct _GUPnPServicePrivate GUPnPServicePrivate;
+#ifndef GUPNPSERVICE_DEFINED
+#define GUPNPSERVICE_DEFINED
typedef struct _GUPnPService GUPnPService;
+#endif
typedef struct _GUPnPServiceClass GUPnPServiceClass;
/**