xfce4-exo: update to 4.16.2

Change log:

4.16.2
======
- Properly initialize GdkRectangle to prevent crash (Issue #57)


4.16.1
======
- Revamp the documentation to modernize and uniformize accross
components
- Fix keyboard navigation when only one item is present (#53)


4.16.0
======
- Focus must not be required in single click mode (Issue #190)
- Remove GLIB_CHECK_VERSION IFDEFs which are obsolete after glib bump
- Adjust padding only for vertical item orientation (Issue #48)
- bump glib (and gio, gthread, etc) to 2.50.0
- Fix GCC warning (false negative)
- Translation Updates:
  Basque, Estonian, Norwegian Bokmål, Portuguese (Brazil), Russian,
  Slovenian, Turkish, Vietnamese

4.15.3
======
- Re-grab tree selection to prevent rare crash (Issue #46)
- Remove unneeded RTL adjustment (Issue #45)
- exo-open: Wrap long URI in error dialog (Issue #26)
- Avoid truncated text in small zoom levels (#42)
- Make ExoIconView reduce selection on a single click (issue #39)
- Partially restore 6fcefce9 (Issue #18)
- Adds new, foreign README.md
- Add check for valid GtkTreeSelection (issue #40)
- Reset cursor on drag end in single-click mode
- exo-open: Change priority of command line parameters (Fixes #20)
- Prevent label from overlapping icon in RTL (Fixes #36)
- Prevent "selection_changed" bursts (#37)
- Small change to documentation for exo_strdup_strftime
- desktop-item-edit: Fix fallback for desktop file type detection
- desktop-item-edit: Improve detection of invalid icon names (Fixes #33)
- AC_CONFIG_MACRO_DIR → AC_CONFIG_MACRO_DIRS (Closes !9)
- Translation Updates:
  Albanian, Amharic, Arabic, Armenian, Armenian (Armenia), Asturian,
  Basque, Belarusian, Bengali, Bulgarian, Catalan, Chinese (China),
  Chinese (Hong Kong), Chinese (Taiwan), Croatian, Czech, Danish, Dutch,
  Eastern Armenian, English (Australia), English (United Kingdom),
  Estonian, Finnish, French, Galician, Greek, Hebrew, Hungarian,
  Icelandic, Indonesian, Interlingue, Italian, Japanese, Kannada,
  Latvian, Malay, Norwegian Bokmål, Norwegian Nynorsk, Occitan (post
  1500), Panjabi (Punjabi), Persian (Iran), Polish, Portuguese (Brazil),
  Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Swedish,
  Telugu, Thai, Turkish, Ukrainian, Urdu, Urdu (Pakistan), Uyghur,
  Vietnamese,

4.15.2
======
- icon-chooser-dialog: Allow removing selected icon (Fixes #2)
- desktop-item-edit: Fix sensitivity of save button (Fixes #28)
- Rework exo_icon_view_scroll_event for overshoot effect (Fixes #25)
- Allow resizing the xfce4-settings window smaller (Fixes #19)
- Drop exo-csource from exo
- Fix build on OpenBSD (!2)
- Fix race condition in make install (Fixes #29)
- Remove unused perl module requirement
- Replace bugzilla occurences with gitlab (Fixes #30)
- Translation Updates:
  Albanian, Chinese (China), Chinese (Hong Kong), Danish, Eastern
  Armenian, French, German, Hebrew, Japanese, Kazakh, Korean, Lithuanian,
  Portuguese, Portuguese (Brazil), Russian, Swedish, Turkish

4.15.1
======
This release transitions several exo components to xfce-settings.
Please use with xfce-settings 4.15.1 or later for best results.
- Removed binaries: exo-compose-mail, exo-helper-2
- Removed from API: ExoCellRendererEllipsizedText,
  ExoIconBar, ExoToolbarsEditor, ExoToolbarsEditorDialog,
  ExoToolbarsModel, ExoToolbarsView, ExoWrapTable, ExoXsessionClient,
  exo_atomic_inc, exo_atomic_dec

Other Updates:
- state variable is a GtkStateFlags
- Fix previous commit
- desktop-item-edit: Fix sensitivity of save button (Bug #16813)
- Add basic GitLab pipeline
- Attach popup window to toplevel parent (Bug #16768)
- Rename Thunar.desktop to thunar.desktop (Bug #16197)
- Extend selection on shift+drag (Bug #7526)
- Do not cancel selection on shift+drag
- Rename Thunar.desktop to thunar.desktop (Bug #16197)
- Fix type declaration (Bug #16678)
- desktop-item-edit: Use new XfceTitledDialog API
- Fix GTimeVal deprecation
- Replace deprecated G_INLINE_FUNC macro
- Replace deprecated macro
- Wrong keyboard navigation after using rubberband in exo-icon-view (Bug #16286)
- Cursor position in icon view not visible/highlighted when using ctrl + arrows (Bug #12227)
- Make sure default applications are properly set in mimeapps.list
- Translation Updates:
  Albanian, Amharic, Arabic, Asturian, Basque, Belarusian, Bengali,
  Catalan, Chinese (Hong Kong), Chinese (Taiwan), Danish, Dutch,
  Estonian, Greek, Hungarian, Icelandic, Interlingue, Italian, Kannada,
  Latvian, Lithuanian, Norwegian Bokmål, Norwegian Nynorsk, Occitan
  (post 1500), Panjabi (Punjabi), Persian (Iran), Portuguese, Romanian,
  Russian, Slovak, Spanish, Telugu, Turkish, Uighur, Urdu, Urdu
  (Pakistan), Vietnamese
This commit is contained in:
gutteridge 2021-11-30 14:15:26 +00:00
parent 941bb8ebf9
commit 5bca3c1da1
6 changed files with 107 additions and 253 deletions

View file

@ -1,13 +1,12 @@
# $NetBSD: Makefile,v 1.71 2021/05/24 19:56:05 wiz Exp $
# $NetBSD: Makefile,v 1.72 2021/11/30 14:15:26 gutteridge Exp $
PKGREVISION= 5
.include "../../meta-pkgs/xfce4/Makefile.common"
VERSION= 0.12.11
VERSION= 4.16.2
DISTNAME= exo-${VERSION}
PKGNAME= xfce4-exo-${VERSION}
CATEGORIES= x11
MASTER_SITES= http://archive.xfce.org/src/xfce/exo/${VERSION:R}/
MASTER_SITES= https://archive.xfce.org/src/xfce/exo/${VERSION:R}/
HOMEPAGE= https://docs.xfce.org/xfce/exo/start
COMMENT= Xfce extension library
@ -19,14 +18,7 @@ DEPENDS+= p5-URI>=0:../../www/p5-URI
PKGCONFIG_OVERRIDE+= exo/exo-1.pc.in
PKG_SYSCONFSUBDIR= xdg/xfce4
EGDIR= ${XFCE4_EGBASE}
CONF_FILES= ${EGDIR}/helpers.rc ${PKG_SYSCONFDIR}/helpers.rc
OWN_DIRS+= ${EGDIR}
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libxfce4ui/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,32 +1,6 @@
@comment $NetBSD: PLIST,v 1.15 2019/08/17 18:38:53 gutteridge Exp $
bin/exo-csource
@comment $NetBSD: PLIST,v 1.16 2021/11/30 14:15:26 gutteridge Exp $
bin/exo-desktop-item-edit
bin/exo-open
bin/exo-preferred-applications
include/exo-1/exo/exo-binding.h
include/exo-1/exo/exo-cell-renderer-ellipsized-text.h
include/exo-1/exo/exo-cell-renderer-icon.h
include/exo-1/exo/exo-config.h
include/exo-1/exo/exo-enum-types.h
include/exo-1/exo/exo-execute.h
include/exo-1/exo/exo-gdk-pixbuf-extensions.h
include/exo-1/exo/exo-gobject-extensions.h
include/exo-1/exo/exo-gtk-extensions.h
include/exo-1/exo/exo-icon-bar.h
include/exo-1/exo/exo-icon-chooser-dialog.h
include/exo-1/exo/exo-icon-view.h
include/exo-1/exo/exo-job.h
include/exo-1/exo/exo-simple-job.h
include/exo-1/exo/exo-string.h
include/exo-1/exo/exo-toolbars-editor-dialog.h
include/exo-1/exo/exo-toolbars-editor.h
include/exo-1/exo/exo-toolbars-model.h
include/exo-1/exo/exo-toolbars-view.h
include/exo-1/exo/exo-tree-view.h
include/exo-1/exo/exo-utils.h
include/exo-1/exo/exo-wrap-table.h
include/exo-1/exo/exo-xsession-client.h
include/exo-1/exo/exo.h
include/exo-2/exo/exo-binding.h
include/exo-2/exo/exo-cell-renderer-icon.h
include/exo-2/exo/exo-config.h
@ -43,189 +17,109 @@ include/exo-2/exo/exo-simple-job.h
include/exo-2/exo/exo-string.h
include/exo-2/exo/exo-thumbnail-preview.h
include/exo-2/exo/exo-thumbnail.h
include/exo-2/exo/exo-toolbars-model.h
include/exo-2/exo/exo-tree-view.h
include/exo-2/exo/exo-utils.h
include/exo-2/exo/exo.h
lib/libexo-1.la
lib/libexo-2.la
lib/pkgconfig/exo-1.pc
lib/pkgconfig/exo-2.pc
lib/xfce4/exo-2/exo-helper-2
lib/xfce4/exo/exo-compose-mail
man/man1/exo-csource.1
man/man1/exo-open.1
share/applications/exo-file-manager.desktop
share/applications/exo-mail-reader.desktop
share/applications/exo-preferred-applications.desktop
share/applications/exo-terminal-emulator.desktop
share/applications/exo-web-browser.desktop
share/examples/xfce4/helpers.rc
share/gtk-doc/html/exo-1/ExoCellRendererEllipsizedText.html
share/gtk-doc/html/exo-1/ExoCellRendererIcon.html
share/gtk-doc/html/exo-1/ExoIconBar.html
share/gtk-doc/html/exo-1/ExoIconChooserDialog.html
share/gtk-doc/html/exo-1/ExoIconView.html
share/gtk-doc/html/exo-1/ExoJob.html
share/gtk-doc/html/exo-1/ExoSimpleJob.html
share/gtk-doc/html/exo-1/ExoToolbarsEditor.html
share/gtk-doc/html/exo-1/ExoToolbarsEditorDialog.html
share/gtk-doc/html/exo-1/ExoToolbarsModel.html
share/gtk-doc/html/exo-1/ExoToolbarsView.html
share/gtk-doc/html/exo-1/ExoTreeView.html
share/gtk-doc/html/exo-1/ExoWrapTable.html
share/gtk-doc/html/exo-1/ExoXsessionClient.html
share/gtk-doc/html/exo-1/ch01.html
share/gtk-doc/html/exo-1/ch02.html
share/gtk-doc/html/exo-1/exo-1.devhelp2
share/gtk-doc/html/exo-1/exo-Binding-Properties-Functions.html
share/gtk-doc/html/exo-1/exo-Executing-Applications.html
share/gtk-doc/html/exo-1/exo-Extensions-to-GObject.html
share/gtk-doc/html/exo-1/exo-Extensions-to-Gtk.html
share/gtk-doc/html/exo-1/exo-Extensions-to-gdk-pixbuf.html
share/gtk-doc/html/exo-1/exo-Miscellaneous-Utility-Functions.html
share/gtk-doc/html/exo-1/exo-String-Utility-Functions.html
share/gtk-doc/html/exo-1/exo-Version-Information.html
share/gtk-doc/html/exo-1/exo-cell-renderers.html
share/gtk-doc/html/exo-1/exo-csource.html
share/gtk-doc/html/exo-1/exo-extensions.html
share/gtk-doc/html/exo-1/exo-gtk-file-chooser-add-thumbnail-preview.png
share/gtk-doc/html/exo-1/exo-icon-chooser-dialog.png
share/gtk-doc/html/exo-1/exo-jobs.html
share/gtk-doc/html/exo-1/exo-miscelleanous.html
share/gtk-doc/html/exo-1/exo-overview.html
share/gtk-doc/html/exo-1/exo-toolbars-editor-dialog.png
share/gtk-doc/html/exo-1/exo-toolbars-editor.png
share/gtk-doc/html/exo-1/exo-toolbars-view.png
share/gtk-doc/html/exo-1/exo-toolbars.html
share/gtk-doc/html/exo-1/exo-tools.html
share/gtk-doc/html/exo-1/exo-widgets.html
share/gtk-doc/html/exo-1/exo-wrap-table.png
share/gtk-doc/html/exo-1/home.png
share/gtk-doc/html/exo-1/index.html
share/gtk-doc/html/exo-1/ix14.html
share/gtk-doc/html/exo-1/left-insensitive.png
share/gtk-doc/html/exo-1/left.png
share/gtk-doc/html/exo-1/right-insensitive.png
share/gtk-doc/html/exo-1/right.png
share/gtk-doc/html/exo-1/style.css
share/gtk-doc/html/exo-1/up-insensitive.png
share/gtk-doc/html/exo-1/up.png
share/gtk-doc/html/exo-2/ExoCellRendererIcon.html
share/gtk-doc/html/exo-2/ExoIconChooserDialog.html
share/gtk-doc/html/exo-2/ExoIconView.html
share/gtk-doc/html/exo-2/ExoJob.html
share/gtk-doc/html/exo-2/ExoSimpleJob.html
share/gtk-doc/html/exo-2/ExoTreeView.html
share/gtk-doc/html/exo-2/ch01.html
share/gtk-doc/html/exo-2/exo-2.devhelp2
share/gtk-doc/html/exo-2/exo-Binding-Properties-Functions.html
share/gtk-doc/html/exo-2/exo-Executing-Applications.html
share/gtk-doc/html/exo-2/exo-Extensions-to-GObject.html
share/gtk-doc/html/exo-2/exo-Extensions-to-Gtk.html
share/gtk-doc/html/exo-2/exo-Extensions-to-gdk-pixbuf.html
share/gtk-doc/html/exo-2/exo-Miscellaneous-Utility-Functions.html
share/gtk-doc/html/exo-2/exo-String-Utility-Functions.html
share/gtk-doc/html/exo-2/exo-Version-Information.html
share/gtk-doc/html/exo-2/exo-cell-renderers.html
share/gtk-doc/html/exo-2/exo-extensions.html
share/gtk-doc/html/exo-2/exo-jobs.html
share/gtk-doc/html/exo-2/exo-miscelleanous.html
share/gtk-doc/html/exo-2/exo-overview.html
share/gtk-doc/html/exo-2/exo-widgets.html
share/gtk-doc/html/exo-2/home.png
share/gtk-doc/html/exo-2/index.html
share/gtk-doc/html/exo-2/ix15.html
share/gtk-doc/html/exo-2/left-insensitive.png
share/gtk-doc/html/exo-2/left.png
share/gtk-doc/html/exo-2/right-insensitive.png
share/gtk-doc/html/exo-2/right.png
share/gtk-doc/html/exo-2/style.css
share/gtk-doc/html/exo-2/up-insensitive.png
share/gtk-doc/html/exo-2/up.png
share/icons/hicolor/24x24/apps/preferences-desktop-default-applications.png
share/icons/hicolor/48x48/apps/preferences-desktop-default-applications.png
share/locale/am/LC_MESSAGES/exo-1.mo
share/locale/ar/LC_MESSAGES/exo-1.mo
share/locale/ast/LC_MESSAGES/exo-1.mo
share/locale/be/LC_MESSAGES/exo-1.mo
share/locale/bg/LC_MESSAGES/exo-1.mo
share/locale/bn/LC_MESSAGES/exo-1.mo
share/locale/ca/LC_MESSAGES/exo-1.mo
share/locale/cs/LC_MESSAGES/exo-1.mo
share/locale/da/LC_MESSAGES/exo-1.mo
share/locale/de/LC_MESSAGES/exo-1.mo
share/locale/el/LC_MESSAGES/exo-1.mo
share/locale/en_AU/LC_MESSAGES/exo-1.mo
share/locale/en_GB/LC_MESSAGES/exo-1.mo
share/locale/es/LC_MESSAGES/exo-1.mo
share/locale/et/LC_MESSAGES/exo-1.mo
share/locale/eu/LC_MESSAGES/exo-1.mo
share/locale/fi/LC_MESSAGES/exo-1.mo
share/locale/fr/LC_MESSAGES/exo-1.mo
share/locale/gl/LC_MESSAGES/exo-1.mo
share/locale/he/LC_MESSAGES/exo-1.mo
share/locale/hr/LC_MESSAGES/exo-1.mo
share/locale/hu/LC_MESSAGES/exo-1.mo
share/locale/hy/LC_MESSAGES/exo-1.mo
share/locale/hy_AM/LC_MESSAGES/exo-1.mo
share/locale/id/LC_MESSAGES/exo-1.mo
share/locale/ie/LC_MESSAGES/exo-1.mo
share/locale/is/LC_MESSAGES/exo-1.mo
share/locale/it/LC_MESSAGES/exo-1.mo
share/locale/ja/LC_MESSAGES/exo-1.mo
share/locale/kk/LC_MESSAGES/exo-1.mo
share/locale/kn/LC_MESSAGES/exo-1.mo
share/locale/ko/LC_MESSAGES/exo-1.mo
share/locale/lt/LC_MESSAGES/exo-1.mo
share/locale/lv/LC_MESSAGES/exo-1.mo
share/locale/ms/LC_MESSAGES/exo-1.mo
share/locale/nb/LC_MESSAGES/exo-1.mo
share/locale/nl/LC_MESSAGES/exo-1.mo
share/locale/nn/LC_MESSAGES/exo-1.mo
share/locale/oc/LC_MESSAGES/exo-1.mo
share/locale/pa/LC_MESSAGES/exo-1.mo
share/locale/pl/LC_MESSAGES/exo-1.mo
share/locale/pt/LC_MESSAGES/exo-1.mo
share/locale/pt_BR/LC_MESSAGES/exo-1.mo
share/locale/ro/LC_MESSAGES/exo-1.mo
share/locale/ru/LC_MESSAGES/exo-1.mo
share/locale/si/LC_MESSAGES/exo-1.mo
share/locale/sk/LC_MESSAGES/exo-1.mo
share/locale/sl/LC_MESSAGES/exo-1.mo
share/locale/sq/LC_MESSAGES/exo-1.mo
share/locale/sr/LC_MESSAGES/exo-1.mo
share/locale/sv/LC_MESSAGES/exo-1.mo
share/locale/te/LC_MESSAGES/exo-1.mo
share/locale/th/LC_MESSAGES/exo-1.mo
share/locale/tr/LC_MESSAGES/exo-1.mo
share/locale/ug/LC_MESSAGES/exo-1.mo
share/locale/uk/LC_MESSAGES/exo-1.mo
share/locale/ur/LC_MESSAGES/exo-1.mo
share/locale/ur_PK/LC_MESSAGES/exo-1.mo
share/locale/vi/LC_MESSAGES/exo-1.mo
share/locale/zh_CN/LC_MESSAGES/exo-1.mo
share/locale/zh_HK/LC_MESSAGES/exo-1.mo
share/locale/zh_TW/LC_MESSAGES/exo-1.mo
share/locale/am/LC_MESSAGES/exo-2.mo
share/locale/ar/LC_MESSAGES/exo-2.mo
share/locale/ast/LC_MESSAGES/exo-2.mo
share/locale/be/LC_MESSAGES/exo-2.mo
share/locale/bg/LC_MESSAGES/exo-2.mo
share/locale/bn/LC_MESSAGES/exo-2.mo
share/locale/ca/LC_MESSAGES/exo-2.mo
share/locale/cs/LC_MESSAGES/exo-2.mo
share/locale/da/LC_MESSAGES/exo-2.mo
share/locale/de/LC_MESSAGES/exo-2.mo
share/locale/el/LC_MESSAGES/exo-2.mo
share/locale/en_AU/LC_MESSAGES/exo-2.mo
share/locale/en_GB/LC_MESSAGES/exo-2.mo
share/locale/es/LC_MESSAGES/exo-2.mo
share/locale/et/LC_MESSAGES/exo-2.mo
share/locale/eu/LC_MESSAGES/exo-2.mo
share/locale/fa_IR/LC_MESSAGES/exo-2.mo
share/locale/fi/LC_MESSAGES/exo-2.mo
share/locale/fr/LC_MESSAGES/exo-2.mo
share/locale/gl/LC_MESSAGES/exo-2.mo
share/locale/he/LC_MESSAGES/exo-2.mo
share/locale/hr/LC_MESSAGES/exo-2.mo
share/locale/hu/LC_MESSAGES/exo-2.mo
share/locale/hy/LC_MESSAGES/exo-2.mo
share/locale/hy_AM/LC_MESSAGES/exo-2.mo
share/locale/hye/LC_MESSAGES/exo-2.mo
share/locale/id/LC_MESSAGES/exo-2.mo
share/locale/ie/LC_MESSAGES/exo-2.mo
share/locale/is/LC_MESSAGES/exo-2.mo
share/locale/it/LC_MESSAGES/exo-2.mo
share/locale/ja/LC_MESSAGES/exo-2.mo
share/locale/kab/LC_MESSAGES/exo-2.mo
share/locale/kk/LC_MESSAGES/exo-2.mo
share/locale/kn/LC_MESSAGES/exo-2.mo
share/locale/ko/LC_MESSAGES/exo-2.mo
share/locale/lt/LC_MESSAGES/exo-2.mo
share/locale/lv/LC_MESSAGES/exo-2.mo
share/locale/ms/LC_MESSAGES/exo-2.mo
share/locale/nb/LC_MESSAGES/exo-2.mo
share/locale/nl/LC_MESSAGES/exo-2.mo
share/locale/nn/LC_MESSAGES/exo-2.mo
share/locale/oc/LC_MESSAGES/exo-2.mo
share/locale/pa/LC_MESSAGES/exo-2.mo
share/locale/pl/LC_MESSAGES/exo-2.mo
share/locale/pt/LC_MESSAGES/exo-2.mo
share/locale/pt_BR/LC_MESSAGES/exo-2.mo
share/locale/ro/LC_MESSAGES/exo-2.mo
share/locale/ru/LC_MESSAGES/exo-2.mo
share/locale/si/LC_MESSAGES/exo-2.mo
share/locale/sk/LC_MESSAGES/exo-2.mo
share/locale/sl/LC_MESSAGES/exo-2.mo
share/locale/sq/LC_MESSAGES/exo-2.mo
share/locale/sr/LC_MESSAGES/exo-2.mo
share/locale/sv/LC_MESSAGES/exo-2.mo
share/locale/te/LC_MESSAGES/exo-2.mo
share/locale/th/LC_MESSAGES/exo-2.mo
share/locale/tr/LC_MESSAGES/exo-2.mo
share/locale/ug/LC_MESSAGES/exo-2.mo
share/locale/uk/LC_MESSAGES/exo-2.mo
share/locale/ur/LC_MESSAGES/exo-2.mo
share/locale/ur_PK/LC_MESSAGES/exo-2.mo
share/locale/vi/LC_MESSAGES/exo-2.mo
share/locale/zh_CN/LC_MESSAGES/exo-2.mo
share/locale/zh_HK/LC_MESSAGES/exo-2.mo
share/locale/zh_TW/LC_MESSAGES/exo-2.mo
share/pixmaps/exo/exo-thumbnail-frame.png
share/xfce4/helpers/Thunar.desktop
share/xfce4/helpers/aterm.desktop
share/xfce4/helpers/balsa.desktop
share/xfce4/helpers/brave.desktop
share/xfce4/helpers/caja.desktop
share/xfce4/helpers/chromium.desktop
share/xfce4/helpers/debian-sensible-browser.desktop
share/xfce4/helpers/debian-x-terminal-emulator.desktop
share/xfce4/helpers/dillo.desktop
share/xfce4/helpers/encompass.desktop
share/xfce4/helpers/epiphany.desktop
share/xfce4/helpers/eterm.desktop
share/xfce4/helpers/evolution.desktop
share/xfce4/helpers/firefox.desktop
share/xfce4/helpers/galeon.desktop
share/xfce4/helpers/geary.desktop
share/xfce4/helpers/gnome-terminal.desktop
share/xfce4/helpers/google-chrome.desktop
share/xfce4/helpers/icecat.desktop
share/xfce4/helpers/icedove.desktop
share/xfce4/helpers/iceweasel.desktop
share/xfce4/helpers/jumanji.desktop
share/xfce4/helpers/kmail.desktop
share/xfce4/helpers/konqueror.desktop
share/xfce4/helpers/links.desktop
share/xfce4/helpers/lynx.desktop
share/xfce4/helpers/midori.desktop
share/xfce4/helpers/mozilla-browser.desktop
share/xfce4/helpers/mozilla-mailer.desktop
share/xfce4/helpers/mutt.desktop
share/xfce4/helpers/nautilus.desktop
share/xfce4/helpers/netscape-navigator.desktop
share/xfce4/helpers/nxterm.desktop
share/xfce4/helpers/opera-browser.desktop
share/xfce4/helpers/pcmanfm-qt.desktop
share/xfce4/helpers/pcmanfm.desktop
share/xfce4/helpers/qterminal.desktop
share/xfce4/helpers/qtfm.desktop
share/xfce4/helpers/qupzilla.desktop
share/xfce4/helpers/rodent.desktop
share/xfce4/helpers/rox-filer.desktop
share/xfce4/helpers/sakura.desktop
share/xfce4/helpers/surf.desktop
share/xfce4/helpers/sylpheed-claws.desktop
share/xfce4/helpers/sylpheed.desktop
share/xfce4/helpers/terminator.desktop
share/xfce4/helpers/thunderbird.desktop
share/xfce4/helpers/urxvt.desktop
share/xfce4/helpers/vimprobable2.desktop
share/xfce4/helpers/w3m.desktop
share/xfce4/helpers/xfce4-terminal.desktop
share/xfce4/helpers/xfe.desktop
share/xfce4/helpers/xterm.desktop

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.34 2020/03/08 16:48:34 wiz Exp $
# $NetBSD: buildlink3.mk,v 1.35 2021/11/30 14:15:26 gutteridge Exp $
BUILDLINK_TREE+= xfce4-exo
@ -6,7 +6,7 @@ BUILDLINK_TREE+= xfce4-exo
XFCE4_EXO_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.xfce4-exo+= xfce4-exo>=0.10.4
BUILDLINK_ABI_DEPENDS.xfce4-exo+= xfce4-exo>=0.12.11nb1
BUILDLINK_ABI_DEPENDS.xfce4-exo+= xfce4-exo>=4.16.2
BUILDLINK_PKGSRCDIR.xfce4-exo?= ../../x11/xfce4-exo
.include "../../x11/libxfce4ui/buildlink3.mk"

View file

@ -1,7 +1,5 @@
$NetBSD: distinfo,v 1.26 2021/10/26 11:34:46 nia Exp $
$NetBSD: distinfo,v 1.27 2021/11/30 14:15:26 gutteridge Exp $
BLAKE2s (exo-0.12.11.tar.bz2) = 518b8c54d3985145392a47b6afaafb19d6ac6d275086ad5fddc700a45a16f68c
SHA512 (exo-0.12.11.tar.bz2) = ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
Size (exo-0.12.11.tar.bz2) = 1333227 bytes
SHA1 (patch-af) = d983808d490ef8f1d47c8a8469b8f3ec4f2d7cf4
SHA1 (patch-exo-helper_helpers_Thunar.desktop.in.in) = efe98db2f48309043c80276c4d39934cb949efa7
BLAKE2s (exo-4.16.2.tar.bz2) = 284bf0a49a81f12f4b7b1e5bee94b256a3f85d259ce95a1c1c3987b2bbac89c4
SHA512 (exo-4.16.2.tar.bz2) = 9c1252d78f5bb900254841a79f1c1b952cb60d9d0197e184266c35a86c340140cdff2460fa83f6fabb66380e2b3d7ab8a08719b4f4784d2215dde51410ce33e8
Size (exo-4.16.2.tar.bz2) = 881098 bytes

View file

@ -1,15 +0,0 @@
$NetBSD: patch-af,v 1.5 2017/06/18 20:39:29 youri Exp $
Adjust config path.
--- exo-helper/helpers/Makefile.in.orig 2015-05-25 19:07:21.000000000 +0000
+++ exo-helper/helpers/Makefile.in
@@ -349,7 +349,7 @@ target_vendor = @target_vendor@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-defaultsdir = $(sysconfdir)/xdg/xfce4
+defaultsdir = $(datadir)/examples/xfce4
defaults_DATA = helpers.rc
desktopdir = $(datadir)/xfce4/helpers
desktop_in_in_files = \

View file

@ -1,15 +0,0 @@
$NetBSD: patch-exo-helper_helpers_Thunar.desktop.in.in,v 1.2 2017/06/18 20:39:29 youri Exp $
Use thunar, not Thunar.
--- exo-helper/helpers/Thunar.desktop.in.in.orig 2015-05-25 18:04:45.000000000 +0000
+++ exo-helper/helpers/Thunar.desktop.in.in
@@ -5,7 +5,7 @@ Icon=Thunar
Type=X-XFCE-Helper
_Name=Thunar
StartupNotify=true
-X-XFCE-Binaries=Thunar;
+X-XFCE-Binaries=thunar;
X-XFCE-Category=FileManager
X-XFCE-Commands=%B;
X-XFCE-CommandsWithParameter=%B "%s";