PR#45476 devel/libthrift: Fix DragonFly breakage

Libthrift requires sys/socket.h to build on DragonFly and likely
other systems as well.  Patch provided with PR was tested on DragonFly
2.13 and NetBSD 5.99 (both x86_64).
This commit is contained in:
marino 2011-11-05 22:54:43 +00:00
parent 74d485b249
commit 5bfd95aa8d
2 changed files with 14 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.5 2011/09/12 15:51:02 taca Exp $
$NetBSD: distinfo,v 1.6 2011/11/05 22:54:43 marino Exp $
SHA1 (thrift-0.7.0.tar.gz) = b8f6877bc75878984355da4efe171ad99ff05b6a
RMD160 (thrift-0.7.0.tar.gz) = d9db8ff077347134101cd017e086511c4317b052
Size (thrift-0.7.0.tar.gz) = 2248326 bytes
SHA1 (patch-ac) = 84032447dc90b7071d8f54fc56dd30584fbc8116
SHA1 (patch-lib__rb__setup.rb) = 4e08bb4c0828306ee2391f5d5760e74a5df30a73
SHA1 (patch-lib_erl_Makefile.in) = 74bfbc9f191f685cb175801a495ae4af0eaa6e69

View file

@ -0,0 +1,12 @@
$NetBSD: patch-ac,v 1.1 2011/11/05 22:54:44 marino Exp $
--- lib/cpp/src/transport/TSSLSocket.h.orig 2011-08-11 13:18:59.000000000 +0000
+++ lib/cpp/src/transport/TSSLSocket.h
@@ -23,6 +23,7 @@
#include <string>
#include <boost/shared_ptr.hpp>
#include <openssl/ssl.h>
+#include <sys/socket.h>
#include "concurrency/Mutex.h"
#include "TSocket.h"