Fix build under SCO OpenServer 5.0.7/3.2.

This commit is contained in:
ryoon 2014-07-17 15:52:25 +00:00
parent 7c3b62c351
commit 5c52d25e56
5 changed files with 75 additions and 9 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.184 2014/05/29 23:36:39 wiz Exp $
# $NetBSD: Makefile,v 1.185 2014/07/17 15:52:25 ryoon Exp $
DISTNAME= netpbm-10.35.80
PKGREVISION= 8
@ -71,6 +71,10 @@ MAKE_ENV+= NETPBMLIBTYPE="unixshared" NETPBMLIBSUFFIX="sl"
MAKE_ENV+= NETPBMLIBTYPE="unixshared" NETPBMLIBSUFFIX="so"
.endif
.if ${OS_VARIANT} == "SCOOSR5"
LDFLAGS.SCO_SV+= -lsocket
.endif
.if !empty(PKGSRC_COMPILER:Mido)
CPPFLAGS+= -DSGI_IDO_CC
.endif

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.86 2014/05/16 12:43:52 ryoon Exp $
$NetBSD: distinfo,v 1.87 2014/07/17 15:52:25 ryoon Exp $
SHA1 (netpbm-10.35.80.tgz) = e2bc82c2fc76775a837596f9774f4b24275f794a
RMD160 (netpbm-10.35.80.tgz) = f8c6dc01ada947f27dd851d954d240f248e07c55
@ -6,7 +6,7 @@ Size (netpbm-10.35.80.tgz) = 2547601 bytes
SHA1 (patch-aa) = fd533685c5b0058f19d1b4525a4b2b9f2b239627
SHA1 (patch-ab) = 4d6508ad837d455ea3f8ebaa704f33f9e089f6e0
SHA1 (patch-ac) = 11c029673a53e9344a477db6cfcb46f32e9f6a93
SHA1 (patch-ad) = b4a5833e18afd5a991aad897674386a3f00c3ee1
SHA1 (patch-ad) = c9ed6aed9d503a94c94a39c8ee088f9ba2a6dd25
SHA1 (patch-ae) = 33a5be2843dd85b530f5e6ba496cd0380cd5edd1
SHA1 (patch-af) = e8965899d577648c6144098f2aa8e1594551666a
SHA1 (patch-ag) = 093fe392a3e6156cc55f225a6f139842c0d00570
@ -20,11 +20,12 @@ SHA1 (patch-aw) = bd890324e95fa7bb893d9d5cdab9d5a33dcff777
SHA1 (patch-ax) = d50e56191192b4caf423ed081581868bb1a63de8
SHA1 (patch-ay) = 60ab532de6d6ec498ada140f795bba327a562e13
SHA1 (patch-cb) = b1be33ae6acfe57bf2f407cd48a6b140c3ddea85
SHA1 (patch-converter_ppm_ppmtompeg_psocket.c) = ebb11ea1867ed401a0299eeb907aad70276ce843
SHA1 (patch-da) = 8ae329469bf0bd55b671dffeb4253b8d14621f5c
SHA1 (patch-db) = 23a05e54043ee84a0b7ec507a383d5cd8adfcca5
SHA1 (patch-dc) = 8ed1365dccf5abb0e158a4f7a65749ff5b244ef3
SHA1 (patch-dd) = 9f9c53959f5afd444ce427b782f9ba2c73068f27
SHA1 (patch-eb) = 8af326d4be7e280764843ce213672186fce3f9a8
SHA1 (patch-lib_libpbm3.c) = 42e7d49fecb559fb1d55345e5053337e60f7458b
SHA1 (patch-lib_libsystem.c) = 6458ae8eac15a13e3b92ddcb546c24ff85067209
SHA1 (patch-lib_libsystem.c) = a140994267e62a90dd63667a0f87c65a2278ed0f
SHA1 (patch-ppmdraw) = d901a690f8f21a1af940129d1edef509b369ea1a

View file

@ -1,8 +1,19 @@
$NetBSD: patch-ad,v 1.20 2006/02/02 16:04:13 joerg Exp $
$NetBSD: patch-ad,v 1.21 2014/07/17 15:52:26 ryoon Exp $
--- converter/ppm/ppmtompeg/parallel.c.orig 2006-02-02 15:52:14.000000000 +0000
--- converter/ppm/ppmtompeg/parallel.c.orig 2006-08-19 03:12:28.000000000 +0000
+++ converter/ppm/ppmtompeg/parallel.c
@@ -27,6 +27,7 @@
@@ -12,7 +12,10 @@
* HEADER FILES *
*==============*/
+/* SCO OpenServer 5.0.7/3.2 does not typedef u_long, when _XOPEN_SOURCE is defined. */
+#if !defined(_SCO_DS)
#define _XOPEN_SOURCE 500 /* Make sure stdio.h contains pclose() */
+#endif
/* _ALL_SOURCE is needed on AIX to make the C library include the
socket services (e.g. define struct sockaddr)
@@ -27,6 +30,7 @@
*/
@ -10,7 +21,7 @@ $NetBSD: patch-ad,v 1.20 2006/02/02 16:04:13 joerg Exp $
#include <stdarg.h>
#include <time.h>
#include <unistd.h>
@@ -36,7 +37,6 @@
@@ -36,7 +40,6 @@
#include <signal.h>
#include <netdb.h>
#include <assert.h>

View file

@ -0,0 +1,27 @@
$NetBSD: patch-converter_ppm_ppmtompeg_psocket.c,v 1.1 2014/07/17 15:52:26 ryoon Exp $
--- converter/ppm/ppmtompeg/psocket.c.orig 2006-08-19 03:12:28.000000000 +0000
+++ converter/ppm/ppmtompeg/psocket.c
@@ -9,7 +9,10 @@
============================================================================*/
+/* SCO OpenServer 5.0.7/3.2 does not typedef u_long, when _XOPEN_SOURCE is defined. */
+#if !defined(_SCO_DS)
#define _XOPEN_SOURCE 500 /* Make sure stdio.h contains pclose() */
+#endif
/* _ALL_SOURCE is needed on AIX to make the C library include the
socket services (e.g. define struct sockaddr)
@@ -44,6 +47,11 @@
#undef _XOPEN_SOURCE
#endif
+/* Avoid vogus error under SCO OpenServer 5.0.7/3.2 with GCC 4.2.4. */
+#if defined(_SCO_DS)
+#define BSD 0
+#endif
+
#include <stdarg.h>
#include <netinet/in.h>
#include <unistd.h>

View file

@ -1,6 +1,7 @@
$NetBSD: patch-lib_libsystem.c,v 1.1 2014/05/16 12:43:52 ryoon Exp $
$NetBSD: patch-lib_libsystem.c,v 1.2 2014/07/17 15:52:26 ryoon Exp $
* For SIGWINCH and SIGIO, _XOPEN_SOURCE should not be defined under OpenBSD 5.5
* SCO OpenServer 5.0.7/3.2 has no SIGURG and SIGIO.
--- lib/libsystem.c.orig 2010-07-10 01:38:01.000000000 +0000
+++ lib/libsystem.c
@ -15,3 +16,25 @@ $NetBSD: patch-lib_libsystem.c,v 1.1 2014/05/16 12:43:52 ryoon Exp $
#include <unistd.h>
#include <stdlib.h>
@@ -201,8 +204,10 @@ signalName(unsigned int const signalClas
return "SIGTTIN";
case SIGTTOU: /* POSIX.1 */
return "SIGTTOU";
+#if defined(SIGURG)
case SIGURG:
return "SIGURG";
+#endif
case SIGXCPU:
return "SIGXCPU";
case SIGXFSZ:
@@ -213,8 +218,10 @@ signalName(unsigned int const signalClas
return "SIGPROF";
case SIGWINCH:
return "SIGWINCH";
+#if defined(SIGIO)
case SIGIO:
return "SIGIO";
+#endif
case SIGSYS:
return "SIGSYS";
default: