Import lxde-common-0.99.1 as x11/lxde-common.

lxde-common package provides a set of default configurations
and startup and logout scripts for LXDE.
This commit is contained in:
youri 2016-05-23 10:06:29 +00:00
parent fa9d942145
commit 5c6f40fde7
6 changed files with 258 additions and 0 deletions

2
x11/lxde-common/DESCR Normal file
View file

@ -0,0 +1,2 @@
lxde-common package provides a set of default configurations
and startup and logout scripts for LXDE.

47
x11/lxde-common/Makefile Normal file
View file

@ -0,0 +1,47 @@
# $NetBSD: Makefile,v 1.1 2016/05/23 10:06:29 youri Exp $
DISTNAME= lxde-common-0.99.1
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=lxde/}
EXTRACT_SUFX= .tar.xz
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://lxde.sourceforge.net/
COMMENT= Default configuration settings and scripts for LXDE
LICENSE= gnu-gpl-v2
USE_TOOLS+= intltool pkg-config gmake
DEPENDS+= dbus>=1:../../sysutils/dbus
DEPENDS+= gtk2-engines>=0:../../x11/gtk2-engines
DEPENDS+= lxpanel>=0:../../sysutils/lxpanel
DEPENDS+= lxsession>=0:../../x11/lxsession
DEPENDS+= openbox>=0:../../wm/openbox
DEPENDS+= xprop>=0:../../x11/xprop
GNU_CONFIGURE= yes
LXDE_CONF= share/examples/lxde
PKG_SYSCONFSUBDIR= xdg
MAKE_DIRS+= ${PKG_SYSCONFDIR}/lxpanel/LXDE/panels \
${PKG_SYSCONFDIR}/lxsession/LXDE \
${PKG_SYSCONFDIR}/openbox/LXDE \
${PKG_SYSCONFDIR}/pcmanfm/LXDE
CONF_FILES+= ${LXDE_CONF}/lxpanel/LXDE/config \
${PKG_SYSCONFDIR}/lxpanel/LXDE/config \
${LXDE_CONF}/lxpanel/LXDE/panels/panel \
${PKG_SYSCONFDIR}/lxpanel/LXDE/panels/panel \
${LXDE_CONF}/lxsession/LXDE/autostart \
${PKG_SYSCONFDIR}/lxsession/LXDE/autostart \
${LXDE_CONF}/lxsession/LXDE/desktop.conf \
${PKG_SYSCONFDIR}/lxsession/LXDE/desktop.conf \
${LXDE_CONF}/openbox/LXDE/menu.xml \
${PKG_SYSCONFDIR}/openbox/LXDE/menu.xml \
${LXDE_CONF}/openbox/LXDE/rc.xml \
${PKG_SYSCONFDIR}/openbox/LXDE/rc.xml \
${LXDE_CONF}/pcmanfm/LXDE/pcmanfm.conf \
${PKG_SYSCONFDIR}/pcmanfm/LXDE/pcmanfm.conf
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

22
x11/lxde-common/PLIST Normal file
View file

@ -0,0 +1,22 @@
@comment $NetBSD: PLIST,v 1.1 2016/05/23 10:06:29 youri Exp $
bin/lxde-logout
bin/openbox-lxde
bin/startlxde
man/man1/lxde-logout.1
man/man1/openbox-lxde.1
man/man1/startlxde.1
share/applications/lxde-logout.desktop
share/applications/lxde-screenlock.desktop
share/examples/lxde/lxpanel/LXDE/config
share/examples/lxde/lxpanel/LXDE/panels/panel
share/examples/lxde/lxsession/LXDE/autostart
share/examples/lxde/lxsession/LXDE/desktop.conf
share/examples/lxde/openbox/LXDE/menu.xml
share/examples/lxde/openbox/LXDE/rc.xml
share/examples/lxde/pcmanfm/LXDE/pcmanfm.conf
share/lxde/images/logout-banner.png
share/lxde/images/lxde-icon.png
share/lxde/wallpapers/lxde_blue.jpg
share/lxde/wallpapers/lxde_green.jpg
share/lxde/wallpapers/lxde_red.jpg
share/xsessions/LXDE.desktop

8
x11/lxde-common/distinfo Normal file
View file

@ -0,0 +1,8 @@
$NetBSD: distinfo,v 1.1 2016/05/23 10:06:29 youri Exp $
SHA1 (lxde-common-0.99.1.tar.xz) = 6dda860cc0c96a3d0d444325ac9f4ee6c3a7b946
RMD160 (lxde-common-0.99.1.tar.xz) = f1aaf284109c54388a5201d4c7a49454cd50ccf4
SHA512 (lxde-common-0.99.1.tar.xz) = f5a14c44d827ba2355efd10c78732157f5645392ebbeb8e2a8126340a36eeba2842eff0c5338bb36623e5fe2da894c89d60a45c0b177704e2260413d63232b05
Size (lxde-common-0.99.1.tar.xz) = 889656 bytes
SHA1 (patch-Makefile.in) = 01b1d4196ce3b16a06a36c71c49516814e5823dc
SHA1 (patch-configure) = 52f637fa4c481defcb96fbcabfbf665593a38e97

View file

@ -0,0 +1,158 @@
$NetBSD: patch-Makefile.in,v 1.1 2016/05/23 10:06:30 youri Exp $
Fix config install.
--- Makefile.in.orig 2016-02-20 23:42:51.000000000 +0000
+++ Makefile.in
@@ -355,9 +355,11 @@ SUBDIRS = man po
bin_SCRIPTS = startlxde lxde-logout openbox-lxde
# Currently these paths are hardcoded.
+exampledir = ${datadir}/examples/lxde
xsessiondir = $(xsesspath)
xsession_DATA = LXDE.desktop
defaultsdir = $(sysconfdir)/xdg/lxsession/LXDE
+defaultsexampledir = $(exampledir)/lxsession/LXDE
defaults_DATA = autostart desktop.conf
desktopdir = $(datadir)/applications
desktop_in_files = lxde-logout.desktop.in lxde-screenlock.desktop.in
@@ -374,15 +376,19 @@ images_DATA = \
images/lxde-icon.png
lxpaneldir = $(sysconfdir)/xdg/lxpanel/LXDE
+lxpanelexampledir = $(exampledir)/lxpanel/LXDE
lxpanel_DATA = lxpanel/config
lxpanel_paneldir = $(sysconfdir)/xdg/lxpanel/LXDE/panels
+lxpanel_panelexampledir = $(exampledir)/lxpanel/LXDE/panels
lxpanel_panel_DATA = lxpanel/panel
openboxdir = $(sysconfdir)/xdg/openbox/LXDE
+openboxexampledir = $(exampledir)/openbox/LXDE
openbox_DATA = \
openbox/rc.xml \
openbox/menu.xml
pcmanfmdir = $(sysconfdir)/xdg/pcmanfm/LXDE
+pcmanfmexampledir = $(exampledir)/pcmanfm/LXDE
pcmanfm_DATA = \
pcmanfm/pcmanfm.conf
@@ -490,18 +496,18 @@ uninstall-binSCRIPTS:
dir='$(DESTDIR)$(bindir)'; $(am__uninstall_files_from_dir)
install-defaultsDATA: $(defaults_DATA)
@$(NORMAL_INSTALL)
- @list='$(defaults_DATA)'; test -n "$(defaultsdir)" || list=; \
+ @list='$(defaults_DATA)'; test -n "$(defaultsexampledir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(defaultsdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(defaultsdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(defaultsexampledir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(defaultsexampledir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(defaultsdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(defaultsdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(defaultsexampledir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(defaultsexampledir)" || exit $$?; \
done
uninstall-defaultsDATA:
@@ -553,18 +559,18 @@ uninstall-imagesDATA:
dir='$(DESTDIR)$(imagesdir)'; $(am__uninstall_files_from_dir)
install-lxpanelDATA: $(lxpanel_DATA)
@$(NORMAL_INSTALL)
- @list='$(lxpanel_DATA)'; test -n "$(lxpaneldir)" || list=; \
+ @list='$(lxpanel_DATA)'; test -n "$(lxpanelexampledir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(lxpaneldir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(lxpaneldir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(lxpanelexampledir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(lxpanelexampledir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(lxpaneldir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(lxpaneldir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(lxpanelexampledir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(lxpanelexampledir)" || exit $$?; \
done
uninstall-lxpanelDATA:
@@ -574,18 +580,18 @@ uninstall-lxpanelDATA:
dir='$(DESTDIR)$(lxpaneldir)'; $(am__uninstall_files_from_dir)
install-lxpanel_panelDATA: $(lxpanel_panel_DATA)
@$(NORMAL_INSTALL)
- @list='$(lxpanel_panel_DATA)'; test -n "$(lxpanel_paneldir)" || list=; \
+ @list='$(lxpanel_panel_DATA)'; test -n "$(lxpanel_panelexampledir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(lxpanel_paneldir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(lxpanel_paneldir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(lxpanel_panelexampledir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(lxpanel_panelexampledir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(lxpanel_paneldir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(lxpanel_paneldir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(lxpanel_panelexampledir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(lxpanel_panelexampledir)" || exit $$?; \
done
uninstall-lxpanel_panelDATA:
@@ -595,18 +601,18 @@ uninstall-lxpanel_panelDATA:
dir='$(DESTDIR)$(lxpanel_paneldir)'; $(am__uninstall_files_from_dir)
install-openboxDATA: $(openbox_DATA)
@$(NORMAL_INSTALL)
- @list='$(openbox_DATA)'; test -n "$(openboxdir)" || list=; \
+ @list='$(openbox_DATA)'; test -n "$(openboxexampledir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(openboxdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(openboxdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(openboxexampledir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(openboxexampledir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(openboxdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(openboxdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(openboxexampledir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(openboxexampledir)" || exit $$?; \
done
uninstall-openboxDATA:
@@ -616,18 +622,18 @@ uninstall-openboxDATA:
dir='$(DESTDIR)$(openboxdir)'; $(am__uninstall_files_from_dir)
install-pcmanfmDATA: $(pcmanfm_DATA)
@$(NORMAL_INSTALL)
- @list='$(pcmanfm_DATA)'; test -n "$(pcmanfmdir)" || list=; \
+ @list='$(pcmanfm_DATA)'; test -n "$(pcmanfmexampledir)" || list=; \
if test -n "$$list"; then \
- echo " $(MKDIR_P) '$(DESTDIR)$(pcmanfmdir)'"; \
- $(MKDIR_P) "$(DESTDIR)$(pcmanfmdir)" || exit 1; \
+ echo " $(MKDIR_P) '$(DESTDIR)$(pcmanfmexampledir)'"; \
+ $(MKDIR_P) "$(DESTDIR)$(pcmanfmexampledir)" || exit 1; \
fi; \
for p in $$list; do \
if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
echo "$$d$$p"; \
done | $(am__base_list) | \
while read files; do \
- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pcmanfmdir)'"; \
- $(INSTALL_DATA) $$files "$(DESTDIR)$(pcmanfmdir)" || exit $$?; \
+ echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(pcmanfmexampledir)'"; \
+ $(INSTALL_DATA) $$files "$(DESTDIR)$(pcmanfmexampledir)" || exit $$?; \
done
uninstall-pcmanfmDATA:

View file

@ -0,0 +1,21 @@
$NetBSD: patch-configure,v 1.1 2016/05/23 10:06:30 youri Exp $
Remove error about sysconfdir.
--- configure.orig 2016-02-20 23:42:52.000000000 +0000
+++ configure
@@ -7119,14 +7119,3 @@ if test -n "$ac_unrecognized_opts" && te
{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: unrecognized options: $ac_unrecognized_opts" >&5
$as_echo "$as_me: WARNING: unrecognized options: $ac_unrecognized_opts" >&2;}
fi
-
-
-if test x"$sysconfdir" != x'/etc'; then
- echo
- echo
- echo 'Error: sysconfdir is not /etc.'
- echo 'Please consider passing --sysconfdir=/etc to configure.';
- echo 'Otherwise default config files will be installed to wrong place.'
- echo
- echo
-fi