Re-add a patch to fix the problems with setlocale(3).

This commit is contained in:
xtraeme 2004-05-23 16:30:03 +00:00
parent f59839502b
commit 5c78f724ad
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.12 2004/05/13 10:04:09 wiz Exp $
$NetBSD: distinfo,v 1.13 2004/05/23 16:30:03 xtraeme Exp $
SHA1 (fluxbox-0.9.9.tar.bz2) = 4322b7abf20b79539c36c74d101a9fb40b6360e2
Size (fluxbox-0.9.9.tar.bz2) = 536673 bytes
@ -7,3 +7,4 @@ SHA1 (patch-ab) = 04076d5633acf396ae981255c0a64f6d29fa0ed2
SHA1 (patch-ac) = f304326b795f96d59446f5a618331b15cdca7970
SHA1 (patch-ad) = ea13a889a03203ce559e9d08c7c83dcc86f21cba
SHA1 (patch-ae) = 63f52138beeeb3fddf8a380d8c1d79b1c841e18c
SHA1 (patch-af) = ed6f1173c0fba36d5883cc2c2a44d30212d09750

View file

@ -0,0 +1,15 @@
$NetBSD: patch-af,v 1.1 2004/05/23 16:30:03 xtraeme Exp $
--- src/I18n.cc.orig 2004-05-23 18:20:51.000000000 +0200
+++ src/I18n.cc 2004-05-23 18:22:21.000000000 +0200
@@ -54,7 +54,9 @@
I18n::I18n():m_multibyte(false), m_catalog_fd((nl_catd)(-1)) {
#ifdef HAVE_SETLOCALE
//make sure we don't get 0 to m_locale string
- char *temp = setlocale(LC_ALL, "");
+ char *temp;
+ (void)setlocale(LC_ALL, "");
+ temp = setlocale(LC_MESSAGES, NULL);
m_locale = ( temp ? temp : "");
if (m_locale.empty()) {
cerr<<"Warning: Failed to set locale, reverting to \"C\""<<endl;