Update to nedit 5.1.1. Notable changes include:

- Significant extensions to the regular expression syntax.
 - Incremental search, and optional search bar.
 - New ctags code with full support for Exuberant Ctags, better
   handling of tag collisions, multiple tag file support, on-demand
   loading of tag files, and automatic reload of modified tag files.
 - Optional display of line numbers along the left side of the text.
 - NEdit can now read and write MS DOS format files.
 - New built-in syntax highlighting patterns for Lex, PostScript, SQL,
   Many syntax highlighting pattern improvements.
 - Improved international character set input
 - New macro subroutines: list_dialog, getenv, set_language_mode.
 - Optional warnings about external modifications to files
 - Clearcase awareness
 - Session manager restart capability
 - Default language mode "*" for user-defined menu items, allows
   per-language variations on a common base
 - Allow additional modifiers like Sun diamond key in user defined
   accelerators
 - Option to sort open previous menu.
 - -geometry and -iconic command line arguments act per-window, and
   can be specified via nc
 - -geometry now specified in characters, rather than pixels
 - -lm (language mode) command line option
 - Save As dialog defaults to same file name
 - .nedit file version mechanism to make future upgrades easier
 - Crash on large amounts of data fed to shell command which does not
   take input
 - Delayed secondary windows when executable statements specified in
   users .neditmacro file
 - Many corrections to online help
 - Many highlight patterns corrections
 - Using window close box in file open/save dialogs leaves nedit server
   unresponsive
 - escape in macro dialogs can cause macro hang
 - Lesstif-specific fixes: attachment warnings in font selector,
   Work around replace dialog focus bug.
 - NEdit no longer maintains original protection settings on files.  It
   allows them to be changed externally.
This commit is contained in:
mjl 2000-05-19 11:24:46 +00:00
parent efab559ea5
commit 5c79fc0bbc
7 changed files with 13 additions and 71 deletions

View file

@ -1,23 +1,19 @@
# $NetBSD: Makefile,v 1.8 1999/12/30 13:13:28 simonb Exp $
# $NetBSD: Makefile,v 1.9 2000/05/19 11:24:46 mjl Exp $
DISTNAME= nedit_source
PKGNAME= nedit-5.0.2
DISTNAME= nedit-5.1.1-src
PKGNAME= nedit-5.1.1
CATEGORIES= editors
MASTER_SITES= ftp://ftp.nedit.org/pub/v5_0_2/
MASTER_SITES= http://ftp.nedit.org/ftp/v5_1_1/
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.nedit.org/
USE_MOTIF= yes
NO_WRKSUBDIR= yes
NO_CONFIGURE= yes
ALL_TARGET= netbsd_nedit
ALL_TARGET= netbsd
post-extract:
.for DIR in source util
@${LN} -s ${FILESDIR}/Makefile.${DIR} ${WRKSRC}/${DIR}/Makefile.netbsd
.endfor
WRKSRC= ${WRKDIR}/${PKGNAME}
do-install:
.for PROGRAM in nc nedit

View file

@ -1,3 +1,3 @@
$NetBSD: md5,v 1.2 1998/08/07 13:21:27 agc Exp $
$NetBSD: md5,v 1.3 2000/05/19 11:24:47 mjl Exp $
MD5 (nedit_source.tar.gz) = f4eb558c83ecb542e07766e2775c1874
MD5 (nedit-5.1.1-src.tar.gz) = dba0970c60debada237ca852b5f57ec8

View file

@ -1,6 +1,6 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 13:50:44 agc Exp $
$NetBSD: patch-sum,v 1.2 2000/05/19 11:24:47 mjl Exp $
MD5 (patch-aa) = fc742864df3ce175ca2c5b3a813a5f83
MD5 (patch-ab) = 809d561a9f896c95c5ea8e5d14bbe314
MD5 (patch-ac) = 3312cc6353cee030d8693d4eb34cfa8a
MD5 (patch-ad) = 0f6f1df2fa6ee8a26269405c20f1829e
This placeholder file is generated by the ``makepatchsum'' target
whenever the patches directory is empty or missing. Its purpose
is to ensure that the presence of any obsolete patches will cause
the proper error to be emitted at build time.

View file

@ -1,13 +0,0 @@
$NetBSD: patch-aa,v 1.2 1998/08/07 10:40:32 agc Exp $
--- source/server.c.orig Thu Mar 19 22:20:24 1998
+++ source/server.c Wed Jun 3 00:06:18 1998
@@ -54,7 +54,7 @@
independent way), please change this (L_cuserid is apparently not ANSI) */
#define MAXUSERNAMELEN 32
-#if defined(VMS) || defined(linux)
+#if defined(VMS) || defined(linux) || defined(__NetBSD__)
#define MAXNODENAMELEN (MAXPATHLEN+2)
#elif defined(SUNOS)
#define MAXNODENAMELEN 9

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.2 1998/08/07 10:40:32 agc Exp $
--- source/nc.c.orig Thu Mar 19 22:20:23 1998
+++ source/nc.c Wed Jun 3 00:06:25 1998
@@ -51,7 +51,7 @@
#define APP_NAME "nc"
#define APP_CLASS "NEditClient"
-#if defined(VMS) || defined(linux)
+#if defined(VMS) || defined(linux) || defined(__NetBSD__)
#define MAXNODENAMELEN (MAXPATHLEN+2)
#elif defined(SUNOS)
#define MAXNODENAMELEN 9

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ac,v 1.2 1998/08/07 10:40:32 agc Exp $
--- Makefile.orig Thu Mar 19 22:20:29 1998
+++ Makefile Wed Jun 3 01:31:53 1998
@@ -42,3 +42,7 @@
linux_nedit:
(cd util; $(MAKE) -f Makefile.linux libNUtil.a)
(cd source; $(MAKE) -f Makefile.linux nedit nc)
+
+netbsd_nedit:
+ (cd util; $(MAKE) -f Makefile.netbsd libNUtil.a)
+ (cd source; $(MAKE) -f Makefile.netbsd nedit nc)

View file

@ -1,16 +0,0 @@
$NetBSD: patch-ad,v 1.1 1998/09/14 21:04:22 garbled Exp $
--- source/Makefile.common.orig Mon Sep 14 13:33:02 1998
+++ source/Makefile.common Mon Sep 14 13:33:29 1998
@@ -12,10 +12,10 @@
all: nedit nc
nedit: $(OBJS) ../util/libNUtil.a
- $(CC) $(CFLAGS) $(OBJS) ../util/libNUtil.a $(LIBS) -o $@
+ $(CC) $(CFLAGS) $(OBJS) ../util/libNUtil.a $(LDFLAGS) $(LIBS) -o $@
nc: nc.o
- $(CC) $(CFLAGS) nc.o ../util/libNUtil.a $(LIBS) -o $@
+ $(CC) $(CFLAGS) nc.o ../util/libNUtil.a $(LDFLAGS) $(LIBS) -o $@
help.o: help.c
$(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@