Fix build with gcc6

This commit is contained in:
markd 2016-07-16 03:36:51 +00:00
parent 077fd7ef7a
commit 5c7f5f1b7a
5 changed files with 70 additions and 2 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.9 2015/11/03 03:29:37 agc Exp $
$NetBSD: distinfo,v 1.10 2016/07/16 03:36:51 markd Exp $
SHA1 (umbrello-4.14.3.tar.xz) = e963fbe9c024948784e37a83ae456965512ef3bc
RMD160 (umbrello-4.14.3.tar.xz) = 20db4af85399cd3cacf3dc1f17b1088d203a3f66
SHA512 (umbrello-4.14.3.tar.xz) = c7510d7411a8c615cb54c5df30688edcb8bccbec07762503a11dbac9eeffffc7e7ecad492d5830ab93f291eab1aa327671a692c7ffa4c72b03bc108b1c38c447
Size (umbrello-4.14.3.tar.xz) = 1508536 bytes
SHA1 (patch-umbrello_widgets_associationline.cpp) = a332ff632675ce223a9227f3d58c1aaf580f5206
SHA1 (patch-umbrello_widgets_associationwidget.cpp) = 2682453288b5d863229053a4ae10876c860ff705

View file

@ -0,0 +1,17 @@
$NetBSD: patch-umbrello_widgets_associationline.cpp,v 1.1 2016/07/16 03:36:51 markd Exp $
make gcc6 happy
--- umbrello/widgets/associationline.cpp.orig 2014-11-04 06:47:37.000000000 +0000
+++ umbrello/widgets/associationline.cpp
@@ -859,8 +859,8 @@ QPainterPath AssociationLine::createOrth
if (points.size() > 1) {
QPointF start = points.first();
QPointF end = points.last();
- qreal deltaX = abs(start.x() - end.x());
- qreal deltaY = abs(start.y() - end.y());
+ qreal deltaX = std::abs(start.x() - end.x());
+ qreal deltaY = std::abs(start.y() - end.y());
// DEBUG("AssociationLine") << "start=" << start << " / end=" << end
// << " / deltaX=" << deltaX << " / deltaY=" << deltaY;
QVector<QPointF> vector;

View file

@ -0,0 +1,29 @@
$NetBSD: patch-umbrello_widgets_associationwidget.cpp,v 1.3 2016/07/16 03:36:51 markd Exp $
make gcc6 happy
--- umbrello/widgets/associationwidget.cpp.orig 2014-11-04 06:47:37.000000000 +0000
+++ umbrello/widgets/associationwidget.cpp
@@ -2118,9 +2118,9 @@ void AssociationWidget::updatePointsExce
p1.setX(xmil + (xfin - xmil)*1/2); p1.setY(ymil + (yfin - ymil)*1/3);
p2.setX(xmil - (xmil - xdeb)*1/2); p2.setY(ymil - (ymil - ydeb)*1/3);
- if (abs(p1.x() - p2.x()) <= 10)
+ if (std::abs(p1.x() - p2.x()) <= 10)
ESPACEX = 15;
- if (abs(p1.y() - p2.y()) <= 10)
+ if (std::abs(p1.y() - p2.y()) <= 10)
ESPACEY = 15;
m_associationLine->setEndPoints(QPointF(xdeb, ydeb), QPointF(xfin, yfin));
@@ -2688,8 +2688,8 @@ void AssociationWidget::constrainTextPos
r = textWidth;
// swap textCenter{X,Y} to convert from Qt coord.system.
const QPointF origTextCenter(textCenterY, textCenterX);
- const int relX = abs(origTextCenter.x() - midP.x());
- const int relY = abs(origTextCenter.y() - midP.y());
+ const int relX = std::abs(origTextCenter.x() - midP.x());
+ const int relY = std::abs(origTextCenter.y() - midP.y());
const double negativeWhenInsideCircle = relX * relX + relY * relY - r * r;
if (negativeWhenInsideCircle <= 0.0) {
return;

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.46 2015/12/19 20:52:12 markd Exp $
$NetBSD: distinfo,v 1.47 2016/07/16 03:45:19 markd Exp $
SHA1 (blender-2.76b.tar.gz) = 7be96d90296cc95e15380ad0ae56cb86f1374a65
RMD160 (blender-2.76b.tar.gz) = 393c03e9ff15631f89ddd0cdfc8548bb87a0bde5
@ -15,3 +15,4 @@ SHA1 (patch-extern_rangetree_range__tree.hh) = 976881b9caad67a2cfb24039652e88786
SHA1 (patch-intern_cycles_util_util__types.h) = 37944c6b0a970468e6791ec4a5beef1ec0ddf190
SHA1 (patch-intern_ghost_SConscript) = d576ea87b5b0f386e2c78efa78351927a105f243
SHA1 (patch-intern_guardedalloc_intern_mallocn__intern.h) = c7bc89af1c03b50ae0bd8af5aacc25cd82dfcbfc
SHA1 (patch-source_blender_imbuf_intern_dds_DirectDrawSurface.cpp) = b38f61900aa30b02479c7397062d71d295932847

View file

@ -0,0 +1,19 @@
$NetBSD: patch-source_blender_imbuf_intern_dds_DirectDrawSurface.cpp,v 1.1 2016/07/16 03:45:19 markd Exp $
--- source/blender/imbuf/intern/dds/DirectDrawSurface.cpp.orig 2015-11-04 10:02:15.000000000 +0000
+++ source/blender/imbuf/intern/dds/DirectDrawSurface.cpp
@@ -55,12 +55,13 @@
// FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
// OTHER DEALINGS IN THE SOFTWARE.
+// Include stdlib first to restore undefined min/max behavior w/ GCC 6
+#include <stdlib.h> // malloc
#include <DirectDrawSurface.h>
#include <BlockDXT.h>
#include <PixelFormat.h>
#include <stdio.h> // printf
-#include <stdlib.h> // malloc
#include <math.h> // sqrt
#include <sys/types.h>