Update harfbuzz to 0.9.19, as well as add an option to compile with icu

support. Changes, apart from minor fixes, include:
    [ft] hb_ft_get_glyph_from_name fails for the name of glyph id 0
    [uniscribe] Fix buffer allocation
    [Indic] Add Javanese config
    [OT] Collect requiredFeature only if features are not provided
    Fix contextual lookup recursion indexing
    Destroy lookups before blobs.
    If variation selector is not consumed by cmap, pass it on to GSUB
    Skip over multiple variation selectors in a row
    util/ansi-print.cc: Use fallback implementation for lround on MSVC
    hb-uniscribe.cc: Re-enable build under Visual Studio
This commit is contained in:
jaapb 2013-08-22 15:34:32 +00:00
parent 57524911a5
commit 5c849e39eb
5 changed files with 30 additions and 34 deletions

View file

@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.19 2013/07/08 22:39:21 tron Exp $
# $NetBSD: Makefile,v 1.20 2013/08/22 15:34:32 jaapb Exp $
DISTNAME= harfbuzz-0.9.18
DISTNAME= harfbuzz-0.9.19
CATEGORIES= fonts
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
EXTRACT_SUFX= .tar.bz2
@ -16,15 +16,18 @@ USE_LANGUAGES= c c++
USE_LIBTOOL= yes
USE_TOOLS+= gmake pkg-config
GNU_CONFIGURE= yes
PKGCONFIG_OVERRIDE= harfbuzz.pc.in
PKGCONFIG_OVERRIDE= src/harfbuzz.pc.in
CONFIGURE_ARGS+= --with-cairo=no
CONFIGURE_ARGS+= --with-icu=no
CONFIGURE_ARGS+= --with-coretext=auto
PLIST_VARS+= icu
LDFLAGS.OpenBSD+= -lz
.include "../../mk/bsd.prefs.mk"
.include "options.mk"
# gcc too old
.if ${OPSYS} == "MirBSD"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2013/07/07 10:19:03 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2013/08/22 15:34:32 jaapb Exp $
bin/hb-ot-shape-closure
bin/hb-shape
include/harfbuzz/hb-blob.h
@ -8,6 +8,7 @@ include/harfbuzz/hb-font.h
include/harfbuzz/hb-ft.h
include/harfbuzz/hb-glib.h
include/harfbuzz/hb-gobject.h
${PLIST.icu}include/harfbuzz/hb-icu.h
include/harfbuzz/hb-ot-layout.h
include/harfbuzz/hb-ot-tag.h
include/harfbuzz/hb-ot.h
@ -18,4 +19,6 @@ include/harfbuzz/hb-unicode.h
include/harfbuzz/hb-version.h
include/harfbuzz/hb.h
lib/libharfbuzz.la
${PLIST.icu}lib/libharfbuzz-icu.la
lib/pkgconfig/harfbuzz.pc
${PLIST.icu}lib/pkgconfig/harfbuzz-icu.pc

View file

@ -1,7 +1,6 @@
$NetBSD: distinfo,v 1.13 2013/07/07 10:23:14 wiz Exp $
$NetBSD: distinfo,v 1.14 2013/08/22 15:34:32 jaapb Exp $
SHA1 (harfbuzz-0.9.18.tar.bz2) = 621943fa0cadbc5514d8c8cdf985b7158baebc2d
RMD160 (harfbuzz-0.9.18.tar.bz2) = 846129218febad5dcdcb914ef943bb19dd9c310b
Size (harfbuzz-0.9.18.tar.bz2) = 902395 bytes
SHA1 (harfbuzz-0.9.19.tar.bz2) = 5603e084fbf8be1b93722c8e2694643361c489e4
RMD160 (harfbuzz-0.9.19.tar.bz2) = d76e52542ac11ac03c3fb4f49fddf1535bfefab6
Size (harfbuzz-0.9.19.tar.bz2) = 926632 bytes
SHA1 (patch-src_hb-open-type-private.hh) = 876f1afdf2c7babb4cd3c2b9c9e4635167ad1021
SHA1 (patch-test_api_Makefile.in) = f19f3b2f96b93e8d3c1aa64d5c6f78cfc385e177

15
fonts/harfbuzz/options.mk Normal file
View file

@ -0,0 +1,15 @@
# $NetBSD: options.mk,v 1.1 2013/08/22 15:34:32 jaapb Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.harfbuzz
PKG_SUPPORTED_OPTIONS+= icu
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Micu)
.include "../../textproc/icu/buildlink3.mk"
CONFIGURE_ARGS+= --with-icu=yes
PKGCONFIG_OVERRIDE+= src/harfbuzz-icu.pc.in
PLIST.icu= yes
.else
CONFIGURE_ARGS+= --with-icu=no
.endif

View file

@ -1,24 +0,0 @@
$NetBSD: patch-test_api_Makefile.in,v 1.1 2013/07/07 10:19:04 wiz Exp $
If not linking against icu, we need to link against libharfbuzz itself.
--- test/api/Makefile.in.orig 2013-05-28 21:20:43.000000000 +0000
+++ test/api/Makefile.in
@@ -148,6 +148,9 @@ test_unicode_OBJECTS = test_unicode-test
@HAVE_GLIB_TRUE@am__DEPENDENCIES_2 = \
@HAVE_GLIB_TRUE@ $(top_builddir)/src/libharfbuzz.la \
@HAVE_GLIB_TRUE@ $(am__DEPENDENCIES_1)
+@HAVE_GLIB_TRUE@@HAVE_ICU_FALSE@test_unicode_DEPENDENCIES = \
+@HAVE_GLIB_TRUE@@HAVE_ICU_FALSE@ $(am__DEPENDENCIES_2) \
+@HAVE_GLIB_TRUE@@HAVE_ICU_FALSE@ $(top_builddir)/src/libharfbuzz.la
@HAVE_GLIB_TRUE@@HAVE_ICU_TRUE@test_unicode_DEPENDENCIES = \
@HAVE_GLIB_TRUE@@HAVE_ICU_TRUE@ $(am__DEPENDENCIES_2) \
@HAVE_GLIB_TRUE@@HAVE_ICU_TRUE@ $(top_builddir)/src/libharfbuzz-icu.la
@@ -390,6 +393,7 @@ MAINTAINERCLEANFILES =
@HAVE_GLIB_TRUE@test_unicode_CPPFLAGS = $(AM_CPPFLAGS) $(GLIB_CFLAGS) \
@HAVE_GLIB_TRUE@ $(am__append_2)
@HAVE_GLIB_TRUE@@HAVE_ICU_TRUE@test_unicode_LDADD = $(LDADD) $(top_builddir)/src/libharfbuzz-icu.la
+@HAVE_GLIB_TRUE@@HAVE_ICU_FALSE@test_unicode_LDADD = $(LDADD) $(top_builddir)/src/libharfbuzz.la
@HAVE_GLIB_TRUE@test_cplusplus_SOURCES = test-cplusplus.cc
@HAVE_GLIB_TRUE@test_c_CPPFLAGS = $(AM_CPPFLAGS) $(am__append_4) \
@HAVE_GLIB_TRUE@ $(am__append_6)