Initial import of getmail.

getmail is intended as a simple replacement for fetchmail. It retrieves mail
(either all messages, or only unread messages) from one or more POP3 servers
for one or more email accounts, and reliably delivers into a qmail-style
Maildir (or mbox file) specified on a per-account basis. It also has support
for domain (multidrop) mailboxes.

Package submitted by Tomasz Luchowski in PR pkg/11929.
This commit is contained in:
jtb 2001-03-05 20:56:44 +00:00
parent b220924ae7
commit 5cda436c76
7 changed files with 74 additions and 0 deletions

33
mail/getmail/Makefile Normal file
View file

@ -0,0 +1,33 @@
# $NetBSD: Makefile,v 1.1.1.1 2001/03/05 20:56:44 jtb Exp $
#
DISTNAME= getmail-2.0.18
CATEGORIES= mail
MASTER_SITES= http://www.qcc.sk.ca/~charlesc/software/getmail-2.0/
MAINTAINER= zuntum@eik.pl
HOMEPAGE= http://www.qcc.sk.ca/~charlesc/software/getmail-2.0/
COMMENT= POP3 mail retriever with reliable Maildir and mbox delivery
DEPENDS+= python>=1.52:../../lang/python
NO_CONFIGURE= YES
NO_BUILD= YES
post-patch:
${SED} "s,@PREFIX@,${PREFIX}," ${WRKSRC}/getmail \
> ${WRKSRC}/getmail.done
${MV} ${WRKSRC}/getmail.done ${WRKSRC}/getmail
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/getmail
cd ${WRKSRC} && \
${INSTALL_DATA} TODO BUGS CHANGELOG getmailrc-example faq.txt \
getmail.txt docs.txt COPYING ${PREFIX}/share/doc/getmail
${INSTALL_SCRIPT_DIR} ${PREFIX}/libexec/getmail
cd ${WRKSRC} && \
${INSTALL_SCRIPT} ConfParser.py timeoutsocket.py getmail.py \
${PREFIX}/libexec/getmail
${INSTALL_SCRIPT} ${WRKSRC}/getmail ${PREFIX}/bin
.include "../../mk/bsd.pkg.mk"

3
mail/getmail/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 2001/03/05 20:56:44 jtb Exp $
MD5 (getmail-2.0.18.tar.gz) = 981495a82f98b12b0fd862fab75e16f1

View file

@ -0,0 +1,3 @@
$NetBSD: patch-sum,v 1.1.1.1 2001/03/05 20:56:44 jtb Exp $
MD5 (patch-aa) = b6bda2bd9f2f60ec170095fd0143e616

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/03/05 20:56:44 jtb Exp $
--- getmail.orig Tue Feb 20 23:24:07 2001
+++ getmail
@@ -1,7 +1,7 @@
#!/bin/sh
# Change this to your getmail directory; defaults to /usr/lib/getmail
-GETMAILPATH="/usr/local/lib/getmail"
+GETMAILPATH="@PREFIX@/libexec/getmail"
OLDPYTHONPATH=${PYTHONPATH}
PYTHONPATH="${GETMAILPATH}:${PYTHONPATH}"

5
mail/getmail/pkg/DESCR Normal file
View file

@ -0,0 +1,5 @@
getmail is intended as a simple replacement for fetchmail. It retrieves mail
(either all messages, or only unread messages) from one or more POP3 servers
for one or more email accounts, and reliably delivers into a qmail-style
Maildir (or mbox file) specified on a per-account basis. It also has support
for domain (multidrop) mailboxes.

2
mail/getmail/pkg/MESSAGE Normal file
View file

@ -0,0 +1,2 @@
Take a look at ${PREFIX}/share/doc/getmail/getmailrc-example to learn
getmailrc syntax.

15
mail/getmail/pkg/PLIST Normal file
View file

@ -0,0 +1,15 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2001/03/05 20:56:44 jtb Exp $
bin/getmail
libexec/getmail/ConfParser.py
libexec/getmail/getmail.py
libexec/getmail/timeoutsocket.py
share/doc/getmail/BUGS
share/doc/getmail/CHANGELOG
share/doc/getmail/COPYING
share/doc/getmail/TODO
share/doc/getmail/docs.txt
share/doc/getmail/faq.txt
share/doc/getmail/getmail.txt
share/doc/getmail/getmailrc-example
@dirrm libexec/getmail
@dirrm share/doc/getmail