Initial import of mousetar-20020202 into the NetBSD packages collection.

Quoting from http://mail-index.netbsd.org/tech-userlevel/2002/10/16/0000.html

"I've written a tar that owes nothing to anything else.  It's in the
public domain and hence is free for NetBSD to steal, anything from
lifting it verbatim to swiping ideas from.

It doesn't currently have anything like --fast-read; that hadn't
occurred to me.  Now that it's been pointed out, I'll be adding it; I
think it's a valuable addition, whether or not NetBSD wants my tar."
This commit is contained in:
agc 2002-10-16 09:34:12 +00:00
parent 15f9d02cd9
commit 5cefa5dc11
5 changed files with 58 additions and 0 deletions

7
sysutils/mousetar/DESCR Normal file
View file

@ -0,0 +1,7 @@
I've written a tar that owes nothing to anything else. It's in the
public domain and hence is free for NetBSD to steal, anything from
lifting it verbatim to swiping ideas from.
It doesn't currently have anything like --fast-read; that hadn't
occurred to me. Now that it's been pointed out, I'll be adding it; I
think it's a valuable addition, whether or not NetBSD wants my tar.

View file

@ -0,0 +1,27 @@
# $NetBSD: Makefile,v 1.1.1.1 2002/10/16 09:34:12 agc Exp $
#
DISTNAME= mousetar-20020202
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/mouse/tar/
DISTFILES= tar.c tar.man
MAINTAINER= packages@netbsd.org
#HOMEPAGE= none
COMMENT= der Mouse's version of tar program
WRKSRC= ${WRKDIR}
do-extract:
for f in ${DISTFILES}; do \
${CP} ${DISTDIR}/$$f ${WRKDIR}; \
done
do-build:
cd ${WRKSRC}; ${CC} ${CFLAGS} tar.c -o mousetar
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/mousetar ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/tar.man ${PREFIX}/man/man1/mousetar.1
.include "../../mk/bsd.pkg.mk"

3
sysutils/mousetar/PLIST Normal file
View file

@ -0,0 +1,3 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2002/10/16 09:34:13 agc Exp $
bin/mousetar
man/man1/mousetar.1

View file

@ -0,0 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2002/10/16 09:34:12 agc Exp $
SHA1 (tar.c) = 2430788c4a873962a75dff23b6eceefa0765c687
Size (tar.c) = 283156 bytes
SHA1 (tar.man) = a43498f78f3122edf1970a471c9bd313c0ace2f1
Size (tar.man) = 49336 bytes
SHA1 (patch-aa) = fcc8cb946c1649c0510cb503c8a2ce1dcf491abb

View file

@ -0,0 +1,14 @@
$NetBSD: patch-aa,v 1.1.1.1 2002/10/16 09:34:13 agc Exp $
--- tar.c 2002/10/16 09:25:24 1.1
+++ tar.c 2002/10/16 09:25:38
@@ -472,8 +472,8 @@
/* NetBSD: fix up itoo/itod and the fs_q?mask fields, and BIG* */
#ifdef TAR_INODE_NETBSD
#include <sys/param.h>
-#include <ufs/ffs/fs.h>
#include <ufs/ufs/dinode.h>
+#include <ufs/ffs/fs.h>
#define rawi_direct direct
#define itoo(sb,i) ino_to_fsbo(sb,i)
#define itod(sb,i) ino_to_fsba(sb,i)