Changes 3.8.4:
Code optimization and refactoring for improved performance. Add the ".clone" and ".save" commands to the command-line shell. Update the banner on the command-line shell to alert novice users when they are using an ephemeral in-memory database. Fix editline support in the command-line shell. Add support for coverage testing of VDBE programs using the SQLITE_TESTCTRL_VDBE_COVERAGE verb of sqlite3_test_control(). Update the _FILE_OFFSET_BITS macro so that builds work again on QNX. Change the datatype of SrcList.nSrc from type u8 to type int to work around an issue in the C compiler on AIX. Get extension loading working on Cygwin. Bug fix: Fix the char() SQL function so that it returns an empty string rather than an "out of memory" error when called with zero arguments. Bug fix: DISTINCT now recognizes that a zeroblob and a blob of all 0x00 bytes are the same thing. Ticket [fccbde530a] Bug fix: Compute the correct answer for queries that contain an IS NOT NULL term in the WHERE clause and also contain an OR term in the WHERE clause and are compiled with SQLITE_ENABLE_STAT4. Ticket [4c86b126f2] Bug fix: Make sure "rowid" columns are correctly resolved in joins between normal tables and WITHOUT ROWID tables. Ticket [c34d0557f7] Bug fix: Make sure the same temporary registers are not used in concurrent co-routines used to implement compound SELECT statements containing ORDER BY clauses, as such use can lead to incorrect answers. Ticket [8c63ff0eca] Bug fix: Ensure that "ORDER BY random()" clauses do not get optimized out. Ticket [65bdeb9739] Bug fix: Repair a name-resolution error that can occur in sub-select statements contained within a TRIGGER. Ticket [4ef7e3cfca] Bug fix: Fix column default values expressions of the form "DEFAULT(-(-9223372036854775808))" so that they work correctly, initializing the column to a floating point value approximately equal to +9223372036854775808.0.
This commit is contained in:
parent
47fee01a63
commit
5d7525aefc
9 changed files with 26 additions and 41 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.26 2014/02/13 07:30:31 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.27 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
DISTNAME= sqlite-doc-3080301
|
||||
PKGNAME= sqlite3-docs-3.8.3.1
|
||||
DISTNAME= sqlite-doc-3080400
|
||||
PKGNAME= sqlite3-docs-3.8.4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/2014/ \
|
||||
http://www.sqlite.org/2014/
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.24 2014/02/13 07:30:31 adam Exp $
|
||||
@comment $NetBSD: PLIST,v 1.25 2014/03/10 17:03:29 adam Exp $
|
||||
share/doc/sqlite3/34to35.html
|
||||
share/doc/sqlite3/35to36.html
|
||||
share/doc/sqlite3/about.html
|
||||
|
@ -611,6 +611,7 @@ share/doc/sqlite3/releaselog/3_8_1.html
|
|||
share/doc/sqlite3/releaselog/3_8_2.html
|
||||
share/doc/sqlite3/releaselog/3_8_3.html
|
||||
share/doc/sqlite3/releaselog/3_8_3_1.html
|
||||
share/doc/sqlite3/releaselog/3_8_4.html
|
||||
share/doc/sqlite3/releaselog/current.html
|
||||
share/doc/sqlite3/requirements.html
|
||||
share/doc/sqlite3/robots.txt
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.24 2014/02/13 07:30:31 adam Exp $
|
||||
$NetBSD: distinfo,v 1.25 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
SHA1 (sqlite-doc-3080301.zip) = 0fe468bbbd4d768b6bfa250739a79badb49f7235
|
||||
RMD160 (sqlite-doc-3080301.zip) = 8835fd223b7edb82c8fb384e7065ea45e52fe1a3
|
||||
Size (sqlite-doc-3080301.zip) = 4603427 bytes
|
||||
SHA1 (sqlite-doc-3080400.zip) = f3765974a7752901aff58b4c7ade4950383bcb24
|
||||
RMD160 (sqlite-doc-3080400.zip) = 50cfedb108db9a75e74299dc958384b64f93b552
|
||||
Size (sqlite-doc-3080400.zip) = 4609851 bytes
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.55 2014/02/13 07:30:31 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.56 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
DISTNAME= sqlite-autoconf-3080301
|
||||
PKGNAME= sqlite3-tcl-3.8.3.1
|
||||
DISTNAME= sqlite-autoconf-3080400
|
||||
PKGNAME= sqlite3-tcl-3.8.4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/2014/ \
|
||||
http://www.sqlite.org/2014/
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.37 2014/02/13 07:30:31 adam Exp $
|
||||
$NetBSD: distinfo,v 1.38 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
SHA1 (sqlite-autoconf-3080301.tar.gz) = a9b0a3d66fb5c2ae51ad2d8a512ca827adc7d59c
|
||||
RMD160 (sqlite-autoconf-3080301.tar.gz) = 61ac2cc27c17fb62a46b66c24791e47bd66aad51
|
||||
Size (sqlite-autoconf-3080301.tar.gz) = 1923168 bytes
|
||||
SHA1 (patch-aa) = c52c1b1d92f1f24b80315a2dba6777e64d7573de
|
||||
SHA1 (patch-ab) = 64a4352b9a8ed0518784837e390541cd4e1bc9aa
|
||||
SHA1 (sqlite-autoconf-3080400.tar.gz) = 19249a798456f88b3a99ef27fa4119d08d89682f
|
||||
RMD160 (sqlite-autoconf-3080400.tar.gz) = 95fc8e8b7585e92d698e6002b42f381434fe48d6
|
||||
Size (sqlite-autoconf-3080400.tar.gz) = 1937306 bytes
|
||||
SHA1 (patch-aa) = 4a12a16498d04e1031dc0802fda731b73e98a32d
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
$NetBSD: patch-aa,v 1.2 2014/02/04 13:28:08 adam Exp $
|
||||
$NetBSD: patch-aa,v 1.3 2014/03/10 17:03:30 adam Exp $
|
||||
|
||||
--- Makefile.in.orig 2009-04-13 11:18:29.000000000 +0200
|
||||
--- Makefile.in.orig 2014-03-10 13:47:51.000000000 +0000
|
||||
+++ Makefile.in
|
||||
@@ -81,7 +81,7 @@ DESTDIR =
|
||||
|
||||
|
|
|
@ -1,15 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.2 2011/04/12 19:00:51 adam Exp $
|
||||
|
||||
* treat DragonFly shlib handling same as NetBSD.
|
||||
|
||||
--- configure.orig 2010-12-08 12:53:41.000000000 +0000
|
||||
+++ configure
|
||||
@@ -9143,7 +9143,7 @@ fi
|
||||
UNSHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.a'
|
||||
TCL_LIB_VERSIONS_OK=nodots
|
||||
;;
|
||||
- NetBSD-*|FreeBSD-[3-4].*)
|
||||
+ NetBSD-*|FreeBSD-[3-4].*|DragonFly-*)
|
||||
# FreeBSD 3.* and greater have ELF.
|
||||
# NetBSD 2.* has ELF and can use 'cc -shared' to build shared libs
|
||||
SHLIB_CFLAGS="-fPIC"
|
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.73 2014/02/13 07:30:31 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.74 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
DISTNAME= sqlite-autoconf-3080301
|
||||
PKGNAME= sqlite3-3.8.3.1
|
||||
DISTNAME= sqlite-autoconf-3080400
|
||||
PKGNAME= sqlite3-3.8.4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= http://www.hwaci.com/sw/sqlite/2014/ \
|
||||
http://www.sqlite.org/2014/
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.84 2014/02/13 07:30:31 adam Exp $
|
||||
$NetBSD: distinfo,v 1.85 2014/03/10 17:03:29 adam Exp $
|
||||
|
||||
SHA1 (sqlite-autoconf-3080301.tar.gz) = a9b0a3d66fb5c2ae51ad2d8a512ca827adc7d59c
|
||||
RMD160 (sqlite-autoconf-3080301.tar.gz) = 61ac2cc27c17fb62a46b66c24791e47bd66aad51
|
||||
Size (sqlite-autoconf-3080301.tar.gz) = 1923168 bytes
|
||||
SHA1 (sqlite-autoconf-3080400.tar.gz) = 19249a798456f88b3a99ef27fa4119d08d89682f
|
||||
RMD160 (sqlite-autoconf-3080400.tar.gz) = 95fc8e8b7585e92d698e6002b42f381434fe48d6
|
||||
Size (sqlite-autoconf-3080400.tar.gz) = 1937306 bytes
|
||||
|
|
Loading…
Reference in a new issue