Sync with ../gcc3 pkg (cpp defaults to -gcc).

This commit is contained in:
martin 2003-07-29 09:02:49 +00:00
parent d3dc7b0e23
commit 5d8126aadb
4 changed files with 36 additions and 3 deletions

View file

@ -1,6 +1,8 @@
$NetBSD: distinfo,v 1.3 2003/07/09 15:23:56 drochner Exp $ $NetBSD: distinfo,v 1.4 2003/07/29 09:02:49 martin Exp $
SHA1 (gcc-3.3.tar.bz2) = 18e23822c6dc9cb462e0ff88bc1b8a20c53da60a SHA1 (gcc-3.3.tar.bz2) = 18e23822c6dc9cb462e0ff88bc1b8a20c53da60a
Size (gcc-3.3.tar.bz2) = 23447616 bytes Size (gcc-3.3.tar.bz2) = 23447616 bytes
SHA1 (patch-aa) = 93a4299e7d64b91f750ba96c75f0487cdf87abea SHA1 (patch-aa) = 93a4299e7d64b91f750ba96c75f0487cdf87abea
SHA1 (patch-af) = ee41c43dbb6e710a9399954793c6ff7c4274e515
SHA1 (patch-ag) = 23fecd85ddca19a2c543827b60ea555ffbdcaa6c
SHA1 (patch-ba) = 9037d2504c5db6458494a18852d57c1ef5c9dcdb SHA1 (patch-ba) = 9037d2504c5db6458494a18852d57c1ef5c9dcdb

View file

@ -1,8 +1,8 @@
# $NetBSD: gcc3.mk,v 1.3 2003/07/17 09:07:57 abs Exp $ # $NetBSD: gcc3.mk,v 1.4 2003/07/29 09:02:50 martin Exp $
# #
# make configuration file for @PKGNAME@ # make configuration file for @PKGNAME@
USE_GCC3= # defined USE_GCC3= # defined
CC= @GCC_PREFIX@/bin/cc CC= @GCC_PREFIX@/bin/cc
CPP= @GCC_PREFIX@/bin/cpp -gcc CPP= @GCC_PREFIX@/bin/cpp
CXX= @GCC_PREFIX@/bin/c++ CXX= @GCC_PREFIX@/bin/c++

View file

@ -0,0 +1,18 @@
$NetBSD: patch-af,v 1.1 2003/07/29 09:02:51 martin Exp $
--- gcc/cppspec.c Wed Jul 23 02:40:54 2003
+++ gcc/cppspec.c Fri Jul 25 17:57:41 2003
@@ -85,6 +85,13 @@
is_cpp_driver = 1;
+ /* NetBSD uses __GNUC__ and friends in header files processed with cpp
+ regularly. Default to old behaviour here. XXX - move me to
+ config/netbsd.h "DEFAULT_CPP_NEED_NO_GCC". */
+#ifdef DEFAULT_CPP_NEED_NO_GCC
+ need_no_gcc = DEFAULT_CPP_NEED_NO_GCC;
+#endif
+
/* First pass. If we see an -S or -c, barf. If we see an input file,
turn off read_stdin. If we see a second input file, it is actually
the output file. If we see a third input file, barf. */

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ag,v 1.1 2003/07/29 09:02:51 martin Exp $
Index: gcc/config/netbsd.h
--- gcc/config/netbsd.h Wed Jul 23 02:41:37 2003
+++ gcc/config/netbsd.h Fri Jul 25 17:57:43 2003
@@ -234,3 +234,7 @@
/* 7 == PROT_READ | PROT_WRITE | PROT_EXEC */ \
(void) mprotect (page, end - page, 7); \
}
+
+/* NetBSD depends on "cpp" having GNUC semantics, and must default as if
+ "cpp -gcc" was called. */
+#define DEFAULT_CPP_NEED_NO_GCC 0