Also look for backtrace() in libexecinfo.
Accepted upstream as part of https://bugs.freedesktop.org/show_bug.cgi?id=69702
This commit is contained in:
parent
53f28d83c6
commit
5d9519d921
2 changed files with 83 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.55 2014/06/14 21:52:56 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.56 2014/06/14 21:57:34 wiz Exp $
|
||||
|
||||
SHA1 (dbus-1.8.4.tar.gz) = 316f1196312a88cc858ba810d4e5d16f70ab9d58
|
||||
RMD160 (dbus-1.8.4.tar.gz) = 929ec1d4ff1a1087fc4ca920f49ee6f89d55b3b7
|
||||
|
@ -9,4 +9,5 @@ SHA1 (patch-al) = 57d08196e9daf49eb6bda2b30f019ce2cad77c6f
|
|||
SHA1 (patch-am) = 8c794ff8b0981e90243ee20c26ae1ecc72e68de8
|
||||
SHA1 (patch-ba) = f9126faf18cd19e897865748ebea1011fe516225
|
||||
SHA1 (patch-bus_dir-watch-kqueue.c) = 86a1f0f78b4d16d8ab29d351057885d8001dd39c
|
||||
SHA1 (patch-configure) = 08fb6cc6e9bc9f23825a6a0f2b8b241169d1cda7
|
||||
SHA1 (patch-dbus_dbus-sysdeps-unix.c) = 043e7bf03686f51faf763f87f43e00308b29571e
|
||||
|
|
81
sysutils/dbus/patches/patch-configure
Normal file
81
sysutils/dbus/patches/patch-configure
Normal file
|
@ -0,0 +1,81 @@
|
|||
$NetBSD: patch-configure,v 1.3 2014/06/14 21:57:34 wiz Exp $
|
||||
|
||||
backtrace() may be in libexecinfo
|
||||
From
|
||||
https://bugs.freedesktop.org/attachment.cgi?id=100403
|
||||
which is part of
|
||||
https://bugs.freedesktop.org/show_bug.cgi?id=69702
|
||||
|
||||
--- configure.orig 2014-06-05 13:56:49.000000000 +0000
|
||||
+++ configure
|
||||
@@ -18860,16 +18860,63 @@ if test "x$ac_cv_header_execinfo_h" = xy
|
||||
cat >>confdefs.h <<_ACEOF
|
||||
#define HAVE_EXECINFO_H 1
|
||||
_ACEOF
|
||||
- for ac_func in backtrace
|
||||
-do :
|
||||
- ac_fn_c_check_func "$LINENO" "backtrace" "ac_cv_func_backtrace"
|
||||
-if test "x$ac_cv_func_backtrace" = xyes; then :
|
||||
- cat >>confdefs.h <<_ACEOF
|
||||
-#define HAVE_BACKTRACE 1
|
||||
-_ACEOF
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for library containing backtrace" >&5
|
||||
+$as_echo_n "checking for library containing backtrace... " >&6; }
|
||||
+if ${ac_cv_search_backtrace+:} false; then :
|
||||
+ $as_echo_n "(cached) " >&6
|
||||
+else
|
||||
+ ac_func_search_save_LIBS=$LIBS
|
||||
+cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
|
||||
+/* Override any GCC internal prototype to avoid an error.
|
||||
+ Use char because int might match the return type of a GCC
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+#ifdef __cplusplus
|
||||
+extern "C"
|
||||
+#endif
|
||||
+char backtrace ();
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
+return backtrace ();
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+for ac_lib in '' execinfo; do
|
||||
+ if test -z "$ac_lib"; then
|
||||
+ ac_res="none required"
|
||||
+ else
|
||||
+ ac_res=-l$ac_lib
|
||||
+ LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
+ fi
|
||||
+ if ac_fn_c_try_link "$LINENO"; then :
|
||||
+ ac_cv_search_backtrace=$ac_res
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext \
|
||||
+ conftest$ac_exeext
|
||||
+ if ${ac_cv_search_backtrace+:} false; then :
|
||||
+ break
|
||||
fi
|
||||
done
|
||||
+if ${ac_cv_search_backtrace+:} false; then :
|
||||
+
|
||||
+else
|
||||
+ ac_cv_search_backtrace=no
|
||||
+fi
|
||||
+rm conftest.$ac_ext
|
||||
+LIBS=$ac_func_search_save_LIBS
|
||||
+fi
|
||||
+{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_search_backtrace" >&5
|
||||
+$as_echo "$ac_cv_search_backtrace" >&6; }
|
||||
+ac_res=$ac_cv_search_backtrace
|
||||
+if test "$ac_res" != no; then :
|
||||
+ test "$ac_res" = "none required" || LIBS="$ac_res $LIBS"
|
||||
+
|
||||
+$as_echo "#define HAVE_BACKTRACE 1" >>confdefs.h
|
||||
+
|
||||
+fi
|
||||
|
||||
fi
|
||||
|
Loading…
Reference in a new issue