Remove lang/icc11.

This commit is contained in:
alnsn 2016-12-30 22:27:04 +00:00
parent 903927062a
commit 5da67ad3af
25 changed files with 1 additions and 4182 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.447 2016/12/29 22:46:30 maya Exp $
# $NetBSD: Makefile,v 1.448 2016/12/30 22:27:04 alnsn Exp $
#
COMMENT= Programming languages
@ -88,7 +88,6 @@ SUBDIR+= guile20
SUBDIR+= gwydion-dylan
SUBDIR+= heirloom-awk
SUBDIR+= hugs
SUBDIR+= icc11
SUBDIR+= icon
SUBDIR+= inform
SUBDIR+= intercal

View file

@ -1 +0,0 @@
Intel C++ Compiler for Linux.

View file

@ -1,7 +0,0 @@
===========================================================================
$NetBSD: MESSAGE,v 1.1 2011/07/20 10:35:18 alnsn Exp $
Please read
${LOCALBASE}/share/doc/icc11/README.bsd
${LOCALBASE}/share/doc/icc11/README.pkgsrc
===========================================================================

View file

@ -1,113 +0,0 @@
# $NetBSD: Makefile,v 1.7 2014/11/03 10:35:33 wiz Exp $
ICC_MAJOR_VERSION= 11.1
ICC_MINOR_VERSION= 080
ICC_VERSION= ${ICC_MAJOR_VERSION}.${ICC_MINOR_VERSION}
CATEGORIES= lang
DISTNAME= l_cproc_p_${ICC_VERSION}
PKGNAME= icc11-${ICC_VERSION}
PKGREVISION= 2
MASTER_SITES= # empty
EXTRACT_SUFX= .tgz
EXTRACT_ELEMENTS= ${ICC_EXTRACT_RPMS}
MAINTAINER= alnsn@NetBSD.org
HOMEPAGE_COMMERCIAL= http://software.intel.com/en-us/articles/intel-compilers/
HOMEPAGE_NONCOMMERCIAL= http://software.intel.com/en-us/articles/non-commercial-software-development/
HOMEPAGE= ${HOMEPAGE_NONCOMMERCIAL}
COMMENT= Intel C++ Compiler for Linux
LICENSE= intel-icc11-license
RESTRICTED= Intel forbids any redistribution
NO_SRC_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_CDROM= ${RESTRICTED}
NO_BIN_ON_FTP= ${RESTRICTED}
NO_SRC_ON_FTP= ${RESTRICTED}
ICC_PREFIX= ${PREFIX}/icc11
ONLY_FOR_PLATFORM+= NetBSD-*-i386 NetBSD-*-x86_64 \
Linux-*-i386 Linux-*-x86_64
USE_TOOLS+= pax make rpm2pkg
USE_LANGUAGES+= c
BUILD_DEPENDS+= rpm2pkg>=2.1:../../pkgtools/rpm2pkg
DEPENDS+= gcc48>=4.8:../../lang/gcc48
DEPENDS+= binutils>=2.17:../../devel/binutils
GCC_PREFIX= ${BUILDLINK_PREFIX.gcc48}
BINUTILS_PREFIX= ${PREFIX}/${MACHINE_GNU_PLATFORM}
EMUL_PLATFORMS= linux-i386 linux-x86_64
EMUL_MODULES.linux= base compat
EMUL_REQD= suse>=11.3
.include "../../mk/bsd.prefs.mk"
.if ${MACHINE_ARCH} == "i386"
ICC_ARCH= ia32
.else
ICC_ARCH= intel64
.endif
SUBST_CLASSES+= installdir vars
SUBST_MESSAGE.installdir=Substituting <INSTALLDIR>
SUBST_STAGE.installdir= pre-configure
SUBST_SED.installdir= -e 's,<INSTALLDIR>,${ICC_PREFIX},g'
SUBST_FILES.installdir= icc11/bin/iccvars.sh \
icc11/bin/iccvars.csh \
icc11/bin/ia32/iccvars_ia32.sh \
icc11/bin/ia32/iccvars_ia32.csh
.if ${MACHINE_ARCH} == "x86_64"
SUBST_FILES.installdir+=icc11/bin/intel64/iccvars_intel64.sh \
icc11/bin/intel64/iccvars_intel64.csh
.endif
SUBST_STAGE.vars= pre-configure
SUBST_VARS.vars= ICC_PREFIX ICC_ARCH OPSYS_EMULDIR GCC_PREFIX BINUTILS_PREFIX
SUBST_FILES.vars= util.h icc xiar README.pkgsrc
PLIST_VARS+= linux netbsd x86_64 linux_x86_64 netbsd_x86_64
PLIST.${LOWER_OPSYS}= yes
PLIST.${MACHINE_ARCH}= yes
PLIST.${LOWER_OPSYS}_${MACHINE_ARCH}=yes
ICC_EXTRACT_RPMS=\
${DISTNAME}/rpm/intel-cproc${ICC_MINOR_VERSION}-11.1-1.i486.rpm \
${DISTNAME}/rpm/intel-cproc${ICC_MINOR_VERSION}-11.1-1.x86_64.rpm \
${DISTNAME}/rpm/intel-cprocsdk${ICC_MINOR_VERSION}-11.1-1.noarch.rpm \
${DISTNAME}/rpm/intel-cprolib${ICC_MINOR_VERSION}-11.1-1.i486.rpm \
${DISTNAME}/rpm/intel-cprolibdev${ICC_MINOR_VERSION}-11.1-1.i486.rpm
.if ${MACHINE_ARCH} == "x86_64"
ICC_EXTRACT_RPMS+=\
${DISTNAME}/rpm/intel-cprolib${ICC_MINOR_VERSION}-11.1-1.x86_64.rpm \
${DISTNAME}/rpm/intel-cprolibdev${ICC_MINOR_VERSION}-11.1-1.x86_64.rpm
.endif
WRKSRC= ${WRKDIR}/${ICC_MAJOR_VERSION}
post-extract:
cd ${WRKDIR} && rpm2pkg -s 4 ${ICC_EXTRACT_RPMS}
cd ${WRKSRC} && mv ${ICC_MINOR_VERSION} icc11
cd ${FILESDIR} && find . ! -type d | pax -rw ${WRKSRC}
if [ -d ${FILESDIR}/${LOWER_OPSYS} ]; then \
cd ${FILESDIR}/${LOWER_OPSYS} && \
find . ! -type d | pax -rw ${WRKSRC}; fi
do-build:
cd ${WRKSRC} && make ${LOWER_OPSYS}-${ICC_ARCH}
do-install:
cd ${WRKSRC} && make install-${LOWER_OPSYS}-${ICC_ARCH} \
PREFIX=${DESTDIR}${PREFIX} PKGMANDIR=${PKGMANDIR}
.include "../../lang/gcc48/buildlink3.mk"
.include "../../devel/binutils/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

File diff suppressed because it is too large Load diff

View file

@ -1,13 +0,0 @@
$NetBSD: distinfo,v 1.1 2011/07/20 10:35:18 alnsn Exp $
SHA1 (l_cproc_p_11.1.080.tgz) = 056271ba15ebfe3c4e8be8da416fec22e02b0101
RMD160 (l_cproc_p_11.1.080.tgz) = 649a533739593c2b323843bee35d73ca8c30fa8e
Size (l_cproc_p_11.1.080.tgz) = 1372032108 bytes
SHA1 (patch-aa) = 7755aca6b6ee4f18da944cbf1f24dabaef3235b5
SHA1 (patch-ab) = 8166464b5975d8191c6f983ae75366533e81cffd
SHA1 (patch-ac) = fb125b7ec5de11947c614bd59f31e38808fc303f
SHA1 (patch-ad) = e5a5fe240d85c91221b9891fb1b19666fbf1f76c
SHA1 (patch-ae) = 43e86473745016aa4cfda89c96088fa3a4e55bcb
SHA1 (patch-af) = b7a892a9499178f85f75316b696792baa5da669b
SHA1 (patch-ag) = 844a550316731acd46cc9bc707678629c2cb16a4
SHA1 (patch-ah) = 15540a029e4c209aba4932ed4d69455060e90e0e

View file

@ -1,122 +0,0 @@
linux-ia32:
linux-intel64:
netbsd-ia32: as ld redefine-syms libicc11bsd-ia32.a
netbsd-intel64: netbsd-ia32 libicc11bsd-intel64.a
.PHONY: redefine-syms
redefine-syms:
find icc11/lib -name *.a -exec objcopy \
--redefine-sym __errno_location=__errno \
--redefine-sym __assert_fail=__assertion_failed \
{} \;
libicc11bsd-ia32.a: icc11bsd-ia32.o
ar r libicc11bsd-ia32.a icc11bsd-ia32.o
objcopy --redefine-sym my_stderr=stderr libicc11bsd-ia32.a
icc11bsd-ia32.o: icc11bsd.c
cc -m32 -fPIC -O icc11bsd.c -c -o icc11bsd-ia32.o
libicc11bsd-intel64.a: icc11bsd-intel64.o
ar r libicc11bsd-intel64.a icc11bsd-intel64.o
objcopy --redefine-sym my_stderr=stderr libicc11bsd-intel64.a
icc11bsd-intel64.o: icc11bsd.c
cc -m64 -fPIC -O icc11bsd.c -c -o icc11bsd-intel64.o
as: as.c util.h util.c
cc -O as.c util.c -o as
ld: ld.c util.h util.c
cc -O ld.c util.c -o ld
install-linux-ia32: ins-common ins-common-ia32 ins-so-ia32
install-linux-intel64: ins-common ins-common-intel64 ins-so-intel64
install-netbsd-ia32: ins-common ins-common-ia32 ins-bsd ins-bsd-ia32
install-netbsd-intel64: ins-common ins-common-intel64 ins-bsd ins-bsd-intel64
.PHONY: ins-common ins-common-ia32 ins-common-intel64 ins-so-ia32 ins-so-intel64 ins-bsd ins-bsd-ia32 ins-bsd-intel64
ins-common: ins-man ins-doc ins-examples ins-misc ins-inc ins-bin
.PHONY: ins-man ins-doc ins-examples ins-misc ins-inc ins-bin
ins-man:
install -m 755 -d ${PREFIX}/${PKGMANDIR}/man1
cd icc11/man/en_US && find man1 ! -type d | pax -rw -pp ${PREFIX}/${PKGMANDIR}
ins-doc:
install -m 755 -d ${PREFIX}/share/doc/icc11
install -m 644 README.bsd README.pkgsrc ${PREFIX}/share/doc/icc11
cd icc11/Documentation && find . ! -type d | \
pax -rw -pp ${PREFIX}/share/doc/icc11
ins-examples:
install -m 755 -d ${PREFIX}/share/examples/icc11
cd icc11/Samples && find . ! -type d | \
pax -rw -pp ${PREFIX}/share/examples/icc11
ins-misc:
find icc11/substitute_headers icc11/perf_headers ! -type d | \
pax -rw -pp ${PREFIX}
ins-inc:
find icc11/include -maxdepth 1 ! -type d ! -name *.orig | \
pax -rw -pp ${PREFIX}
ins-bin:
find icc11/bin -maxdepth 1 ! -type d | pax -rw -pp ${PREFIX}
install -m 755 icc ${PREFIX}/icc11/bin
install -m 755 xiar ${PREFIX}/icc11/bin
cp -p ${PREFIX}/icc11/bin/icc ${PREFIX}/icc11/bin/icpc
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/codecov
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/prelink
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/profdcg
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/profmerge
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/proforder
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/tselect
cp -p ${PREFIX}/icc11/bin/xiar ${PREFIX}/icc11/bin/xild
ins-common-ia32: ins-inc-ia32 ins-bin-ia32 ins-lib-ia32
ins-common-intel64: ins-inc-intel64 ins-bin-intel64 ins-lib-intel64
.PHONY: ins-inc-ia32 ins-bin-ia32 ins-lib-ia32
.PHONY: ins-inc-intel64 ins-bin-intel64 ins-lib-intel64
ins-so-ia32:
find icc11/lib/ia32 ! -type d | grep -w so | pax -rw -pp ${PREFIX}
ins-so-intel64:
find icc11/lib ! -type d | grep -w so | pax -rw -pp ${PREFIX}
ins-lib-ia32:
find icc11/lib/ia32 ! -type d | grep -vw so | pax -rw -pp ${PREFIX}
ins-lib-intel64:
find icc11/lib ! -type d | grep -vw so | pax -rw -pp ${PREFIX}
ins-bin-ia32:
find icc11/bin/ia32 ! -type d | pax -rw -pp ${PREFIX}
ins-bin-intel64:
find icc11/bin ! -type d | pax -rw -pp ${PREFIX}
ins-inc-ia32:
find icc11/include/ia32 ! -type d ! -name *.orig | pax -rw -pp ${PREFIX}
ins-inc-intel64:
find icc11/include ! -type d ! -name *.orig | pax -rw -pp ${PREFIX}
ins-bsd-ia32: libicc11bsd-ia32.a
install -m 644 libicc11bsd-ia32.a ${PREFIX}/icc11/lib/ia32/libicc11bsd.a
ins-bsd-intel64: libicc11bsd-intel64.a
install -m 644 libicc11bsd-ia32.a ${PREFIX}/icc11/lib/ia32/libicc11bsd.a
install -m 644 libicc11bsd-intel64.a ${PREFIX}/icc11/lib/intel64/libicc11bsd.a
ins-bsd: as ld
install -m 755 -d ${PREFIX}/icc11/libexec
install -m 755 as ${PREFIX}/icc11/libexec
install -m 755 ld ${PREFIX}/icc11/libexec

View file

@ -1,18 +0,0 @@
Disclaimer: this document is not a part of Intel distribution.
Intel C++ compiler does not run natively on BSD systems and some
options will never be supported. Most options that require linking
with Linux libraries fall into this category. For instance,
-shared-intel
-openmp
-mkl=[lib]
-opt-malloc-options=n, n > 0
are not supported.
However, runtime CPU detection and profile guided optimization seem
to work even though correspondent intel libraries depend on a couple
of glibc functions.
Global optimization (-ipo) works for some packages.

View file

@ -1,49 +0,0 @@
Disclaimer: this document is not a part of Intel distribution.
How to use pkgsrc with the Intel C++ Compiler
=============================================
License
-------
The compiler will search for a license file in a directory specified
by ${INTEL_LICENSE_FILE} variable if it's set, then in
@ICC_PREFIX@/licenses, ${HOME}/intel/licenses and /opt/intel/licenses
directories.
There is one caveat, though. Pkgsrc creates a fake home directory
so ${HOME}/intel/licenses is not a good choice for building
packages.
Bootstrap
---------
Some options below are probably redundant but these commands work
for me:
$ cat > /tmp/mk-fragment <<EOF
PKGSRC_COMPILER=icc
ICCBASE=@ICC_PREFIX@
NOGCCERROR=yes
EOF
$ env PKGSRC_COMPILER=icc \
> ICCBASE=@ICC_PREFIX@ \
> NOGCCERROR=yes \
> CC=@ICC_PREFIX@/bin/icc \
> CPP='@ICC_PREFIX@/bin/icc -E' \
> CXX=@ICC_PREFIX@/bin/icpc \
> ./bootstrap \
> --compiler=icc \
> --mk-fragment=/tmp/mk-fragment \
> ...
Building Packages
-----------------
Add these lines to your mk.conf file:
PKGSRC_COMPILER=icc
ICCBASE=@ICC_PREFIX@
NOGCCERROR=yes

View file

@ -1,35 +0,0 @@
#include <errno.h>
#include <stdlib.h>
#include <string.h>
#include <sys/syslimits.h>
#include <unistd.h>
#include "util.h"
int main(int argc, char* argv[])
{
int i;
char *s;
char emul[PATH_MAX];
for(i = 1; i < argc; i++) {
if(strncmp(argv[i], "/tmp/i", 6) == 0) {
strlcpy(emul, EMULDIR, sizeof(emul));
strlcpy(emul + EMULDIR_LEN, argv[i], sizeof(emul) - EMULDIR_LEN);
move_tmpicc(emul);
}
}
if((s = getenv("ICC11_REALAS")) == NULL)
s = "as";
argv[0] = s;
execvp(s, argv);
s = strerror(errno);
write(STDERR_FILENO, argv[0], strlen(argv[0]));
write(STDERR_FILENO, ": ", 3);
write(STDERR_FILENO, s, strlen(s));
write(STDERR_FILENO, "\n", 1);
return EXIT_FAILURE;
}

View file

@ -1,52 +0,0 @@
#!/bin/sh
LANG=C
LC_MESSAGES=C
export LANG LC_MESSAGES
ICC11_REALAS="@BINUTILS_PREFIX@/bin/as"
icc_arch=@ICC_ARCH@
for opt in "$@"
do
case "${opt}"
in
-m32) icc_arch=ia32 ;;
-m64) icc_arch=intel64 ;;
-dryrun) dryrun=1 ;;
-Qlocation,as,*)
ICC11_REALAS="${opt#-Qlocation,as,}/as"
;;
-Qlocation,ld,*)
ICC11_REALLD="${opt#-Qlocation,ld,}/ld"
export ICC11_REALLD
;;
-shared-intel|-openmp|-mkl=*|-opt-malloc-options=[1-9])
echo "${opt} is not supported on $(uname)." 1>&2
exit 1
;;
esac
done
export ICC11_REALAS
INTEL_LICENSE_FILE="${INTEL_LICENSE_FILE:+${INTEL_LICENSE_FILE}:}@ICC_PREFIX@/licenses:/opt/intel/licenses:${HOME}/intel/licenses"
export INTEL_LICENSE_FILE
PATH="@ICC_PREFIX@/bin/${icc_arch}:@GCC_PREFIX@/bin:${PATH:-/bin:/usr/bin}"
export PATH
if [ -z "${dryrun}" ]
then
exec ${0##*/} -Ulinux -U__linux__ -U__linux -U__gnu_linux__ -D__NetBSD__ "$@" \
"-Qlocation,as,@ICC_PREFIX@/libexec" \
"-Qlocation,ld,@ICC_PREFIX@/libexec"
else
${0##*/} -Ulinux -U__linux__ -U__linux -U__gnu_linux__ -D__NetBSD__ "$@" \
"-Qlocation,as,@ICC_PREFIX@/libexec" \
"-Qlocation,ld,@ICC_PREFIX@/libexec" 3>&1 1>&2 2>&3 3>&- | \
sed -e 's|^\( *\)/lib[64]*/ld-linux[x864-]*\.so\.2\([ \]*\)$|\1/usr/libexec/ld.elf_so\2|' \
-e 's|^\( *\)/usr/lib[64]*/crt1.o\([ \]*\)$|\1/usr/lib/crt0.o\2|' \
-e 's|^\( *\)-ldl\([ \]*\)$|\1-licc11bsd\2|' 3>&1 1>&2 2>&3 3>&-
fi

View file

@ -1,22 +0,0 @@
#include <assert.h>
#include <elf.h>
#include <stddef.h>
#include <stdio.h>
FILE* my_stderr = stderr;
struct dl_phdr_info {
Elf32_Addr dlpi_addr;
const char *dlpi_name;
const Elf32_Phdr *dlpi_phdr;
Elf32_Half dlpi_phnum;
};
int dl_iterate_phdr(
int (*callback)(struct dl_phdr_info *info, size_t size, void *data),
void *data)
{
assert(0 && "dl_iterate_phdr is not implemented");
return 1;
}

View file

@ -1,45 +0,0 @@
#include <errno.h>
#include <stdlib.h>
#include <string.h>
#include <sys/syslimits.h>
#include <unistd.h>
#include "util.h"
int main(int argc, char* argv[])
{
int i;
char *s;
char emul[PATH_MAX];
for(i = 1; i < argc; i++) {
if(strcmp(argv[i], "-ldl") == 0)
argv[i] = "-licc11bsd";
else if(strcmp(argv[i], "/usr/lib/crt1.o") == 0)
argv[i] = "/usr/lib/crt0.o";
else if(strcmp(argv[i], "/usr/lib64/crt1.o") == 0)
argv[i] = "/usr/lib/crt0.o";
else if(strcmp(argv[i], "/lib/ld-linux.so.2") == 0)
argv[i] = "/usr/libexec/ld.elf_so";
else if(strcmp(argv[i], "/lib64/ld-linux-x86-64.so.2") == 0)
argv[i] = "/usr/libexec/ld.elf_so";
else if(strncmp(argv[i], "/tmp/i", 6) == 0) {
strlcpy(emul, EMULDIR, sizeof(emul));
strlcpy(emul + EMULDIR_LEN, argv[i], sizeof(emul) - EMULDIR_LEN);
move_tmpicc(emul);
}
}
if((s = getenv("ICC11_REALLD")) == NULL)
s = "ld";
argv[0] = s;
execvp(s, argv);
s = strerror(errno);
write(STDERR_FILENO, argv[0], strlen(argv[0]));
write(STDERR_FILENO, ": ", 3);
write(STDERR_FILENO, s, strlen(s));
write(STDERR_FILENO, "\n", 1);
return EXIT_FAILURE;
}

View file

@ -1,24 +0,0 @@
#!/bin/sh
LANG=C
LC_MESSAGES=C
export LANG LC_MESSAGES
icc_arch=@ICC_ARCH@
for opt in "$@"
do
case "${opt}"
in
-m32) icc_arch=ia32 ;;
-m64) icc_arch=intel64 ;;
esac
done
INTEL_LICENSE_FILE="${INTEL_LICENSE_FILE:+${INTEL_LICENSE_FILE}:}@ICC_PREFIX@/licenses:/opt/intel/licenses:${HOME}/intel/licenses"
export INTEL_LICENSE_FILE
PATH="@ICC_PREFIX@/bin/${icc_arch}:@GCC_PREFIX@/bin:${PATH:-/bin:/usr/bin}"
export PATH
exec ${0##*/} "-Qlocation,as,@BINUTILS_PREFIX@/bin" "$@"

View file

@ -1,43 +0,0 @@
#include <fcntl.h>
#include <stdlib.h>
#include <sys/stat.h>
#include <unistd.h>
#include "util.h"
// Relaxed error checking/reporting is fine because exec'd
// program will report a missing file if the function fails.
void move_tmpicc(const char* emul)
{
char buf[1024];
struct stat st;
int bytes, src, dst;
const char* real = emul + EMULDIR_LEN;
const char* tail = real + (sizeof("/tmp/i") - 1);
if(strncmp(tail, "cc", 2) != 0 && strncmp(tail, "po_icc", 6) != 0)
return;
if(stat(real, &st) == 0)
return;
if(stat(emul, &st) < 0 || !(st.st_mode & S_IFREG))
return;
src = open(emul, O_RDONLY, 0644);
dst = open(real, O_WRONLY|O_CREAT|O_EXCL, st.st_mode);
while((bytes = read(src, buf, sizeof(buf))) > 0) {
if(write(dst, buf, bytes) != bytes) {
bytes = -1;
break;
}
}
if(src >= 0)
close(src);
if(dst >= 0 && close(dst) < 0)
bytes = -1;
if(bytes < 0 || unlink(emul) < 0)
unlink(real);
}

View file

@ -1,3 +0,0 @@
#define EMULDIR "@OPSYS_EMULDIR@"
#define EMULDIR_LEN (sizeof(EMULDIR) - 1)
void move_tmpicc(const char* emul);

View file

@ -1,13 +0,0 @@
#!/bin/sh
LANG=C
LC_MESSAGES=C
export LANG LC_MESSAGES
INTEL_LICENSE_FILE="${INTEL_LICENSE_FILE:+${INTEL_LICENSE_FILE}:}@ICC_PREFIX@/licenses:/opt/intel/licenses:${HOME}/intel/licenses"
export INTEL_LICENSE_FILE
PATH="@ICC_PREFIX@/bin/@ICC_ARCH@:@GCC_PREFIX@/bin:${PATH:-/bin:/usr/bin}"
export PATH
exec ${0##*/} "$@"

View file

@ -1,24 +0,0 @@
$NetBSD: patch-aa,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/complex.h.orig 2009-10-03 22:44:32.000000000 +0100
+++ icc11/include/complex.h
@@ -54,7 +54,7 @@ extern "C" {
#endif
/* for Microsoft compatibility */
-#if !defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__) && !defined(__INTEL_COMPILER)
+#if !defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__) && !defined(__INTEL_COMPILER)
#define _LIBIMF_LONGLONG __int64
#else
#define _LIBIMF_LONGLONG long long int
@@ -75,7 +75,7 @@ extern "C" {
#if !defined(__cplusplus) /* No _Complex or GNU __complex__ types available for C++ */
-#if (!defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
+#if (!defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
# define complex _Complex
# define _Complex_I (1.0iF)
# undef I

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/fenv.h.orig 2009-10-03 22:44:32.000000000 +0100
+++ icc11/include/fenv.h
@@ -28,7 +28,7 @@ extern "C" {
#if defined(_DLL) && (defined(_WIN32) || defined(_WIN64)) /* Windows DLL */
# define _FENV_PUBAPI __declspec(dllimport) __cdecl
-#elif defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__) /* Linux, MacOS, FreeBSD or QNX */
+#elif defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__) /* Linux, MacOS, FreeBSD, NetBSD or QNX */
# define _FENV_PUBAPI /* do not change this line! */
#else /* Windows static */
# define _FENV_PUBAPI __cdecl

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ac,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/ia32/xmmintrin.h.orig 2009-10-03 22:44:35.000000000 +0100
+++ icc11/include/ia32/xmmintrin.h
@@ -455,7 +455,7 @@ extern __m128 __cdecl _mm_cvtsi64_ss(__
/*
* Include the SSE2 definitions for compatibility with gcc.
*/
-#if defined (__linux__) || defined (__QNX__) || defined(__APPLE__) || defined(__FreeBSD__)
+#if defined (__linux__) || defined (__QNX__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__)
#include <emmintrin.h>
#endif

View file

@ -1,113 +0,0 @@
$NetBSD: patch-ad,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__) and definitions of FP_* constants on NetBSD.
--- icc11/include/math.h.orig 2009-11-01 14:41:27.000000000 +0000
+++ icc11/include/math.h
@@ -27,7 +27,7 @@
# error "This Intel <math.h> is for use with only the Intel compilers!"
#endif
-#if defined(__linux__) || defined (__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)
+#if defined(__linux__) || defined (__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)
# if defined(fpclassify)
# undef fpclassify
# endif
@@ -51,7 +51,7 @@
# endif
#endif /* __linux__ */
-#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)
+#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)
# if defined(isgreater)
# undef isgreater
# endif
@@ -70,9 +70,9 @@
# if defined(isunordered)
# undef isunordered
# endif
-#endif /* __linux__ || __APPLE__ || __FreeBSD__ || __QNX__ */
+#endif /* __linux__ || __APPLE__ || __FreeBSD__ || __NetBSD__ || __QNX__ */
-#if (!defined (__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__)) || defined (__PURE_INTEL_C99_HEADERS__)
+#if (!defined (__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)) || defined (__PURE_INTEL_C99_HEADERS__)
#if !(defined (DECIMAL_DIG))
#define DECIMAL_DIG 21
#endif
@@ -95,20 +95,20 @@ typedef double double_t;
typedef float float_t;
typedef double double_t;
#endif /* FLT_EVAL_METHOD */
-#endif /* (!__linux__ && !__APPLE__ && !__FreeBSD__ && !__QNX__) || __PURE_INTEL_C99_HEADERS__ */
+#endif /* (!__linux__ && !__APPLE__ && !__FreeBSD__ && !__NetBSD__ && !__QNX__) || __PURE_INTEL_C99_HEADERS__ */
#if defined(__APPLE__)
#undef NAN
#endif
-#if (!defined(__linux__) && !defined(__FreeBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
+#if (!defined(__linux__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
static unsigned int __qnan[] = {0x7fc00001};
#define NAN (*((float *)__qnan))
#endif
-#if defined(__PURE_INTEL_C99_HEADERS__) || !(defined(__linux__) || defined(__unix__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)) /* We need to define FP_ILOGB0, FP_ILOGBNAN */
-#if (defined(__linux__) || defined(__unix__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)) && !(defined(__ECL) || defined(__ECC)) /* Linux/unix or MacOS */
+#if defined(__PURE_INTEL_C99_HEADERS__) || !(defined(__linux__) || defined(__unix__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)) /* We need to define FP_ILOGB0, FP_ILOGBNAN */
+#if (defined(__linux__) || defined(__unix__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)) && !(defined(__ECL) || defined(__ECC)) /* Linux/unix or MacOS */
#define FP_ILOGB0 (-2147483647 - 1)
#define FP_ILOGBNAN (-2147483647 - 1)
#else /* Windows and Intel(R) Itanium(R) architecture */
@@ -117,7 +117,7 @@ static unsigned int __qnan[] = {0x7fc000
#endif
#endif
-#if (!defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
+#if (!defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)) || defined(__PURE_INTEL_C99_HEADERS__)
static unsigned int __huge_valf[] = {0x7f800000};
#define HUGE_VALF (*((double *)__huge_valf))
static unsigned int __huge_vall[] = {0, 0, 0x00007f80, 0};
@@ -153,7 +153,7 @@ extern "C" {
#endif
/* for Microsoft compatibility */
-#if !defined (__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__) && !defined(__INTEL_COMPILER)
+#if !defined (__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__) && !defined(__INTEL_COMPILER)
#define _LIBIMF_LONGLONG __int64
#else
#define _LIBIMF_LONGLONG long long int
@@ -182,6 +182,15 @@ extern "C" {
# define FP_ZERO (16)
# define FP_SUBNORMAL (8)
# define FP_NORMAL (4)
+#elif defined (__NetBSD__)
+#define FP_INFINITE 0x00
+#define FP_NAN 0x01
+#define FP_NORMAL 0x02
+#define FP_SUBNORMAL 0x03
+#define FP_ZERO 0x04
+/* NetBSD extensions */
+#define _FP_LOMD 0x80 /* range for machine-specific classes */
+#define _FP_HIMD 0xff
#else
# define FP_NAN (0)
# define FP_INFINITE (1)
@@ -300,7 +309,7 @@ _LIBIMF_EXT _LIBIMF_INT __signbitl (
)
-#if defined (__FreeBSD__)
+#if defined (__FreeBSD__) || defined (__NetBSD__)
#define fpclassify( __x__ ) __IMFC99MACRO1ARG_ALL( __x__, fpclassify, __, f, __, d, __, l)
#define isinf( __x__ ) __IMFC99MACRO1ARG_ALL( __x__, isinf, __, f, , , __, l)
@@ -1142,7 +1151,7 @@ _LIBIMF_EXT ___pmatherrl _LIBIMF_PUBAPI
/* Standard conformance support */
-#if (!defined(__linux__) || !defined(__USE_MISC)) || defined (__PURE_INTEL_C99_HEADERS__)
+#if ((!defined(__linux__) || !defined(__USE_MISC)) && !defined(_NETBSD_SOURCE)) || defined (__PURE_INTEL_C99_HEADERS__)
typedef enum ___LIB_VERSIONIMF_TYPE {
_IEEE_ = -1 /* IEEE-like behavior */
,_SVID_ /* SysV, Rel. 4 behavior */

View file

@ -1,67 +0,0 @@
$NetBSD: patch-ae,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__) and definitions of FP_* constants on NetBSD.
--- icc11/include/mathimf.h.orig 2009-10-03 22:44:32.000000000 +0100
+++ icc11/include/mathimf.h
@@ -53,7 +53,7 @@
# define __IMFCOMPLEXON
#endif
-#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)
+#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)
# if defined(fpclassify)
# undef fpclassify
# endif
@@ -77,7 +77,7 @@
# endif
#endif /* __linux__ */
-#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__QNX__)
+#if defined(__linux__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__QNX__)
# if defined(isgreater)
# undef isgreater
# endif
@@ -99,7 +99,7 @@
#endif /* __linux__ || __APPLE__ */
#if !(defined(__unix__) || defined(__APPLE__) || defined(__QNX__)) /* We need to define FP_ILOGB0, FP_ILOGBNAN */
-#if (defined(__FreeBSD__)) && !(defined(__ECL) || defined(__ECC)) /* FreeBSD - for other unix macro are defined in included math.h*/
+#if (defined(__FreeBSD__) || defined(__NetBSD__)) && !(defined(__ECL) || defined(__ECC)) /* FreeBSD & NetBSD - for other unix macro are defined in included math.h*/
#define FP_ILOGB0 (-2147483647 - 1)
#define FP_ILOGBNAN (-2147483647 - 1)
#else /* Windows */
@@ -108,7 +108,7 @@
#endif
#endif
-#if !defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__)
+#if !defined(__linux__) && !defined(__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)
static unsigned int __huge_valf[] = {0x7f800000};
#define HUGE_VALF (*(double *) __huge_valf)
static unsigned int __huge_vall[] = {0, 0, 0x00007f80, 0};
@@ -172,6 +172,15 @@ extern "C" {
# define FP_ZERO (16)
# define FP_SUBNORMAL (8)
# define FP_NORMAL (4)
+#elif defined(__NetBSD__)
+#define FP_INFINITE 0x00
+#define FP_NAN 0x01
+#define FP_NORMAL 0x02
+#define FP_SUBNORMAL 0x03
+#define FP_ZERO 0x04
+/* NetBSD extensions */
+#define _FP_LOMD 0x80 /* range for machine-specific classes */
+#define _FP_HIMD 0xff
#else
# define FP_NAN (0)
# define FP_INFINITE (1)
@@ -286,7 +295,7 @@ _LIBIMF_EXT _LIBIMF_INT __signbitl (
)
-#if defined (__FreeBSD__)
+#if defined (__FreeBSD__) || defined(__NetBSD__)
#define fpclassify( __x__ ) __IMFC99MACRO1ARG_ALL( __x__, fpclassify, __, f, __, d, __, l)
#define isinf( __x__ ) __IMFC99MACRO1ARG_ALL( __x__, isinf, __, f, , , __, l)

View file

@ -1,15 +0,0 @@
$NetBSD: patch-af,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/stddef.h.orig 2009-10-03 22:44:32.000000000 +0100
+++ icc11/include/stddef.h
@@ -19,7 +19,7 @@
#define _STDDEF
*/
-#if defined(__QNX__) || defined(__FreeBSD__)
+#if defined(__QNX__) || defined(__FreeBSD__) || defined(__NetBSD__)
#include_next <stddef.h>
#undef offsetof

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ag,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/tgmath.h.orig 2009-10-03 22:44:32.000000000 +0100
+++ icc11/include/tgmath.h
@@ -19,7 +19,7 @@
#else
#if !defined(__PURE_INTEL_C99_HEADERS__) && !(defined(_WIN32) || defined(_WIN64))
-#if !defined (__APPLE__) && !defined(__FreeBSD__) && !defined(__QNX__)
+#if !defined (__APPLE__) && !defined(__FreeBSD__) && !defined(__NetBSD__) && !defined(__QNX__)
# include_next <tgmath.h> /* utilize and expand sys header */
#endif

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ah,v 1.1 2011/07/20 10:35:19 alnsn Exp $
Add ifdef(__NetBSD__).
--- icc11/include/intel64/xmmintrin.h.orig 2009-10-12 22:33:06.000000000 +0100
+++ icc11/include/intel64/xmmintrin.h
@@ -455,7 +455,7 @@ extern __m128 __cdecl _mm_cvtsi64_ss(__
/*
* Include the SSE2 definitions for compatibility with gcc.
*/
-#if defined (__linux__) || defined (__QNX__) || defined(__APPLE__) || defined(__FreeBSD__)
+#if defined (__linux__) || defined (__QNX__) || defined(__APPLE__) || defined(__FreeBSD__) || defined(__NetBSD__)
#include <emmintrin.h>
#endif