evolution-data-server: build with libical-3

This commit is contained in:
markd 2018-04-25 05:57:58 +00:00
parent 75e571256d
commit 5daf38b24a
7 changed files with 139 additions and 5 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.170 2018/04/16 14:34:50 wiz Exp $
# $NetBSD: Makefile,v 1.171 2018/04/25 05:57:58 markd Exp $
DISTNAME= evolution-data-server-2.32.3
PKGREVISION= 51
PKGREVISION= 52
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/evolution-data-server/2.32/}
EXTRACT_SUFX= .tar.bz2

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.87 2018/01/29 12:47:08 jperkin Exp $
$NetBSD: distinfo,v 1.88 2018/04/25 05:57:58 markd Exp $
SHA1 (evolution-data-server-2.32.3.tar.bz2) = cbf32c3438c4f1650b35b87007a337ebc1c56cec
RMD160 (evolution-data-server-2.32.3.tar.bz2) = adc8b07aef41a89d16fc426541c12190a3688b8f
@ -10,7 +10,11 @@ SHA1 (patch-addressbook_libebook_e-book.c) = ac32dc97eb0a66bf0c912d384655fdde47d
SHA1 (patch-bd) = 8df85b9ab7ae71558fb939565e944b614de628bb
SHA1 (patch-ca) = e879d29105997045e1293fe627ec55a05e5ba88d
SHA1 (patch-calendar_backends_caldav_e-cal-backend-caldav.c) = 756ce60a8b684369bf7b0c14f2f52e735253c381
SHA1 (patch-calendar_libecal_e-cal.c) = 0478b795b298bbab23db39f7a63bd3529691dd95
SHA1 (patch-calendar_backends_contacts_e-cal-backend-contacts.c) = d44e6d0e56b9840e01cebdb39442669ec86247bd
SHA1 (patch-calendar_libecal_e-cal-component.c) = f0a896d159d4daa8c6bed4143d3888156d9bb7e5
SHA1 (patch-calendar_libecal_e-cal-recur.c) = fb5256d428f1b7e3a6eb3a89f058059f3ae67b8f
SHA1 (patch-calendar_libecal_e-cal-time-util.c) = 4b7c1cd7f40509a9cafc9fc481a49573cc4b869b
SHA1 (patch-calendar_libecal_e-cal.c) = 2b489dfedec0d22d1c64b9fb99526c92a8493253
SHA1 (patch-calendar_libedata-cal_e-cal-backend-intervaltree.c) = af78b5854666325a9dd1229702968c093805ec03
SHA1 (patch-calendar_libegdbus_Makefile.in) = ac5aabae5160967c498f12c0f29be3e206e03622
SHA1 (patch-camel_providers_imapx_camel-imapx-tokens.txt) = 8a62d2064d9bda5f9f79eb9473e71734560c3983

View file

@ -0,0 +1,14 @@
$NetBSD: patch-calendar_backends_contacts_e-cal-backend-contacts.c,v 1.1 2018/04/25 05:57:58 markd Exp $
work with libical-3
--- calendar/backends/contacts/e-cal-backend-contacts.c.orig 2011-04-21 19:35:36.000000000 +0000
+++ calendar/backends/contacts/e-cal-backend-contacts.c
@@ -501,7 +501,6 @@ cdate_to_icaltime (EContactDate *cdate)
ret.month = cdate->month;
ret.day = cdate->day;
ret.is_date = TRUE;
- ret.is_utc = FALSE;
ret.zone = NULL;
ret.is_daylight = FALSE;

View file

@ -0,0 +1,73 @@
$NetBSD: patch-calendar_libecal_e-cal-component.c,v 1.1 2018/04/25 05:57:58 markd Exp $
Work with libical-3
--- calendar/libecal/e-cal-component.c.orig 2011-04-21 19:35:36.000000000 +0000
+++ calendar/libecal/e-cal-component.c
@@ -2414,7 +2414,7 @@ get_datetime (struct datetime *datetime,
This makes the timezone code simpler. */
if (datetime->tzid_param)
dt->tzid = g_strdup (icalparameter_get_tzid (datetime->tzid_param));
- else if (dt->value && dt->value->is_utc)
+ else if (dt->value && icaltime_is_utc (*dt->value))
dt->tzid = g_strdup ("UTC");
else
dt->tzid = NULL;
@@ -2449,9 +2449,9 @@ set_datetime (ECalComponent *comp, struc
/* If the TZID is set to "UTC", we set the is_utc flag. */
if (dt->tzid && !strcmp (dt->tzid, "UTC"))
- dt->value->is_utc = 1;
- else
- dt->value->is_utc = 0;
+ dt->value->zone = icaltimezone_get_utc_timezone ();
+ else if (dt->value->zone == icaltimezone_get_utc_timezone ())
+ dt->value->zone = NULL;
if (datetime->prop) {
(* prop_set_func) (datetime->prop, *dt->value);
@@ -2471,7 +2471,7 @@ set_datetime (ECalComponent *comp, struc
icalproperty_add_parameter (datetime->prop, datetime->tzid_param);
}
} else if (datetime->tzid_param) {
- icalproperty_remove_parameter (datetime->prop, ICAL_TZID_PARAMETER);
+ icalproperty_remove_parameter_by_kind (datetime->prop, ICAL_TZID_PARAMETER);
datetime->tzid_param = NULL;
}
}
@@ -3407,7 +3407,7 @@ e_cal_component_set_organizer (ECalCompo
priv->organizer.sentby_param);
}
} else if (priv->organizer.sentby_param) {
- icalproperty_remove_parameter (priv->organizer.prop, ICAL_SENTBY_PARAMETER);
+ icalproperty_remove_parameter_by_kind (priv->organizer.prop, ICAL_SENTBY_PARAMETER);
priv->organizer.sentby_param = NULL;
}
@@ -3424,7 +3424,7 @@ e_cal_component_set_organizer (ECalCompo
priv->organizer.cn_param);
}
} else if (priv->organizer.cn_param) {
- icalproperty_remove_parameter (priv->organizer.prop, ICAL_CN_PARAMETER);
+ icalproperty_remove_parameter_by_kind (priv->organizer.prop, ICAL_CN_PARAMETER);
priv->organizer.cn_param = NULL;
}
@@ -3441,7 +3441,7 @@ e_cal_component_set_organizer (ECalCompo
priv->organizer.language_param);
}
} else if (priv->organizer.language_param) {
- icalproperty_remove_parameter (priv->organizer.prop, ICAL_LANGUAGE_PARAMETER);
+ icalproperty_remove_parameter_by_kind (priv->organizer.prop, ICAL_LANGUAGE_PARAMETER);
priv->organizer.language_param = NULL;
}
@@ -4386,7 +4386,7 @@ e_cal_component_set_summary (ECalCompone
priv->summary.altrep_param);
}
} else if (priv->summary.altrep_param) {
- icalproperty_remove_parameter (priv->summary.prop, ICAL_ALTREP_PARAMETER);
+ icalproperty_remove_parameter_by_kind (priv->summary.prop, ICAL_ALTREP_PARAMETER);
priv->summary.altrep_param = NULL;
}

View file

@ -0,0 +1,18 @@
$NetBSD: patch-calendar_libecal_e-cal-recur.c,v 1.1 2018/04/25 05:57:58 markd Exp $
work with libical-3
--- calendar/libecal/e-cal-recur.c.orig 2011-04-21 19:35:36.000000000 +0000
+++ calendar/libecal/e-cal-recur.c
@@ -3738,10 +3738,7 @@ cal_object_time_from_time (CalObjTime *c
{
struct icaltimetype tt;
- if (zone)
- tt = icaltime_from_timet_with_zone (t, FALSE, zone);
- else
- tt = icaltime_from_timet (t, FALSE);
+ tt = icaltime_from_timet_with_zone (t, FALSE, zone);
cotime->year = tt.year;
cotime->month = tt.month - 1;

View file

@ -0,0 +1,14 @@
$NetBSD: patch-calendar_libecal_e-cal-time-util.c,v 1.1 2018/04/25 05:57:58 markd Exp $
work with libical-3
--- calendar/libecal/e-cal-time-util.c.orig 2011-04-21 19:35:36.000000000 +0000
+++ calendar/libecal/e-cal-time-util.c
@@ -724,7 +724,6 @@ tm_to_icaltimetype (struct tm *tm, gbool
itt.month = tm->tm_mon + 1;
itt.year = tm->tm_year+ 1900;
- itt.is_utc = 0;
itt.is_date = is_date;
return itt;

View file

@ -1,4 +1,4 @@
$NetBSD: patch-calendar_libecal_e-cal.c,v 1.1 2016/01/31 07:01:55 richard Exp $
$NetBSD: patch-calendar_libecal_e-cal.c,v 1.2 2018/04/25 05:57:58 markd Exp $
The e-calendar-factory process did not terminate automatically
when the user logged out of the graphical desktop environment, and
@ -6,6 +6,8 @@ e-calendar-factory thus redundantly consumed system resources.
(https://bugzilla.redhat.com/show_bug.cgi?id=1141760 and upstream
https://bugzilla.gnome.org/show_bug.cgi?id=646117)
work with libical-3
--- calendar/libecal/e-cal.c.orig 2011-04-21 19:36:35.000000000 +0000
+++ calendar/libecal/e-cal.c
@@ -709,7 +709,6 @@ e_cal_activate (GError **error)
@ -16,3 +18,12 @@ e-calendar-factory thus redundantly consumed system resources.
cal_connection_closed_id = g_dbus_connection_signal_subscribe (connection,
NULL, /* sender */
"org.freedesktop.DBus", /* interface */
@@ -2725,7 +2724,7 @@ add_instance (ECalComponent *comp, time_
if (instances_hold->start_zone)
itt = icaltime_from_timet_with_zone (start, datetime.value->is_date, instances_hold->start_zone);
else {
- itt = icaltime_from_timet (start, datetime.value->is_date);
+ itt = icaltime_from_timet_with_zone (start, datetime.value->is_date, NULL);
if (datetime.tzid) {
g_free ((gchar *) datetime.tzid);