It may hide build failure on NetBSD, but not resolve real issues,
furthermore, it may introduce build failure for other platforms.
This commit is contained in:
obache 2014-04-03 13:02:59 +00:00
parent a90da7ff57
commit 5def0460c0
2 changed files with 1 additions and 16 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.27 2014/03/25 07:53:35 obache Exp $
$NetBSD: distinfo,v 1.28 2014/04/03 13:02:59 obache Exp $
SHA1 (coreutils-8.22.tar.xz) = cc7fe47b21eb49dd2ee4cdb707570f42fb2c8cc6
RMD160 (coreutils-8.22.tar.xz) = c3da7ade1d3ac82e97ac4a24c70376af8b9b503b
@ -6,4 +6,3 @@ Size (coreutils-8.22.tar.xz) = 5335124 bytes
SHA1 (patch-Makefile.in) = fce694c56777081a6a54d157dd0573945250f381
SHA1 (patch-lib-fflush.c) = 106e9c7d05fff290f24cb69e1b2c80d0077c62bd
SHA1 (patch-lib-fseeko.c) = 9f4b0294698648011c64869fc0e642f910e9d47f
SHA1 (patch-lib_strncat.c) = 415f45d29a6d073d4e90eaadf45b7fdc6107b05c

View file

@ -1,14 +0,0 @@
$NetBSD: patch-lib_strncat.c,v 1.1 2014/03/25 07:53:35 obache Exp $
* strncat is defined as a macro in NetBSD-6
--- lib/strncat.c.orig 2013-12-04 15:02:02.000000000 +0000
+++ lib/strncat.c
@@ -19,6 +19,7 @@
/* Specification. */
#include <string.h>
+#undef strncat
char *
strncat (char *dest, const char *src, size_t n)