net/powerdns-recursor: Support DragonFly

Fix endian setting on DragonFly (Same as FreeBSD) to fix build.
This commit is contained in:
marino 2012-08-07 23:31:03 +00:00
parent 7a93b9172c
commit 5e0fa5453f
3 changed files with 27 additions and 5 deletions

View file

@ -1,10 +1,11 @@
$NetBSD: distinfo,v 1.6 2012/02/28 10:49:27 roy Exp $
$NetBSD: distinfo,v 1.7 2012/08/07 23:31:03 marino Exp $
SHA1 (pdns-recursor-3.3.tar.bz2) = 2f42955b8b8de355709e9072da2d5dbfadd7ffac
RMD160 (pdns-recursor-3.3.tar.bz2) = 17bd7ac68892c3fca218c3dc3e70074dd9e748d6
Size (pdns-recursor-3.3.tar.bz2) = 145785 bytes
SHA1 (patch-Makefile) = 840d0be6dd7decf4b037efc4f9da05a97815ce8e
SHA1 (patch-dns.hh) = 1ed10a5ffa59f84fa17c8dfd5e2c57476f7eb75c
SHA1 (patch-brg_endian.h) = 2fb9d3231e969b2be57d160b0952e11091ae6e26
SHA1 (patch-dns.hh) = 4d24a3c2bad973e05ed4b1c20bacce3b70992e5a
SHA1 (patch-kqueuemplexer.cc) = e67ca0cc9703e5ba5f89f85eefd457c72495ca52
SHA1 (patch-pdns__recursor.1) = 33170dd8ec13b0607ebf2ef8366656c565ca4664
SHA1 (patch-pdns__recursor.cc) = 2f66151305a34229f5789b765434995e2918c4ff

View file

@ -0,0 +1,14 @@
$NetBSD: patch-brg_endian.h,v 1.1 2012/08/07 23:31:03 marino Exp $
--- brg_endian.h.orig 2010-09-21 16:22:09.000000000 +0000
+++ brg_endian.h
@@ -34,7 +34,8 @@
/* Include files where endian defines and byteswap functions may reside */
#if defined( __sun )
# include <sys/isa_defs.h>
-#elif defined( __FreeBSD__ ) || defined( __OpenBSD__ ) || defined( __NetBSD__ )
+#elif defined( __FreeBSD__ ) || defined( __OpenBSD__ ) || defined( __NetBSD__ ) || \
+ defined( __DragonFly__ )
# include <sys/endian.h>
#elif defined( BSD ) && ( BSD >= 199103 ) || defined( __APPLE__ ) || \
defined( __CYGWIN32__ ) || defined( __DJGPP__ ) || defined( __osf__ )

View file

@ -1,10 +1,17 @@
$NetBSD: patch-dns.hh,v 1.1 2012/02/28 10:49:28 roy Exp $
$NetBSD: patch-dns.hh,v 1.2 2012/08/07 23:31:03 marino Exp $
Only attempt to define byte order if unset.
Add DragonFly support
--- dns.hh.orig 2010-09-21 16:22:09.000000000 +0000
--- dns.hh.orig 2012-08-07 23:18:28.526524000 +0000
+++ dns.hh
@@ -181,7 +181,7 @@ enum {
@@ -176,12 +176,12 @@ enum {
#ifdef WIN32
#define BYTE_ORDER 1
#define LITTLE_ENDIAN 1
-#elif __FreeBSD__ || __APPLE__
+#elif defined(__FreeBSD__) || defined(__APPLE__) || defined(__DragonFly__)
#include <machine/endian.h>
#elif __linux__
# include <endian.h>