Fix xpkgwedge problems noted by John Darrow <John.P.Darrow@wheaton.edu> in

pkg/13191.  The changes suggested in the PR were applied, and one more
change to look for the appdefaults file under ${PREFIX} instead of under
${X11BASE}.
This commit is contained in:
jlam 2001-09-14 03:19:22 +00:00
parent 2168996ed4
commit 5e267bc07d
5 changed files with 32 additions and 36 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.9 2001/02/25 04:18:28 hubertf Exp $
# $NetBSD: Makefile,v 1.10 2001/09/14 03:19:22 jlam Exp $
DISTNAME= XBanner1.31
PKGNAME= xbanner-1.31
@ -10,19 +10,23 @@ HOMEPAGE= http://chaos.fullerton.edu/XBanner/
COMMENT= Make XDM login screen look pretty
USE_IMAKE= YES
USE_XPM= YES
NO_INSTALL_MANPAGES= YES
DOCDIR= ${PREFIX}/share/doc/xbanner
post-install:
@${INSTALL_DATA_DIR} ${X11PREFIX}/share/doc/xbanner
do-install:
for f in freetemp random_effect xb_check xbanner; do \
${INSTALL_PROGRAM} ${WRKSRC}/$$f ${PREFIX}/bin; \
done
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xbanner
for f in Changes.txt Credits.txt Resource_Reference.html \
XBanner_Users_Manual.html email.gif fonttips.html \
index.html red_line.gif rnd_doc.html stars.gif \
xb_check.html; do \
${INSTALL_DATA} ${WRKSRC}/docs/$$f ${X11PREFIX}/share/doc/xbanner; \
${INSTALL_DATA} ${WRKSRC}/docs/$$f ${DOCDIR}; \
done
${INSTALL_DATA} ${WRKSRC}/samples/XBanner.ad \
${X11PREFIX}/lib/X11/app-defaults/XBanner
${INSTALL_DATA_DIR} ${PREFIX}/lib/X11/app-defaults
${INSTALL_DATA} ${WRKSRC}/samples/XBanner.ad \
${PREFIX}/lib/X11/app-defaults/XBanner
.include "../../graphics/xpm/buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.2 2001/04/19 11:07:49 skrll Exp $
$NetBSD: distinfo,v 1.3 2001/09/14 03:19:22 jlam Exp $
SHA1 (XBanner1.31.tar.gz) = 90bd958c81f30d8a92db7b89b340fd1803ca8e58
Size (XBanner1.31.tar.gz) = 289732 bytes
SHA1 (patch-aa) = 0929c4a8e598c7a88ff0a49f803ccebb8e04ebd8
SHA1 (patch-aa) = c1598a751c6897f94ecb181e292dfd06b5ac059a
SHA1 (patch-ab) = ccd98d3fefd4e3359cc618d6f4d614d01c4ff2c3
SHA1 (patch-ac) = aad66c6fd4cebeea211f50f88250fb95a4acd266
SHA1 (patch-ac) = f686a47858b30950de7fbf7140f39cacac896287

View file

@ -1,4 +1,4 @@
$NetBSD: patch-aa,v 1.3 1998/11/12 15:01:17 agc Exp $
$NetBSD: patch-aa,v 1.4 2001/09/14 03:19:23 jlam Exp $
--- Imakefile.orig Thu May 15 22:38:25 1997
+++ Imakefile Wed Aug 19 00:21:21 1998
@ -17,17 +17,7 @@ $NetBSD: patch-aa,v 1.3 1998/11/12 15:01:17 agc Exp $
XCOMM *** Remove following line if you don't have XPM!
-DEFINES=-DHAS_XPM
+DEFINES=-DHAS_XPM -DX11BASE=\"${X11BASE}\"
+DEFINES=-DHAS_XPM -DPREFIX=\"${PREFIX}\"
AllTarget($(PROGRAMS))
SingleProgramTarget(xbanner, backg.o colors.o effect.o linger.o pix.o plasma.o ripples.o util.o xbanner.o xres.o , /**/ , -lXpm -lX11 -lm )
@@ -23,6 +23,6 @@
SingleProgramTarget(random_effect, random_effect.o , /**/ , /**/ )
XCOMM Install directives
-InstallTarget(install,xbanner, --strip --mode "0755" --owner root --group bin , $(LOCALBINDIR))
-InstallTarget(install,freetemp, --strip --mode "0755" --owner root --group bin , $(LOCALBINDIR))
-InstallTarget(install,xb_check, --strip --mode "0755" --owner root --group bin , $(LOCALBINDIR))
+InstallTarget(install,xbanner, -s -m 0755 -o root -g bin , $(LOCALBINDIR))
+InstallTarget(install,freetemp, -s -m 0755 -o root -g bin , $(LOCALBINDIR))
+InstallTarget(install,xb_check, -s -m 0755 -o root -g bin , $(LOCALBINDIR))

View file

@ -1,4 +1,4 @@
$NetBSD: patch-ac,v 1.2 1998/11/12 15:01:17 agc Exp $
$NetBSD: patch-ac,v 1.3 2001/09/14 03:19:23 jlam Exp $
--- xres.c.orig Thu May 15 22:38:25 1997
+++ xres.c Wed Aug 19 00:18:07 1998
@ -7,7 +7,7 @@ $NetBSD: patch-ac,v 1.2 1998/11/12 15:01:17 agc Exp $
#ifndef vms
- strcpy(line,"/usr/lib/X11/app-defaults/");
+ strcpy(line,X11BASE "/lib/X11/app-defaults/");
+ strcpy(line,PREFIX "/lib/X11/app-defaults/");
strcat(line,PRGCLASS);
appdefDB = XrmGetFileDatabase(line);
if(appdefDB==NULL && getenv("XAPPLRESDIR")!=NULL)

View file

@ -1,17 +1,19 @@
@comment $NetBSD: PLIST,v 1.2 1998/08/18 22:31:59 tron Exp $
bin/xbanner
@comment $NetBSD: PLIST,v 1.3 2001/09/14 03:19:23 jlam Exp $
bin/freetemp
bin/random_effect
bin/xb_check
bin/xbanner
lib/X11/app-defaults/XBanner
share/doc/xbanner/stars.gif
share/doc/xbanner/rnd_doc.html
share/doc/xbanner/red_line.gif
share/doc/xbanner/index.html
share/doc/xbanner/fonttips.html
share/doc/xbanner/email.gif
share/doc/xbanner/XBanner_Users_Manual.html
share/doc/xbanner/Resource_Reference.html
share/doc/xbanner/Credits.txt
share/doc/xbanner/Changes.txt
share/doc/xbanner/Credits.txt
share/doc/xbanner/Resource_Reference.html
share/doc/xbanner/XBanner_Users_Manual.html
share/doc/xbanner/email.gif
share/doc/xbanner/fonttips.html
share/doc/xbanner/index.html
share/doc/xbanner/red_line.gif
share/doc/xbanner/rnd_doc.html
share/doc/xbanner/stars.gif
share/doc/xbanner/xb_check.html
@dirrm share/doc/xbanner
@unexec rmdir -p %D/lib/X11/app-defaults 2>/dev/null || true