XQilla is an XQuery and XPath 2 library and command line utility written in C++,
implemented on top of the Xerces-C library.
This commit is contained in:
parent
177b2768c5
commit
5e3ee5f7da
6 changed files with 466 additions and 0 deletions
2
textproc/xqilla/DESCR
Normal file
2
textproc/xqilla/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
XQilla is an XQuery and XPath 2 library and command line utility written in C++,
|
||||
implemented on top of the Xerces-C library.
|
21
textproc/xqilla/Makefile
Normal file
21
textproc/xqilla/Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/02/23 08:34:14 adam Exp $
|
||||
|
||||
DISTNAME= XQilla-2.2.4
|
||||
PKGNAME= ${DISTNAME:tl}
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=xqilla/}
|
||||
|
||||
MAINTAINER= pkgsrc-users@NetBSD.org
|
||||
HOMEPAGE= http://xqilla.sourceforge.net/
|
||||
COMMENT= XQuery and XPath 2 processor
|
||||
LICENSE= apache-2.0
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_LIBTOOL= yes
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS+= --with-xerces=${BUILDLINK_PREFIX.xerces-c}
|
||||
|
||||
.include "../../textproc/xerces-c/buildlink3.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
408
textproc/xqilla/PLIST
Normal file
408
textproc/xqilla/PLIST
Normal file
|
@ -0,0 +1,408 @@
|
|||
@comment $NetBSD: PLIST,v 1.1.1.1 2011/02/23 08:34:14 adam Exp $
|
||||
bin/xqilla
|
||||
include/xqc.h
|
||||
include/xqilla/ast/ASTNode.hpp
|
||||
include/xqilla/ast/ASTNodeImpl.hpp
|
||||
include/xqilla/ast/ConstantFoldingFunction.hpp
|
||||
include/xqilla/ast/ContextTuple.hpp
|
||||
include/xqilla/ast/ConvertFunctionArg.hpp
|
||||
include/xqilla/ast/ForTuple.hpp
|
||||
include/xqilla/ast/LetTuple.hpp
|
||||
include/xqilla/ast/LocationInfo.hpp
|
||||
include/xqilla/ast/NumericFunction.hpp
|
||||
include/xqilla/ast/OrderByTuple.hpp
|
||||
include/xqilla/ast/StaticAnalysis.hpp
|
||||
include/xqilla/ast/StaticType.hpp
|
||||
include/xqilla/ast/TupleNode.hpp
|
||||
include/xqilla/ast/WhereTuple.hpp
|
||||
include/xqilla/ast/XPath1Compat.hpp
|
||||
include/xqilla/ast/XQAnalyzeString.hpp
|
||||
include/xqilla/ast/XQApplyTemplates.hpp
|
||||
include/xqilla/ast/XQAtomize.hpp
|
||||
include/xqilla/ast/XQAttributeConstructor.hpp
|
||||
include/xqilla/ast/XQCallTemplate.hpp
|
||||
include/xqilla/ast/XQCastAs.hpp
|
||||
include/xqilla/ast/XQCastableAs.hpp
|
||||
include/xqilla/ast/XQCommentConstructor.hpp
|
||||
include/xqilla/ast/XQContextItem.hpp
|
||||
include/xqilla/ast/XQCopy.hpp
|
||||
include/xqilla/ast/XQCopyOf.hpp
|
||||
include/xqilla/ast/XQDOMConstructor.hpp
|
||||
include/xqilla/ast/XQDocumentConstructor.hpp
|
||||
include/xqilla/ast/XQDocumentOrder.hpp
|
||||
include/xqilla/ast/XQEffectiveBooleanValue.hpp
|
||||
include/xqilla/ast/XQElementConstructor.hpp
|
||||
include/xqilla/ast/XQFunction.hpp
|
||||
include/xqilla/ast/XQFunctionCall.hpp
|
||||
include/xqilla/ast/XQFunctionConversion.hpp
|
||||
include/xqilla/ast/XQFunctionDeref.hpp
|
||||
include/xqilla/ast/XQFunctionRef.hpp
|
||||
include/xqilla/ast/XQGlobalVariable.hpp
|
||||
include/xqilla/ast/XQIf.hpp
|
||||
include/xqilla/ast/XQInlineFunction.hpp
|
||||
include/xqilla/ast/XQInstanceOf.hpp
|
||||
include/xqilla/ast/XQLiteral.hpp
|
||||
include/xqilla/ast/XQMap.hpp
|
||||
include/xqilla/ast/XQNamespaceBinding.hpp
|
||||
include/xqilla/ast/XQNamespaceConstructor.hpp
|
||||
include/xqilla/ast/XQNav.hpp
|
||||
include/xqilla/ast/XQOperator.hpp
|
||||
include/xqilla/ast/XQOrderingChange.hpp
|
||||
include/xqilla/ast/XQPIConstructor.hpp
|
||||
include/xqilla/ast/XQPredicate.hpp
|
||||
include/xqilla/ast/XQQuantified.hpp
|
||||
include/xqilla/ast/XQReturn.hpp
|
||||
include/xqilla/ast/XQSequence.hpp
|
||||
include/xqilla/ast/XQStep.hpp
|
||||
include/xqilla/ast/XQTextConstructor.hpp
|
||||
include/xqilla/ast/XQTreatAs.hpp
|
||||
include/xqilla/ast/XQTypeswitch.hpp
|
||||
include/xqilla/ast/XQValidate.hpp
|
||||
include/xqilla/ast/XQVariable.hpp
|
||||
include/xqilla/axis/NodeTest.hpp
|
||||
include/xqilla/axis/SelfAxis.hpp
|
||||
include/xqilla/context/Collation.hpp
|
||||
include/xqilla/context/ContextHelpers.hpp
|
||||
include/xqilla/context/DynamicContext.hpp
|
||||
include/xqilla/context/ExternalFunctionResolver.hpp
|
||||
include/xqilla/context/ItemFactory.hpp
|
||||
include/xqilla/context/MessageListener.hpp
|
||||
include/xqilla/context/ModuleResolver.hpp
|
||||
include/xqilla/context/RegexGroupStore.hpp
|
||||
include/xqilla/context/Scope.hpp
|
||||
include/xqilla/context/StaticContext.hpp
|
||||
include/xqilla/context/URIResolver.hpp
|
||||
include/xqilla/context/UpdateFactory.hpp
|
||||
include/xqilla/context/VarHashEntry.hpp
|
||||
include/xqilla/context/VariableStore.hpp
|
||||
include/xqilla/context/VariableTypeStore.hpp
|
||||
include/xqilla/context/impl/CodepointCollation.hpp
|
||||
include/xqilla/context/impl/CollationImpl.hpp
|
||||
include/xqilla/context/impl/ItemFactoryImpl.hpp
|
||||
include/xqilla/context/impl/VarHashEntryImpl.hpp
|
||||
include/xqilla/context/impl/VarStoreImpl.hpp
|
||||
include/xqilla/context/impl/VariableStoreTemplate.hpp
|
||||
include/xqilla/context/impl/XQContextImpl.hpp
|
||||
include/xqilla/context/impl/XQDynamicContextImpl.hpp
|
||||
include/xqilla/debug/ASTDebugHook.hpp
|
||||
include/xqilla/debug/DebugHookDecorator.hpp
|
||||
include/xqilla/debug/DebugListener.hpp
|
||||
include/xqilla/debug/InputParser.hpp
|
||||
include/xqilla/debug/InteractiveDebugger.hpp
|
||||
include/xqilla/debug/StackFrame.hpp
|
||||
include/xqilla/debug/TupleDebugHook.hpp
|
||||
include/xqilla/dom-api/XPath2Result.hpp
|
||||
include/xqilla/dom-api/XQillaExpression.hpp
|
||||
include/xqilla/dom-api/XQillaNSResolver.hpp
|
||||
include/xqilla/dom-api/impl/XQillaNSResolverImpl.hpp
|
||||
include/xqilla/events/ContentSequenceFilter.hpp
|
||||
include/xqilla/events/EventGenerator.hpp
|
||||
include/xqilla/events/EventHandler.hpp
|
||||
include/xqilla/events/EventSerializer.hpp
|
||||
include/xqilla/events/NSFixupFilter.hpp
|
||||
include/xqilla/events/QueryPathTreeFilter.hpp
|
||||
include/xqilla/events/SequenceBuilder.hpp
|
||||
include/xqilla/exceptions/ASTException.hpp
|
||||
include/xqilla/exceptions/ContextException.hpp
|
||||
include/xqilla/exceptions/DynamicErrorException.hpp
|
||||
include/xqilla/exceptions/FunctionException.hpp
|
||||
include/xqilla/exceptions/IllegalArgumentException.hpp
|
||||
include/xqilla/exceptions/ItemException.hpp
|
||||
include/xqilla/exceptions/NamespaceLookupException.hpp
|
||||
include/xqilla/exceptions/QueryInterruptedException.hpp
|
||||
include/xqilla/exceptions/QueryTimeoutException.hpp
|
||||
include/xqilla/exceptions/StaticErrorException.hpp
|
||||
include/xqilla/exceptions/TypeErrorException.hpp
|
||||
include/xqilla/exceptions/TypeNotFoundException.hpp
|
||||
include/xqilla/exceptions/XMLParseException.hpp
|
||||
include/xqilla/exceptions/XPath2ErrorException.hpp
|
||||
include/xqilla/exceptions/XPath2TypeCastException.hpp
|
||||
include/xqilla/exceptions/XPath2TypeMatchException.hpp
|
||||
include/xqilla/exceptions/XQException.hpp
|
||||
include/xqilla/exceptions/XQillaException.hpp
|
||||
include/xqilla/fastxdm/FastXDMConfiguration.hpp
|
||||
include/xqilla/framework/BaseMemoryManager.hpp
|
||||
include/xqilla/framework/ProxyMemoryManager.hpp
|
||||
include/xqilla/framework/ReferenceCounted.hpp
|
||||
include/xqilla/framework/StringPool.hpp
|
||||
include/xqilla/framework/XPath2MemoryManager.hpp
|
||||
include/xqilla/framework/XPath2MemoryManagerImpl.hpp
|
||||
include/xqilla/framework/XQillaExport.hpp
|
||||
include/xqilla/fulltext/AllMatches.hpp
|
||||
include/xqilla/fulltext/DefaultTokenStore.hpp
|
||||
include/xqilla/fulltext/DefaultTokenizer.hpp
|
||||
include/xqilla/fulltext/FTAnd.hpp
|
||||
include/xqilla/fulltext/FTContains.hpp
|
||||
include/xqilla/fulltext/FTContent.hpp
|
||||
include/xqilla/fulltext/FTDistance.hpp
|
||||
include/xqilla/fulltext/FTMildnot.hpp
|
||||
include/xqilla/fulltext/FTOption.hpp
|
||||
include/xqilla/fulltext/FTOr.hpp
|
||||
include/xqilla/fulltext/FTOrder.hpp
|
||||
include/xqilla/fulltext/FTRange.hpp
|
||||
include/xqilla/fulltext/FTScope.hpp
|
||||
include/xqilla/fulltext/FTSelection.hpp
|
||||
include/xqilla/fulltext/FTUnaryNot.hpp
|
||||
include/xqilla/fulltext/FTWindow.hpp
|
||||
include/xqilla/fulltext/FTWords.hpp
|
||||
include/xqilla/fulltext/Match.hpp
|
||||
include/xqilla/fulltext/TokenInfo.hpp
|
||||
include/xqilla/fulltext/TokenStore.hpp
|
||||
include/xqilla/fulltext/Tokenizer.hpp
|
||||
include/xqilla/functions/ExternalFunction.hpp
|
||||
include/xqilla/functions/FuncFactory.hpp
|
||||
include/xqilla/functions/FunctionAbs.hpp
|
||||
include/xqilla/functions/FunctionAdjustDateTimeToTimezone.hpp
|
||||
include/xqilla/functions/FunctionAdjustDateToTimezone.hpp
|
||||
include/xqilla/functions/FunctionAdjustTimeToTimezone.hpp
|
||||
include/xqilla/functions/FunctionAnalyzeString.hpp
|
||||
include/xqilla/functions/FunctionAvg.hpp
|
||||
include/xqilla/functions/FunctionBaseURI.hpp
|
||||
include/xqilla/functions/FunctionBoolean.hpp
|
||||
include/xqilla/functions/FunctionCeiling.hpp
|
||||
include/xqilla/functions/FunctionCodepointEqual.hpp
|
||||
include/xqilla/functions/FunctionCodepointsToString.hpp
|
||||
include/xqilla/functions/FunctionCollection.hpp
|
||||
include/xqilla/functions/FunctionCompare.hpp
|
||||
include/xqilla/functions/FunctionConcat.hpp
|
||||
include/xqilla/functions/FunctionConstructor.hpp
|
||||
include/xqilla/functions/FunctionContains.hpp
|
||||
include/xqilla/functions/FunctionCount.hpp
|
||||
include/xqilla/functions/FunctionCurrentDate.hpp
|
||||
include/xqilla/functions/FunctionCurrentDateTime.hpp
|
||||
include/xqilla/functions/FunctionCurrentTime.hpp
|
||||
include/xqilla/functions/FunctionData.hpp
|
||||
include/xqilla/functions/FunctionDateTime.hpp
|
||||
include/xqilla/functions/FunctionDayFromDate.hpp
|
||||
include/xqilla/functions/FunctionDayFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionDaysFromDuration.hpp
|
||||
include/xqilla/functions/FunctionDeepEqual.hpp
|
||||
include/xqilla/functions/FunctionDefaultCollation.hpp
|
||||
include/xqilla/functions/FunctionDistinctValues.hpp
|
||||
include/xqilla/functions/FunctionDoc.hpp
|
||||
include/xqilla/functions/FunctionDocAvailable.hpp
|
||||
include/xqilla/functions/FunctionDocument.hpp
|
||||
include/xqilla/functions/FunctionDocumentURI.hpp
|
||||
include/xqilla/functions/FunctionEmpty.hpp
|
||||
include/xqilla/functions/FunctionEncodeForUri.hpp
|
||||
include/xqilla/functions/FunctionEndsWith.hpp
|
||||
include/xqilla/functions/FunctionError.hpp
|
||||
include/xqilla/functions/FunctionEscapeHtmlUri.hpp
|
||||
include/xqilla/functions/FunctionExactlyOne.hpp
|
||||
include/xqilla/functions/FunctionExists.hpp
|
||||
include/xqilla/functions/FunctionFalse.hpp
|
||||
include/xqilla/functions/FunctionFloor.hpp
|
||||
include/xqilla/functions/FunctionFunctionArity.hpp
|
||||
include/xqilla/functions/FunctionFunctionName.hpp
|
||||
include/xqilla/functions/FunctionHoursFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionHoursFromDuration.hpp
|
||||
include/xqilla/functions/FunctionHoursFromTime.hpp
|
||||
include/xqilla/functions/FunctionId.hpp
|
||||
include/xqilla/functions/FunctionIdref.hpp
|
||||
include/xqilla/functions/FunctionImplicitTimezone.hpp
|
||||
include/xqilla/functions/FunctionInScopePrefixes.hpp
|
||||
include/xqilla/functions/FunctionIndexOf.hpp
|
||||
include/xqilla/functions/FunctionInsertBefore.hpp
|
||||
include/xqilla/functions/FunctionIriToUri.hpp
|
||||
include/xqilla/functions/FunctionLang.hpp
|
||||
include/xqilla/functions/FunctionLast.hpp
|
||||
include/xqilla/functions/FunctionLocalNameFromQName.hpp
|
||||
include/xqilla/functions/FunctionLocalname.hpp
|
||||
include/xqilla/functions/FunctionLookup.hpp
|
||||
include/xqilla/functions/FunctionLowerCase.hpp
|
||||
include/xqilla/functions/FunctionMatches.hpp
|
||||
include/xqilla/functions/FunctionMax.hpp
|
||||
include/xqilla/functions/FunctionMin.hpp
|
||||
include/xqilla/functions/FunctionMinutesFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionMinutesFromDuration.hpp
|
||||
include/xqilla/functions/FunctionMinutesFromTime.hpp
|
||||
include/xqilla/functions/FunctionMonthFromDate.hpp
|
||||
include/xqilla/functions/FunctionMonthFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionMonthsFromDuration.hpp
|
||||
include/xqilla/functions/FunctionName.hpp
|
||||
include/xqilla/functions/FunctionNamespaceURIForPrefix.hpp
|
||||
include/xqilla/functions/FunctionNamespaceURIFromQName.hpp
|
||||
include/xqilla/functions/FunctionNamespaceUri.hpp
|
||||
include/xqilla/functions/FunctionNilled.hpp
|
||||
include/xqilla/functions/FunctionNodeName.hpp
|
||||
include/xqilla/functions/FunctionNormalizeSpace.hpp
|
||||
include/xqilla/functions/FunctionNormalizeUnicode.hpp
|
||||
include/xqilla/functions/FunctionNot.hpp
|
||||
include/xqilla/functions/FunctionNumber.hpp
|
||||
include/xqilla/functions/FunctionOneOrMore.hpp
|
||||
include/xqilla/functions/FunctionParseHTML.hpp
|
||||
include/xqilla/functions/FunctionParseJSON.hpp
|
||||
include/xqilla/functions/FunctionParseXML.hpp
|
||||
include/xqilla/functions/FunctionPartialApply.hpp
|
||||
include/xqilla/functions/FunctionPosition.hpp
|
||||
include/xqilla/functions/FunctionPrefixFromQName.hpp
|
||||
include/xqilla/functions/FunctionQName.hpp
|
||||
include/xqilla/functions/FunctionRegexGroup.hpp
|
||||
include/xqilla/functions/FunctionRemove.hpp
|
||||
include/xqilla/functions/FunctionReplace.hpp
|
||||
include/xqilla/functions/FunctionResolveQName.hpp
|
||||
include/xqilla/functions/FunctionResolveURI.hpp
|
||||
include/xqilla/functions/FunctionReverse.hpp
|
||||
include/xqilla/functions/FunctionRoot.hpp
|
||||
include/xqilla/functions/FunctionRound.hpp
|
||||
include/xqilla/functions/FunctionRoundHalfToEven.hpp
|
||||
include/xqilla/functions/FunctionSecondsFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionSecondsFromDuration.hpp
|
||||
include/xqilla/functions/FunctionSecondsFromTime.hpp
|
||||
include/xqilla/functions/FunctionSerializeJSON.hpp
|
||||
include/xqilla/functions/FunctionStartsWith.hpp
|
||||
include/xqilla/functions/FunctionStaticBaseURI.hpp
|
||||
include/xqilla/functions/FunctionString.hpp
|
||||
include/xqilla/functions/FunctionStringJoin.hpp
|
||||
include/xqilla/functions/FunctionStringLength.hpp
|
||||
include/xqilla/functions/FunctionStringToCodepoints.hpp
|
||||
include/xqilla/functions/FunctionSubsequence.hpp
|
||||
include/xqilla/functions/FunctionSubstring.hpp
|
||||
include/xqilla/functions/FunctionSubstringAfter.hpp
|
||||
include/xqilla/functions/FunctionSubstringBefore.hpp
|
||||
include/xqilla/functions/FunctionSum.hpp
|
||||
include/xqilla/functions/FunctionTime.hpp
|
||||
include/xqilla/functions/FunctionTimezoneFromDate.hpp
|
||||
include/xqilla/functions/FunctionTimezoneFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionTimezoneFromTime.hpp
|
||||
include/xqilla/functions/FunctionTokenize.hpp
|
||||
include/xqilla/functions/FunctionTrace.hpp
|
||||
include/xqilla/functions/FunctionTranslate.hpp
|
||||
include/xqilla/functions/FunctionTrue.hpp
|
||||
include/xqilla/functions/FunctionUnordered.hpp
|
||||
include/xqilla/functions/FunctionUnparsedText.hpp
|
||||
include/xqilla/functions/FunctionUpperCase.hpp
|
||||
include/xqilla/functions/FunctionYearFromDate.hpp
|
||||
include/xqilla/functions/FunctionYearFromDateTime.hpp
|
||||
include/xqilla/functions/FunctionYearsFromDuration.hpp
|
||||
include/xqilla/functions/FunctionZeroOrOne.hpp
|
||||
include/xqilla/functions/XQUserFunction.hpp
|
||||
include/xqilla/functions/XQillaFunction.hpp
|
||||
include/xqilla/items/ATAnySimpleType.hpp
|
||||
include/xqilla/items/ATAnyURIOrDerived.hpp
|
||||
include/xqilla/items/ATBase64BinaryOrDerived.hpp
|
||||
include/xqilla/items/ATBooleanOrDerived.hpp
|
||||
include/xqilla/items/ATDateOrDerived.hpp
|
||||
include/xqilla/items/ATDateTimeOrDerived.hpp
|
||||
include/xqilla/items/ATDecimalOrDerived.hpp
|
||||
include/xqilla/items/ATDoubleOrDerived.hpp
|
||||
include/xqilla/items/ATDurationOrDerived.hpp
|
||||
include/xqilla/items/ATFloatOrDerived.hpp
|
||||
include/xqilla/items/ATGDayOrDerived.hpp
|
||||
include/xqilla/items/ATGMonthDayOrDerived.hpp
|
||||
include/xqilla/items/ATGMonthOrDerived.hpp
|
||||
include/xqilla/items/ATGYearMonthOrDerived.hpp
|
||||
include/xqilla/items/ATGYearOrDerived.hpp
|
||||
include/xqilla/items/ATHexBinaryOrDerived.hpp
|
||||
include/xqilla/items/ATNotationOrDerived.hpp
|
||||
include/xqilla/items/ATQNameOrDerived.hpp
|
||||
include/xqilla/items/ATStringOrDerived.hpp
|
||||
include/xqilla/items/ATTimeOrDerived.hpp
|
||||
include/xqilla/items/ATUntypedAtomic.hpp
|
||||
include/xqilla/items/AnyAtomicType.hpp
|
||||
include/xqilla/items/DatatypeFactory.hpp
|
||||
include/xqilla/items/DatatypeLookup.hpp
|
||||
include/xqilla/items/DateOrTimeType.hpp
|
||||
include/xqilla/items/FunctionRef.hpp
|
||||
include/xqilla/items/Item.hpp
|
||||
include/xqilla/items/Node.hpp
|
||||
include/xqilla/items/Numeric.hpp
|
||||
include/xqilla/items/Timezone.hpp
|
||||
include/xqilla/items/impl/ATBooleanOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATDateOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATDateTimeOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATDecimalOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATDoubleOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATDurationOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATFloatOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATGDayOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATGMonthDayOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATGMonthOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATGYearMonthOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATGYearOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATQNameOrDerivedImpl.hpp
|
||||
include/xqilla/items/impl/ATTimeOrDerivedImpl.hpp
|
||||
include/xqilla/mapm/m_apm.h
|
||||
include/xqilla/operators/And.hpp
|
||||
include/xqilla/operators/ArithmeticOperator.hpp
|
||||
include/xqilla/operators/ComparisonOperator.hpp
|
||||
include/xqilla/operators/Divide.hpp
|
||||
include/xqilla/operators/Equals.hpp
|
||||
include/xqilla/operators/Except.hpp
|
||||
include/xqilla/operators/GeneralComp.hpp
|
||||
include/xqilla/operators/GreaterThan.hpp
|
||||
include/xqilla/operators/GreaterThanEqual.hpp
|
||||
include/xqilla/operators/IntegerDivide.hpp
|
||||
include/xqilla/operators/Intersect.hpp
|
||||
include/xqilla/operators/LessThan.hpp
|
||||
include/xqilla/operators/LessThanEqual.hpp
|
||||
include/xqilla/operators/Minus.hpp
|
||||
include/xqilla/operators/Mod.hpp
|
||||
include/xqilla/operators/Multiply.hpp
|
||||
include/xqilla/operators/NodeComparison.hpp
|
||||
include/xqilla/operators/NotEquals.hpp
|
||||
include/xqilla/operators/Or.hpp
|
||||
include/xqilla/operators/OrderComparison.hpp
|
||||
include/xqilla/operators/Plus.hpp
|
||||
include/xqilla/operators/Range.hpp
|
||||
include/xqilla/operators/UnaryMinus.hpp
|
||||
include/xqilla/operators/Union.hpp
|
||||
include/xqilla/optimizer/ASTCopier.hpp
|
||||
include/xqilla/optimizer/ASTReleaser.hpp
|
||||
include/xqilla/optimizer/ASTVisitor.hpp
|
||||
include/xqilla/optimizer/Optimizer.hpp
|
||||
include/xqilla/optimizer/PartialEvaluator.hpp
|
||||
include/xqilla/optimizer/QueryPathNode.hpp
|
||||
include/xqilla/optimizer/QueryPathTreeGenerator.hpp
|
||||
include/xqilla/optimizer/StaticTyper.hpp
|
||||
include/xqilla/parser/QName.hpp
|
||||
include/xqilla/runtime/ClosureResult.hpp
|
||||
include/xqilla/runtime/EmptyResult.hpp
|
||||
include/xqilla/runtime/LazySequenceResult.hpp
|
||||
include/xqilla/runtime/Result.hpp
|
||||
include/xqilla/runtime/ResultBuffer.hpp
|
||||
include/xqilla/runtime/ResultBufferImpl.hpp
|
||||
include/xqilla/runtime/ResultImpl.hpp
|
||||
include/xqilla/runtime/Sequence.hpp
|
||||
include/xqilla/runtime/SequenceResult.hpp
|
||||
include/xqilla/runtime/SingleResult.hpp
|
||||
include/xqilla/runtime/TupleResult.hpp
|
||||
include/xqilla/schema/AnyAtomicTypeDatatypeValidator.hpp
|
||||
include/xqilla/schema/DocumentCache.hpp
|
||||
include/xqilla/schema/DocumentCacheImpl.hpp
|
||||
include/xqilla/schema/SchemaValidatorFilter.hpp
|
||||
include/xqilla/schema/SequenceType.hpp
|
||||
include/xqilla/simple-api/XQQuery.hpp
|
||||
include/xqilla/simple-api/XQilla.hpp
|
||||
include/xqilla/simple-api/XQillaConfiguration.hpp
|
||||
include/xqilla/update/FunctionPut.hpp
|
||||
include/xqilla/update/PendingUpdateList.hpp
|
||||
include/xqilla/update/UApplyUpdates.hpp
|
||||
include/xqilla/update/UDelete.hpp
|
||||
include/xqilla/update/UInsertAfter.hpp
|
||||
include/xqilla/update/UInsertAsFirst.hpp
|
||||
include/xqilla/update/UInsertAsLast.hpp
|
||||
include/xqilla/update/UInsertBefore.hpp
|
||||
include/xqilla/update/UInsertInto.hpp
|
||||
include/xqilla/update/URename.hpp
|
||||
include/xqilla/update/UReplace.hpp
|
||||
include/xqilla/update/UReplaceValueOf.hpp
|
||||
include/xqilla/update/UTransform.hpp
|
||||
include/xqilla/utils/ContextUtils.hpp
|
||||
include/xqilla/utils/NumUtils.hpp
|
||||
include/xqilla/utils/PrintAST.hpp
|
||||
include/xqilla/utils/UCANormalizer.hpp
|
||||
include/xqilla/utils/UTF8Str.hpp
|
||||
include/xqilla/utils/XMLChCompare.hpp
|
||||
include/xqilla/utils/XPath2NSUtils.hpp
|
||||
include/xqilla/utils/XPath2Utils.hpp
|
||||
include/xqilla/utils/XQillaPlatformUtils.hpp
|
||||
include/xqilla/utils/XStr.hpp
|
||||
include/xqilla/xerces/XercesConfiguration.hpp
|
||||
include/xqilla/xqilla-dom3.hpp
|
||||
include/xqilla/xqilla-simple.hpp
|
||||
include/xqilla/xqilla-xqc.h
|
||||
include/xqilla/xqts/TestSuiteParser.hpp
|
||||
include/xqilla/xqts/TestSuiteResultListener.hpp
|
||||
include/xqilla/xqts/TestSuiteRunner.hpp
|
||||
lib/libxqilla.la
|
14
textproc/xqilla/buildlink3.mk
Normal file
14
textproc/xqilla/buildlink3.mk
Normal file
|
@ -0,0 +1,14 @@
|
|||
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/02/23 08:34:14 adam Exp $
|
||||
|
||||
BUILDLINK_TREE+= xqilla
|
||||
|
||||
.if !defined(XQILLA_BUILDLINK3_MK)
|
||||
XQILLA_BUILDLINK3_MK:=
|
||||
|
||||
BUILDLINK_API_DEPENDS.xqilla+= xqilla>=2.2.4
|
||||
BUILDLINK_PKGSRCDIR.xqilla?= ../../textproc/xqilla
|
||||
|
||||
.include "../../textproc/xerces-c/buildlink3.mk"
|
||||
.endif # XQILLA_BUILDLINK3_MK
|
||||
|
||||
BUILDLINK_TREE+= -xqilla
|
6
textproc/xqilla/distinfo
Normal file
6
textproc/xqilla/distinfo
Normal file
|
@ -0,0 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/02/23 08:34:14 adam Exp $
|
||||
|
||||
SHA1 (XQilla-2.2.4.tar.gz) = edd1681a6bb9d310b6aaca6af0584eb96df3b8eb
|
||||
RMD160 (XQilla-2.2.4.tar.gz) = ec4268452c98d7c87e8bf7dccaf0ebc7ff19f167
|
||||
Size (XQilla-2.2.4.tar.gz) = 15667750 bytes
|
||||
SHA1 (patch-src_items_DatatypeFactoryTemplate.hpp) = 6d9ef8eb7b31d5fa8ffa7c85fe20dd45a32f90c3
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-src_items_DatatypeFactoryTemplate.hpp,v 1.1.1.1 2011/02/23 08:34:14 adam Exp $
|
||||
|
||||
Fix C++ error.
|
||||
|
||||
--- src/items/DatatypeFactoryTemplate.hpp.orig 2011-02-23 07:08:39.000000000 +0000
|
||||
+++ src/items/DatatypeFactoryTemplate.hpp
|
||||
@@ -79,7 +79,7 @@ public:
|
||||
AnyAtomicType::Ptr createInstance(const XMLCh* value,
|
||||
const DynamicContext* context) const
|
||||
{
|
||||
- return createInstanceNoCheck(DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeURI(),
|
||||
+ return this->createInstanceNoCheck(DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeURI(),
|
||||
DatatypeFactoryTemplate<TYPE>::getPrimitiveTypeName(), value, context);
|
||||
}
|
||||
|
Loading…
Reference in a new issue