Update to vipec-2.0.4
Changes included in version 2.0.4 --------------------------------- - Fixed printing under windows. - You can now plot the real and imaginary parts of the circuit input and output impedances Changes included in version 2.0.3 --------------------------------- - Moved to Qt version 2.1.0 - The help browser is now integrated into the ViPEC application. - Fixed a bug in calculating the circuit output impedance. - Input and output impedances ouput to a graph now works. Changes included in version 2.0.2 --------------------------------- - Improved data storage of graphs and Smith charts - Double buffering implemented for drawing of graphs and Smith charts to reduce flicker. - Improved font management - Fixed display bug in Table view - Fixed bug with output to 2 port parameter files under Windows - Added support for Group Delay, see help files for more details as well as sample circuit: group_delay.ckt
This commit is contained in:
parent
9babef79cc
commit
5e50bdbf36
8 changed files with 85 additions and 125 deletions
|
@ -1,45 +1,40 @@
|
|||
# $NetBSD: Makefile,v 1.16 2000/08/16 02:08:52 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.17 2000/08/28 19:52:33 dmcmahill Exp $
|
||||
#
|
||||
|
||||
DISTNAME= vipec-2.0.1
|
||||
DISTNAME= vipec-2.0.4
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= http://netfold.com/~vipec/public_ftp/stable/
|
||||
|
||||
MAINTAINER= dmcmahill@netbsd.org
|
||||
HOMEPAGE= http://www.netfold.com/~vipec/
|
||||
|
||||
DEPENDS+= qt2-2.0.2:../../x11/qt
|
||||
DEPENDS+= qt21-2.1.1:../../x11/qt21
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LIBTOOL= yes
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
USE_X11= yes
|
||||
|
||||
EVAL_PREFIX+= QT2DIR=qt2
|
||||
CONFIGURE_ENV+= "QTDIR=${QT2DIR}/qt2" \
|
||||
EVAL_PREFIX+= QT2DIR=qt21
|
||||
CONFIGURE_ENV+= "QTDIR=${QT2DIR}/qt21" \
|
||||
all_libraries="-Wl,-R${LOCALBASE}/lib -L${LOCALBASE}/lib -Wl,-R${X11BASE}/lib -L${X11BASE}/lib"
|
||||
CONFIGURE_ARGS+= "--with-qt-dir=${QT2DIR}/qt2"
|
||||
CONFIGURE_ARGS+= "--with-qt-dir=${QT2DIR}/qt21"
|
||||
|
||||
post-extract:
|
||||
${MV} -f ${WRKSRC}/bin/start_vipec_help ${WRKSRC}/bin/start_vipec_help.in
|
||||
|
||||
pre-configure:
|
||||
${RM} -f ${WRKSRC}/config.cache
|
||||
|
||||
post-configure:
|
||||
${SED} 's;@prefix@;${PREFIX};g' ${WRKSRC}/bin/start_vipec_help.in > ${WRKSRC}/bin/start_vipec_help
|
||||
post-patch:
|
||||
${MV} -f ${WRKSRC}/vipec/helpwindow.cpp ${WRKSRC}/vipec/helpwindow.cpp.in
|
||||
${SED} "s;@prefix@;${PREFIX};g" ${WRKSRC}/vipec/helpwindow.cpp.in > \
|
||||
${WRKSRC}/vipec/helpwindow.cpp
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/vipec/vipec ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/bin/start_vipec_help ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/examples/vipec
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/ckt/*.ckt ${PREFIX}/share/examples/vipec
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/ckt/*.s2p ${PREFIX}/share/examples/vipec
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/vipec
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/vipec/models
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/*.html ${PREFIX}/share/doc/vipec
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/*.gif ${PREFIX}/share/doc/vipec
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/*.png ${PREFIX}/share/doc/vipec
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/models/*.html ${PREFIX}/share/doc/vipec/models
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/models/*.gif ${PREFIX}/share/doc/vipec/models
|
||||
${INSTALL_DATA} ${WRKSRC}/vipec/help/models/*.png ${PREFIX}/share/doc/vipec/models
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
$NetBSD: md5,v 1.2 2000/03/28 21:48:42 dmcmahill Exp $
|
||||
$NetBSD: md5,v 1.3 2000/08/28 19:52:34 dmcmahill Exp $
|
||||
|
||||
MD5 (vipec-2.0.1.tar.gz) = 40c8f97dc7c4ddb55b13703e1f1f0d4c
|
||||
MD5 (vipec-2.0.4.tar.gz) = c9b92e9218193442b3a67c266fd16609
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
$NetBSD: patch-sum,v 1.8 2000/08/16 02:08:52 wiz Exp $
|
||||
$NetBSD: patch-sum,v 1.9 2000/08/28 19:52:34 dmcmahill Exp $
|
||||
|
||||
MD5 (patch-aa) = 5a621d4a4a240fbb447a1e2d073bdb99
|
||||
MD5 (patch-ac) = 5c6d861bdd44b775784b06bf6952e7e2
|
||||
MD5 (patch-ad) = 9ad5068ca9710e3f1a88706508971d10
|
||||
MD5 (patch-aa) = 07722f7965ca78c5bb96cf339eb7ddd8
|
||||
MD5 (patch-ab) = 88aa4452920bdb56a25df5d902d05178
|
||||
MD5 (patch-ac) = 232a978b2094cf9003a73e8c47460756
|
||||
|
|
|
@ -1,46 +1,32 @@
|
|||
$NetBSD: patch-aa,v 1.5 2000/04/01 18:54:00 dmcmahill Exp $
|
||||
$NetBSD: patch-aa,v 1.6 2000/08/28 19:52:34 dmcmahill Exp $
|
||||
|
||||
--- configure.orig Wed Oct 27 19:59:43 1999
|
||||
+++ configure Sat Apr 1 13:33:09 2000
|
||||
@@ -10,5 +10,5 @@
|
||||
# Defaults:
|
||||
ac_help=
|
||||
-ac_default_prefix=/opt
|
||||
+ac_default_prefix=/usr/local
|
||||
# Any additions from configure.in:
|
||||
ac_help="$ac_help
|
||||
@@ -32,5 +32,5 @@
|
||||
build=NONE
|
||||
cache_file=./config.cache
|
||||
-exec_prefix=/opt/vipec
|
||||
+exec_prefix=NONE
|
||||
host=NONE
|
||||
no_create=
|
||||
@@ -1027,5 +1027,5 @@
|
||||
X_LDFLAGS=""
|
||||
--- configure.orig Mon May 22 14:34:07 2000
|
||||
+++ configure Mon Aug 28 14:15:03 2000
|
||||
@@ -4214,5 +4214,5 @@
|
||||
x_libraries="/usr/lib"; else
|
||||
x_libraries=$ac_x_libraries
|
||||
- X_LDFLAGS="-L$x_libraries"
|
||||
+ X_LDFLAGS="-L$x_libraries -Wl,-R$x_libraries"
|
||||
fi
|
||||
all_includes="$all_includes $X_INCLUDES"
|
||||
@@ -2178,5 +2178,5 @@
|
||||
all_includes="$X_INCLUDES"
|
||||
@@ -4501,5 +4501,5 @@
|
||||
|
||||
CXXFLAGS="$CXXFLAGS -I$qt_incdir"
|
||||
-LDFLAGS="-L$qt_libdir $X_LDFLAGS"
|
||||
+LDFLAGS="-L$qt_libdir -Wl,-R$qt_libdir $X_LDFLAGS"
|
||||
LIBS="$LIBS -lqt -lXext -lX11 $LIBSOCKET"
|
||||
CXXFLAGS="$CXXFLAGS -I$qt_incdir $all_includes"
|
||||
-LDFLAGS="-L$qt_libdir $all_libraries $USER_LDFLAGS"
|
||||
+LDFLAGS="-L$qt_libdir -Wl,-R$qt_libdir $all_libraries $USER_LDFLAGS"
|
||||
LIBS="$LIBS $LIBQT"
|
||||
|
||||
@@ -2266,5 +2266,5 @@
|
||||
@@ -4631,5 +4631,5 @@
|
||||
CXXFLAGS="$CXXFLAGS -I$qt_includes"
|
||||
LDFLAGS="$X_LDFLAGS"
|
||||
-LIBS="-lqt -lXext -lX11 $LIBSOCKET"
|
||||
+LIBS="-lqt -lXext -lX11 -lz -lpng -lSM $LIBSOCKET"
|
||||
+LIBS="-lqt -lXext -lX11 -lz -lpng -lSM $LIBSOCKET"
|
||||
LD_LIBRARY_PATH=
|
||||
export LD_LIBRARY_PATH
|
||||
@@ -2335,5 +2335,5 @@
|
||||
@@ -4737,5 +4737,5 @@
|
||||
QT_LDFLAGS=""
|
||||
else
|
||||
- QT_LDFLAGS="-L$qt_libraries"
|
||||
+ QT_LDFLAGS="-L$qt_libraries -Wl,-R$qt_libraries"
|
||||
all_libraries="$QT_LDFLAGS $all_libraries"
|
||||
all_libraries="$all_libraries $QT_LDFLAGS"
|
||||
fi
|
||||
|
|
11
cad/vipec/patches/patch-ab
Normal file
11
cad/vipec/patches/patch-ab
Normal file
|
@ -0,0 +1,11 @@
|
|||
$NetBSD: patch-ab,v 1.3 2000/08/28 19:52:35 dmcmahill Exp $
|
||||
|
||||
--- vipec/helpwindow.cpp.orig Mon May 22 14:44:20 2000
|
||||
+++ vipec/helpwindow.cpp Mon Aug 28 15:41:37 2000
|
||||
@@ -36,5 +36,5 @@
|
||||
vipecHome = dir.absPath();
|
||||
}
|
||||
- home_ = vipecHome + "/help/index.html";
|
||||
+ home_ = "@prefix@/share/doc/vipec/index.html";
|
||||
|
||||
helpBrowser_ = new QTextBrowser( this );
|
|
@ -1,25 +1,29 @@
|
|||
$NetBSD: patch-ac,v 1.5 2000/08/16 02:08:53 wiz Exp $
|
||||
$NetBSD: patch-ac,v 1.6 2000/08/28 19:52:35 dmcmahill Exp $
|
||||
|
||||
--- vipec/Makefile.in.orig Wed Oct 27 20:01:06 1999
|
||||
+++ vipec/Makefile.in Sat Apr 1 14:25:50 2000
|
||||
@@ -158,5 +158,5 @@
|
||||
bin_PROGRAMS = vipec
|
||||
vipec_SOURCES = drawingframe.cpp circuiteditor.cpp vipec.cpp view.cpp vector.cpp utils.cpp twoports.cpp table.cpp smith.cpp smallmatrix.cpp setup.cpp parser.cpp paramset.cpp netanal.cpp matrix.cpp main.cpp graphutils.cpp graph.cpp convert.cpp config.cpp block.cpp analyser.cpp
|
||||
--- vipec/Makefile.in.orig Mon May 22 16:11:40 2000
|
||||
+++ vipec/Makefile.in Mon Aug 28 14:11:06 2000
|
||||
@@ -194,5 +194,5 @@
|
||||
bin_PROGRAMS = vipec
|
||||
vipec_SOURCES = helpwindow.cpp vipec.cpp view.cpp vector.cpp utils.cpp twoports.cpp table.cpp smith.cpp smallmatrix.cpp setup.cpp parser.cpp paramset.cpp netanal.cpp matrix.cpp main.cpp graphutils.cpp graph.cpp drawingframe.cpp convert.cpp config.cpp circuiteditor.cpp block.cpp analyser.cpp
|
||||
-vipec_LDADD = -lqt -lXext -lX11 $(LIBSOCKET)
|
||||
+vipec_LDADD = -lqt -lXext -lX11 -lz -lpng -lSM -lICE $(LIBSOCKET)
|
||||
+vipec_LDADD = -lqt -lXext -lX11 -lz -lpng -ljpeg -lSM -lICE $(LIBSOCKET)
|
||||
|
||||
SUBDIRS = images ckt help
|
||||
@@ -193,4 +193,5 @@
|
||||
CXXFLAGS = @CXXFLAGS@
|
||||
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
+CXXCOMPILE2 = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS)
|
||||
LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
CXXLD = $(CXX)
|
||||
@@ -205,4 +206,7 @@
|
||||
@@ -246,4 +246,5 @@
|
||||
#>+ 1
|
||||
CXXCOMPILE = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $(KDE_CXXFLAGS)
|
||||
+CXXCOMPILE2 = $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(KDE_CXXFLAGS)
|
||||
#>- LTCXXCOMPILE = $(LIBTOOL) --mode=compile $(CXX) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
|
||||
#>+ 1
|
||||
@@ -262,4 +263,11 @@
|
||||
SOURCES = $(vipec_SOURCES)
|
||||
OBJECTS = $(vipec_OBJECTS)
|
||||
+
|
||||
+# avoid a bug with "c++ -O*" on some machines. This is noted with
|
||||
+# gcc version egcs-2.91.60 19981201 (egcs-1.1.1 release)
|
||||
+.if (${MACHINE_ARCH} == "mipsel")
|
||||
+analyser.o: analyser.cpp
|
||||
+ $(CXXCOMPILE2) -c analyser.cpp
|
||||
+.endif
|
||||
|
||||
all: all-redirect
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
$NetBSD: patch-ad,v 1.1 2000/03/28 21:48:43 dmcmahill Exp $
|
||||
|
||||
--- bin/start_vipec_help.in.orig Sun Mar 5 07:38:28 2000
|
||||
+++ bin/start_vipec_help.in Tue Mar 28 13:10:55 2000
|
||||
@@ -1,15 +1,25 @@
|
||||
+#!/bin/sh
|
||||
+
|
||||
# Script to start HTML browser and load help file
|
||||
if [ -z $VIPECHOME ]
|
||||
then
|
||||
- VIPECHOME=/opt/vipec
|
||||
+ VIPECHOME=@prefix@
|
||||
fi
|
||||
|
||||
-if [ -z "`ps -ef | grep netscape | grep -v grep`" ]
|
||||
+URL="file://$VIPECHOME/share/doc/vipec/index.html"
|
||||
+VIEWER=@prefix@/bin/netscape
|
||||
+
|
||||
+if [ -x $VIEWER ]
|
||||
then
|
||||
- netscape "file://$VIPECHOME/help/index.html"
|
||||
+ if [ -z "`ps -alx | grep netscape | grep -v grep`" ]
|
||||
+ then
|
||||
+ $VIEWER $URL
|
||||
+ else
|
||||
+ $VIEWER -noraise -remote "openURL($URL, newwindow)"
|
||||
+ fi
|
||||
else
|
||||
- netscape -noraise -remote "openURL(file://$VIPECHOME/help/index.html, newwindow)"
|
||||
+ echo "$VIEWER is not available for online help"
|
||||
+ echo "Please refer to $URL for help"
|
||||
fi
|
||||
-
|
||||
|
||||
|
|
@ -1,42 +1,41 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2000/03/28 21:48:43 dmcmahill Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2000/08/28 19:52:35 dmcmahill Exp $
|
||||
bin/vipec
|
||||
bin/start_vipec_help
|
||||
share/doc/vipec/models/bipolar.gif
|
||||
share/doc/vipec/models/bipolar.png
|
||||
share/doc/vipec/models/bipolar.html
|
||||
share/doc/vipec/models/capacitor.gif
|
||||
share/doc/vipec/models/capacitor.png
|
||||
share/doc/vipec/models/capacitor.html
|
||||
share/doc/vipec/models/inductor.gif
|
||||
share/doc/vipec/models/inductor.png
|
||||
share/doc/vipec/models/inductor.html
|
||||
share/doc/vipec/models/inductorq.gif
|
||||
share/doc/vipec/models/inductorq.png
|
||||
share/doc/vipec/models/inductorq.html
|
||||
share/doc/vipec/models/resistor.gif
|
||||
share/doc/vipec/models/resistor.png
|
||||
share/doc/vipec/models/resistor.html
|
||||
share/doc/vipec/models/block.gif
|
||||
share/doc/vipec/models/block.png
|
||||
share/doc/vipec/models/block.html
|
||||
share/doc/vipec/models/clin.gif
|
||||
share/doc/vipec/models/clin.png
|
||||
share/doc/vipec/models/clin.html
|
||||
share/doc/vipec/models/gyrator.gif
|
||||
share/doc/vipec/models/gyrator.png
|
||||
share/doc/vipec/models/gyrator.html
|
||||
share/doc/vipec/models/tlin2port.gif
|
||||
share/doc/vipec/models/tlin2port.png
|
||||
share/doc/vipec/models/tlin2port.html
|
||||
share/doc/vipec/models/tlin4port.gif
|
||||
share/doc/vipec/models/tlin4port.png
|
||||
share/doc/vipec/models/tlin4port.html
|
||||
share/doc/vipec/models/tloc.gif
|
||||
share/doc/vipec/models/tloc.png
|
||||
share/doc/vipec/models/tloc.html
|
||||
share/doc/vipec/models/tlsc.gif
|
||||
share/doc/vipec/models/tlsc.png
|
||||
share/doc/vipec/models/tlsc.html
|
||||
share/doc/vipec/models/vccs.gif
|
||||
share/doc/vipec/models/vccs.png
|
||||
share/doc/vipec/models/vccs.html
|
||||
share/doc/vipec/models/striplinesub.html
|
||||
share/doc/vipec/models/ustripsub.html
|
||||
share/doc/vipec/models/stripline.html
|
||||
share/doc/vipec/models/mustripline.html
|
||||
share/doc/vipec/models/mustripline.gif
|
||||
share/doc/vipec/models/stripline.gif
|
||||
share/doc/vipec/models/striplinecoupled.gif
|
||||
share/doc/vipec/models/striplinesub.gif
|
||||
share/doc/vipec/models/ustripcoupled.gif
|
||||
share/doc/vipec/models/ustripsub.gif
|
||||
share/doc/vipec/models/mustripline.png
|
||||
share/doc/vipec/models/stripline.png
|
||||
share/doc/vipec/models/striplinecoupled.png
|
||||
share/doc/vipec/models/striplinesub.png
|
||||
share/doc/vipec/models/ustripcoupled.png
|
||||
share/doc/vipec/models/ustripsub.png
|
||||
share/doc/vipec/models/striplinecoupled.html
|
||||
share/doc/vipec/models/ustripcoupled.html
|
||||
share/doc/vipec/defining_circuit.html
|
||||
|
@ -46,7 +45,7 @@ share/doc/vipec/license.html
|
|||
share/doc/vipec/structure_of_circuit_file.html
|
||||
share/doc/vipec/units_of_measure.html
|
||||
share/doc/vipec/what_is.html
|
||||
share/doc/vipec/circuit.gif
|
||||
share/doc/vipec/circuit.png
|
||||
share/doc/vipec/defining_frequency.html
|
||||
share/doc/vipec/defining_output.html
|
||||
share/examples/vipec/3dbcoup.ckt
|
||||
|
@ -56,15 +55,15 @@ share/examples/vipec/amplifier2.ckt
|
|||
share/examples/vipec/amplifier3.ckt
|
||||
share/examples/vipec/bandpass.ckt
|
||||
share/examples/vipec/bandpass2.ckt
|
||||
share/examples/vipec/bfr505.s2p
|
||||
share/examples/vipec/bandpass2.s2p
|
||||
share/examples/vipec/coupled.ckt
|
||||
share/examples/vipec/filter.ckt
|
||||
share/examples/vipec/group_delay.ckt
|
||||
share/examples/vipec/lna.ckt
|
||||
share/examples/vipec/mustrip.ckt
|
||||
share/examples/vipec/nec70000.s2p
|
||||
share/examples/vipec/slin_coupled.ckt
|
||||
share/examples/vipec/stripline.ckt
|
||||
share/examples/vipec/test.ckt
|
||||
share/examples/vipec/vhfrx1.ckt
|
||||
@dirrm share/doc/vipec/models
|
||||
@dirrm share/doc/vipec
|
||||
|
|
Loading…
Reference in a new issue