Move xpdf from graphics to print, per pkg/14154.

This commit is contained in:
wiz 2001-10-04 12:00:45 +00:00
parent 2007a944a4
commit 5e53178b75
9 changed files with 5 additions and 113 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.2 2001/09/27 23:17:50 jlam Exp $
# $NetBSD: Makefile,v 1.3 2001/10/04 12:00:45 wiz Exp $
#
DISTNAME= doc2html
@ -13,7 +13,7 @@ COMMENT= PERL external filter for htdig to convert numerous doc formats to HTML
DEPENDS+= xlHtml-[0-9]*:../../converters/xlHtml
DEPENDS+= rtf2html-[0-9]*:../../converters/rtf2html
DEPENDS+= ghostscript{,-nox11}-[6-9]*:../../print/ghostscript
DEPENDS+= xpdf-[0-9]*:../../graphics/xpdf
DEPENDS+= xpdf-[0-9]*:../../print/xpdf
DEPENDS+= catdoc-[0-9]*:../../textproc/catdoc
USE_PERL5= YES

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.159 2001/09/23 20:40:43 tron Exp $
# $NetBSD: Makefile,v 1.160 2001/10/04 12:00:45 wiz Exp $
#
COMMENT= Graphics tools and libraries
@ -152,7 +152,6 @@ SUBDIR+= xfig
SUBDIR+= xgraph
SUBDIR+= xli
SUBDIR+= xpaint
SUBDIR+= xpdf
SUBDIR+= xplot
SUBDIR+= xpm
SUBDIR+= xsane

View file

@ -1,45 +0,0 @@
# $NetBSD: Makefile,v 1.27 2001/09/27 23:18:14 jlam Exp $
# FreeBSD Id: Makefile,v 1.12 1998/03/11 03:08:12 vanilla Exp
#
DISTNAME= xpdf-0.92
CATEGORIES= graphics print
MASTER_SITES= ftp://ftp.foolabs.com/pub/xpdf/ \
${MASTER_SITE_SUNSITE:=apps/graphics/viewers/X/}
EXTRACT_SUFX= .tgz
MAINTAINER= packages@netbsd.org
HOMEPAGE= http://www.foolabs.com/xpdf/
COMMENT= Display tool for PDF files
DEPENDS+= ghostscript-fonts-[0-9]*:../../fonts/ghostscript-fonts
CONFLICTS= xpdf-crypto-[0-9]*
USE_BUILDLINK_ONLY= YES
USE_X11BASE= YES
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --enable-japanese
CONFIGURE_ARGS+= --enable-chinese
CONFIGURE_ARGS+= --with-freetype-includes=${BUILDLINK_DIR}/include
CONFIGURE_ARGS+= --with-t1-includes=${BUILDLINK_DIR}/include
CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS}"
MAKE_ENV+= SED="${SED}" ECHO="${ECHO}"
.include "../../mk/bsd.prefs.mk"
.if defined(PAPERSIZE) && ${PAPERSIZE} == "A4"
CONFIGURE_ARGS+= --enable-a4-paper
.endif
post-install:
${SED} -e "s|@@LOCALBASE@@|${LOCALBASE}|g" \
${FILESDIR}/xpdf-app-defaults \
> ${X11PREFIX}/lib/X11/app-defaults/Xpdf
.include "../../graphics/freetype-lib/buildlink.mk"
.include "../../graphics/xpm/buildlink.mk"
.include "../../textproc/t1lib/buildlink.mk"
.include "../../mk/x11.buildlink.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,5 +0,0 @@
$NetBSD: distinfo,v 1.2 2001/04/21 09:54:30 wiz Exp $
SHA1 (xpdf-0.92.tgz) = a3c1f2ffa9dffa64284106b00d10cf61c5ce22ce
Size (xpdf-0.92.tgz) = 917813 bytes
SHA1 (patch-aa) = dbac2c341499df0ab4c1e3e9c072eb14a5d78fed

View file

@ -1,16 +0,0 @@
xpdf.t1TimesRoman: @@LOCALBASE@@/share/ghostscript/fonts/n021003l.pfb
xpdf.t1TimesItalic: @@LOCALBASE@@/share/ghostscript/fonts/n021023l.pfb
xpdf.t1TimesBold: @@LOCALBASE@@/share/ghostscript/fonts/n021004l.pfb
xpdf.t1TimesBoldItalic: @@LOCALBASE@@/share/ghostscript/fonts/n021024l.pfb
xpdf.t1Helvetica: @@LOCALBASE@@/share/ghostscript/fonts/n019003l.pfb
xpdf.t1HelveticaOblique: @@LOCALBASE@@/share/ghostscript/fonts/n019023l.pfb
xpdf.t1HelveticaBold: @@LOCALBASE@@/share/ghostscript/fonts/n019004l.pfb
xpdf.t1HelveticaBoldOblique: @@LOCALBASE@@/share/ghostscript/fonts/n019024l.pfb
xpdf.t1Courier: @@LOCALBASE@@/share/ghostscript/fonts/n022003l.pfb
xpdf.t1CourierOblique: @@LOCALBASE@@/share/ghostscript/fonts/n022023l.pfb
xpdf.t1CourierBold: @@LOCALBASE@@/share/ghostscript/fonts/n022004l.pfb
xpdf.t1CourierBoldOblique: @@LOCALBASE@@/share/ghostscript/fonts/n022024l.pfb
xpdf.t1Symbol: @@LOCALBASE@@/share/ghostscript/fonts/s050000l.pfb
xpdf.t1ZapfDingbats: @@LOCALBASE@@/share/ghostscript/fonts/d050000l.pfb
xpdf.freeTypeControl: aa
xpdf.t1libControl: aa

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.3 2000/10/06 15:23:47 dmcmahill Exp $
Avoid a toolchain bug on mipsel noted in NetBSD-1.4.2/pmax
--- xpdf/Makefile.in.orig Tue Aug 15 01:01:52 2000
+++ xpdf/Makefile.in Fri Oct 6 10:27:43 2000
@@ -19,4 +19,7 @@
CXXFLAGS = @CXXFLAGS@ @DEFS@ @OPTIONS@ -I$(GOOSRCDIR) -I$(LTKSRCDIR) -I$(srcdir) @X_CFLAGS@ @Xpm_CFLAGS@ @t1_CFLAGS@ @freetype_CFLAGS@
+CXXFLAGS_NOOPT!= ${ECHO} ${CXXFLAGS} | ${SED} 's/-O[0-9]*//g'
+
+
LDFLAGS = @LDFLAGS@
@@ -258,4 +261,7 @@
config.h Params.h TextOutputDev.h OutputDev.h XOutputDev.h T1Font.h \
SFont.h TTFont.h XOutputFontInfo.h
+.if (${MACHINE_ARCH} == "mipsel")
+ ${CXX} ${CXXFLAGS_NOOPT} -c XOutputDev.cc
+.endif
XRef.o: ./XRef.cc ../goo/gmem.h Object.h ../goo/gtypes.h \
../goo/GString.h Array.h Dict.h Stream.h Lexer.h Parser.h Decrypt.h \

View file

@ -1,6 +0,0 @@
Xpdf is a viewer for Portable Document Format (PDF) files.
Xpdf is designed to be small and efficient. It runs under X,
but does not use the Motif or Xt libraries. Use of the T1 library
provides superior rendering of type 1 fonts, and also permits
run-time configuration of the exact fonts to be used.

View file

@ -1,14 +0,0 @@
@comment $NetBSD: PLIST,v 1.4 2000/08/21 06:49:17 fredb Exp $
bin/xpdf
bin/pdftops
bin/pdftotext
bin/pdfinfo
bin/pdftopbm
bin/pdfimages
man/man1/xpdf.1
man/man1/pdftops.1
man/man1/pdftotext.1
man/man1/pdfinfo.1
man/man1/pdftopbm.1
man/man1/pdfimages.1
lib/X11/app-defaults/Xpdf

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.59 2001/10/03 23:23:05 wiz Exp $
# $NetBSD: Makefile,v 1.60 2001/10/04 12:00:45 wiz Exp $
#
COMMENT= Desktop publishing
@ -51,6 +51,7 @@ SUBDIR+= teTeX-bin
SUBDIR+= teTeX-share
SUBDIR+= teTeX-sharesrc
SUBDIR+= transfig
SUBDIR+= xpdf
SUBDIR+= xpp
.include "../mk/bsd.pkg.subdir.mk"