Update ruby-xmlparser package to 0.6.8.1.
- Avoid C90'ism from code; content of patch-ab was merged.
This commit is contained in:
parent
62666dcc1f
commit
5e54cdfef0
3 changed files with 8 additions and 36 deletions
|
@ -1,15 +1,14 @@
|
|||
# $NetBSD: Makefile,v 1.4 2005/04/11 21:47:42 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.5 2005/06/25 02:34:27 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= xmlparser-0.6.8
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-xmlparser-0.6.8
|
||||
PKGREVISION= 2
|
||||
DISTNAME= xmlparser-0.6.8.1
|
||||
PKGNAME= ${RUBY_PKGPREFIX}-${DISTNAME}
|
||||
CATEGORIES= textproc ruby
|
||||
MASTER_SITES= http://www.yoshidam.net/
|
||||
|
||||
MAINTAINER= taca@NetBSD.org
|
||||
HOMEPAGE= http://www.yoshidam.net/Ruby.html#xmlparser
|
||||
COMMENT= expat interface module for Ruby
|
||||
COMMENT= Expat interface module for Ruby
|
||||
|
||||
RUBY_HAS_ARCHLIB= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
|
|
|
@ -1,7 +1,6 @@
|
|||
$NetBSD: distinfo,v 1.2 2005/02/24 14:48:49 agc Exp $
|
||||
$NetBSD: distinfo,v 1.3 2005/06/25 02:34:27 taca Exp $
|
||||
|
||||
SHA1 (ruby/xmlparser-0.6.8.tar.gz) = 9a53a7c576347ac8bccbc56fb55afef3fb32268d
|
||||
RMD160 (ruby/xmlparser-0.6.8.tar.gz) = 8f7531490dcc06eb99deb76bfbbe983d6a154046
|
||||
Size (ruby/xmlparser-0.6.8.tar.gz) = 140589 bytes
|
||||
SHA1 (ruby/xmlparser-0.6.8.1.tar.gz) = a392d1a65b9ddf1499fb55778595e14ee686ff80
|
||||
RMD160 (ruby/xmlparser-0.6.8.1.tar.gz) = 63841ebf9f259c683eab2ed03c17b2e479c73607
|
||||
Size (ruby/xmlparser-0.6.8.1.tar.gz) = 140667 bytes
|
||||
SHA1 (patch-aa) = caf2667257f38503b6ac5094b570d19f0d16eb69
|
||||
SHA1 (patch-ab) = 6f0f9ba927bc0ad1c2ece2c3a10875056b91cbfd
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2004/11/28 04:51:38 taca Exp $
|
||||
|
||||
--- xmlparser.c.orig Tue Apr 6 14:16:09 2004
|
||||
+++ xmlparser.c
|
||||
@@ -526,8 +526,9 @@ iterElementDeclHandler(void *recv,
|
||||
XML_Content *model)
|
||||
{
|
||||
XMLParser* parser;
|
||||
+ VALUE content;
|
||||
GET_PARSER(recv, parser);
|
||||
- VALUE content = makeContentArray(parser, model);
|
||||
+ content = makeContentArray(parser, model);
|
||||
rb_yield(rb_ary_new3(4, symELEMENT_DECL,
|
||||
TO_(rb_str_new2(name)),
|
||||
content, recv));
|
||||
@@ -929,8 +930,9 @@ myElementDeclHandler(void *recv,
|
||||
XML_Content *model)
|
||||
{
|
||||
XMLParser* parser;
|
||||
+ VALUE content;
|
||||
GET_PARSER(recv, parser);
|
||||
- VALUE content = makeContentArray(parser, model);
|
||||
+ content = makeContentArray(parser, model);
|
||||
rb_funcall((VALUE)recv, id_elementDeclHandler, 2,
|
||||
TO_(rb_str_new2(name)), content);
|
||||
}
|
Loading…
Reference in a new issue