Remove old TYPO3 (4.4.6) package in www/typo3_44.
It was intended to maintain pkgsrc-2010Q4 branch, but recent security problem has fixed as newer release (4.5) only. So, remove this directory.
This commit is contained in:
parent
a11edfc19c
commit
5e5a5b6b33
8 changed files with 0 additions and 6312 deletions
|
@ -1,24 +0,0 @@
|
|||
# $NetBSD: DEINSTALL,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
|
||||
TYPO3_DIR="@PREFIX@/@TYPO3DIR@"
|
||||
TYPO3_SITEDIR="${TYPO3_DIR}/@SITEDIR@"
|
||||
TYPO3_SUBDIRS="uploads/tf uploads/pics uploads/media uploads typo3temp \
|
||||
typo3conf/l10n typo3conf/ext typo3conf \
|
||||
fileadmin/user_upload/_temp_ fileadmin/user_upload fileadmin/_temp_ \
|
||||
fileadmin ${DIR}"
|
||||
|
||||
case ${STAGE} in
|
||||
DEINSTALL)
|
||||
(
|
||||
cd ${TYPO3_SITEDIR}
|
||||
${RM} -f typo3conf/ENABLE_INSTALL_TOOL
|
||||
${RM} -f typo3conf/temp*.php
|
||||
${RM} -fr typo3temp/*
|
||||
for d in ${TYPO3_SUBDIRS}; do
|
||||
test -d $d && ${RMDIR} $d 2>/dev/null
|
||||
done
|
||||
)
|
||||
${RMDIR} ${TYPO3_SITEDIR} 2>/dev/null
|
||||
${RMDIR} ${TYPO3_DIR} 2>/dev/null
|
||||
;;
|
||||
esac
|
|
@ -1,4 +0,0 @@
|
|||
TYPO3 is a free Open Source content management system for enterprise
|
||||
purposes on the web and in intranets. It offers full flexibility and
|
||||
extendability while featuring an accomplished set of ready-made
|
||||
interfaces, functions and modules.
|
|
@ -1,15 +0,0 @@
|
|||
===========================================================================
|
||||
$NetBSD: MESSAGE,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
|
||||
If you update from old release (4.2.3 or before), you will need to create
|
||||
a new encryption key.
|
||||
|
||||
(1) Upgrade to the new TYPO3 version.
|
||||
(2) Clear the configuration cache
|
||||
(3) Open the install tool and choose menu 1 ("Basic Configuration").
|
||||
(4) Scroll to the bottom of the page and click on the button
|
||||
"Generate random key".
|
||||
(5) Submit the form by clicking on "Update localconf.php".
|
||||
(6) Clear the configuration and page cache again.
|
||||
|
||||
===========================================================================
|
|
@ -1,97 +0,0 @@
|
|||
# $NetBSD: Makefile,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
#
|
||||
|
||||
DISTNAME= ${TYPO3NAME}
|
||||
PKGNAME= typo3-${VER}
|
||||
CATEGORIES= www
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=typo3/}
|
||||
DISTFILES= ${TYPO3NAME}${EXTRACT_SUFX} ${SITESRC}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= taca@NetBSD.org
|
||||
HOMEPAGE= http://typo3.com/
|
||||
COMMENT= The typo3 content management system
|
||||
LICENSE= gnu-gpl-v2
|
||||
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-{mysql,pgsql}>=5.1.0:../../databases/php-mysql
|
||||
DEPENDS+= ${PHP_PKG_PREFIX}-zlib>=5.2.0:../../archivers/php-zlib/
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
VER= 4.4.6
|
||||
NO_BUILD= yes
|
||||
USE_TOOLS= pax
|
||||
|
||||
TYPO3NAME= typo3_src-${VER}
|
||||
SITESRC= dummy-${VER}
|
||||
|
||||
# maybe resides in lang/php/phpversion.mk
|
||||
REPLACE_INTERPRETER+= php
|
||||
REPLACE.php.old= .*php[^ ]*
|
||||
REPLACE.php.new= ${PREFIX}/bin/php
|
||||
REPLACE_FILES.php= typo3/cli_dispatch.phpsh \
|
||||
typo3/mod/user/ws/cli/ws_cli.phpsh \
|
||||
typo3/sysext/indexed_search/cli/indexer_cli.phpsh
|
||||
|
||||
TYPO3DATADIR= fileadmin fileadmin/_temp_ fileadmin/user_upload \
|
||||
typo3conf typo3conf/ext typo3conf/l10n typo3temp uploads \
|
||||
uploads/media uploads/pics uploads/tf
|
||||
|
||||
BUILD_DEFS+= APACHE_GROUP
|
||||
|
||||
FILES_SUBST+= TYPO3DIR=${TYPO3DIR:Q} SITEDIR=${SITEDIR:Q}
|
||||
PLIST_SUBST+= EGDIR=${EGDIR:Q} SITEDIR=${SITEDIR:Q} \
|
||||
TYPO3DIR=${TYPO3DIR:Q} TYPO3NAME=${TYPO3NAME:Q}
|
||||
|
||||
EGDIR= share/examples/typo3
|
||||
|
||||
INSTALLATION_DIRS+= ${EGDIR} ${TYPO3DIR}/${SITEDIR} ${TYPO3DIR}/${TYPO3NAME}
|
||||
|
||||
CONF_FILES_PERMS+= ${EGDIR}/localconf.php \
|
||||
${TYPO3DIR}/${SITEDIR}/typo3conf/localconf.php \
|
||||
${REAL_ROOT_USER} ${APACHE_GROUP} 0660
|
||||
|
||||
.for d in ${TYPO3DATADIR}
|
||||
OWN_DIRS_PERMS+= ${TYPO3DIR}/${SITEDIR}/${d} ${REAL_ROOT_USER} \
|
||||
${APACHE_GROUP} 0770
|
||||
CHECK_PERMS_SKIP+= ${TYPO3DIR}/${SITEDIR}/${d}
|
||||
.endfor
|
||||
|
||||
SUBST_CLASSES+= conf
|
||||
SUBST_FILES.conf+= ${WRKDIR}/README
|
||||
SUBST_FILES.conf+= ${WRKSRC}/t3lib/config_default.php
|
||||
SUBST_SED.conf+= -e 's|@PREFIX@|${PREFIX:Q}|g'
|
||||
SUBST_SED.conf+= -e 's|@TYPO3DIR@|${TYPO3DIR:Q}|g'
|
||||
SUBST_SED.conf+= -e 's|@SITEDIR@|${SITEDIR:Q}|g'
|
||||
SUBST_STAGE.conf= post-configure
|
||||
|
||||
PRINT_PLIST_AWK+= /^${EGDIR:S|/|\\/|g}/ \
|
||||
{ gsub(/${EGDIR:S|/|\\/|g}/, "$${EGDIR}") }
|
||||
PRINT_PLIST_AWK+= /^${TYPO3DIR:S|/|\\/|g}\/${TYPO3NAME}/ \
|
||||
{ gsub(/${TYPO3DIR:S|/|\\/|g}\/${TYPO3NAME}/, \
|
||||
"$${TYPO3DIR}/$${TYPO3NAME}") }
|
||||
PRINT_PLIST_AWK+= /^${TYPO3DIR:S|/|\\/|g}\/${SITEDIR}/ \
|
||||
{ gsub(/${TYPO3DIR:S|/|\\/|g}\/${SITEDIR}/, \
|
||||
"$${TYPO3DIR}/$${SITEDIR}") }
|
||||
|
||||
.include "../../mk/bsd.prefs.mk"
|
||||
|
||||
SITEDIR?= www
|
||||
TYPO3DIR?= share/typo3
|
||||
|
||||
post-extract:
|
||||
${CP} ${FILESDIR}/README ${WRKDIR}
|
||||
|
||||
pre-install:
|
||||
${FIND} ${WRKSRC:Q} -name "*.orig*" -exec ${RM} -f {} \;
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}; \
|
||||
pax -rw . ${DESTDIR}${PREFIX}/${TYPO3DIR}/${TYPO3NAME}
|
||||
cd ${WRKDIR}/${SITESRC}; \
|
||||
pax -rw . ${DESTDIR}${PREFIX}/${TYPO3DIR}/${SITEDIR}
|
||||
${RM} -f ${DESTDIR}${PREFIX}/${TYPO3DIR}/${SITEDIR}/typo3conf/localconf.php
|
||||
${INSTALL_DATA} ${WRKDIR}/${SITESRC}/typo3conf/localconf.php \
|
||||
${DESTDIR}${PREFIX}/${EGDIR}
|
||||
|
||||
.include "../../lang/php/phpversion.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
6132
www/typo3_44/PLIST
6132
www/typo3_44/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,9 +0,0 @@
|
|||
$NetBSD: distinfo,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
|
||||
SHA1 (dummy-4.4.6.tar.gz) = 408fe168155daa45d3aeee70650576217d727522
|
||||
RMD160 (dummy-4.4.6.tar.gz) = 8b4b15d639c02e405db26b07b1cd6fb3a51ee812
|
||||
Size (dummy-4.4.6.tar.gz) = 9763 bytes
|
||||
SHA1 (typo3_src-4.4.6.tar.gz) = 0728827dae0e204beb3fa46773ba4b7acf4aff4c
|
||||
RMD160 (typo3_src-4.4.6.tar.gz) = c7c1887530b2eb390bd2796b1041755de5fddf23
|
||||
Size (typo3_src-4.4.6.tar.gz) = 18540098 bytes
|
||||
SHA1 (patch-aa) = 95de6e8e518ec9b8c0227d75fa0cc85ab63ae1cb
|
|
@ -1,14 +0,0 @@
|
|||
$NetBSD: README,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
|
||||
1. Set up typo3; Add below line in your httpd.conf.
|
||||
|
||||
Alias /typo3 @PREFIX@/@TYPO3DIR@/@SITEDIR@
|
||||
|
||||
Or set DocumentRoot to @PREFIX@/@TYPO3DIR@/@SITEDIR@.
|
||||
|
||||
2. First, enable TYPO3 installer.
|
||||
|
||||
# cp /dev/null @PREFIX@/@TYPO3DIR@/@SITEDIR@/typo3conf/ENABLE_INSTALL_TOOL
|
||||
|
||||
3. Access typo3 site. You will be redirected to installer.
|
||||
|
|
@ -1,17 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1.1.1 2011/02/07 12:51:17 taca Exp $
|
||||
|
||||
Better default path.
|
||||
|
||||
--- t3lib/config_default.php.orig 2010-07-28 09:32:12.000000000 +0000
|
||||
+++ t3lib/config_default.php
|
||||
@@ -35,8 +35,8 @@ $TYPO3_CONF_VARS = array(
|
||||
'gdlib_png' => FALSE, // Boolean. Enables the use of GD, with PNG only. This means that all items normally generated as gif-files will be png-files instead!
|
||||
|
||||
'im' => TRUE, // Boolean. Enables the use of IM.
|
||||
- 'im_path' => '/usr/X11R6/bin/', // Path to the IM tools 'convert', 'combine', 'identify'.
|
||||
- 'im_path_lzw' => '/usr/bin/', // Path to the IM tool 'convert' with LZW enabled! See 'gif_compress'. If your version 4.2.9 of ImageMagick is compiled with LZW you may leave this field blank AND disable the flag 'gif_compress'! Tip: You can call LZW 'convert' with a prefix like 'myver_convert' by setting this path with it, eg. '/usr/bin/myver_' instead of just '/usr/bin/'.
|
||||
+ 'im_path' => '@PREFIX@/bin/', // Path to the IM tools 'convert', 'combine', 'identify'.
|
||||
+ 'im_path_lzw' => '@PREFIX@/bin/', // Path to the IM tool 'convert' with LZW enabled! See 'gif_compress'. If your version 4.2.9 of ImageMagick is compiled with LZW you may leave this field blank AND disable the flag 'gif_compress'! Tip: You can call LZW 'convert' with a prefix like 'myver_convert' by setting this path with it, eg. '/usr/bin/myver_' instead of just '/usr/bin/'.
|
||||
|
||||
'im_version_5' => '', // String. Set this if you're using ImageMagick/GraphicsMagick but not IM 4.x. Setting this value will automatically configure some settings for use with the specified program version. Allowed values are: "im4", "im5", "im6" and "gm" (uses GraphicsMagick instead of ImageMagick).
|
||||
'im_negate_mask' => FALSE, // Boolean. Indicates if the mask images should be inverted first. This depends of the ImageMagick version. Below ver. 5.1 this should be false. Above ImageMagick version 5.2+ it should be true. Just set the flag if the masks works opposite the intension!
|
Loading…
Reference in a new issue