Update to 1.2.15:

version 1.2.15beta1 [December 3, 2006]
  Generated configure with autoconf-2.61 instead of 2.60
  Revised configure.ac to update libpng.pc and libpng-config.

version 1.2.15beta2 [December 3, 2006]
  Always export MMX asm functions, just stubs if not building pnggccrd.c

version 1.2.15beta3 [December 4, 2006]
  Add "png_bytep" typecast to profile while calculating length in pngwutil.c

version 1.2.15beta4 [December 7, 2006]
  Added scripts/CMakeLists.txt
  Changed PNG_NO_ASSEMBLER_CODE to PNG_NO_MMX_CODE in scripts, like 1.4.0beta

version 1.2.15beta5 [December 7, 2006]
  Changed some instances of PNG_ASSEMBLER_* to PNG_MMX_* in pnggccrd.c
  Revised scripts/CMakeLists.txt

version 1.2.15beta6 [December 13, 2006]
  Revised scripts/CMakeLists.txt and configure.ac

version 1.2.15rc1 [December 18, 2006]
  Revised scripts/CMakeLists.txt

version 1.2.15rc2 [December 21, 2006]
  Added conditional #undef jmpbuf in pngtest.c to undo #define in AIX headers.
  Added scripts/makefile.nommx

version 1.2.15rc3 [December 25, 2006]
  Fixed shared library numbering error that was intruduced in 1.2.15beta6.

version 1.2.15rc4 [December 27, 2006]
  Fixed handling of rgb_to_gray when png_ptr->color.gray isn't set.

version 1.2.15rc5 [December 31, 2006]
  Revised handling of rgb_to_gray.

version 1.2.15 [January 5, 2007]
  Added some (unsigned long) typecasts in pngtest.c to avoid printing errors.
This commit is contained in:
wiz 2007-01-06 21:48:50 +00:00
parent 580849be19
commit 5e7908cb5b
3 changed files with 6 additions and 45 deletions

View file

@ -1,16 +1,13 @@
# $NetBSD: Makefile,v 1.88 2007/01/03 20:38:46 rillig Exp $
# $NetBSD: Makefile,v 1.89 2007/01/06 21:48:50 wiz Exp $
DISTNAME= libpng-1.2.14
DISTNAME= libpng-1.2.15
PKGNAME= ${DISTNAME:S/lib//}
PKGREVISION= 1
# temporary, distfile was changed after release
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libpng/} \
http://www.libpng.org/pub/png/src/ \
ftp://swrinde.nde.swri.edu/pub/png/src/ \
ftp://ftp.simplesystems.org/pub/libpng/src/ \
ftp://ftp.fu-berlin.de/unix/graphics/png/src/
DIST_SUBDIR= libpng-1.2.14-20061130
EXTRACT_SUFX= .tar.bz2
MAINTAINER= fredb@NetBSD.org

View file

@ -1,9 +1,8 @@
$NetBSD: distinfo,v 1.35 2007/01/03 16:23:10 tv Exp $
$NetBSD: distinfo,v 1.36 2007/01/06 21:48:50 wiz Exp $
SHA1 (libpng-1.2.14-20061130/libpng-1.2.14.tar.bz2) = 3cf3efcada7896982b165ea34ed6b399ef7fb4af
RMD160 (libpng-1.2.14-20061130/libpng-1.2.14.tar.bz2) = 37c91bc411a8c4bc467bb8b229a4e39bcca4bd8a
Size (libpng-1.2.14-20061130/libpng-1.2.14.tar.bz2) = 620379 bytes
SHA1 (libpng-1.2.15.tar.bz2) = a561350b588c7997b107a3417b56a725b5dc5af7
RMD160 (libpng-1.2.15.tar.bz2) = 3fb0dcb7764c0fcb7bf349a617f3463869177aab
Size (libpng-1.2.15.tar.bz2) = 624008 bytes
SHA1 (patch-aa) = 4b6437906e6f2f644c731a293859e64f69300bb0
SHA1 (patch-ab) = 979175c65587686b339a5556e8bcae3be95a07ca
SHA1 (patch-ac) = 87850d6ac555f1d8863a96d287a1ccccfa89230b
SHA1 (patch-ae) = b9bf9de3caa32ac78a17685cdd5df5b80d1ccbbf

View file

@ -1,35 +0,0 @@
$NetBSD: patch-ab,v 1.10 2006/04/16 19:39:46 wiz Exp $
--- pngtest.c.orig 2006-04-14 11:22:24.000000000 +0000
+++ pngtest.c
@@ -576,7 +576,7 @@ png_debug_free(png_structp png_ptr, png_
}
if (pinfo->next == NULL)
{
- fprintf(STDERR, "Pointer %x not found\n", (unsigned int)ptr);
+ fprintf(STDERR, "Pointer %p not found\n", ptr);
break;
}
ppinfo = &pinfo->next;
@@ -1433,8 +1433,8 @@ main(int argc, char *argv[])
current_allocation);
while (pinfo != NULL)
{
- fprintf(STDERR, " %lu bytes at %x\n", pinfo->size,
- (unsigned int) pinfo->pointer);
+ fprintf(STDERR, " %lu bytes at %p\n", pinfo->size,
+ pinfo->pointer);
pinfo = pinfo->next;
}
}
@@ -1508,8 +1508,8 @@ main(int argc, char *argv[])
current_allocation);
while (pinfo != NULL)
{
- fprintf(STDERR," %lu bytes at %x\n",
- pinfo->size, (unsigned int)pinfo->pointer);
+ fprintf(STDERR," %lu bytes at %p\n",
+ pinfo->size, pinfo->pointer);
pinfo = pinfo->next;
}
}