Fix configure script to cope with hesiod in libc as well as in -lhesiod.
This commit is contained in:
parent
fad75985f7
commit
5eb9b486dc
3 changed files with 110 additions and 1 deletions
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/10/29 21:53:10 tnn Exp $
|
||||
$NetBSD: distinfo,v 1.7 2011/10/08 05:56:00 dholland Exp $
|
||||
|
||||
SHA1 (zephyr-20010518.tar.gz) = cd2fca9c2f0bfaa8e69c94813bedc87d66d3ac1c
|
||||
RMD160 (zephyr-20010518.tar.gz) = 1082db0df40e4ac1007e4b2b4f8adc15cf8a8ab0
|
||||
Size (zephyr-20010518.tar.gz) = 342259 bytes
|
||||
SHA1 (patch-aa) = f4338f0da9085e1780c52c9b2be2366b7a0f22c2
|
||||
SHA1 (patch-ab) = 61cbadf511806c1c16e489ac6d14de347b09277a
|
||||
SHA1 (patch-aclocal_m4) = 5414d637ec7de322cbf27c211345df241a914df1
|
||||
SHA1 (patch-ad) = b0f8c408afc2e7fe9a673a5f2ec562a3e34e225c
|
||||
SHA1 (patch-ae) = e0d0776b891db5b8542285899e22c886337cc6c7
|
||||
SHA1 (patch-af) = 4ebb22fa3c1b2ed351ee267be737d34d8292129c
|
||||
|
@ -16,3 +17,4 @@ SHA1 (patch-ak) = 7c2084aac1e4b30124c380fbc369cb6a6b41eb17
|
|||
SHA1 (patch-al) = d61151a84bb9a55c21b2d757650064390127f8c8
|
||||
SHA1 (patch-am) = 40fc00c67f78485b0d45a86ab97aa8ae662dda40
|
||||
SHA1 (patch-an) = 94556f92c2d00b4a9d26a230259e28d72b70a1f4
|
||||
SHA1 (patch-configure) = bc6604cfa9aa8f652336165e0bbe0e02686e1a88
|
||||
|
|
27
chat/zephyr/patches/patch-aclocal_m4
Normal file
27
chat/zephyr/patches/patch-aclocal_m4
Normal file
|
@ -0,0 +1,27 @@
|
|||
$NetBSD: patch-aclocal_m4,v 1.1 2011/10/08 05:56:00 dholland Exp $
|
||||
|
||||
Cope with hesiod in libc as well as in -lhesiod.
|
||||
|
||||
--- aclocal.m4.orig 2001-05-18 20:41:37.000000000 +0000
|
||||
+++ aclocal.m4
|
||||
@@ -273,8 +273,10 @@ if test "$hesiod" != yes; then
|
||||
CPPFLAGS="$CPPFLAGS -I$hesiod/include"
|
||||
LDFLAGS="$LDFLAGS -L$hesiod/lib"
|
||||
fi
|
||||
-AC_CHECK_LIB(hesiod, hes_resolve, :,
|
||||
- [AC_MSG_ERROR(Hesiod library not found)])])
|
||||
+AC_CHECK_FUNC(hes_resolve, HESIOD_LIBS=,
|
||||
+ AC_CHECK_LIB(hesiod, hes_resolve, HESIOD_LIBS="-lhesiod":,
|
||||
+ [AC_MSG_ERROR(Hesiod library not found)]))
|
||||
+])
|
||||
|
||||
AC_DEFUN(ATHENA_HESIOD,
|
||||
[AC_ARG_WITH(hesiod,
|
||||
@@ -282,7 +284,6 @@ AC_DEFUN(ATHENA_HESIOD,
|
||||
[hesiod="$withval"], [hesiod=no])
|
||||
if test "$hesiod" != no; then
|
||||
ATHENA_HESIOD_CHECK
|
||||
- HESIOD_LIBS="-lhesiod"
|
||||
AC_DEFINE(HAVE_HESIOD)
|
||||
fi
|
||||
AC_SUBST(HESIOD_LIBS)])
|
80
chat/zephyr/patches/patch-configure
Normal file
80
chat/zephyr/patches/patch-configure
Normal file
|
@ -0,0 +1,80 @@
|
|||
$NetBSD: patch-configure,v 1.1 2011/10/08 05:56:00 dholland Exp $
|
||||
|
||||
Regenerate after patching aclocal.m4.
|
||||
|
||||
--- configure.orig 2001-05-18 20:41:38.000000000 +0000
|
||||
+++ configure
|
||||
@@ -3354,8 +3354,54 @@ if test "$hesiod" != yes; then
|
||||
CPPFLAGS="$CPPFLAGS -I$hesiod/include"
|
||||
LDFLAGS="$LDFLAGS -L$hesiod/lib"
|
||||
fi
|
||||
+echo $ac_n "checking for hes_resolve""... $ac_c" 1>&6
|
||||
+echo "configure:3359: checking for hes_resolve" >&5
|
||||
+if eval "test \"`echo '$''{'ac_cv_func_hes_resolve'+set}'`\" = set"; then
|
||||
+ echo $ac_n "(cached) $ac_c" 1>&6
|
||||
+else
|
||||
+ cat > conftest.$ac_ext <<EOF
|
||||
+#line 3364 "configure"
|
||||
+#include "confdefs.h"
|
||||
+/* System header to define __stub macros and hopefully few prototypes,
|
||||
+ which can conflict with char hes_resolve(); below. */
|
||||
+#include <assert.h>
|
||||
+/* Override any gcc2 internal prototype to avoid an error. */
|
||||
+/* We use char because int might match the return type of a gcc2
|
||||
+ builtin and then its argument prototype would still apply. */
|
||||
+char hes_resolve();
|
||||
+
|
||||
+int main() {
|
||||
+
|
||||
+/* The GNU C library defines this for functions which it implements
|
||||
+ to always fail with ENOSYS. Some functions are actually named
|
||||
+ something starting with __ and the normal name is an alias. */
|
||||
+#if defined (__stub_hes_resolve) || defined (__stub___hes_resolve)
|
||||
+choke me
|
||||
+#else
|
||||
+hes_resolve();
|
||||
+#endif
|
||||
+
|
||||
+; return 0; }
|
||||
+EOF
|
||||
+if { (eval echo configure:3387: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_func_hes_resolve=yes"
|
||||
+else
|
||||
+ echo "configure: failed program was:" >&5
|
||||
+ cat conftest.$ac_ext >&5
|
||||
+ rm -rf conftest*
|
||||
+ eval "ac_cv_func_hes_resolve=no"
|
||||
+fi
|
||||
+rm -f conftest*
|
||||
+fi
|
||||
+
|
||||
+if eval "test \"`echo '$ac_cv_func_'hes_resolve`\" = yes"; then
|
||||
+ echo "$ac_t""yes" 1>&6
|
||||
+ HESIOD_LIBS=
|
||||
+else
|
||||
+ echo "$ac_t""no" 1>&6
|
||||
echo $ac_n "checking for hes_resolve in -lhesiod""... $ac_c" 1>&6
|
||||
-echo "configure:3359: checking for hes_resolve in -lhesiod" >&5
|
||||
+echo "configure:3405: checking for hes_resolve in -lhesiod" >&5
|
||||
ac_lib_var=`echo hesiod'_'hes_resolve | sed 'y%./+-%__p_%'`
|
||||
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
@@ -3389,13 +3435,15 @@ LIBS="$ac_save_LIBS"
|
||||
fi
|
||||
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
|
||||
echo "$ac_t""yes" 1>&6
|
||||
- :
|
||||
+ HESIOD_LIBS="-lhesiod":
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
{ echo "configure: error: Hesiod library not found" 1>&2; exit 1; }
|
||||
fi
|
||||
|
||||
- HESIOD_LIBS="-lhesiod"
|
||||
+fi
|
||||
+
|
||||
+
|
||||
cat >> confdefs.h <<\EOF
|
||||
#define HAVE_HESIOD 1
|
||||
EOF
|
Loading…
Reference in a new issue