Reorder "#include" statements and include "string.h" in various files
to make this build with GCC 4.x.
This commit is contained in:
parent
88c1ab479c
commit
5ee779e705
8 changed files with 115 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.9 2006/01/13 02:02:50 joerg Exp $
|
||||
$NetBSD: distinfo,v 1.10 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
SHA1 (xgalaga-2.0.34.tar.gz) = 82dcb328af0d9e779c566f4225d7f072b1c17b7d
|
||||
RMD160 (xgalaga-2.0.34.tar.gz) = bf2cc91820c1cdb8e02bd35347b309cac27b3ba4
|
||||
|
@ -7,3 +7,10 @@ SHA1 (patch-aa) = 5857b8641701bc34a97fbca31411478c0c47501a
|
|||
SHA1 (patch-ab) = 75c407d95d4ab4b7dad6625050439eda5a012839
|
||||
SHA1 (patch-ac) = ca85bafaa637fc03d1c53a527c7804a95c146fe3
|
||||
SHA1 (patch-ad) = 22b946b261c4d0969e48bf5de1ba0d55c3649bb8
|
||||
SHA1 (patch-ae) = 2e9f31a279aa5ecd14a0843dc18d151e7990aed0
|
||||
SHA1 (patch-af) = 83856e8718bcbe6f40b4c156199c4db56cdf8777
|
||||
SHA1 (patch-ag) = 0e4270a29bac33ae21e5a837feb7fe87fa650173
|
||||
SHA1 (patch-ah) = 88bb0385cc1091eae83475fa26296419095f10a6
|
||||
SHA1 (patch-ai) = 21dc08a4d6d04fca2a374034b79de8ab9c953793
|
||||
SHA1 (patch-aj) = d1577211627e280aef977ff7c1cf2b48c02f1c3f
|
||||
SHA1 (patch-ak) = ef0077094fb3814c0b83f8dd274dc620e8e34f61
|
||||
|
|
13
games/xgalaga/patches/patch-ae
Normal file
13
games/xgalaga/patches/patch-ae
Normal file
|
@ -0,0 +1,13 @@
|
|||
$NetBSD: patch-ae,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- libsprite/data.h.orig 1998-04-12 07:03:22.000000000 +0100
|
||||
+++ libsprite/data.h 2006-07-02 15:26:28.000000000 +0100
|
||||
@@ -10,6 +10,8 @@
|
||||
#include <assert.h>
|
||||
#include <string.h>
|
||||
|
||||
+#include "struct.h"
|
||||
+
|
||||
#ifdef XPM
|
||||
#ifdef HACKED_XPMLIB
|
||||
#include "xpmlib-3.4b/xpm.h"
|
24
games/xgalaga/patches/patch-af
Normal file
24
games/xgalaga/patches/patch-af
Normal file
|
@ -0,0 +1,24 @@
|
|||
$NetBSD: patch-af,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- main.c.orig 1998-05-11 07:52:59.000000000 +0100
|
||||
+++ main.c 2006-07-02 15:28:05.000000000 +0100
|
||||
@@ -7,6 +7,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#ifdef HAVE_SYS_TIME_H
|
||||
#include <sys/time.h>
|
||||
#endif
|
||||
@@ -14,10 +15,10 @@
|
||||
# include <unistd.h>
|
||||
#endif
|
||||
#include "libsprite/Wlib.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "images.h"
|
||||
#include "defs.h"
|
||||
-#include "struct.h"
|
||||
#include "paths.h"
|
||||
#include "proto.h"
|
||||
#include "sound.h"
|
14
games/xgalaga/patches/patch-ag
Normal file
14
games/xgalaga/patches/patch-ag
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ag,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- data.c.orig 1998-05-11 07:37:19.000000000 +0100
|
||||
+++ data.c 2006-07-02 15:30:36.000000000 +0100
|
||||
@@ -5,8 +5,8 @@
|
||||
#include "Wlib.h"
|
||||
#include "images.h"
|
||||
#include "defs.h"
|
||||
-#include "data.h"
|
||||
#include "struct.h"
|
||||
+#include "data.h"
|
||||
|
||||
int buttonDown = 0;
|
||||
|
12
games/xgalaga/patches/patch-ah
Normal file
12
games/xgalaga/patches/patch-ah
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ah,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- pathfile.c.orig 1998-04-30 06:11:56.000000000 +0100
|
||||
+++ pathfile.c 2006-07-02 15:31:23.000000000 +0100
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#include "paths.h"
|
||||
#include "pathfile.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "defs.h"
|
||||
|
14
games/xgalaga/patches/patch-ai
Normal file
14
games/xgalaga/patches/patch-ai
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-ai,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- title.c.orig 1998-05-11 07:52:59.000000000 +0100
|
||||
+++ title.c 2006-07-02 15:32:19.000000000 +0100
|
||||
@@ -7,8 +7,8 @@
|
||||
#include "Wlib.h"
|
||||
#include "defs.h"
|
||||
#include "images.h"
|
||||
-#include "data.h"
|
||||
#include "struct.h"
|
||||
+#include "data.h"
|
||||
#include "proto.h"
|
||||
|
||||
W_Image *pauseImage, *titleImage;
|
18
games/xgalaga/patches/patch-aj
Normal file
18
games/xgalaga/patches/patch-aj
Normal file
|
@ -0,0 +1,18 @@
|
|||
$NetBSD: patch-aj,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- score.c.orig 1998-04-30 06:11:58.000000000 +0100
|
||||
+++ score.c 2006-07-02 15:33:07.000000000 +0100
|
||||
@@ -4,11 +4,12 @@
|
||||
|
||||
#include <config.h>
|
||||
#include <stdio.h>
|
||||
+#include <string.h>
|
||||
#include "Wlib.h"
|
||||
#include "images.h"
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
#include "defs.h"
|
||||
-#include "struct.h"
|
||||
#include "proto.h"
|
||||
|
||||
char scorestr[40] = "Score: 0000000", shipstr[4] ="";
|
12
games/xgalaga/patches/patch-ak
Normal file
12
games/xgalaga/patches/patch-ak
Normal file
|
@ -0,0 +1,12 @@
|
|||
$NetBSD: patch-ak,v 1.1 2006/07/02 14:36:19 tron Exp $
|
||||
|
||||
--- sound.c.orig 1998-04-12 07:03:21.000000000 +0100
|
||||
+++ sound.c 2006-07-02 15:33:52.000000000 +0100
|
||||
@@ -24,6 +24,7 @@
|
||||
#endif
|
||||
#include <signal.h>
|
||||
#include <sys/stat.h>
|
||||
+#include "struct.h"
|
||||
#include "data.h"
|
||||
|
||||
|
Loading…
Reference in a new issue