PR pkg/47792
Correct install PREFIX found on Modules/CMakeGenericSystem.cmake. The example of problem was found on wip/trustedQSL (1.14)
This commit is contained in:
parent
5304cb6831
commit
5f2811ec33
3 changed files with 25 additions and 3 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.70 2013/03/04 10:01:13 roy Exp $
|
||||
# $NetBSD: Makefile,v 1.71 2013/05/03 00:58:05 mef Exp $
|
||||
|
||||
DISTNAME= cmake-${CMAKE_API}.10
|
||||
PKGREVISION= 4
|
||||
PKGREVISION= 5
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= http://www.cmake.org/files/v${CMAKE_API}/
|
||||
|
||||
|
@ -47,6 +47,12 @@ SUBST_FILES.cmake+= Modules/FindX11.cmake
|
|||
SUBST_FILES.cmake+= Modules/Platform/UnixPaths.cmake
|
||||
SUBST_VARS.cmake= LOCALBASE X11BASE
|
||||
|
||||
SUBST_CLASSES+= prefix
|
||||
SUBST_STAGE.prefix= pre-configure
|
||||
SUBST_MESSAGE.prefix= Fixing PREFIX path.
|
||||
SUBST_FILES.prefix+= Modules/CMakeGenericSystem.prefix
|
||||
SUBST_VARS.prefix= PREFIX
|
||||
|
||||
SUBST_CLASSES+= flags
|
||||
SUBST_STAGE.flags= pre-configure
|
||||
SUBST_MESSAGE.flags= Fixing compiler flags.
|
||||
|
|
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.43 2013/02/16 11:40:37 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.44 2013/05/03 00:58:06 mef Exp $
|
||||
|
||||
SHA1 (cmake-2.8.10.tar.gz) = 6384f2295d01f04d017e2701447378598b4c7223
|
||||
RMD160 (cmake-2.8.10.tar.gz) = 9af9e3f26f0f3d827ef566f99050fe6a2721dd25
|
||||
Size (cmake-2.8.10.tar.gz) = 5766728 bytes
|
||||
SHA1 (patch-Modules_CMakeGenericSystem.cmake) = 86fd39261d6788787a44515094e6c38451699e64
|
||||
SHA1 (patch-Modules_FindPNG.cmake) = 55de08bb7882bc98c78dcad0d1aa7016b4b03564
|
||||
SHA1 (patch-Modules_FindX11.cmake) = e5c9f5fd382effb85ae75fe603de00e5e58d788a
|
||||
SHA1 (patch-Modules_Platform_SunOS.cmake) = 7a53ae3c902dd69ee22ef9fe0ae2a022d5284f16
|
||||
|
|
15
devel/cmake/patches/patch-Modules_CMakeGenericSystem.cmake
Normal file
15
devel/cmake/patches/patch-Modules_CMakeGenericSystem.cmake
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Modules_CMakeGenericSystem.cmake,v 1.1 2013/05/03 00:58:07 mef Exp $
|
||||
|
||||
Correct Install PREFIX, see SUBST_CLASSES+= prefix in Makefile
|
||||
|
||||
--- Modules/CMakeGenericSystem.cmake.orig 2012-11-01 00:32:05.000000000 +0900
|
||||
+++ Modules/CMakeGenericSystem.cmake 2013-05-01 23:45:47.000000000 +0900
|
||||
@@ -166,7 +166,7 @@ endif()
|
||||
|
||||
# Choose a default install prefix for this platform.
|
||||
if(CMAKE_HOST_UNIX)
|
||||
- set(CMAKE_INSTALL_PREFIX "/usr/local"
|
||||
+ set(CMAKE_INSTALL_PREFIX "@PREFIX@"
|
||||
CACHE PATH "Install path prefix, prepended onto install directories.")
|
||||
else()
|
||||
GetDefaultWindowsPrefixBase(CMAKE_GENERIC_PROGRAM_FILES)
|
Loading…
Reference in a new issue