Fix build failure (set_debug_log_from_config)

This commit is contained in:
dholland 2012-06-16 05:34:31 +00:00
parent ab347f4c1e
commit 5f4f5a7f4d
2 changed files with 17 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.28 2012/05/12 05:44:46 adam Exp $
$NetBSD: distinfo,v 1.29 2012/06/16 05:34:31 dholland Exp $
SHA1 (jabberd-2.2.16.tar.gz) = d39f7475ec676a127e948f2c5f73d7605ec5a7f9
RMD160 (jabberd-2.2.16.tar.gz) = c778babd0a883506f874dff56f879f800533e73c
@ -7,3 +7,4 @@ SHA1 (patch-Makefile.in) = 10d7ad04ee5c0844e948f0302420a77a89c05b08
SHA1 (patch-configure) = cf61b12c93c94e167c710a776128b73bb91ce0c3
SHA1 (patch-s2s_out.c) = 89580485bc82ce57e22c382eb464b60c3820f346
SHA1 (patch-sm_mod_roster.c) = f43d80c2abfd31d99016b4738a717d3c6db183ce
SHA1 (patch-util_log_c) = acc4f8747976ac189ccd95b9a3b5809887da4a32

View file

@ -0,0 +1,15 @@
$NetBSD: patch-util_log_c,v 1.1 2012/06/16 05:34:31 dholland Exp $
Provide set_debug_log_from_config() when DEBUG is turned off; avoids
link failure.
--- util/log.c~ 2012-05-04 14:51:08.000000000 +0000
+++ util/log.c
@@ -263,4 +263,7 @@ void debug_log(const char *file, int lin
void set_debug_flag(int v)
{ }
+
+int set_debug_log_from_config(config_t c)
+{ return 0; }
#endif