From pkgsrc-wip and originally packaged by

Bruce J.A. Nourish. Thank you, Bruce.

The foomatic-filters package provides foomatic-rip and foomatic-gswrapper.

foomatic-rip uses an external renderer (like GhostScript) to
translate PostScript to printer's native language. The printer
capabilities are described in PPD files.  foomatic-rip works with
every known spooler.

foomatic-gswrapper massages arguments to make Ghostscript execute
properly as a filter.
This commit is contained in:
reed 2005-04-28 22:29:43 +00:00
parent 24b4b49ccc
commit 5f51a95530
5 changed files with 76 additions and 0 deletions

View file

@ -0,0 +1,9 @@
The foomatic-filters package provides foomatic-rip and foomatic-gswrapper.
foomatic-rip uses an external renderer (like GhostScript) to
translate PostScript to printer's native language. The printer
capabilities are described in PPD files. foomatic-rip works with
every known spooler.
foomatic-gswrapper massages arguments to make Ghostscript execute
properly as a filter.

View file

@ -0,0 +1,43 @@
# $NetBSD: Makefile,v 1.1.1.1 2005/04/28 22:29:43 reed Exp $
DISTNAME= foomatic-filters-3.0.2
CATEGORIES= print
MASTER_SITES= http://www.linuxprinting.org/download/foomatic/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.linuxprinting.org/
COMMENT= Spooler independent postscript printing filter
# You may choose from any of the following, if you wish
DEPENDS+= mpage-[0-9]*:../../print/mpage
#DEPENDS+= a2ps-[0-9]*:../../print/a2ps
#DEPENDS+= enscript-[0-9]*:../../print/enscript
CONFLICTS+= foomatic-gswrapper-[0-9]
GNU_CONFIGURE= YES
CONFIG_GUESS_OVERRIDE= ${WRKSRC}/config.guess
CONFIG_SUB_OVERRIDE= ${WRKSRC}/config.sub
# Rather than wrestle with the maintainer's horribly broken configure
# scripts, we just override everything here
CONFIGURE_ENV+= CUPS=${LOCALBASE}/share/cups
CONFIGURE_ENV+= CUPS_FILTERS=${LOCALBASE}/lib/cups/filter
CONFIGURE_ENV+= PRINTCAP=/etc/printcap
USE_GNU_TOOLS+= make
USE_PERL5= yes
USE_PKGINSTALL= yes
PERL5_REQD= 5.6
INSTALL_TARGET= install-bin install-man
PKG_SYSCONFSUBDIR= foomatic
EGDIR= ${PREFIX}/share/examples/foomatic-filters/
CONF_FILES= ${EGDIR}/filter.conf ${PKG_SYSCONFDIR}/filter.conf
post-install:
${INSTALL_DATA_DIR} ${EGDIR}
${INSTALL_DATA} ${WRKSRC}/filter.conf ${EGDIR}
.include "../../mk/ghostscript.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -0,0 +1,7 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2005/04/28 22:29:43 reed Exp $
bin/foomatic-gswrapper
bin/foomatic-rip
man/man1/foomatic-gswrapper.1
man/man1/foomatic-rip.1
share/examples/foomatic-filters/filter.conf
@dirrm share/examples/foomatic-filters

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2005/04/28 22:29:43 reed Exp $
SHA1 (foomatic-filters-3.0.2.tar.gz) = 6d949949f432212632c704904272bc32f287b577
RMD160 (foomatic-filters-3.0.2.tar.gz) = 612529ea462f7f1500f30ffed4aec105b410936c
Size (foomatic-filters-3.0.2.tar.gz) = 125875 bytes
SHA1 (patch-aa) = 3bc18d45ead52a31d10e82f7e0030d8c92359277

View file

@ -0,0 +1,11 @@
$NetBSD: patch-aa,v 1.1.1.1 2005/04/28 22:29:43 reed Exp $
--- foomatic-rip.in.orig 2004-01-21 20:42:35.000000000 -0700
+++ foomatic-rip.in
@@ -48,5 +48,5 @@ my $execpath = "@prefix@/bin:/usr/local/
# CUPS raster drivers are searched here
-my $cupsfilterpath = "@prefix@/lib/cups/filter:/usr/local/lib/cups/filter:/usr/local/libexec/cups/filter:/opt/cups/filter:/usr/lib/cups/filter";
+my $cupsfilterpath = "@CUPS_FILTERS@";
# Location of the configuration file "filter.conf", this file can be