Initial import of libhfs (factored out of hfsutils-3.2.6)

This commit is contained in:
fredb 1999-10-17 04:28:19 +00:00
parent 584365f37e
commit 5f875f83e3
10 changed files with 155 additions and 0 deletions

31
devel/libhfs/Makefile Normal file
View file

@ -0,0 +1,31 @@
# $NetBSD: Makefile,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
#
DISTNAME= hfsutils-3.2.6
PKGNAME= libhfs-3.2.6
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.mars.org/pub/hfs/
MAINTAINER= wrstuden@netbsd.org
HOMEPAGE= http://www.mars.org/home/rob/proj/hfs/
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I./
USE_LIBTOOL= yes
ALL_TARGET= all_lib
do-install:
${INSTALL_DATA_DIR} ${PREFIX}/include/libhfs
cd ${WRKSRC}/libhfs; \
${LIBTOOL} --mode=install ${INSTALL_PROGRAM} libhfs.la ${PREFIX}/lib; \
${INSTALL_DATA} apple.h data.h hfs.h libhfs.h ${PREFIX}/include/libhfs
cd ${WRKSRC}/librsrc; \
${LIBTOOL} --mode=install ${INSTALL_PROGRAM} librsrc.la ${PREFIX}/lib; \
${INSTALL_DATA} librsrc.h rsrc.h ${PREFIX}/include/libhfs
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/libhfs
cd ${WRKSRC}/doc; ${INSTALL_DATA} charset.txt libhfs.txt librsrc.txt \
${PREFIX}/share/doc/libhfs
.include "../../mk/bsd.pkg.mk"

3
devel/libhfs/files/md5 Normal file
View file

@ -0,0 +1,3 @@
$NetBSD: md5,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
MD5 (hfsutils-3.2.6.tar.gz) = fa572afd6da969e25c1455f728750ec4

View file

@ -0,0 +1,6 @@
$NetBSD: patch-sum,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
MD5 (patch-aa) = e0af75d3b1b96457b615ebd39a1134e2
MD5 (patch-ab) = d877864417566b1386a29c9c3b3d90d7
MD5 (patch-ac) = 3e0d500a80d2774f4b53f82bff098fd5
MD5 (patch-ad) = c136763eaf36f692d7867df1f1d636f1

View file

@ -0,0 +1,31 @@
$NetBSD: patch-aa,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
--- libhfs/Makefile.in.orig Mon Nov 2 16:08:51 1998
+++ libhfs/Makefile.in Fri Oct 15 12:23:01 1999
@@ -60,7 +60,7 @@
TARGETS = $(HFSTARGET)
-HFSTARGET = libhfs.a
+HFSTARGET = libhfs.la
HFSOBJS = os.o data.o block.o low.o medium.o file.o btree.o node.o \
record.o volume.o hfs.o version.o $(LIBOBJS)
@@ -113,12 +113,15 @@
###############################################################################
$(HFSTARGET): $(HFSOBJS)
- $(AR) $@ $(HFSOBJS)
- $(RANLIB) $@
+ $(LIBTOOL) --mode=link $(CC) -o $(HFSTARGET) $(HFSOBJS:.o=.lo) \
+ -rpath $(LIBDEST) -version-info 1:0
os.c: os/$(OS).c
rm -f $@
$(SOFTLINK) os/$(OS).c $@
+
+.c.o:
+ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c $(.IMPSRC)
### DEPENDENCIES FOLLOW #######################################################

View file

@ -0,0 +1,33 @@
$NetBSD: patch-ab,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
--- librsrc/Makefile.in.orig Sat Apr 11 20:33:26 1998
+++ librsrc/Makefile.in Fri Oct 15 12:45:57 1999
@@ -57,7 +57,7 @@
TARGETS = $(RSRCTARGET)
-RSRCTARGET = librsrc.a
+RSRCTARGET = librsrc.la
RSRCOBJS = data.o rsrc.o version.o $(LIBOBJS)
###############################################################################
@@ -110,14 +110,17 @@
###############################################################################
$(RSRCTARGET): $(RSRCOBJS)
- $(AR) $@ $(RSRCOBJS)
- $(RANLIB) $@
+ $(LIBTOOL) --mode=link $(CC) -o $(RSRCTARGET) $(RSRCOBJS:.o=.lo) \
+ -rpath $(LIBDEST) -version-info 1:0
main.o:
$(CC) $(CFLAGS) -I. -I../libhfs -c main.c -o $@
main: librsrc.a main.o
$(CC) $(LDFLAGS) -L. -L../libhfs main.o -lhfs -lrsrc -o $@
+
+.c.o:
+ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) -c $(.IMPSRC)
### DEPENDENCIES FOLLOW #######################################################

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ac,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
--- libhfs/libhfs.h.orig Mon Nov 2 16:09:02 1998
+++ libhfs/libhfs.h Fri Oct 15 12:53:29 1999
@@ -19,8 +19,8 @@
* $Id: patch-ac,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
*/
-# include "hfs.h"
-# include "apple.h"
+# include <hfs.h>
+# include <apple.h>
extern int errno;

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ad,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
--- librsrc/librsrc.h.orig Sat Apr 11 03:27:19 1998
+++ librsrc/librsrc.h Fri Oct 15 12:55:15 1999
@@ -19,7 +19,7 @@
* $Id: patch-ad,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
*/
-# include "rsrc.h"
+# include <rsrc.h>
extern int errno;

1
devel/libhfs/pkg/COMMENT Normal file
View file

@ -0,0 +1 @@
library for accessing HFS (Apple Macintosh) volumes

6
devel/libhfs/pkg/DESCR Normal file
View file

@ -0,0 +1,6 @@
These are the libraries from Rob Mars' HFS Utilities. These libraries
provide routines for programs to access HFS (Apple Macintosh) partitions,
including routines to access and manipulate "resource forks".
The HFS Utilities command line tools and GUI themselves may be found
in the sysutils/hfsutils and sysutils/xhfs packages, respectively.

16
devel/libhfs/pkg/PLIST Normal file
View file

@ -0,0 +1,16 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1999/10/17 04:28:19 fredb Exp $
lib/libhfs.a
lib/libhfs.so.1.0
lib/librsrc.a
lib/librsrc.so.1.0
include/libhfs/apple.h
include/libhfs/data.h
include/libhfs/hfs.h
include/libhfs/libhfs.h
include/libhfs/librsrc.h
include/libhfs/rsrc.h
share/doc/libhfs/charset.txt
share/doc/libhfs/libhfs.txt
share/doc/libhfs/librsrc.txt
@dirrm include/libhfs
@dirrm share/doc/libhfs