Update eblook to 1.6.1.
eblook supports EB 4.x. While here, enable pkgviews installation.
This commit is contained in:
parent
44b28dc8c5
commit
5fa82e8e80
4 changed files with 10 additions and 48 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: CHANGES,v 1.7928 2004/11/20 16:00:35 uebayasi Exp $
|
||||
$NetBSD: CHANGES,v 1.7929 2004/11/20 16:06:21 uebayasi Exp $
|
||||
|
||||
Changes to the packages collection and infrastructure in 2004:
|
||||
|
||||
|
@ -5357,3 +5357,4 @@ Changes to the packages collection and infrastructure in 2004:
|
|||
Updated cgoban-java to 2.6.7 [rh 2004-11-20]
|
||||
Added RealPlayerGold-10.0.1 [rh 2004-11-20]
|
||||
Updated eb to 4.1.1 [uebayasi 2004-11-20]
|
||||
Updated eblook to 1.6.1 [uebayasi 2004-11-20]
|
||||
|
|
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.12 2004/10/03 00:18:19 tv Exp $
|
||||
# $NetBSD: Makefile,v 1.13 2004/11/20 16:06:21 uebayasi Exp $
|
||||
#
|
||||
|
||||
DISTNAME= eblook-1.6
|
||||
PKGREVISION= 1
|
||||
DISTNAME= eblook-1.6.1
|
||||
CATEGORIES= japanese textproc
|
||||
MASTER_SITES= http://openlab.ring.gr.jp/edict/eblook/dist/
|
||||
|
||||
|
@ -10,9 +9,12 @@ MAINTAINER= uebayasi@NetBSD.org
|
|||
HOMEPAGE= http://openlab.ring.gr.jp/edict/eblook/
|
||||
COMMENT= Interactive command-line interface for EPWING electric dictionaries
|
||||
|
||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||
|
||||
USE_BUILDLINK3= YES
|
||||
GNU_CONFIGURE= YES
|
||||
INFO_FILES= eblook.info
|
||||
CONFIGURE_ARGS+=--with-eb-conf=${PKG_SYSCONFDIR.eb}/eb.conf
|
||||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
|
|
|
@ -1,5 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.2 2004/03/19 16:02:17 uebayasi Exp $
|
||||
$NetBSD: distinfo,v 1.3 2004/11/20 16:06:21 uebayasi Exp $
|
||||
|
||||
SHA1 (eblook-1.6.tar.gz) = 5b8fc0b85edb044e43b16608e7f3afd5b9db0148
|
||||
Size (eblook-1.6.tar.gz) = 418216 bytes
|
||||
SHA1 (patch-aa) = 1b0b6b4132e67fc51b23e60c45264fddec5b711a
|
||||
SHA1 (eblook-1.6.1.tar.gz) = 401c97437fdf94a90969e856c3a9d1c6c3646e47
|
||||
Size (eblook-1.6.1.tar.gz) = 440727 bytes
|
||||
|
|
|
@ -1,40 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.1 2004/03/19 16:02:17 uebayasi Exp $
|
||||
|
||||
--- codeconv.c.orig Sat Mar 8 23:29:47 2003
|
||||
+++ codeconv.c Sat Mar 20 00:27:25 2004
|
||||
@@ -213,7 +213,7 @@
|
||||
olen=TEST_LENGTH;
|
||||
|
||||
/* euc-jp => current code ¤ÎÊÑ´¹¥Æ¥¹¥È */
|
||||
- if (iconv(etoc,&test1,&ilen,&test2,&olen) == ((size_t)-1))
|
||||
+ if (iconv(etoc,(const char **)&test1,&ilen,&test2,&olen) == ((size_t)-1))
|
||||
return 0;
|
||||
if (iconv(etoc,NULL,&ilen,&test2,&olen) == ((size_t)-1))
|
||||
return 0;
|
||||
@@ -222,7 +222,7 @@
|
||||
test2=test2_0;
|
||||
ilen=TEST_LENGTH-olen;
|
||||
olen=TEST_LENGTH;
|
||||
- if (iconv(ctoe,&test2,&ilen,&test3,&olen) == ((size_t)-1))
|
||||
+ if (iconv(ctoe,(const char **)&test2,&ilen,&test3,&olen) == ((size_t)-1))
|
||||
return 0;
|
||||
if (iconv(ctoe,NULL,&ilen,&test3,&olen) == ((size_t)-1))
|
||||
return 0;
|
||||
@@ -661,7 +661,7 @@
|
||||
size_t ret;
|
||||
if (cur_to_euc == (iconv_t) -1)
|
||||
return CODECONV_ERROR;
|
||||
- ret = iconv(cur_to_euc,in_buf,in_len,out_buf,out_len);
|
||||
+ ret = iconv(cur_to_euc,(const char **)in_buf,in_len,out_buf,out_len);
|
||||
if (ret != ((size_t)-1))
|
||||
ret = iconv(cur_to_euc, NULL, in_len, out_buf, out_len);
|
||||
#if defined (HAVE_ERRNO_H) && defined (E2BIG)
|
||||
@@ -770,7 +770,7 @@
|
||||
size_t ret;
|
||||
if (euc_to_cur == (iconv_t) -1)
|
||||
return CODECONV_ERROR;
|
||||
- ret = iconv(euc_to_cur,in_buf,in_len,out_buf,out_len);
|
||||
+ ret = iconv(euc_to_cur,(const char **)in_buf,in_len,out_buf,out_len);
|
||||
if (ret != ((size_t)-1))
|
||||
ret = iconv(euc_to_cur,NULL,in_len,out_buf,out_len);
|
||||
#if defined (HAVE_ERRNO_H) && defined (E2BIG)
|
Loading…
Reference in a new issue